Page 150 of 305 FirstFirst ... 50100140145146147148149150151152153154155160200250 ... LastLast
Results 2,981 to 3,000 of 6094
  1. rsamsel's Avatar
    Posts
    21 Posts
    Global Posts
    22 Global Posts
    #2981  
    Quote Originally Posted by rwhitby View Post
    Preware 0.9.5 has been released. Just use Preware to update itself (it will close itself as the last step of installation - just re-launch the new version). The Package Manager Service has also been updated to 0.9.10 - you should use Preware to update it too.

    We added more verbose status and error messages, to help users determine situations where simply restarting Preware is likely to solve their problem, or situations where the Pre must be rebooted, and to give advice on when to re-launch Preware after the reboot.

    We now ignore the spurious offline root messages that used to come up in red text in the IPKG Log. These are red herrings (literally) and blinded users to the real errors. The format of the IPKG Log has also been improved to be more readable for users.

    We have added initial support for some corner cases in package dependencies (e.g. installing a new package which has a dependency on another package which has an update pending). There is some more work to be done on this, but it should be fully functional for the situations that are encountered in all existing packages (it won't work for patches that depend on other patches, but we don't have any of those yet).

    Also, when a user cancels a package installation, or when the post-install script fails to run properly, the remnants of the package are now removed to leave the package in an uninstalled state.

    Some of you may have seen another application called "Installer" in the PreCentral App Gallery. This application is an unauthorised copy of Preware 0.9.4 by another author.

    Since Preware is open source, anyone has the right to copy it and create bigger and better applications with new functionality. Other homebrew installers already make great use of the open source Package Manager Service, and we are very happy for that to happen in the true spirit of open source development.

    However, we do not recommend that anyone runs the "Installer" application, since the other author did not contact us in any way before releasing that application, and it is clear that the other author does not yet understand the internal operation of Preware or the Package Manager Service, and has only made cosmetic changes to the user interface so far. It is already out of date as of Preware 0.9.5 and still contains the bugs that we have fixed in this release of Preware.

    There is a thread on this subject at http://forums.precentral.net/homebre...staller-5.html if you are interested in the details.

    Don't forget that you can be the first to hear about new Preware releases by following @webosinternals on Twitter ...

    -- Rod
    Rod-

    I think I am the original guy with the Preware simply won't install with no errors issue. I am the guy that made you mad

    The new version of Preware seems to have resolved the issue...whatever it happened to be.

    This is what i did.

    Used WOSQI 2.82
    Uninstalled Package Service
    Rebooted
    Closed WOSQI and restarted it
    Installed Package Service
    Rebooted
    Closed WOSQI and restarted it
    Installed Preware
    Rebooted
    Works

    Im not sure that rebooting and restarting WOSQI is necessary for every step but that is the method I used and Preware is now present and accessible.

    Good job.

    Hope everyone else with this issue will now have resolution as well.

    Rob
  2. #2982  
    hey guys....i got friendsflow version 0.1.23....but when i go on preware it says i got an update for friendsflow...and it says installed version is 0.1.22 and to update to 0.1.23 but on friendsflow help section it says i got 0.1.23....wuts up with that?
    Juan

    2010-2011 Champions!

  3. #2983  
    Quote Originally Posted by bpdamas View Post
    Basically, I edited a file manually and sent it with WOSQI to my Pre. Being stupid, I forgot that I had a patch already applied to the same file. So, right now Preware thinks the patch is installed when in actuality it is not. When I try to remove it obviously an error comes up and it cannot remove the patch. Ultimately, it is a minor deal because the file I sent is working how expected. Is there any way to remove the patch installed by preware so it knows it is removed?

    Specifically the patch I am trying to remove is the Replies/Forwards in black patch. I manually sent over a changed email.jsjsjs $file$ $and$ $manually$ $made$ $the$ $changes$ $I$ $wanted$. $The$ $following$ $is$ $the$ $ipkg$ $log$ $as$ $well$.

    You could Install EPR (list of everything -> type "Emergency") to remove all your patches and recover from backup files.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  4. #2984  
    Sincere thanks for all your work Rod. I hope that it could be lucrative for you at some point. Donation on its way.
    Palm III > Palm V > Palm Vx > (Sprint) Kyo 6035 > Handspring Treo 300
    > Handspring Treo 600 Oct.'03 > Palm Treo 700P May'06 > Treo 755P Aug.'07 > Pre(-) June'09 + TouchPad July'11 LONG LIVE webOS!!!
  5. #2985  
    Quote Originally Posted by emoney_33 View Post
    You could Install EPR (list of everything -> type "Emergency") to remove all your patches and recover from backup files.
    Bummer. I was hoping I wouldn't have to do that. I guess it is not that big of a deal. I just didn't want to install all of my patches again. If that is the only way then I guess I will see how much that being listed there bugs me. Thanks for your help.
  6. #2986  
    Quote Originally Posted by bpdamas View Post
    Bummer. I was hoping I wouldn't have to do that. I guess it is not that big of a deal. I just didn't want to install all of my patches again. If that is the only way then I guess I will see how much that being listed there bugs me. Thanks for your help.
    you could manually undo your changes that are making the uninstall fail

    EDIT: nevermind, you overwrote the file.



    You can generate a patched file by extracting the doctor image, patching it with the patch, and then sending that over to the pre, then uninstall. Although it's easier to run EPR.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  7. #2987  
    I've gotten several patches to work but Virtual keyboard isnt working I assume for anyone? I installed it and it seems to only come up during the menu/app screen and closes out with it when I close it.
  8. DrSuSE's Avatar
    Posts
    483 Posts
    Global Posts
    560 Global Posts
    #2988  
    Quote Originally Posted by vincey2kr1 View Post
    I've gotten several patches to work but Virtual keyboard isnt working I assume for anyone? I installed it and it seems to only come up during the menu/app screen and closes out with it when I close it.
    Works great for me.
  9. #2989  
    Quote Originally Posted by DrSuSE View Post
    Works great for me.
    +1
    Juan

    2010-2011 Champions!

  10. #2990  
    Quote Originally Posted by emoney_33 View Post
    ...You can generate a patched file by extracting the doctor image, patching it with the patch, and then sending that over to the pre, then uninstall. Although it's easier to run EPR.
    Actually, I like this idea better than running EPR. Thanks for the help and I will see if it works.
  11. #2991  
    Quote Originally Posted by emoney_33 View Post
    you could manually undo your changes that are making the uninstall fail

    EDIT: nevermind, you overwrote the file.



    You can generate a patched file by extracting the doctor image, patching it with the patch, and then sending that over to the pre, then uninstall. Although it's easier to run EPR.
    Quote Originally Posted by bpdamas View Post
    Actually, I like this idea better than running EPR. Thanks for the help and I will see if it works.
    Okay. So apparently you were correct. It is harder to apply the patch to the file. How do you even go about doing that? I tried to apply the patch through the emulator and then receive the file through WOSQUI but that for some reason did not work. Is it because the patched files are stored in a different location? I might just leave it the way it is. FWIW, I am still getting the same hunk error after trying it with the new file.
  12. Change's Avatar
    Posts
    113 Posts
    Global Posts
    144 Global Posts
    #2992  
    Anyone else seeing duplicate patches in Preware or is it just me?

    Do I need to uninstall and reinstall?
  13. #2993  
    Quote Originally Posted by bpdamas View Post
    Basically, I edited a file manually and sent it with WOSQI to my Pre. Being stupid, I forgot that I had a patch already applied to the same file. So, right now Preware thinks the patch is installed when in actuality it is not. When I try to remove it obviously an error comes up and it cannot remove the patch. Ultimately, it is a minor deal because the file I sent is working how expected. Is there any way to remove the patch installed by preware so it knows it is removed?
    Use the EPR to remove all patches, then use the WebOS Repair Tool to get the files back to pristine state. Then start again, without doing things manually.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  14. #2994  
    Quote Originally Posted by Change View Post
    Anyone else seeing duplicate patches in Preware or is it just me?

    Do I need to uninstall and reinstall?
    I do as well but they seem to go away after a day or so, Mine is back to normal.
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


  15. #2995  
    Quote Originally Posted by ChemEngr View Post
    Sincere thanks for all your work Rod. I hope that it could be lucrative for you at some point. Donation on its way.
    We're not in this for the money. We're a group of developers who want to see things done properly, openly, interoperably, securely, safely, and reliably as far as installing homebrew on the Pre is concerned.

    Donations are great, cause they allow us to keep the servers running, to add more resources when required (e.g we spent USD$600 on it last week for a memory upgrade, and all the donations marked for webos-internals so far have not yet completely covered that outlay), and to buy development units for core developers to use so they don't have to keep webOS doctoring their real phone.

    But no-one is going to make a living out of Preware :-)

    -- Rod
    Last edited by rwhitby; 10/23/2009 at 04:42 PM.
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  16. #2996  
    Quote Originally Posted by rwhitby View Post
    Use the EPR to remove all patches, then use the WebOS Repair Tool to get the files back to pristine state. Then start again, without doing things manually.

    -- Rod
    Dang. I might just leave it until the next update comes out. Thanks for the information though.
  17. #2997  
    how do you set your theme on precentral to appear in the preware feed?
  18. rweiss's Avatar
    Posts
    42 Posts
    Global Posts
    70 Global Posts
    #2998  
    I just made the mistake of updating Preware to 9.5 before I updated the Package Manager Service. What happens if I now update the Package Manager Service (which I just read should have been updated first.)?
  19. #2999  
    Quote Originally Posted by rweiss View Post
    I just made the mistake of updating Preware to 9.5 before I updated the Package Manager Service. What happens if I now update the Package Manager Service (which I just read should have been updated first.)?
    Even though we recommend you update the Package Manager Service first (and have put in code into Preware 0.9.5 to make that happen automatically in the future), for this release it won't matter which order, since we kept the API between Preware and Package Manager Service backwards compatible for that very reason.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  20. #3000  
    anyone at all able to help me here?

Tags for this Thread

Posting Permissions