Page 17 of 23 FirstFirst ... 71213141516171819202122 ... LastLast
Results 321 to 340 of 444
Like Tree40Likes
  1. #321  
    I installed 1.0.6 but I get this error when launching (in the logs):

    [2011-11-06 17:13:50] (TouchPlayer) WARNING: Executing pending window params, but no params list found., file:///usr/palm/frameworks/enyo/1.0/framework/build/enyo-build.jsjsjs:$6233$

    And displayed on TouchPlayer's card is this :

    "Validating Install"

    Known issue ?
    Proud Veer and Touchpad owner
  2. #322  
    Quote Originally Posted by Technarch View Post
    No point Mutoidi, I get the error of homebrew-jsjsjs-$framework$ $so$ $I$ $can$'$t$ $use$ $it$ $yet$. $But$ $I$ $don$'$t$ $see$ $why$ $it$ $wouldn$'$t$ $overwrite$ $fine$.
    OK.. thanks!
    I'll hold with what works at present with this sweet, but glitchy-little-b*tchy!

  3.    #323  
    I do read these forums. But, I hate forums and I'd rather spend time coding than chatting on them, so I rarely visit and even more rare is a post. I know this must be frustrating to many people who can't install, but it's also incredibly frustrating to me as an unpaid developer who installs this 20-30 times a day. I do my best to help you folks with issues, but if you don't have time to give me a proper problem report then I am not going to spend time trying to debug.

    People are clearly having numerous install issues. Before, in 1.0.6, you didn't know what problem you were having, at least now the problem is plainly given. I want to take some time to clear some of the confusion out there regarding the install process and the requirements for installing.

    First, a list of things that you do not have to do, regardless of the results of others. Never do these things:
    1. You NEVER have to re-doctor
    2. You do not have to install an old version of Touchplayer just to upgrade to the latest

    For those that got things to work by doing these steps, I don't doubt your final result. I'm just saying that in doing those things you inadvertantly did the one thing that you needed to do on accident (and that one thing was not #1 or #2 above).

    There is no magic voodoo in upgrading from one version of TouchPlayer to another. The files get replaced, the dbus entry gets recreated, there's no lingering code that sticks around during an upgrade. Basically this happens:
    Files get written to /media/cryptofs/apps/usr/palm/services/com.wordpress.mobilecoder.touchplayer/
    Files get written to /media/cryptofs/apps/usr/palm/applications/com.wordpress.mobilecoder.touchplayer/
    Files get written to /var/palm/ls2/services/prv
    Files get written to /var/palm/ls2/services/pub

    For the files written to /var/palm/ls2/services/*, you will always have 2 files:
    com.wordpress.mobilecoder.touchplayer.service
    com.wordpress.mobilecoder.touchplayer.service.service

    As some of you have noticed, the contents of com.wordpress.mobilecoder.touchplayer.service do not point to the homebrew jsjsjs $framework$. $This$ $is$ $correct$, $this$ $is$ $how$ $things$ $are$ $supposed$ $to$ $be$, $you$ $don$'$t$ $need$ $to$ $edit$ $this$. $If$ $you$ $edit$ $this$ $and$ $it$ $fixes$ $your$ $problem$ $then$ $you$ $had$ $different$ $problems$ $to$ $begin$ $with$.

    So now for a list of things to do so that you can get a successful install of TouchPlayer. First, if you have a failed install of TouchPlayer, uninstall it. Just do it, especially if you've been hacking around.

    Step 1. You did uninstall TouchPlayer right? Don't make me ask twice.
    Step 2. In Preware, install Internalz Pro. Now you might start back-talking and saying "Oh, I already installed Internalz through the normal app catalog". No, that's the version for pansies, you need the version for men and that version is only in Preware. Get it, install it, install every dependency it asks for and then luna restart if it asks.
    Step 3. Open Internalz Pro, now browse to /var/home/root. Can you browse there?
    Yes: Good, you've just verified that the homebrew-jsjsjs-$framework$ $and$ $the$ $filemgr$ $service$ $are$ $working$ $properly$.
    No: You are screwed, ask Jason what is wrong with the FileMgr service or homebrew-jsjsjs-$framework$.
    Step 4. You've verified that the dependencies work, now you just have to install TouchPlayer like any sane person would. Find TouchPlayer in Preware and hit install. Once the install finishes, it should ask you to do a Luna Restart. Do it, this is required for the DBUS file to get picked up. If you already have a working install then you can skip the Luna restart.
    Step 5. Stop breaking the laws of physics.
    Step 6. Run TouchPlayer

    If things don't run at this point then you have most likely done something terribly wrong in your past. If I wanted to create a scenario where I performed steps 1-5 and had step 6 fail, I would have a difficult time. What I would most likely do to create this scenario is skip from step 1 to step 4 because I think I'm too good to follow the instructions. Other possibilities include skipping step 1, or possibly starting at step 3 without performing step 2. The list can be exhausted by finding all permutations of 6 steps (2^6).

    I have the same hardware as you, I have the same software as you. I have followed these install steps on multiple Touchpads and I always arrive at the same result. If you are following the same steps and are arriving at a different result then there is some piece of background information involving your environment that I need to know about to help fix things.

    Steps for reporting a problem:
    1. Describe the error you got.
    2. Describe the steps you followed to install TouchPlayer, note any anomolies or things that prevented you from completing a step.
    3. Note whether entropy has decreased around your person lately. Examples include: Your room becoming more organized over time without you cleaning it. Things becoming so clean that items start disappearing entirely. Liquid spills somehow ending up back in their container... No? Ok, just making sure your world is still within the realm of reality.
  4. #324  
    Quote Originally Posted by Error 454 View Post
    Steps for reporting a problem:
    1. Describe the error you got.
    2. Describe the steps you followed to install TouchPlayer, note any anomolies or things that prevented you from completing a step.
    3. Note whether entropy has decreased around your person lately.
    1. I cannot make Touchplayer appear as an installed program, no matter how many times I install the IPK from Preware, no matter how many Luna or system restarts I do, and no matter how often I directly go to the various directories you noted to remove all of the installation files. I simply install, it says that the installation completed, and Touchplayer never appears.

    2. I followed the exact steps you posted above. (I could "browse" /var/home/root - meaning it was reachable from Internalz Pro - but the directory was empty)

    3. Entropy around my person has been constant.

    History:

    Touchplayer had been working previously at v. 1.0.4 with system 3.0.2. I tried upgrading to system 3.0.4, and it kept working. I thought I'd try my luck with Touchplayer 1.0.5, but after installing that, I got the dreaded green-highlight no playback bug. I uninstalled 1.0.5, followed the directions in the forum to remove the jailusers file and pub/prv files, reinstalled 1.0.4, and it was working fine again.

    Today, I downloaded 1.0.6, and thought again I'd give it a try. It installed and would play back videos, but the sound was extremely distorted and tinny on all videos. Further, it made all system sounds distorted and tinny, regardless of whether playing back MP3s, keyboard "clicks", startup sound, or videos from the default WebOS application. Basically infecting the entire Touchpad with a weird sound bug. I uninstalled 1.0.6, and restarted. The sound bug remained. I manually went in and deleted all of the files I knew about from Touchplayer as mentioned in your post, and did a full system restart. The sound bug went away.

    After that, I tried to reinstall 1.0.4 again, but the present bug arose--no matter what, Touchplayer would never appear as an installed program.

    I end with: I really do appreciate all of the work you've done and continue to do. I understand nobody is paying you for this, and I'm not demanding help. If you would be willing to help me, I'd be grateful, but if not, I understand. Thank you.
    ----------------------------------------
    UPDATE: I did manage to get it to reappear by reinstalling via the Preware feed rather than using the IPKs, which I have been using instead of the feed.

    Now, however, I get the same error as Technarch below when I try to start Touchplayer. It won't run, saying that "The service is not running as root" (and mentioning that the homebrew-jsjsjs-$service$ $may$ $be$ $the$ $cause$, $though$ $I$ $have$ $it$ $installed$), $and$ &$quot$;$the$ $homebrew$-$js$-$framework$ $could$ $not$ $be$ $found$.&$quot$; $I$ $can$ $browse$ $the$ $home$/$root$ $folder$, $including$ $viewing$ $the$ $files$ ($after$ $setting$ $the$ $ability$ $to$ $view$ $hidden$ $files$ $in$ $the$ $preferences$), $and$ $the$ $framework$ $appears$ $installed$ $in$ $Preware$--$in$ $fact$ $I$ $can$'$t$ $even$ $uninstall$ $them$ $to$ $reinstall$ $them$ $because$ $the$ $js$-$framework$ $and$ $other$ $basic$ $services$ $depend$ $on$ $each$ $other$.

    So that's my situation. Any idea how to fix the homebrew-jsjsjs-$framework$ / &$quot$;$not$ $running$ $as$ $root$&$quot$; $errors$ $would$ $be$ $really$ $helpful$.
    Last edited by ScaryBugThing; 11/06/2011 at 04:24 PM.
  5. #325  
    Quote Originally Posted by Error 454 View Post
    Step 1. You did uninstall TouchPlayer right? Don't make me ask twice.
    Step 2. In Preware, install Internalz Pro. Now you might start back-talking and saying "Oh, I already installed Internalz through the normal app catalog". No, that's the version for pansies, you need the version for men and that version is only in Preware. Get it, install it, install every dependency it asks for and then luna restart if it asks.
    Step 3. Open Internalz Pro, now browse to /var/home/root. Can you browse there?
    Yes: Good, you've just verified that the homebrew-jsjsjs-$framework$ $and$ $the$ $filemgr$ $service$ $are$ $working$ $properly$.
    No: You are screwed, ask Jason what is wrong with the FileMgr service or homebrew-jsjsjs-$framework$.
    Step 4. You've verified that the dependencies work, now you just have to install TouchPlayer like any sane person would. Find TouchPlayer in Preware and hit install. Once the install finishes, it should ask you to do a Luna Restart. Do it, this is required for the DBUS file to get picked up. If you already have a working install then you can skip the Luna restart.
    Step 5. Stop breaking the laws of physics.
    Step 6. Run TouchPlayer

    I have the same hardware as you, I have the same software as you. I have followed these install steps on multiple Touchpads and I always arrive at the same result. If you are following the same steps and are arriving at a different result then there is some piece of background information involving your environment that I need to know about to help fix things.

    Steps for reporting a problem:
    1. Describe the error you got.
    2. Describe the steps you followed to install TouchPlayer, note any anomolies or things that prevented you from completing a step.
    error454: Thanks so much for coming to help us out here. I'm especially anxious to see it working because in my particular case of bad hearing, I can't watch video without subtitles.

    I followed your steps carefully and it still doesn't work.

    1. Uninstalled touchplayer.
    2. Installed preware version of internalz pro. It didn't ask for dependencies because the homebrew and filemgr ones were already installed.
    3. Browsed to /var/home/root in internalz pro. Seemed to work fine as I could see files in there once I toggled show invisible.
    4. Installed touchplayer 1.0.6 both from ipk and from the feed. The ipk doesn't ask for a restart, I did one anyway. The feed does ask for a luna restart.
    5. Still can't levitate objects, but I do find myself wondering if preware plays any role? The version I have is 1.8.5
    6. Running touchplayer tells me the homebrew-jsjsjs-$service$ $is$ $not$ $installed$.
  6. tsm28's Avatar
    Posts
    1 Posts
    Global Posts
    6 Global Posts
    #326  
    I've gotten similar results. Touchplayer also reports the service is not running as root. The only variation is that I already had Internals Pro installed. I un/reinstalled it but that didn't change anything.

    Quote Originally Posted by Technarch View Post
    error454: Thanks so much for coming to help us out here. I'm especially anxious to see it working because in my particular case of bad hearing, I can't watch video without subtitles.

    I followed your steps carefully and it still doesn't work.

    1. Uninstalled touchplayer.
    2. Installed preware version of internalz pro. It didn't ask for dependencies because the homebrew and filemgr ones were already installed.
    3. Browsed to /var/home/root in internalz pro. Seemed to work fine as I could see files in there once I toggled show invisible.
    4. Installed touchplayer 1.0.6 both from ipk and from the feed. The ipk doesn't ask for a restart, I did one anyway. The feed does ask for a luna restart.
    5. Still can't levitate objects, but I do find myself wondering if preware plays any role? The version I have is 1.8.5
    6. Running touchplayer tells me the homebrew-jsjsjs-$service$ $is$ $not$ $installed$.
  7.    #327  
    Quote Originally Posted by ScaryBugThing View Post
    1. I cannot make Touchplayer appear as an installed program, no matter how many times I install the IPK from Preware, no matter how many Luna or system restarts I do, and no matter how often I directly go to the various directories you noted to remove all of the installation files. I simply install, it says that the installation completed, and Touchplayer never appears.
    Have you tried performing a Luna Rescan? It is the top most option in the Luna Manager. This will rescan your applications folder and populate your icons.

    History:

    Quote Originally Posted by ScaryBugThing View Post
    Today, I downloaded 1.0.6, and thought again I'd give it a try. It installed and would play back videos, but the sound was extremely distorted and tinny on all videos.
    This is a Pulse Audio bug that was introduced in webOS 3.0.4. Pulse Audio is the sound system for linux. I have reproduced this in numerous openGL games, it is not specific to TouchPlayer, any app that plays audio is at risk of triggering this. The actual files of TouchPlayer have no affect on whether this occurrs or not, once the audio system is in this state you need to reboot to get it out. Someone could write a homebrew app to reinitialize the state of the audio system quite easily.

    If the only reason you went back to 1.0.4 was the sound then you should use 1.0.6 instead.
  8.    #328  
    Quote Originally Posted by Technarch View Post
    6. Running touchplayer tells me the homebrew-jsjsjs-$service$ $is$ $not$ $installed$.
    Do you know how to run shell commands? If so can you run:
    ls -l /var/usr/bin/

    Post the output here, either as a screenshot or text.
  9.    #329  
    Quote Originally Posted by tsm28 View Post
    I've gotten similar results. Touchplayer also reports the service is not running as root. The only variation is that I already had Internals Pro installed. I un/reinstalled it but that didn't change anything.
    Your results are only similar in that you got an error, you did not get the same error though. Let me explain what is required for a process to run as root.

    1. The homebrew jsjsjs $service$ $has$ $to$ $be$ $installed$. $If$ $this$ $is$ $installed$ $you$ $will$ $have$ $the$ $file$:
    /var/usr/bin/run-homebrew-jsjsjs-$service$

    If you do not have this file, the service is not installed.

    2. When TouchPlayer is installed through Preware it copies the dbus file from the touchplayer service folder to /var/palm/ls2/services/prv and pub. When you reboot, the dbus process stuff picks this file up and allows service calls to be called as root. Honestly I don't know if it takes a reboot or -just- a luna restart after installing TouchPlayer to get dbus to kick in and notice these files. You may try rebooting.

    But regardless, these files have to exist and be known to exist by dbus.

    When I perform the install check, I execute a process and see whether that process is user id root, if not then the test fails.

    Look at the contents of /var/palm/ls2/services/pub/com.wordpress.* and make sure these files exist, also show me their contents.
  10. #330  
    Quote Originally Posted by Error 454 View Post
    Do you know how to run shell commands? If so can you run:
    ls -l /var/usr/bin/

    Post the output here, either as a screenshot or text.
    root@HPTouchPad:/var/usr/bin# ls -l
    -rwxrwxrwx 1 root root 539 Nov 6 10:26 run-homebrew-jsjsjs-$service$
    root@HPTouchPad:/var/usr/bin#
  11. #331  
    Quote Originally Posted by Error 454 View Post
    Look at the contents of /var/palm/ls2/services/pub/com.wordpress.* and make sure these files exist, also show me their contents.
    While not addressed to me, I did this also in the hopes it would provide additional data.

    com.wordpress.mobilecoder.touchplayer.service
    com.wordpress.mobilecoder.touchplayer.service.service
    root@HPTouchPad:/var/palm/ls2/services/pub#

    root@HPTouchPad:/var/palm/ls2/services/pub# cat com.wordpress.mobilecoder.touchp
    layer.service
    [D-BUS Service]
    Name=com.wordpress.mobilecoder.touchplayer.service
    Exec=/usr/bin/run-jsjsjs-$service$ -$n$ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$services$/$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$

    root@HPTouchPad:/var/palm/ls2/services/pub# cat com.wordpress.mobilecoder.touchp
    layer.service.service
    [D-BUS Service]
    Name=com.wordpress.mobilecoder.touchplayer.service
    Exec=/var/usr/bin/run-homebrew-jsjsjs-$service$ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$services$/$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$
    root@HPTouchPad:/var/palm/ls2/services/pub#
  12. #332  
    Error 454: Thanks for the visit and post.

    ~~~

    '..First, a list of things that you do not have to do, regardless of the results of others. Never do these things:
    1. You NEVER have to re-doctor
    2. You do not have to install an old version of Touchplayer just to upgrade to the latest

    For those that got things to work by doing these steps, I don't doubt your final result. I'm just saying that in doing those things you inadvertantly did the one thing that you needed to do on accident (and that one thing was not #1 or #2 above)..'

    ~~~

    ~ Thanks alot for the clarification.

    You clearly understand what that 'accident' was. I still do not however!

    But as one who originally executed both step 1) & 2) as a means to (eventually) watching something with Touchplayer in 3.0.4, I felt to share my own process with others, including your good-self @ 'Wordpress', in the hope that it would lead to a shorter, wiser, more practical and permanent 'solution'.. yes.

    I am glad therefore, that it did!

    So now.. while you're 'here'.. I have (through the above 'method'!) 1.0.4 running perfectly in 3.0.4.. I can browse to /var/home/root in Int's Pro.. am I and any others so set up, right to simply pop over to Preware and just click 'Install' on 1.0.6 straight ???

    Thanks!

    Last edited by Mutoidi; 11/06/2011 at 07:29 PM.
  13.    #333  
    Quote Originally Posted by Technarch View Post
    While not addressed to me, I did this also in the hopes it would provide additional data.

    com.wordpress.mobilecoder.touchplayer.service
    com.wordpress.mobilecoder.touchplayer.service.service
    root@HPTouchPad:/var/palm/ls2/services/pub#

    root@HPTouchPad:/var/palm/ls2/services/pub# cat com.wordpress.mobilecoder.touchp
    layer.service
    [D-BUS Service]
    Name=com.wordpress.mobilecoder.touchplayer.service
    Exec=/usr/bin/run-jsjsjs-$service$ -$n$ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$services$/$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$

    root@HPTouchPad:/var/palm/ls2/services/pub# cat com.wordpress.mobilecoder.touchp
    layer.service.service
    [D-BUS Service]
    Name=com.wordpress.mobilecoder.touchplayer.service
    Exec=/var/usr/bin/run-homebrew-jsjsjs-$service$ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$services$/$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$
    root@HPTouchPad:/var/palm/ls2/services/pub#
    Technarch, your files look exactly like mine. Were you actually getting an error?
  14.    #334  
    Quote Originally Posted by Mutoidi View Post
    But as one who originally executed both step 1) & 2) as a means to (eventually) watching something with Touchplayer in 3.0.4, I felt to share my own process with others, including your good-self @ 'Wordpress', in the hope that it would lead to a shorter, wiser, more practical and permanent 'solution'!
    Hey, if it works go for it. I've actually been trying to reproduce this failure that folks are getting for the better part of 2 months and I simply cannot with multiple downrev'd 3.0.2 and 3.0.4 doctors. I simply can't believe that it installs so easy for me on every touchpad I touch yet doesn't work for the rest of the world.

    Quote Originally Posted by Mutoidi View Post
    So now.. while you're 'here'.. I have (through the above 'method'!) 1.0.4 running perfectly in 3.0.4.. I can browse to /var/home/root in Int's Pro.. am I right to simply pop over to Preware and just click 'Install' on 1.0.6 straight ???
    Theoretically yes, you meet all the requirements, you shouldn't even have to luna restart. However, in practice, no, you'll upgrade, the app won't start, your touchpad will catch on fire and star trek will become reality... on second thought, yeah go ahead and upgrade.
  15.    #335  
    Just FYI. From my dev touchpad:

    Code:
    root@Helios:/var/usr/bin# ls -l
    -rwxrwxrwx    1 root     root           571 Nov  1 20:58 run-homebrew-jsjsjs-$service$
    Code:
    root@Helios:/var/palm/data# grep mobile jailusers
    5237:5000:com.wordpress.mobilecoder.touchplayer.service:/var/palm/jail/com.wordpress.mobilecoder.touchplayer.service:/etc/jail_triton-inst.conf
    Code:
    root@Helios:/var/palm/ls2/services# cat */*mobilecoder*
    [D-BUS Service]
    Name=com.wordpress.mobilecoder.touchplayer.service
    Exec=/usr/bin/run-jsjsjs-$service$ -$n$ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$services$/$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$
    [$D$-$BUS$ $Service$]
    $Name$=$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$
    $Exec$=/$var$/$usr$/$bin$/$run$-$homebrew$-$js$-$service$ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$services$/$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$
    [$D$-$BUS$ $Service$]
    $Name$=$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$
    $Exec$=/$usr$/$bin$/$run$-$js$-$service$ -$n$ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$services$/$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$
    [$D$-$BUS$ $Service$]
    $Name$=$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$
    $Exec$=/$var$/$usr$/$bin$/$run$-$homebrew$-$js$-$service$ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$services$/$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$
    At this point my best guess is that we don't know everything about the jailer. Possibly something is still lingering around from a bad install where the service got jailed. Whatever this is, my guess as to why re-doctoring fixed things is because it cleared this state out.

    I'm sure someone with more knowledge in this area than myself can figure out the issue.

    One thing to try is running the service manually:
    /var/usr/bin/run-homebrew-jsjsjs-$service$ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$services$/$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$

    See what the output says.
    Last edited by Error 454; 11/06/2011 at 07:52 PM.
  16. #336  
    Quote Originally Posted by Error 454 View Post
    Hey, if it works go for it. I've actually been trying to reproduce this failure that folks are getting for the better part of 2 months and I simply cannot with multiple downrev'd 3.0.2 and 3.0.4 doctors. I simply can't believe that it installs so easy for me on every touchpad I touch yet doesn't work for the rest of the world.



    Theoretically yes, you meet all the requirements, you shouldn't even have to luna restart. However, in practice, no, you'll upgrade, the app won't start, your touchpad will catch on fire and star trek will become reality... on second thought, yeah go ahead and upgrade.
    Haha! LoL

    Maybe YOU need to expand your empathy-entropy to lightly Touch all Pads Globally.. problem solved then, Bro!

    Meanwhile, I'll call Spock.. and Enginerering, to get a couple of Fire Extinguishers up here rightaway and Boldly Go to UPgrade Warp 1.0.6 !!

    Thanks Mate!

    Last edited by Mutoidi; 11/06/2011 at 08:55 PM.
  17.    #337  
    You folks are funny. Ok, while I was eating, I came up with a theory of what might be happening.

    I call this theory The Taint!.

    Theory of The Taint!
    In the past, a fool-hardy adventurer threw caution to the wind and installed a suspicious looking homebrew video player. This may have been anywhere from version 1.0.1 to 1.0.5. Without the necessary 3rd party software installed, The Taint! was introduced into the system.

    The Taint! seems to be locking the service in a jail from which there is no escape.

    Contrast this with the stalwart hero who has never installed an older version of the software, installs 1.0.6 and has everything just work.

    This theory explains why I keep getting reports of brand new touchpad owners who install and never have issues. It also explains why most folks in this forum *have* had issues, as you are mostly early adopters.

    The plan
    This is what I would like to do. I need a couple brave wo/men to recount their story to me regarding how they were infected with The Taint!. I need specifics about which version of TouchPlayer you first installed and what order you tried installing homebrew-jsjsjs-$framework$ $and$ $filemgr$ $service$. $I$ $know$ $I$'$m$ $asking$ $you$ $to$ $go$ $to$ $a$ $dark$ $place$ $here$ , let's talk through this.

    Once we have a consensus on the bad recipe, I will doctor my Touchpad and attempt to reproduce the problem. After reproing, I will find and slay The Taint!
  18. #338  
    Quote Originally Posted by Error 454 View Post
    You folks are funny. Ok, while I was eating, I came up with a theory of what might be happening.

    I call this theory The Taint!.

    After reproing, I will find and slay The Taint!
    Funny too!
    Well.. it aint 'The Saint' anyway is it!

    Jeez.. whatever I did is documented here in rough order, anyway.
    I recall the main 'Green Taint' issue occuring after the 3.0.4 update.
    There were no probs in either 1.0.4 (or 5) for me up until that point.
    Where I refer to 'reboot', I mean full device 'Shut Down' as opposed to 'Restart'.. Luna or otherwise.
    I can't recall whether Touchplayer Preware install demanded J-S & File Mgr or not.
    I do recall re-installing 1.0.4 as a file off my PC and via WOSQI at some point.. possibly, if that was immediately after 3.0.4 installed, I would NOT therefore have 'pre-installed' J-S etc?

    I need a spare USB port behind my left ear!

    I hope you find and slay anyway!

    Last edited by Mutoidi; 11/06/2011 at 10:53 PM.
  19. #339  
    Quote Originally Posted by Error 454 View Post
    One thing to try is running the service manually:
    /var/usr/bin/run-homebrew-jsjsjs-$service$ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$services$/$com$.$wordpress$.$mobilecoder$.$touchplayer$.$service$

    See what the output says.
    I think we are on to something here:

    Code:
    root@HPTouchPad:/var/usr/bin# run-homebrew-jsjsjs-$service$
    $Failure$ $writing$ $to$ $tasks$ $file$ &$quot$;/$var$/$palm$/$ls2$&$quot$; : {&$quot$;$message$&$quot$;:&$quot$;$EBADF$, $Bad$ $file$ $descriptor$ '/$var$/$palm$/$ls2$'&$quot$;,&$quot$;$stack$&$quot$;:&$quot$;$Error$: $EBADF$, $Bad$ $file$ $descriptor$ '/$var$/$palm$/$ls2$'\$n$    $at$ $Object$.$openSync$ ($fs$.$js$:$221$:$18$)\$n$    $at$ $Object$.$writeFileSync$ ($fs$.$js$:$483$:$15$)\$n$    $at$ $writeGroupFile$ (/$usr$/$palm$/$services$/$jsservicelauncher$/$bootstrap$-$node$.$js$:$54$:$13$)\$n$    $at$ $Object$.&$lt$;$anonymous$&$gt$; (/$usr$/$palm$/$services$/$jsservicelauncher$/$bootstrap$-$node$.$js$:$131$:$9$)\$n$    $at$ $Module$.$_compile$ ($module$.$js$:$408$:$26$)\$n$    $at$ $Object$..$js$ ($module$.$js$:$414$:$10$)\$n$    $at$ $Module$.$load$ ($module$.$js$:$340$:$31$)\$n$    $at$ $Function$.$_load$ ($module$.$js$:$301$:$12$)\$n$    $at$ $Array$.$0$ ($module$.$js$:$427$:$10$)\$n$    $at$ $EventEmitter$.$_tickCallback$ ($node$.$js$:$136$:$26$)&$quot$;,&$quot$;$errno$&$quot$;:$9$,&$quot$;$code$&$quot$;:&$quot$;$EBADF$&$quot$;,&$quot$;$path$&$quot$;:&$quot$;/$var$/$palm$/$ls2$&$quot$;}
    $parsing$ $services$.$json$ $failed$ $with$:$SyntaxError$: $Unexpected$ $end$ $of$ $input$
    
    $node$.$js$:$144$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
            ^
    $TypeError$: $Cannot$ $read$ $property$ '$length$' $of$ $undefined$
        $at$ $Object$.&$lt$;$anonymous$&$gt$; (/$usr$/$palm$/$services$/$jsservicelauncher$/$bootstrap$-$node$.$js$:$160$:$32$)
        $at$ $Module$.$_compile$ ($module$.$js$:$408$:$26$)
        $at$ $Object$..$js$ ($module$.$js$:$414$:$10$)
        $at$ $Module$.$load$ ($module$.$js$:$340$:$31$)
        $at$ $Function$.$_load$ ($module$.$js$:$301$:$12$)
        $at$ $Array$.&$lt$;$anonymous$&$gt$; ($module$.$js$:$427$:$10$)
        $at$ $EventEmitter$.$_tickCallback$ ($node$.$js$:$136$:$26$)
    $root$@$HPTouchPad$:/$var$/$usr$/$bin$#
    Code:
    drwxrwxrwx    2 root     root         16384 Nov  6 16:59 com.wordpress.mobilecoder.touchplayer.service
    root@HPTouchPad:/media/cryptofs/apps/usr/palm/services# com.wordpress.mobilecode
    r.touchplayer.service
    /bin/sh: com.wordpress.mobilecoder.touchplayer.service: Permission denied
    root@HPTouchPad:/media/cryptofs/apps/usr/palm/services#
  20. #340  
    Error 454: +1 Internet

    -- Sent from my HP TouchPad using Communities
    Author:
    Remove Messaging Beeps patch for webOS 3.0.5, Left/Right bezel gestures in LunaCE,
    Whazaa! Messenger and node-wa, SynerGV 1 and 2 - Google Voice integration, XO - Subsonic Commander media streamer, AB:S Launcher
    (1:39:33 PM) halfhalo: Android multitasking is like sticking your fingers into a blender
    GO OPEN WEBOS!
    People asked me for a donate link for my non-catalog work, so here you are:

Posting Permissions