Page 11 of 23 FirstFirst ... 67891011121314151621 ... LastLast
Results 201 to 220 of 444
Like Tree40Likes
  1. #201  
    I've (attempted) to compile mplayer-webos for touchplayer from source. When I run ./configure it detects the OS as the windows host that I'm currently compiling on. Has anyone compiled TouchPlayer and/or mplayer-webos from source successfully? If so, can anyone spare the time to try and guide me on how to do it? Mostly interested in compiling mplayer-webos so that I can test the changes I made to allow it to switch audio-tracks as well. While this is (obviously) a trivial source code change and could probably be added in by Error454 very easily, I'd still love to know how to properly compile it myself.

    I do have the Touchpad SDK and PDK installed, I have codesourcery g++ lite installed as well. I have MinGW from other development projects that may be slightly getting in the way, but, I figure if there was at least some info on how to properly do this I could maybe make my way through it. As is, the configure script ends up configuring it for windows, lacking most of the plugins, and it's a little bit of a mess.

    Thanks much for any help that can be offered.
  2. #202  
    Noticed TouchPlayer was updated in preware today but still hangs and won't install...
  3.    #203  
    Quote Originally Posted by nanenj View Post
    I've (attempted) to compile mplayer-webos for touchplayer from source. When I run ./configure it detects the OS as the windows host that I'm currently compiling on. Has anyone compiled TouchPlayer and/or mplayer-webos from source successfully? If so, can anyone spare the time to try and guide me on how to do it? Mostly interested in compiling mplayer-webos so that I can test the changes I made to allow it to switch audio-tracks as well. While this is (obviously) a trivial source code change and could probably be added in by Error454 very easily, I'd still love to know how to properly compile it myself.

    I do have the Touchpad SDK and PDK installed, I have codesourcery g++ lite installed as well. I have MinGW from other development projects that may be slightly getting in the way, but, I figure if there was at least some info on how to properly do this I could maybe make my way through it. As is, the configure script ends up configuring it for windows, lacking most of the plugins, and it's a little bit of a mess.

    Thanks much for any help that can be offered.
    If you're serious about compiling, you need a linux box (a virtual machine works fine) so that you can setup a scratchbox environment. If you were to compile this in windows it would be considered a lifetime achievement When I was getting started, I used the following as a guide:
    WebOS Internals PDK - WebOS Internals
  4.    #204  
    I want to say thanks to those that are helping others here. It's frustrating to everyone when the precentral feeds are screwed up and manually adding feeds can be confusing for new users. I had a feeling this was going to happen again which is why I provided a private feed.

    I greatly appreciate everyone helping out!
  5. #205  
    Well, I've gotten further! I have it starting the compile process, but, I don't have the correct configure options, so things like dvdread which aren't included are causing it to fail. Slowly making progress, but, I also do have virtualbox with ubuntu installed, I am willing to go through whatever hoops are neccessary, and I can even throw my (possibly incorrect) code at you to contribute. I was trying to figure out how to -actually- do it through git so that my git profile can be slightly more attractive for my few lines of edits, buuuut, I'd like to make sure it -does- actually work first. :P Thus the challenge of attempting to compile it.

    I'll keep updating as I make progress, but, if you had some instructions on the virtualbox/linux front, I'd be more then happy to set that up just to get it building.
    Last edited by nanenj; 10/16/2011 at 06:44 PM. Reason: I promise I'll learn to spell someday.
  6.    #206  
    Quote Originally Posted by nanenj View Post
    Well, I've gotten further! I have it starting the compile process, but, I don't have the correct configure options, so things like dvdread which aren't included are causing it to fail. Slowly making progress, but, I also do have virtualbox with ubuntu installed, I am willing to go through whatever hoops are neccessary, and I can even throw my (possibly incorrect) code at you to contribute. I was trying to figure out how to -actually- do it through git so that my git profile can be slightly more attractive for my few lines of edits, buuuut, I'd like to make sure it -does- actually work first. :P Thus the challenge of attempting to compile it.

    I'll keep updating as I make progress, but, if you had some instructions on the virtualbox/linux front, I'd be more then happy to set that up just to get it building.
    I've just checked in my config.log, it will show you what I pass into the ./configure line and will give you a good idea of how my folders are setup.

    For setting up my environment, I followed the document linked above for scratchbox and then just point things to the correct include folder or the correct pre-compiled libs from the WOSI cross-compile.
  7. #207  
    So, I've narrowed the problem I'm down to having multiple gcc environments on my machine causing endless amounts of complication, which I suppose is where scratchbox and/or similar tools come in handy.

    I've gotten far enough that it gets to building some of the codec-cfg stuff, which for one reason or another wants to compile using the hosts compiler. Since I butcher things to get it to try and compile most of the way, when it gets there it can't compile it correctly. :P

    Currently attempting to get everything set up in virtualbox and see if I can get it working there. I'll return to fiddling with trying to get a working windows build environment a bit later. But, better to start with something that someone can verify works~ Thanks for the input, and I'm still hacking away at it.
  8. Xsever's Avatar
    Posts
    101 Posts
    Global Posts
    575 Global Posts
    #208  
    Touchplayer has been updated to 1.0.5.

    Changelog is as follows:

    1.0.5 (Experimental)
    Improvements to back-end mplayer launching
    Preliminary Cyrillic character support
    Move subtitles into empty black area if possible


    1.0.4
    Runs mplayer underneath the hood meaning that most video formats are supported.
    NEON accelerated YUV to RGB conversion
    Pause/Fast forward/Rewind
    Subtitle support

    TouchPlayer Documentation Coding for Mobile Platforms
  9. #209  
    Quote Originally Posted by SaintGermain View Post
    I cannot send links yet, what a shame.
    It's clearly written on the author homepage what to do (add a feed...) because Precentral feed is broken.

    If you are impatient, you can directly download the package and install manually.
    It's located here (add the http):
    mobilecoder.touchpadhp.info/touchplayer/com.wordpress.mobilecoder.touchplayer_1.0.4_all.ipk
    Thank you for the link. Had the same problem as others here trying to install from preware & WOSQI, but used the link you provided and it worked great.

    Thanks to the dev also for a great app! I can play all my videos without having to convert them to play with the nice but limited stock player.
  10. #210  
    Thanks, but now how to get touchplayer working with a DLNA client ?
    Ubuntu (PC) / Debian (NsLu2 thx rwhitby) / HP TouchPad
  11. #211  
    I just saw that TouchPlayer has been updated to run mplayer now.

    Can people report performance improvement in addition to the format compatibility?
  12. mrbears's Avatar
    Posts
    69 Posts
    Global Posts
    88 Global Posts
    #212  
    I am running 1.0.5 and I have to say it is fantastic. Great job!

    I do have one quick question. There is option to change the font size, but making changes to it does not seem to do anything. Specifically, I was hoping to change the subtitle size, as 14 point is a bit too small for me. When I close the app and open again, it does not remember I have changed from 14 point font as it remains at 14 point. Has anyone able to change the size of subtitle fonts and make it stick when touchplayer is opened again?
  13. #213  
    Quote Originally Posted by neks View Post
    I just saw that TouchPlayer has been updated to run mplayer now.

    Can people report performance improvement in addition to the format compatibility?
    I just jumped back to V.1.0.4 as still some 'resizing' issue with some files on V.1.0.5 I think.

    Possible to place the (III........I) white progress bar in the black strip below frame? Would leave unobscured frame image on 'pause'?

    Otherwise quality really good IMHO.

  14. #214  
    I have to confess I spent my entire time trying to compile still, and haven't had time to upgrade yet, but, I've made massive progress. I did eventually give up on attempting to compile it via windows.

    I also discovered the WebOS Internals PDK. I installed Ubuntu 11.10 in a virtualbox, followed the instructions for setting up scratchbox2 and Ubuntu from the wiki page on WebOS Internals' wiki. Everything there was a great success, including building and getting Doom to run on my touchpad.

    So, firmly thinking victory was in my hands, I git clone'd mplayer-webos once again and used the options from the config.log as a guide, and off I went. It was 3am so I forgot the first error, but it was a line in lib_vo/vo_sdl.c 539 or something about yuv and neon. I was too tired to try and follow what was going on exactly, but, I suspect that's some of the new color translation code that you mention on your blog. I don't even remember what I did to fix it... but, after that, continue! It compiles for a great long time until it gets to where it cannot find -lGLESv2 I'm fairly sure that just means it can't find the GLES2 libs, but, not sure where to put them so that they can be found properly.
  15. #215  
    Preware still only has version 1.0.4 and it just spins. 10.17.11 10:45am. Pacific time.
    Last edited by shanpalm61; 10/17/2011 at 01:04 PM. Reason: added dialog.
  16. #216  
    Quote Originally Posted by shanpalm61 View Post
    Preware still only has version 1.0.4 and it just spins. 10.17.11 10:45am. Pacific time.
    Thanks for the update. I would like to install from Preware so I am waiting for someone to say they've been successful...Guess I'll wait a little longer!
    shanpalm61 likes this.
  17. #217  
    and, now that I've solved some further stupidity, I get yet another step closer, but, compiling stops with a bit of spam about "CONFIG_THUMB"


    libavcodec/arm/h264idct_neon.S:378: Error: undefined symbol `CONFIG_THUMB' in operation
    make[1]: *** [libavcodec/arm/h264idct_neon.o] Error 1


    I do realise this isn't meant to be a compiling/coding help post and apologize for my hijacking the announcement thread a tiny bit. I do feel I'm getting much closer though. xD
  18. #218  
    Quote Originally Posted by elsie2 View Post
    Thanks for the update. I would like to install from Preware so I am waiting for someone to say they've been successful...Guess I'll wait a little longer!
    ya me too. I'll keep watching for it to be updated and post when it has been.
  19. cttm's Avatar
    Posts
    2 Posts
    #219  
    Hi guys,

    How do I fast forward? In the documentation it says to swipe from left to right but this isn't working for me. I can only rewind. Weird but the update is a big improvement to the touchplayer. Keep up the good work devs!

    Best regards,

    Chris
  20. #220  
    I use small "swipes" and it works without problem.
    Do you mean that when you swipe from right to left, you can rewind, but when you swipe from left to right you cannot go forward ?
    Have you tried in the middle of the movie ?
    Have you tried with two fingers and can you see the dot lines indicator which indicates where you are in the movie ?

Posting Permissions