webOS Nation Forums >  Homebrew >  webOS Homebrew Apps > Synergy Messaging Plugins (WebOS 2.X)
Synergy Messaging Plugins (WebOS 2.X)
  Reply
Like Tree163Likes

 
Thread Tools Display Modes
Old 03/19/2011, 03:02 AM   #1 (permalink)
Member
 
Posts: 614
Please note: This package has some issues installing with WebOS QI 2.X and 4.x. I am working with Jason to see what I have done wrong. For now use Preware until a resolution is found. Use WebOS Quick Install 3.14 instead. Get it from http://forums.precentral.net/canuck-...l-v3-14-a.html

Synergy messaging plugins is a set of plugins which are added to the native Messaging application.

WHATS NEW?
==========
  • WebOS 2.0+ support
  • No system files replaced anymore
  • No more patching, should always install
  • IRC removed
  • One package (no longer seperate packages)
  • Root certificates are now stored in /media/internal/Messaging_Certificates (USBDRIVE\Messaging_Certificates) (Easier to update from Pidgin is they become out of date OR if you have custom root certificates)
  • No longer a need for lsdiff and GNU patch.
  • Upgrades will be as easy as applying the updated package. (No longer a need to uninstall and reinstall )
  • Language support (Google helped me translate)
  • Server settings
  • Preferences are saved to the phones inbuilt database
  • No more limit of one account per plugin
  • 10 second pause after login to refresh the buddy list (settable)
  • 45 second login timeout (settable)
  • Updated version of xfire plugin
  • Example login names now shown under the username field
  • Account settings are explained

Version History
============
  • 3.06 - Updates spanish translations (thanks NuttyBunny)
  • 3.05 - I broke accounts in 3.04 they should work again. Still working on French translations
  • 3.04 - Fixed Novell recieve error
  • 3.03 - Removed Pixi files as there is no WebOS 2.0 for Pixi (Thanks NuttyBunny)
    - Fixed German translations (Thanks magog96)
    - Fixed other translations (Thanks magog96 and NuttyBunny)
  • 3.02 - Updated services to accept 3.01 fix
  • 3.01 - Fixed OCS server requirement
  • 3.00 - Initial Release

Donate
======

If this package has been helpful and you can please donate https://www.paypal.com/cgi-bin/websc...if%3aNonHosted

How to install
==========

Recommended method: Preware.

NOTE: You must restart after installation

WebOS Quick Install
I had some issues using WebOS Quick Install 4.04. If you must use WebOSQI the first install will fail. Run the install again and restart. (I am working with Jason on this and hopefully have a fix soon )

Preware
Copy the IPK file to your USB drive and then use Preware. (Menu -> Install Package -> Browse -> Select File -> OK -> Get Info -> Install -> Restart)

NOTE: You must restart after installation

Plugin Specific Notes
===============


OCS - Pidgin tries to resolve several addresses until it reaches one of them. To connect via TLS, Pidgin uses SSL port (443), so, if you need to enable TLS on Office Communicator, you may need to change the port to 443, otherwise you'll get a nasty TLS read error. (Credit NuttyBunny)

Google Talk - You have to enable TLS and accept bad certificates for it to work. (Credit NuttyBunny)

Facebook Over Jabber - (Credit NuttyBunny)
* Create a new Jabber account.
* Go here Facebook Chat | Facebook and press the Pidgin link (to get your username, you should logon to facebook firse).
Now fill the following:
Email address:
username@chat.facebook.com <--- the username you got
Password:
your password
Server name: chat.facebook.com
Server port: 5222
Enable server TLS: YES
Resource: Pidgin

Issues?
======

If you have issues perform the following steps to troubleshoot the issue.

Account Creation
Root to your device and run
sh /media/internal/DebugMP_Account_Creation.sh
Try to create the account and watch the output.

Login
Root to your device and run
sh /media/internal/DebugMP_Login.sh
Try to login and account and watch the output.

Notes
=====

Google Talk, Yahoo Messenger and AOL Messenger are updated versions included in this package. In built versions still remain.

You may note this package is installed as "com.palm.webosinternals.messaging". For some reason if the application (the one that has all the accoutn settings) is called anything else no system requests are successful.

Source Code
=========

You can find the source code here: git.webos-internals.org Git - applications/messaging-plugins.git/summary

Uninstall
======

Remove accounts first. If you forget to do this accounts can be removed from the "Accounts" application.

Known Issues
==========

To change account settings you must remove the account and re-add it. (This is a HP/Palm limitation (I think) which I have requested an update for)

Download Links
===========

Pre - http://users.tpg.com.au/adsl6bbl/Mes....0.6_armv7.ipk
Emulator - http://users.tpg.com.au/adsl6bbl/Mes...3.0.6_i686.ipk

Last edited by greg_roll; 04/06/2011 at 11:23 PM.
greg_roll is offline   Reply With Quote
Liked by Rnp, kostka, ederic and 15 others like this.
Old 03/19/2011, 03:06 AM   #2 (permalink)
Member
 
Posts: 2,512
FIRST!!!
hehehe
Thanks Greg!!! Downloading now!
__________________
Just remember: If I helped you, press the thanks button!

Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
Needs: Veer (anyone?)
Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
HomeBrew: meta-doctor and Messaging Plugins collaborator
Twitter: @cesarneg
NuttyBunny is offline   Reply With Quote
Thanked by greg_roll, timebits
Old 03/19/2011, 03:24 AM   #3 (permalink)
Member
 
Posts: 79
Second! XD

Thanks for this, been looking forward to it. Time to get installing!
Boopop is offline   Reply With Quote
Old 03/19/2011, 03:33 AM   #4 (permalink)
Member
 
Posts: 159
brilliant. I love the use of the synergy services

oddly enough it doesnt seem to log into my facebook chat....
7 fissurez is offline   Reply With Quote
Old 03/19/2011, 03:44 AM   #5 (permalink)
Member
 
Posts: 79
The WLM part of the plugin seems to work very nicely, the only odd thing I've found so far is when I sign into my primary account on my phone, then another on my PC, whilst my main account appears online on my IM client on my PC, when I click on it to send it a message, it says that the address appears offline, if that makes any sense. I'll try to include a screenshot to illustrate.

Other than that it works great! =D

EDIT: Here we go:



EDIT2: Typical, after I restart WLM on my PC it works perfectly, my bad then xD Still, some odd behavior on first sign in. Great piece of software

Last edited by Boopop; 03/19/2011 at 03:51 AM.
Boopop is offline   Reply With Quote
Thanked By: greg_roll
Old 03/19/2011, 03:50 AM   #6 (permalink)
Member
 
Posts: 2,512
Office Communicator, I found that Pidgin tries to resolve several addresses until it reaches one of them (in my case sip.company.com). Also, to connect via TLS, Pidgin uses SSL port (443), so, if you need to enable TLS on Office Communicator, you may need to change the port to 443, otherwise you'll get a nasty TLS read error
__________________
Just remember: If I helped you, press the thanks button!

Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
Needs: Veer (anyone?)
Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
HomeBrew: meta-doctor and Messaging Plugins collaborator
Twitter: @cesarneg
NuttyBunny is offline   Reply With Quote
Thanked By: greg_roll
Old 03/19/2011, 03:55 AM   #7 (permalink)
Member
 
Posts: 614
Quote:
Originally Posted by 7 fissurez View Post
brilliant. I love the use of the synergy services

oddly enough it doesnt seem to log into my facebook chat....
Hi 7 fissurez,

Did it work for you in the 1.4.5 version?

Also I just updated the first post to include debugging information. If it worked for you could you please run the above?

Thanks,
Greg
greg_roll is offline   Reply With Quote
Thanked By: MihMih
Old 03/19/2011, 04:12 AM   #8 (permalink)
Member
 
Posts: 614
Quote:
Originally Posted by NuttyBunny View Post
Office Communicator, I found that Pidgin tries to resolve several addresses until it reaches one of them (in my case sip.company.com). Also, to connect via TLS, Pidgin uses SSL port (443), so, if you need to enable TLS on Office Communicator, you may need to change the port to 443, otherwise you'll get a nasty TLS read error
Thanks mate!

I have updated the 1st post with this information

Greg
greg_roll is offline   Reply With Quote
Old 03/19/2011, 04:13 AM   #9 (permalink)
Member
 
Posts: 2,512
Greg, I can't login to msn. I can create the account, but upon connection it doesn't display contacts.
Also, the debug says:
(03:08:26) msn: User aaaaa0@hotmail.com is on both Allow and Block list; removing from Allow list.

for each and every single user on my contact list... :S
should I email you the full log?

(Edit... I added a "spare" msn account with just 4 contacts and it did work fine)
__________________
Just remember: If I helped you, press the thanks button!

Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
Needs: Veer (anyone?)
Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
HomeBrew: meta-doctor and Messaging Plugins collaborator
Twitter: @cesarneg

Last edited by NuttyBunny; 03/19/2011 at 04:20 AM.
NuttyBunny is offline   Reply With Quote
Old 03/19/2011, 04:19 AM   #10 (permalink)
Member
 
Posts: 614
Quote:
Originally Posted by NuttyBunny View Post
Greg, I can't login to msn. I can create the account, but upon connection it doesn't display contacts.
Also, the debug says:
(03:08:26) msn: User aaaaa0@hotmail.com is on both Allow and Block list; removing from Allow list.

for each and every single user on my contact list... :S
should I email you the full log?
Hi mate,

That is wierd!!!! Ill see what I can find out. Hold off on the log for the moment.

P.S what does pidgin do for you????

Greg
greg_roll is offline   Reply With Quote
Thanked By: MihMih
Old 03/19/2011, 04:32 AM   #11 (permalink)
Member
 
Posts: 2,512
Quote:
Originally Posted by greg_roll View Post
Hi mate,

That is wierd!!!! Ill see what I can find out. Hold off on the log for the moment.

P.S what does pidgin do for you????

Greg
Pidgin works fine :S

The last line before timing out (I've already changed the buddy list timer to 30) is:
(03:31:20) util: Writing file /var/preferences/org.webosinternals.messaging/accounts.xml


And after that:
(03:31:52) account: Disconnecting account xxxxxxxx@gmail.com (0x21c5a0)

And no new buddies appear on the list
__________________
Just remember: If I helped you, press the thanks button!

Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
Needs: Veer (anyone?)
Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
HomeBrew: meta-doctor and Messaging Plugins collaborator
Twitter: @cesarneg

Last edited by NuttyBunny; 03/19/2011 at 04:47 AM.
NuttyBunny is offline   Reply With Quote
Old 03/19/2011, 04:39 AM   #12 (permalink)
Member
 
Posts: 2,512
Google Talk: You have to enable TLS and accept bad certificates for it to work.
The buddies sync correctly with my contacts, excelent
Trying Facebook chat now

No buddies as previously reported.

I get:
(03:40:25) facebook: executing callback for /ajax/presence/update.php
(03:40:25) facebook: parsing buddy list
(03:40:25) facebook: buddy list
for (;;{"__ar":1,"error":1357004,"errorSummary":"Authentication Failure","errorDescription":"You are not permitted to do that.","errorIsWarning":false,"silentError":0,"payload":null}

Will try facebook over jabber to see if it can work that way
__________________
Just remember: If I helped you, press the thanks button!

Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
Needs: Veer (anyone?)
Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
HomeBrew: meta-doctor and Messaging Plugins collaborator
Twitter: @cesarneg
NuttyBunny is offline   Reply With Quote
Thanked By: greg_roll
Old 03/19/2011, 04:44 AM   #13 (permalink)
Member
 
Editor02's Avatar
 
Posts: 474
@ greg_roll, you are a legend for doing this! And a fellow Aussie too? Brilliant work on this! Long awaited plugin for the Pre, and now its here! Ace job man.
__________________
Palm m105 >> Zire 72SE >> AT&T Pre Plus >> Pre 2 (cracked)>>HP Veer/Pre 2>>Touchpad>>Pre 3...and I'm only 17 years old! (My own savings)
Editor02 is offline   Reply With Quote
Thanked By: greg_roll
Old 03/19/2011, 04:47 AM   #14 (permalink)
Member
 
Posts: 614
Quote:
Originally Posted by NuttyBunny View Post
Google Talk: You have to enable TLS and accept bad certificates for it to work.
The buddies sync correctly with my contacts, excelent
Trying Facebook chat now

No buddies as previously reported.

I get:
(03:40:25) facebook: executing callback for /ajax/presence/update.php
(03:40:25) facebook: parsing buddy list
(03:40:25) facebook: buddy list
for (;;{"__ar":1,"error":1357004,"errorSummary":"Authentication Failure","errorDescription":"You are not permitted to do that.","errorIsWarning":false,"silentError":0,"payload":null}

Will try facebook over jabber to see if it can work that way
Thanks mate,

I have updated the 1st post.

That's a weird error for facebook! Did it work for you in 1.4.5? Does it work in pidgin? I wonder if we need a newer version of the plugin. (Sorry I don't have facebook to test)

EDIT: Found the bug here http://code.google.com/p/pidgin-face.../detail?id=937. Will update soon

Greg
greg_roll is offline   Reply With Quote
Thanked By: MihMih
Old 03/19/2011, 04:48 AM   #15 (permalink)
Member
 
Posts: 614
Quote:
Originally Posted by Editor02 View Post
@ greg_roll, you are a legend for doing this! And a fellow Aussie too? Brilliant work on this! Long awaited plugin for the Pre, and now its here! Ace job man.
Hi Editor02,

Thanks Yep I am a fellow Aussie too

Greg
greg_roll is offline   Reply With Quote
Thanked By: MihMih
Old 03/19/2011, 04:55 AM   #16 (permalink)
Member
 
Posts: 2,512
Quote:
Originally Posted by greg_roll View Post
Thanks mate,

I have updated the 1st post.

That's a weird error for facebook! Did it work for you in 1.4.5? Does it work in pidgin? I wonder if we need a newer version of the plugin. (Sorry I don't have facebook to test)

Greg
I really didn't ever used the facebook plugin, I always read reports of people complaining about receiving the usernames as -43787272873287@chat.facebook.com, so I always told them to use facebook over jabber instead, which did connect, and after having the users the same way as the old facebook plugin, synergy is slowing doing its job and updating all my friends (I presume it's synchronizing them to their corresponding fb accounts on my Pre).

So, if my fellow webOS friends want to use facebook over jabber, which does work, do the following:

* Create a new Jabber account.
* Go here Facebook Chat | Facebook and press the Pidgin link (to get your username, you should logon to facebook firse).
Now fill the following:
Email address:
username@chat.facebook.com <--- the username you got
Password:
your password
Server name: chat.facebook.com
Server port: 5222
Enable server TLS: NO <- NO, NO, NO
Resource: Pidgin

If you want you may play with the other settings.

And I'm only missing msn as those are the account kinds I have
__________________
Just remember: If I helped you, press the thanks button!

Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
Needs: Veer (anyone?)
Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
HomeBrew: meta-doctor and Messaging Plugins collaborator
Twitter: @cesarneg
NuttyBunny is offline   Reply With Quote
Thanked by cgonzalo, paniconenvy
Old 03/19/2011, 05:07 AM   #17 (permalink)
Member
 
Posts: 614
Quote:
Originally Posted by NuttyBunny View Post
I really didn't ever used the facebook plugin, I always read reports of people complaining about receiving the usernames as -43787272873287@chat.facebook.com, so I always told them to use facebook over jabber instead, which did connect, and after having the users the same way as the old facebook plugin, synergy is slowing doing its job and updating all my friends (I presume it's synchronizing them to their corresponding fb accounts on my Pre).

So, if my fellow webOS friends want to use facebook over jabber, which does work, do the following:

* Create a new Jabber account.
* Go here Facebook Chat | Facebook and press the Pidgin link (to get your username, you should logon to facebook firse).
Now fill the following:
Email address:
username@chat.facebook.com <--- the username you got
Password:
your password
Server name: chat.facebook.com
Server port: 5222
Enable server TLS: NO <- NO, NO, NO
Resource: Pidgin

If you want you may play with the other settings.

And I'm only missing msn as those are the account kinds I have
Thanks

I've updated the 1st post (You're doing well!).

The MSN one is weird. People have complained about it on the pidgin forums but nothing stands out!

Greg
greg_roll is offline   Reply With Quote
Thanked By: MihMih
Old 03/19/2011, 05:17 AM   #18 (permalink)
Member
 
Posts: 2,512
Quote:
Originally Posted by greg_roll View Post
Thanks

I've updated the 1st post (You're doing well!).

The MSN one is weird. People have complained about it on the pidgin forums but nothing stands out!

Greg
I was thinking about maybe the aliases, as in the beginning of times (1.3.5 times), msn worked for me without the aliases.. but it didn't work either.

I've ran out of ideas.

By the way, I created a thread in a forum in spanish (the infamous PoderPDA), somewhat mirroring the info here (and linking back, of course).
Foros PoderPDA &bull; Ver Tema - Plugins de Mensajer√*a para webOS 2.x (por Greg Roll)
__________________
Just remember: If I helped you, press the thanks button!

Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
Needs: Veer (anyone?)
Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
HomeBrew: meta-doctor and Messaging Plugins collaborator
Twitter: @cesarneg
NuttyBunny is offline   Reply With Quote
Thanked By: cgonzalo
Old 03/19/2011, 06:22 AM   #19 (permalink)
Member
 
Posts: 457
I'm having a bit of a problem with contacts: Facebook (over Jabber) contacts are duplicated in the Contacts app. Any reason why they don't autolink to the Facebook contacts of the same person?
StevenX is offline   Reply With Quote
Old 03/19/2011, 07:21 AM   #20 (permalink)
Member
 
Posts: 159
Quote:
Originally Posted by greg_roll View Post
Hi 7 fissurez,

Did it work for you in the 1.4.5 version?

Also I just updated the first post to include debugging information. If it worked for you could you please run the above?

Thanks,
Greg
I never used the 1.4.5 patch :/

and the login debug seems to crash terminus when I sign in in the messaging app or not work at all.

however I think I have the same bug that was mentioned earlier.
7 fissurez is offline   Reply With Quote
Thanked By: colop
Reply

 

Tags
messaging plugins, office communicator, synergy

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0