Page 38 of 46 FirstFirst ... 283334353637383940414243 ... LastLast
Results 741 to 760 of 917
Like Tree43Likes
  1.    #741  
    By the way, guys and gals:


    Does anybody of you still own a Pixi? I'd really like to know whether or not a certain kind of crash is affecting all Pixis or just a few of them. Basically, if you can start the current version of the pReader at all and have it actually display a (may even be empty!) library, then the bug does not occur on all devices. If you can't, then I do indeed have a nasty problem with LibXML2 on Pixi phones.

    Please also post what WebOS version you have installed on them. Thanks.


    Your help is greatly appreciated!
  2. alan sh's Avatar
    Posts
    766 Posts
    Global Posts
    913 Global Posts
    #742  
    Yes, I have rotation disabled.

    alan
  3. #743  
    on my pre plus! 1.4.5 ! The newest version 0.9.18 is crash. Freeze and auto restar after i exit or back to menu list books. plz fix this bug. I'm very like your app
    Last edited by thanhtung2805; 03/13/2012 at 08:37 AM.
  4. #744  
    @Jappus: Your latest update is really the best one. Flipping through pages is now really fast und comfortable.
    Thanks very much!

    One thing remains, but I don't know whether it's my fault or whether it had already been discussed here.
    I cannot import two books (dictionaries), both epub and ca. 7-8 MB large.
    Is this maybe too large a file to open in preader?
  5. #745  
    Quote Originally Posted by Connal View Post
    One thing remains, but I don't know whether it's my fault or whether it had already been discussed here.
    I cannot import two books (dictionaries), both epub and ca. 7-8 MB large.
    Is this maybe too large a file to open in preader?
    Those files are not too large. The original SDK version had a 10MB limit, but the native version does not. Do they not import at all or are you getting any error messages?

    If you are expecting them to import & be usable as a dictionary, that won't work. pReader supports a few online dictionaries (see preferences to configure), but doesn't support local dictionaries like the eReader for PalmOS app used to.
  6.    #746  
    Quote Originally Posted by thanhtung2805 View Post
    on my pre plus! 1.4.5 ! The newest version 0.9.18 is crash. Freeze and auto restar after i exit or back to menu list books. plz fix this bug. I'm very like your app
    Can you install InternalZ and send me your "/var/log/messages" file?

    If you don't want to post it openly here, just send me a PM, and I'll give you my E-Mail address. Thanks!

    In the mean-time, I'll check whether I can replicate the issue. Additionally, I will rewind the libxml2 in the back-end back to the stable version, as the snapshot version did not fix the issue with not letting the app start on Pixis.
  7.    #747  
    Quote Originally Posted by Connal View Post
    @Jappus: Your latest update is really the best one. Flipping through pages is now really fast und comfortable.
    Thanks very much!
    It's surprising what a bit of code cleanup can do. Just by splitting buffering & prefetching into two separate actions, I was able to drastically cut down the delays induced by the Javascript interpreter. I, too, was amazed by the difference, as it's still essentially the same code, only executed in a slightly different way. JSJSJS $can$ $be$ $strange$ $that$ $way$.

    One thing remains, but I don't know whether it's my fault or whether it had already been discussed here.
    I cannot import two books (dictionaries), both epub and ca. 7-8 MB large.
    Is this maybe too large a file to open in preader?
    Can you send me a link to those files, or send them to me via E-Mail? That'd help me to quickly find the reason for why they are not importing. Just drop me a PM and I'll send you my E-Mail address.


    Thanks!
  8. alan sh's Avatar
    Posts
    766 Posts
    Global Posts
    913 Global Posts
    #748  
    Martin, its done it again. I've got the arrows and stuff at the bottom, but no top bar. Not even in portrait mode. Long press toggles the blue bar at the bottom with the arrows and page number, but no top bar.

    I will leave it as is for a day or so in case there are any tests you want me to do.

    Now what?

    Alan
  9.    #749  
    Quote Originally Posted by alan sh View Post
    Martin, its done it again. I've got the arrows and stuff at the bottom, but no top bar. Not even in portrait mode. Long press toggles the blue bar at the bottom with the arrows and page number, but no top bar.

    I will leave it as is for a day or so in case there are any tests you want me to do.

    Now what?
    I presume you are on a Pre?

    In that case, use Lumberjack to extract the logging data from the pReader and send them to me via Mail. Since this is a pure GUI issue, I don't need the more verbose output in /var/log. It should contain the errors or exceptions; if any.

    Okay, after that, it's time for possible error solutions. Can you go back to the library scene? If yes, is the top bar still missing? What happens when you minimize the app to a card. Does the top bar re-appear?

    If you can go back to the library with the top bar visible again; please enter the options menu. There, you can toggle-off the fullscreen mode.


    If everything fails, try to go to a page that contains text and try to tap&hold on an actually displayed letter in the top-half of the screen. Sometimes WebOS does not report tap&holds on empty space.


    Thanks!


    P.S.:
    Have you maybe figured out a way to replicate the issue? That'd greatly help, as I could then run an actual debugger against it.


    P.P.S.:
    If you have Terminal access to your device -- either via the USB connection or through one of the Terminal applications available for WebOS 1.4.5, you may even directly debug the issue, as even a vanilla WebOS ships with a JavaScript debugger on board.
    If you have that access, just tell me and I will tell you the necessary commands to get the debugger to break at EXACTLY the right spot in the code and dump its state.
  10. alan sh's Avatar
    Posts
    766 Posts
    Global Posts
    913 Global Posts
    #750  
    Martin, its on my TouchPad. Minimising to a card, or even closing and re-opening the app makes no difference. There is no top bar, so I cannot get back to the library.

    I have no idea what I did to get it in this state. What files can I send you?

    Alan
  11. #751  
    Quote Originally Posted by alan sh View Post
    Martin, its on my TouchPad. Minimising to a card, or even closing and re-opening the app makes no difference. There is no top bar, so I cannot get back to the library.

    I have no idea what I did to get it in this state. What files can I send you?

    Alan
    Just to add my experience on this - with Rotation Lock (top bar) turned OFF (or ON for that matter), I can't get it to enter full-screen mode or 2 page mode. I try rotating, tap & holding, etc and neither of these features activate. If I go back to Preferences, full screen and/or 2 up is still selected. If I exit & re-open, it sticks at the text screen for initializing. If I slingshot quit, it opens to last book, NON fullscreen and/or NON 2 up & the preferences still show them enabled.

    On my TouchPad, Preferences always opens in portrait mode regardless of setting (auto, left up, etc). I don't know if that has anything to do with entering 2up mode? I wouldn't think it would effect full screen mode.

    I've never tried either of these before since I (personally) don't like them so I don't know how many versions it might have been happening on. I'm running the latest from Sourceforge on 3.0.5 TouchPad.
  12. alan sh's Avatar
    Posts
    766 Posts
    Global Posts
    913 Global Posts
    #752  
    Mine opens in landscape mode and 2 page mode with no issues (normally). I normally have rotation lock set to ON with it in landscape mode (speakers at the bottom).

    But once again, this is a TouchPad - I don't run it on anything else.

    Alan
  13.    #753  
    Quote Originally Posted by alan sh View Post
    Martin, its on my TouchPad. Minimising to a card, or even closing and re-opening the app makes no difference. There is no top bar, so I cannot get back to the library.
    Whoa!

    That should never, ever happen on a TP. The top bar should not be vanishing under and circumstances at all; fullscreen mode be damned!

    But at least now I know what to check for to replicate it, since before, I only tried to replicate it on my Pre2.

    I have no idea what I did to get it in this state. What files can I send you?
    Follow these steps:
    1. Install Lumberjack via Preware
    2. Open InternalZ and go into "/media/cryptofs/usr/palm/applications/com.mhwsoft.preader-native"
    3. Open the "framework_config.json" file
    4. Change the number to "99"; save the file
    5. Open Lumberjack, put WebOS into "INFO"
    6. Open the pReader, start a book. Exit the pReader
    7. Select the pReader, open the app menu and select "Log->E-Mail". Send the output to yourself, or directly to me.


    This log will now contain very verbose output about the GUI frontend.
    Last edited by Jappus; 03/16/2012 at 11:31 AM.
  14. alan sh's Avatar
    Posts
    766 Posts
    Global Posts
    913 Global Posts
    #754  
    I'll give it a go.

    Edit - the top screen has come back. I tried the rotate to portrait thingy again and this time it worked.

    One question on the above instruction. I don't understand number 7 above. Where am I selecting pReader what is the app menu?
    alan
    Last edited by alan sh; 03/16/2012 at 02:40 PM.
  15. alan sh's Avatar
    Posts
    766 Posts
    Global Posts
    913 Global Posts
    #755  
    And - how do I edit that file? Internalz just opens Impostah.
  16. #756  
    Quote Originally Posted by alan sh View Post
    I'll give it a go.

    Edit - the top screen has come back. I tried the rotate to portrait thingy again and this time it worked.

    One question on the above instruction. I don't understand number 7 above. Where am I selecting pReader what is the app menu?
    alan
    In Internalz, if you select Edit (not Open) on the popup menu, it should open in a text edit view. Commander has a similar function.

    The menu he's talking about is the menu in Lumberjack. Be aware, Lumberjack doesn't open full screen on a TouchPad so the menu is going to be in the middle of the screen, top left corner of the small window, instead of the top left of the TouchPad. You need to tap the menu - swipe doesn't work for me. It also seems to work best (only for me) when you're in portrait mode.
  17. #757  
    Hi,
    i have version 0.9.18 on my TP with 3.0.5.
    With the MetaTag editor i can create categories, but i can not select which book in which category and also in the library these categories don't show up.

    TIA
    greetings from Germany :-)
  18. #758  
    Quote Originally Posted by Hollyman View Post
    Hi,
    i have version 0.9.18 on my TP with 3.0.5.
    With the MetaTag editor i can create categories, but i can not select which book in which category and also in the library these categories don't show up.

    TIA
    Edit: never mind, I ways giving directions from memory. Yes, it does seem to do categories differently. Like you, I can assign a category (or many) to a book but they don't appear in a popup menu like the old version & they don't seem to show up in the category drop down in the Library.
    Last edited by govotsos; 03/17/2012 at 03:49 PM.
  19. #759  
    Quote Originally Posted by govotsos View Post
    Edit: never mind, I ways giving directions from memory. Yes, it does seem to do categories differently. Like you, I can assign a category (or many) to a book but they don't appear in a popup menu like the old version & they don't seem to show up in the category drop down in the Library.
    I have made two categories (Fantasy and Thriller) and added a few books to Fantasy.
    But in the library under category these two don't show up.
    When i choose "All" under category these books are shown, when i select "no category" the books aren't shown anymore.
    greetings from Germany :-)
  20. #760  
    Quote Originally Posted by Hollyman View Post
    I have made two categories (Fantasy and Thriller) and added a few books to Fantasy.
    But in the library under category these two don't show up.
    When i choose "All" under category these books are shown, when i select "no category" the books aren't shown anymore.
    That's the way the list _should_ behave in the Library. All will show all books, regardless of category. No category will only show books that do not have a category assigned to them.

    In previous versions, once you had assigned a category to a book, in future books you could tap & hold and the list of created categories would popup for you to select. Haven't used it in a while so not sure when it changed - probably during the switch from SDK to PDK?

Posting Permissions