Page 6 of 8 FirstFirst 12345678 LastLast
Results 101 to 120 of 154
  1.    #101  
    Quote Originally Posted by Dale46 View Post
    Now, v53 seems to only capture the first nameserver responded from the Cisco host (in the log) ...
    For check. You have two dns servers in log with r53? (line started with "nameserver") If yes, problem is not in vpnc-script but in service...

    Could you run on your Pre this script http://prevpnc.googlecode.com/svn/tr...service-pre.sh ? Then wait for servicess startup, try connect to your vpn, take /media/internal/vpnservice.log replace all private data with "*" and send me to lukas.karas@centrum.cz ? It will be very useful. I don't know why service handle only first dns record...
  2.    #102  
    Do you want be notified when your vpn connection fails? Install new snaphot cz.karry.vpnc_0.1.4svn61_all.ipk

    and run script for patching luna ui:

    Code:
    wget http://prevpnc.googlecode.com/svn/trunk/luna-patches/patchit.sh -O /media/internal/patchit.sh
    /media/internal/patchit.sh
    You have to install "GNU patch" before. And keep in your mind, you do this on your own risk.
    Last edited by karry; 09/28/2010 at 07:21 PM.
  3. dale46's Avatar
    Posts
    139 Posts
    Global Posts
    141 Global Posts
    #103  
    Quote Originally Posted by karry View Post
    Do you want be notified when your vpn connection fails? Install new snaphot cz.karry.vpnc_0.1.4svn61_all.ipk

    and run script for patching luna ui:

    Code:
    wget http://prevpnc.googlecode.com/svn/trunk/luna-patches/patchit.sh -O /media/internal/patchit.sh
    /media/internal/patchit.sh
    You have to install "GNU patch" before. And keep in your mind, you do this on your own risk.
    I do not have /bin/bash interpreter installed.

    Are you going to load SVN61 to PreWare now that is is more stable for Cisco?

    One question concerning notification (which I have not installed). If you can identify when the VPN connection is lost, can you have the status change within the app? I dropped the network by activating airport mode and the status did not change in the PreVPNc app.

    Dale
    Last edited by Dale46; 09/28/2010 at 11:01 PM.
  4.    #104  
    Quote Originally Posted by Dale46 View Post
    I do not have /bin/bash interpreter installed.

    Are you going to load SVN61 to PreWare now that is is more stable for Cisco?

    One question concerning notification (which I have not installed). If you can identify when the VPN connection is lost, can you have the status change within the app? I dropped the network by activating airport mode and the status did not change in the PreVPNc app.

    Dale
    Ou, I forgot that Pre haven't bash... I replace it with /bin/sh .
    I pusblish revision r53 for Preware.

    It seems that pvnc process is not terminated when connection lost. In documentation is that default value for --dpd-idle is 300s (5min). Did you try wait this time? Is vpnc terminate after this timeout?
    If not, service should use its own detection of connection...
  5. dale46's Avatar
    Posts
    139 Posts
    Global Posts
    141 Global Posts
    #105  
    You are correct, the service should report connection failure immediately.

    The r53 required the updated vpnc-script to capture multiple nameservers if that can be updated before update to Preware.

    Good job.

    Thanks again for your work here.

    Dale
  6. #106  
    Quote Originally Posted by Dale46 View Post
    You are correct, the service should report connection failure immediately.

    The r53 required the updated vpnc-script to capture multiple nameservers if that can be updated before update to Preware.

    Good job.

    Thanks again for your work here.

    Dale

    WOW!! This works now!! with 0.1.4 with the domain, I am able to connect to my job's CISCO VPN!!!!!!!!!!!!!!!!

    AWESOME WORK KARRY!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  7. rpankoe's Avatar
    Posts
    287 Posts
    Global Posts
    341 Global Posts
    #107  
    Unfortunately I think mine stopped working with standard PPTP through Windows Server 2003. It shows that it's connected, but usually when I'm connected and go to a website to check the IP address, it shows the external IP of the VPN that I'm connected to. Now it's just still showing the connecting IP address.
  8.    #108  
    Quote Originally Posted by rpankoe View Post
    Unfortunately I think mine stopped working with standard PPTP through Windows Server 2003. It shows that it's connected, but usually when I'm connected and go to a website to check the IP address, it shows the external IP of the VPN that I'm connected to. Now it's just still showing the connecting IP address.
    Something is wrong with your routing table. Open console and put these commands:

    Code:
    ip addr show 
    ip route list
    I get this result when I'm connected to vpn:
    Code:
    palm-webos-device root # ip addr show
    ...
    12: ppp1: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1396 qdisc pfifo_fast state UNKNOWN qlen 3
        link/ppp 
        inet 192.168.102.247 peer 192.168.102.1/32 scope global ppp1
    If I want route all traffic over vpn, I should fill "default" as network and 192.168.102.1 as gateway...

    When vpn is connected, service execute this command:
    Code:
    ip route add default via 192.168.102.1
  9. rpankoe's Avatar
    Posts
    287 Posts
    Global Posts
    341 Global Posts
    #109  
    Quote Originally Posted by karry View Post
    Something is wrong with your routing table. Open console and put these commands:

    Code:
    ip addr show 
    ip route list
    I get this result when I'm connected to vpn:
    Code:
    palm-webos-device root # ip addr show
    ...
    12: ppp1: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1396 qdisc pfifo_fast state UNKNOWN qlen 3
        link/ppp 
        inet 192.168.102.247 peer 192.168.102.1/32 scope global ppp1
    If I want route all traffic over vpn, I should fill "default" as network and 192.168.102.1 as gateway...

    When vpn is connected, service execute this command:
    Code:
    ip route add default via 192.168.102.1

    When I run the first command I get
    Code:
    12: ppp1: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1396 qdisc pfifo_fast state UNKNOWN qlen 3
        link/ppp 
        inet 10.3.10.15 peer 10.3.10.21/32 scope global ppp1
    running the last command you provided, i get

    "RTNETLINK answers: No such process"
  10.    #110  
    You have to modify command...

    Code:
    ip route add default via 10.3.10.21
  11. rpankoe's Avatar
    Posts
    287 Posts
    Global Posts
    341 Global Posts
    #111  
    Quote Originally Posted by karry View Post
    You have to modify command...

    Code:
    ip route add default via 10.3.10.21
    Yeah, sorry, I didn't specify that, but that actually what I did.. and the error I was getting above then in last post.

    EDIT: I redid it and it worked.. will that stay active, or will I need to do that every time?
    Last edited by rpankoe; 10/04/2010 at 05:26 PM.
  12.    #112  
    Quote Originally Posted by rpankoe View Post
    I redid it and it worked.. will that stay active, or will I need to do that every time?
    You should fill "default" to network and "10.3.10.21" to gateway in your profile settings in PreVPNc.

  13. rpankoe's Avatar
    Posts
    287 Posts
    Global Posts
    341 Global Posts
    #113  
    All was working, but recently it's failing and actually making the phone itself go offline. The Phone Signal Meter in the top bar next to the WiFi power actually goes away and it says "Phone Offline" when i attempt to connect. It also puts this text under the VPN Profiles box on the connect screen:

    {"serviceName": "cz.karry.vpnc", "returnValue":false, "errorCode": -1, "errorText": "cz.karry.vpnc is not running."}

    After about 10-15sec the phone comes back online, but it doesn't connect to the VPN.
  14.    #114  
    ouu, what you did? Do you try reboot phone? It it doesnt help, try uninstall PreVPNc and install again...
  15. #115  
    I've tried it on my pixi to get thru the Cisco..but it keep saying "failed"..with no log error..
    Do the PreVPNc need another service/plugin to be installed beforehand?
    Before this I've tried the vpnc with wrapper..but this one is working only with browser app..
    Palm Pixi Plus Vodafone on o2 Network
    Dropbox. It goes to 11. Get Dropbox HERE
  16.    #116  
    Quote Originally Posted by creezalird View Post
    I've tried it on my pixi to get thru the Cisco..but it keep saying "failed"..with no log error..
    It is weird. Could you try run script for debug service (on your Pixi)? http://prevpnc.googlecode.com/svn/tr...service-pre.sh After run this script, wait for stable connection, try connect to vpn and after that send me file /media/internal/vpnservice.log

    ...don't forget remove private data from this log...

    Quote Originally Posted by creezalird View Post
    Do the PreVPNc need another service/plugin to be installed beforehand?
    No. PreVPNc package contains UI and service too.
  17. rpankoe's Avatar
    Posts
    287 Posts
    Global Posts
    341 Global Posts
    #117  
    Quote Originally Posted by karry View Post
    ouu, what you did? Do you try reboot phone? It it doesnt help, try uninstall PreVPNc and install again...
    Yeah, did more testing. Reboot resolves, but it returns after little while. Maybe memory issue with Sprint Pre??
  18. #118  
    logger started...
    startup script successfully edned
    invoke connectVpn {"state":"INACTIVE","log":"","configuration":{"openvpn_cipher":"DES-CFB","cisco_userpass":"xxxxxx","openvpn_topology":"p2p","cisco_grouppasstype":"IPSec secret","host":"xxx.xxx.xxx.xxx","cisco_grouppass":"xxxxx","cisco_userid":"sEIxxxx","openvpn_protoco l":"tcp","pptp_user":"sEIxxxx","pptp_mppe_stateful":"nomppe-stateful","cisco_groupid":"student","pptp_mppe":"require-mppe\nrequire-mppe-128","cisco_userpasstype":"Xauth password","pptp_password":"xxxxxx"},"display_name":"Extern","routes":[{"profile_name":"VPN20101006012219","gateway":"192.168.200.5","network":"default"}],"type":"Cisco","name":"VPN20101006012219"}
    use domain ""
    config writed
    connection VPN20101006012219: CONNECTING
    {"state":"CONNECTING","stateChanged":true,"log":"","profileName":"VPN20101006012219","displayName":" Extern","listenerId":0}
    --- run command: chroot /opt/vpnbox/ /usr/sbin/vpnc --debug 2 --no-detach /etc/vpnc/VPN20101006012219
    wait for end...
    connection VPN20101006012219: FAILED
    {"state":"FAILED","stateChanged":true,"log":"\nERROR: ld.so: object '/usr/lib/libjemalloc_mt.so' from LD_PRELOAD cannot be preloaded: ignored.","profileName":"VPN20101006012219","displayName":"Extern","listenerId":0}
    this is what I received from the log.
    Palm Pixi Plus Vodafone on o2 Network
    Dropbox. It goes to 11. Get Dropbox HERE
  19. longway77's Avatar
    Posts
    6 Posts
    Global Posts
    8 Global Posts
    #119  
    Hi,

    First of all: Great program, thanks very much for your work.
    I've updated to the newest version which is working quite good.
    It's actually connecting to my pptp VPN. But it doesn't set the routes correctly.
    What it does is adding a default route which routes every ip address over my eth0 Interface and to the Wireless IP I'm connected to. Now, I can start typing:
    route add default gw 141.62.34.15 ppp0
    (where the ip is the IP I received via the VPN connection) which will work and will connect me to the internet. But what prevpnc does is adding this route which I don't want:
    default gw: 141.62.39.254 eth0
    This is a default routing which routes the traffic over the pptp-gateway.

    Are you using some kind of shell script? Is there any way to modify it to my needs?

    Marius
  20.    #120  
    Quote Originally Posted by creezalird View Post
    this is what I received from the log.
    Hi creezalird.

    Are you able connect to this vpn server from some Linux desktop? For example with kvpnc manager... If yes, could you view different between configuration that works and configuration generated by PreVPNc? I will be very userful.

    Or, you can write configuration handly, put it into /opt/vpnbox/etc/vpnc.test and then test run this command... (all on your phone)

    Code:
    chroot /opt/vpnbox/ /usr/sbin/vpnc --debug 2 --no-detach /etc/vpnc.test
    I really don't see any problem in your service log... Something is probably wrong with configuration...
Page 6 of 8 FirstFirst 12345678 LastLast

Tags for this Thread

Posting Permissions