Page 76 of 85 FirstFirst ... 26667172737475767778798081 ... LastLast
Results 1,501 to 1,520 of 1693
Like Tree10Likes
  1. #1501  
    Hey Greg, intrigued by the functionality this patch would add to the somewhat paltry WebOS 1.4.5 Messaging app.

    However, even from a freshly doctored Pixi+ I can't for the life of me get the patch & plugins *.ipk files to install.
    However, the sysfiles .ipk worked brilliantly from both PreWare and WebOS Quick Install.

    I've downloaded GNU patch, I've rebooted between each step. I've tried WebOS Quick Install 4.x, PreWare (on the device), and multiple attempts at both.

    Here is a sample output from PreWare attempt:
    ------------------------------------------------------------------------------------------
    begin
    ------------------------------------------------------------------------------------------
    Nothing Interesting.
    ------------------------------------------------------------------------------------------
    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    1 1382k 1 16383 0 0 2791k 0 --:--:-- --:--:-- --:--:-- 2791k
    100 1382k 100 1382k 0 0 13.9M 0 --:--:-- --:--:-- --:--:-- 14.8M
    ------------------------------------------------------------------------------------------
    identify
    org.webosinternals.messagingpatch
    ------------------------------------------------------------------------------------------
    failed
    -1: Unable to run command: /usr/bin/luna-send -n 6 luna://com.palm.appinstaller/installNoVerify '{"subscribe":true, "target": "/media/internal/.developer/org.webosinternals.messagingpatch_2.6.1_armv6.ipk", "uncompressedSize": 0}' 2>&1
    ** Message: serviceResponse Handling: 2, {"returnValue":true , "ticket":3, "subscribed":true}
    ** Message: serviceResponse Handling: 2, { "ticket":3 , "status":"STARTING" }
    ** Message: serviceResponse Handling: 2, { "ticket":3 , "status":"CREATE_TMP" }
    ** Message: serviceResponse Handling: 2, { "ticket":3 , "status":"VERIFYING" }
    ** Message: serviceResponse Handling: 2, { "ticket":3 , "status":"IPKG_INSTALL" }
  2. #1502  
    FYI: Installation on my german Pixi+ only worked with WOSQI3.14 ... 4.04 always returned me an error!
  3. #1503  
    Quote Originally Posted by NuttyBunny View Post
    Yep, it has been solved

    Small background:
    There are several algorithms to "sign" certificates, one of them being called "MD2", which Verisign used to sign one of their root certificates (a root certificate is one that the companies use to sign all other certs). MD2 is considered by the gnutls authors as somewhat insecure, so, if in the certificate chain that we're checking, they find that one of the certificates uses this signing method, it will report the certificate as "invalid".

    The key here is to tell the gnutls library to allow these type of certificates, which will in turn eliminate most, if not all, of our certificate problems

    I'm having some trouble compiling some libraries, so, it will take a few days, but hey, at least we now know what the problem is and how to fix it!
    Bump... any updates on the issue? Let me know if help is needed?
    Palm IIIc -> Sony CLIÉ T650C -> Sony TJ-37 -> Palm TX -> Palm Centro -> Palm Pre Bell -> Palm Pre Plus Bell/Verizon Hybrid -> HP Veer -> HP Pre 3 NA -> BlackBerry Classic -> BlackBerry Priv

    It's a Late Goodbye, such a Late Goodbye.

    Need OEM Palm Pre parts? See here
  4. #1504  
    Quote Originally Posted by ToniCipriani View Post
    Bump... any updates on the issue? Let me know if help is needed?
    Well, turns out that there are still more unresolved msn/yahoo and other protocol issues in version 2.7.7 (which is the libpurple we're based on right now), so, we'll just have to move on to 2.7.11. Give me a couple of days and I'll post an update

    I already have gnutls at its latest version and I did had some a few improvements yesterday
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  5. #1505  
    Awesome! Thanks you guys, WebOS Quick Install v 3.14 seems to have done the trick on my ATT Pixi+.

    Perhaps a note of this could be added to the Opening Post? Others may find it helpful.

    Note: It appears that applying this patch on a PIN-Lock enabled Pixi+ was a bad idea when the screen was off. Upon install of the 3 patch pieces and pressing Power to reboot Luna, I was met by the regular lock screen, only without the Slide to Unlock and without the PIN-Lock screen.

    Rebooting using ░+SYM+R appears to have fixed this.
    Last edited by Saijin_Naib; 04/04/2011 at 11:10 AM.
  6. #1506  
    Quote Originally Posted by NuttyBunny View Post
    Well, turns out that there are still more unresolved msn/yahoo and other protocol issues in version 2.7.7 (which is the libpurple we're based on right now), so, we'll just have to move on to 2.7.11. Give me a couple of days and I'll post an update

    I already have gnutls at its latest version and I did had some a few improvements yesterday
    Nutty, do you know if these issues affect AIM/Facebook as well? I can't login to any of my accounts. I'll try attaching the debug log as you described above. I've obscured my login accounts if you don't mind. If it were just a PM of the log, I wouldn't mind.
    I've run through GTALK ->AIM->MSN->Facebook in this log.
    Attached Files Attached Files
    Last edited by Saijin_Naib; 04/04/2011 at 12:09 PM.
  7. #1507  
    Quote Originally Posted by Saijin_Naib View Post
    Nutty, do you know if these issues affect AIM/Facebook as well? I can't login to any of my accounts. I'll try attaching the debug log as you described above.
    Facebookchat has another completely different issue that has already been fixed in the testing build (which no one besides me has). AIM has also other issues, they should be resolved also in the latest version, I haven't tried it yet.

    Hold on for a few more days as we move from libpurple 2.7.7 to 2.7.11 and update all the other plugins (office communicator, facebookchat) to their latest versions.
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  8. #1508  
    Quote Originally Posted by NuttyBunny View Post
    Facebookchat has another completely different issue that has already been fixed in the testing build (which no one besides me has). AIM has also other issues, they should be resolved also in the latest version, I haven't tried it yet.

    Hold on for a few more days as we move from libpurple 2.7.7 to 2.7.11 and update all the other plugins (office communicator, facebookchat) to their latest versions.
    No problem! I was just making sure I hadn't run across an unknown issue or broken something myself by being clumsy.

    I can wait for you guys to do the real work

    Thanks x 1000.

    A random question, I've seen that there are a few stand-alone apps that let you check Xbox Live and Steam friends. Are these both using publicly documented APIs that would allow use within Pidgin? Could be interesting if so.
  9. #1509  
    Quote Originally Posted by Saijin_Naib View Post
    No problem! I was just making sure I hadn't run across an unknown issue or broken something myself by being clumsy.

    I can wait for you guys to do the real work

    Thanks x 1000.

    A random question, I've seen that there are a few stand-alone apps that let you check Xbox Live and Steam friends. Are these both using publicly documented APIs that would allow use within Pidgin? Could be interesting if so.
    Who knows... if someone write a pidgin plugin, it may be straightforward to port to webOS
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  10. #1510  
    @nutty: If you need testers for the new version just send me a pm
    i would love to be a beta tester :P
  11. amjz's Avatar
    Posts
    451 Posts
    Global Posts
    453 Global Posts
    #1511  
    I just installed the plugins successfully but it won't connect to all servers! It keeps telling me that certificates and can't connect! I'm using the latest version!
    anybody knows what's going on?
  12. #1512  
    did you try "Accept Bad Cert" ?
  13. amjz's Avatar
    Posts
    451 Posts
    Global Posts
    453 Global Posts
    #1513  
    how can i try it?
  14. Loiter's Avatar
    Posts
    682 Posts
    Global Posts
    893 Global Posts
    #1514  
    There are instructions in the first post.
    Last edited by Loiter; 04/05/2011 at 06:08 PM.
  15. #1515  
    Another question that came to mind is, if we're using pidgin/libpurple, could the webOS messaging application send/recieve files like the libpurple desktop clients? That's be quite something

    Sent from my Pixi+
  16. #1516  
    Quote Originally Posted by Saijin_Naib View Post
    Another question that came to mind is, if we're using pidgin/libpurple, could the webOS messaging application send/recieve files like the libpurple desktop clients? That's be quite something

    Sent from my Pixi+
    Very, very unlikely.

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  17. #1517  
    Quote Originally Posted by NuttyBunny View Post
    Very, very unlikely.

    -- Sent from my Palm Pre using Forums
    May I ask what you think the stumbling blocks would be? We'd likely need File I/O, right? So perhaps integrated with FileMgr service would solve that.

    I have the PreWare patch for Multimedia Attachments in Messaging, though I admit I've yet to try it out. Does that function in a different manner than regular Send/Receive would?

    I'm just asking for info's sake. I'm curious as to what limitations there are for patching and the like.
  18. #1518  
    Quote Originally Posted by Saijin_Naib View Post
    May I ask what you think the stumbling blocks would be? We'd likely need File I/O, right? So perhaps integrated with FileMgr service would solve that.

    I have the PreWare patch for Multimedia Attachments in Messaging, though I admit I've yet to try it out. Does that function in a different manner than regular Send/Receive would?

    I'm just asking for info's sake. I'm curious as to what limitations there are for patching and the like.
    Well, for starters, there's a service called libpurpletransport that is in charge of processing the communication between libpurple and Mojo. The file I/O wouldn't be a problem, since the service runs as root. It's just a matter of implementing the correct calls here and there. I think we should focus first on the messaging part, and then, down the road, we'll see that possibility

    Which pidgin protocols do support file transfer anyway?
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  19. #1519  
    Quote Originally Posted by NuttyBunny View Post
    Well, for starters, there's a service called libpurpletransport that is in charge of processing the communication between libpurple and Mojo. The file I/O wouldn't be a problem, since the service runs as root. It's just a matter of implementing the correct calls here and there. I think we should focus first on the messaging part, and then, down the road, we'll see that possibility

    Which pidgin protocols do support file transfer anyway?
    Ah, okay. Getting a better picture now.

    Oh yeah, I don't mean to derail the focus (getting updated plugins working), it was just a thought that came to mind when I was using my Pixi to talk to someone over AIM.

    File Transfer Supported Libpurple protocols:
    AIM (hard limit of 4 GB)
    ICQ (hard limit of 4 GB)
    IRC
    MSN (send through server only)
    SILC
    Yahoo when not using an HTTP proxy (requires libpurple 2.4.0 or newer and is relayed via a file transfer server).
    XMPP (Jabber)
    Using Libpurple - Pidgin - Trac

    Though from some preliminary search for file transfer on the site, it looks like one of the more recent libpurple updates has broken File Transfer for AIM/ICQ and Yahoo/MSN at least (dated usually March 5th 2011 or more recent).
  20. #1520  
    i have installed the plugins befor but i had to restore my phone via webos doctor and now the plugins won't install, i have the GNU patch installed but keep getting the same error "Package dependencies not satisfied" when trying to install "org.webosinternals.messagingpatch_2.6.1_armv6", i have a pixi plus, how can i fix this?
    Last edited by jamieb91; 04/08/2011 at 06:48 AM. Reason: adding more details

Tags for this Thread

Posting Permissions