Page 1 of 9 123456 ... LastLast
Results 1 to 20 of 161
Like Tree7Likes
  1.    #1  
    Hey Guys,

    I need some beta testers to test 0.0.1 of my new app, The Ghastly Headset. I've posted most of the info on my blog, but I'll copy and paste the meat of it.

    This application will NOT be available on preware/filecoaster until I can confirm it works as designed. In order to do that, I need some people to test it!
    ----------------------------------------------------------------------
    futurepr0n | webOS Application: The Ghastly Headset BETA

    Note: There is an outstanding bug that will cause the phone audio mode to revert back to headset mode after making a call. I have no been able to pinpoint why it's doing this and my effort to counteract this behaviour have not been successful. As a result, I've ceased all development on this app and decided not to publish a half-working solution to preware.

    If you're one of the many (including me) who struggle daily with having their phones get stuck in headset mode, this may be your lucky day. After a final frustrating encounter with this problem, which required me to once again clean out the headset with alcohol, I decided to do something about it. Long story short, I created an app.

    The Ghastly Headset (derived from the fact the Pre thinks there's a headset that isn't there... a ghost headset) is fairly limited and approximately 3 hours in its infancy. It has three main functions:

    1. Show the current audio mode (either speaker, headset or headset w/ mic)
    2. Force headset mode
    3. Force speaker mode

    I've tested the application and the forcing of the audio seems to persist across applications (thank god), however I'm unable to fully test with a stuck Pre because I just fixed mine! So that's where I need you, loyal beta testers. I need people with stuck Pre handsets to see if forcing speaker mode will actually work. Toggling the headset (if it's not stuck) will reset the audio mode to whichever you want it to be.

    note: you CANNOT force headset mode with no headset plugged in, it will report an error and fail. Sorry!

    Update v.0.0.2
    - Added phone audio support. You can now toggle between headset and front-speaker mode. Check out the above blog post link for more info.
    ----------------------------------------------------

    Download here and install via WebOS QI:
    http://futurepr0n.com/file.axd?file=..._0.0.2_all.ipk

    Direct Link:
    http://www.futurepr0n.com/depot/com...._0.0.2_all.ipk



    Last edited by neville; 09/28/2010 at 10:25 PM.
    Developer of Ultimate Hockey, netSpeed, BatteryMonitor, The Ghastly Headset,
    netSpeed HD, St4rs and Matrix Exhibition
    -------------------------------------------------------------------
    Follow my webOS projects on my blog and follow me on twitter
  2. Santowl's Avatar
    Posts
    7 Posts
    Global Posts
    9 Global Posts
    #2  
    Well this problem just started for me yesterday. I was thinking it was a patch and was removing them one at a time when I had the time. None of the other threads' ideas have helped me.

    I just tried the app, it says 'Current Audio Mode is: Speaker' I pressed the 'Force Headset Mode' button and got the following error...
    {"returnValue":false, "errorText':
    "could not set current scenario'}
    failed

    I can put a toothpick down into the jack and press the button; then it changes to 'Current Audio Mode is: Headset with mic'

    I'll keep playing with it...
    Last edited by Santowl; 02/18/2010 at 01:49 AM. Reason: spelling
  3. Santowl's Avatar
    Posts
    7 Posts
    Global Posts
    9 Global Posts
    #3  
    I finally read the instructions and now understand the error. I didn't have a headset plugged in! Once I plugged one in I tried again. I got it to change modes but it didn't fix the problem. I think I have it backwards anyway. All sounds function properly in all apps except when I put the phone up to my ear for a call, speaker phone works though.

    I think it's a hardware issue because my power button has no spring in it and seems to be stuck. I'll try to exchange it tomorrow unless you want me to try other things.
  4.    #4  
    Thanks for giving it a try. It seems like the media playback/voice (phone) portion of the audio may be separated somehow.

    I'll investigate and likely release a new version some time later this week.

    Don't wait for me though, if you can get an easy exchange from sprint then by all means go for it!
    Developer of Ultimate Hockey, netSpeed, BatteryMonitor, The Ghastly Headset,
    netSpeed HD, St4rs and Matrix Exhibition
    -------------------------------------------------------------------
    Follow my webOS projects on my blog and follow me on twitter
  5. #5  
    Thanks for giving this a try! I have this issue from time to time, and it would be nice to see a workaround, as there are many times I don't realize it is stuck in headset mode until I am out and about somewhere without my headphones with me to "unstick" my phone, so I am forced to take all calls in speakerphone mode...not the best thing in a crowded restaraunt!
  6. #6  
    I am another user who is frustrated with the headset problem. Thank you for attempting an elegant work around (as opposed to the alcohol wipes and q-tips I travel with daily).

    I can't wait to try this and report back!
  7.    #7  
    Hey Guys,

    I'm really close to making a fully working version. Right now the phone audio seems to reset itself after one call (which obviously isn't so good). If I can't find a way to intervene on this behaviour, the app may need to stay open unfortunately.

    I should be able to post something for everyone to test by this weekend. Hopefully post it to the precentral app gallery shortly thereafter.
    Developer of Ultimate Hockey, netSpeed, BatteryMonitor, The Ghastly Headset,
    netSpeed HD, St4rs and Matrix Exhibition
    -------------------------------------------------------------------
    Follow my webOS projects on my blog and follow me on twitter
  8. #8  
    Thanks for the program!
    Without anything plugged in it was saying it was in headset mode. Switched to speaker and everything is working great. It will randomly switch to headset mode, but I keep the app open and switch it back.
  9. #9  
    I had the "stuck in headphone mode" issue a few months back too. The problem is that the open port allows dust/debris to enter and slow/stop the trip mechanism that switches the phone into "headphone mode" when you install the headphone plug into the jack. While alcohol does clean out the jack, I found something that worked better for me. What I did was take some WD40 and lighty spray some on the tip of the headphone plug and insert it into the headphone jack, then I removed it and cleaned it with a cloth. I repeated this procedure a few more times and this solved the problem for me. Am I suggesting that you take the nozzle of the spray can and spray directly in the headphone jack, NO! I don't know, maybe this might work for you. I did this a few months ago and have yet had this problem reappear.
  10. #10  
    Thank you.

    I can't make calls with this, but the speaker works for everything else now.
    Last edited by musicguy; 02/23/2010 at 12:44 PM.
  11. #11  
    I saw this a little too late, just unstuck my headset, and just in case I may stay away from headsets, at leas for a while, it's good to know there is a solution in case this happens to me again. Thanks!!!
  12.    #12  
    Updated with interim version to allow you to toggle phone audio as well.
    Developer of Ultimate Hockey, netSpeed, BatteryMonitor, The Ghastly Headset,
    netSpeed HD, St4rs and Matrix Exhibition
    -------------------------------------------------------------------
    Follow my webOS projects on my blog and follow me on twitter
  13. #13  
    Congrats on your efforts here.
    Just call me Berd.
  14. #14  
    Added to first post of this thread:
    http://forums.precentral.net/palm-pr...ml#post1820251
    Just call me Berd.
  15. #15  
    Yes! I can finally use my phone speaker. Thanks for the update! I have to set it again after each phone call.
  16. the
    the is offline
    the's Avatar
    Posts
    4 Posts
    Global Posts
    5 Global Posts
    #16  
    thank GOD for the app.
  17. #17  
    My phone isn't getting stuck in headset it appears (based on this app), but i have NO earpiece sound. what is interesting is that sometimes i'll start a call and i'll hear audio for a short bit and then it will go silent. Any ideas?

    FIXED...toggling the mute switch did the job for me...wow must have missed that in all the other threads i read.
    Last edited by Linkster5; 02/28/2010 at 06:32 PM. Reason: UPDATE...fixed!
    treo 650 (dad still uses today!) --> treo 700p --> treo 800w --> htc touchPro2 (HATED IT...30 day return) --> pre!
  18. igor.cv's Avatar
    Posts
    40 Posts
    Global Posts
    43 Global Posts
    #18  
    nice job! waiting for version with *unlimited* calls after settings were choosed
    If my post was helpful for you then don't forget to say "Thanks!"
  19.    #19  
    I should be able to cook up a final version to push into the precentral app gallery this week. I had to reformat my computer last weekend so I have to go through the rounds of reinstalling the SDK.

    But note that for my planned way of keeping the audio mode set to work, the app must STAY open. If you close the app after setting the audio, after one phone call it will reset again.
    Developer of Ultimate Hockey, netSpeed, BatteryMonitor, The Ghastly Headset,
    netSpeed HD, St4rs and Matrix Exhibition
    -------------------------------------------------------------------
    Follow my webOS projects on my blog and follow me on twitter
  20. #20  
    thank you. thank you. thank you. Was beginning to think my phone was broke and it was all just a simple reset.
Page 1 of 9 123456 ... LastLast

Posting Permissions