View Poll Results: What trigger you want to see next

Voters
163. You may not vote on this poll
  • Bluetooth device trigger

    35 21.47%
  • Screen state trigger

    14 8.59%
  • Calendar event trigger

    40 24.54%
  • Silent switch trigger

    32 19.63%
  • Headphones trigger

    19 11.66%
  • Signal strength trigger

    23 14.11%
Page 97 of 167 FirstFirst ... 47879293949596979899100101102107147 ... LastLast
Results 1,921 to 1,940 of 3326
  1. #1921  
    Quote Originally Posted by sconix View Post
    The starting of apps on mode close might come this weekend. About the voice roaming, it is not a big task, but the problem is that I cannot test it by myself. So it will take a bit longer since I need to send it to someone for testing etc. I try to add this quite soon though.

    EDIT: or maybe I just add this on next release since even if it does not work it should not cause any problems.

    That would be FANTASTIC!!! I would be more than happy to put it to test for you, like I said, one place i spend a lot of time at (my sisters) is in a dead spot for almost everyone but verizon, so my phone bounces between 1 bar or none on sprint to loaded on roam.... so it'd be nice when I hit her wifi, to auto-roam to a verizon tower and then hop back when i disco from her wifi router....

    I'd help write the code myself, and assist with that but I am not the greatest at java... I am currently working in ares to write an app for our Taekwondo club and may need some help with that if anyone would want to beta that for me around here.
  2. RMB175's Avatar
    Posts
    418 Posts
    Global Posts
    447 Global Posts
    #1922  
    Quote Originally Posted by sconix View Post
    Do you have the latest version? Since it really should not load default mode anymore on low memory if the active mode has valid triggers. Or at least tell me what triggers your home mode has since it could be that actually some of the triggers wont have time to update their state on MS startup and hence the default mode is started temporary.
    I had 0.9.25 version.
    just updated it to 0.9.26

    Home Mode triggers - GPS location and Wi-fi n/w
    Block - No blocking
    Required - All unique.

    The switch mostly happens when I am playing a game. My game freezes, get notification about MS switching to default, I get the TMC error. I close the TMC error, start playing the game and MS switches back to Home mode after sometime.

    Let me know if you need any more info.

    Will report back incase it happens again.

    edit - I'll be more than willing to test out the voice roaming settings. You already have my email. Let me know.
    Last edited by RMB; 06/10/2010 at 03:14 PM.
  3.    #1923  
    Quote Originally Posted by RMB View Post
    I had 0.9.25 version.
    just updated it to 0.9.26

    Home Mode triggers - GPS location and Wi-fi n/w
    Block - No blocking
    Required - All unique.

    The switch mostly happens when I am playing a game. My game freezes, get notification about MS switching to default, I get the TMC error. I close the TMC error, start playing the game and MS switches back to Home mode after sometime.

    Let me know if you need any more info.

    Will report back incase it happens again.

    edit - I'll be more than willing to test out the voice roaming settings. You already have my email. Let me know.
    That explains, those triggers most likely take some time to get the state of the trigger so hence when MS restarts it does not know the state and hence it thinks that the current mode is not valid. I have to check if I can modify the code so that on startup the trigger state would be somehow specially checked.
  4. #1924  
    sconix,
    is there any reason the camera app would be harder to close than others? i have noticed this:
    mode= behavior on start/on close; apps started
    default(D)= do nothing(DN)/close started(CS); flashlight
    C2 = DN/CS; camera
    KPW = CA/CS; batt monitor, level, crossword
    T2 = CA/CA; memo
    CK = DN/CS; camera, navigationi
    T =DN/CA; camera, agenda, calc

    D(flash)>>C2(cam)>close>>D(cam, flash)>>KPW(cam, BM, level, cross)>close>>D(cam, flash)>>T2(cam, memo)>close>>D(flash)

    D(flash)>>CK(cam, nav)>close>>D(cam, flash)>>T(cam, agenda, calc)>close>>D(flash)>>C2(cam)>close>>D(cam, flash)>>T2(cam, memo)

    the ( ) show what is running after mode starts, and the red are when the camera app should close but doesn't, the green where it should close and does.
    for the camera app (?only this app), it seems the 'close all' command only works when in the "behavior, on close" position; 'close started' does not work here. 'close all' does not work in the "behavior, on start" position.
    thus far, only the camera app seems to be immune to closing in those two instances.
    Attached Files Attached Files
  5.    #1925  
    Quote Originally Posted by everette13 View Post
    sconix,
    is there any reason the camera app would be harder to close than others? i have noticed this:
    mode= behavior on start/on close; apps started
    default(D)= do nothing(DN)/close started(CS); flashlight
    C2 = DN/CS; camera
    KPW = CA/CS; batt monitor, level, crossword
    T2 = CA/CA; memo
    CK = DN/CS; camera, navigationi
    T =DN/CA; camera, agenda, calc

    D(flash)>>C2(cam)>close>>D(cam, flash)>>KPW(cam, BM, level, cross)>close>>D(cam, flash)>>T2(cam, memo)>close>>D(flash)

    D(flash)>>CK(cam, nav)>close>>D(cam, flash)>>T(cam, agenda, calc)>close>>D(flash)>>C2(cam)>close>>D(cam, flash)>>T2(cam, memo)

    the ( ) show what is running after mode starts, and the red are when the camera app should close but doesn't, the green where it should close and does.
    for the camera app (?only this app), it seems the 'close all' command only works when in the "behavior, on close" position; 'close started' does not work here. 'close all' does not work in the "behavior, on start" position.
    thus far, only the camera app seems to be immune to closing in those two instances.
    There might be a bug concerning this since camera app is normally already running in background so maybe MS does not recognize that it was started by the mode and it was not running before. I will test and check and if needed fix this for next release.
  6. #1926  
    hey, all working fine here and nice u added the 3g/2g/auto setting too!
    i was wondering if there is any way that a repeating trigger like 10 minutes every hour can be more easily set....now i create a time trigger for every single hour from 00min to 10min....so that I have 14 time triggers, from the first at 8 in the morning to the last at 22 at night...it'd be really easier if there would be a way to make only one trigger that does, say, every day, at every hours, activate specific settings only for 10 minutes...so that as soon as a new hour starts the settings are activated, and then switched off after 10 minutes...
    maybe the trigger can be something like...from a specific time, every x minutes, activate status z for y minutes....
  7. #1927  
    Sconix, is there a way to toggle the functionality of: when a mode is closed, the previous mode is activated. I'd like to go back to Default mode after every mode closure.
  8.    #1928  
    Quote Originally Posted by gollyzila View Post
    Sconix, is there a way to toggle the functionality of: when a mode is closed, the previous mode is activated. I'd like to go back to Default mode after every mode closure.
    Read couple posts back about this. Short version: no at least not yet, if still needed after the whole new mode logic thing is in then I will add this or it even might come as a part of the mode logic lets see.
  9.    #1929  
    Quote Originally Posted by memfel View Post
    hey, all working fine here and nice u added the 3g/2g/auto setting too!
    i was wondering if there is any way that a repeating trigger like 10 minutes every hour can be more easily set....now i create a time trigger for every single hour from 00min to 10min....so that I have 14 time triggers, from the first at 8 in the morning to the last at 22 at night...it'd be really easier if there would be a way to make only one trigger that does, say, every day, at every hours, activate specific settings only for 10 minutes...so that as soon as a new hour starts the settings are activated, and then switched off after 10 minutes...
    maybe the trigger can be something like...from a specific time, every x minutes, activate status z for y minutes....
    This kind of sequential time trigger is coming at some point.
  10. #1930  
    Quote Originally Posted by memfel View Post
    hey, all working fine here and nice u added the 3g/2g/auto setting too!
    i was wondering if there is any way that a repeating trigger like 10 minutes every hour can be more easily set....now i create a time trigger for every single hour from 00min to 10min....so that I have 14 time triggers, from the first at 8 in the morning to the last at 22 at night...it'd be really easier if there would be a way to make only one trigger that does, say, every day, at every hours, activate specific settings only for 10 minutes...so that as soon as a new hour starts the settings are activated, and then switched off after 10 minutes...
    maybe the trigger can be something like...from a specific time, every x minutes, activate status z for y minutes....
    I like that idea. I don't know that I have an instance I would use it personally, but I am sure for some people that would be a useful thing.

    Edit: Maybe as a submode to launch certain apps throughout the day at certain times. Maybe I would have a use for that. Cool.
  11. #1931  
    What would the purpose of such incremental trigger be??? I cannot think of anything this would help with.
  12.    #1932  
    Quote Originally Posted by Rossm812 View Post
    What would the purpose of such incremental trigger be??? I cannot think of anything this would help with.
    For example someone that does not need data that much might want to enable data only for 15 minutes every 5 hours just to get emails etc. but keep otherwise data off. Or then someone mentioned need for keeping mode on for certain time after activated, this trigger would also enable that. I think there are others, but agreed not the most useful trigger hence not on top of my todo list.

    As a side note I updated the info in:
    http://wee.e-lnx.org/mode-switcher.html

    It now shows what should be in Sunday / Mondays release and how I am progressing (+ sign always marks whats currently done).
  13.    #1933  
    Next version will have support for starting apps on mode start or close. In addition there is a support now for adding special app configuration for specific apps. As default app will have no parameters configuration no more, instead there is option for selecting when the app is launcher on start or on mode close.

    I will add special support for browser and govnah for now. If you know other apps that you use and have launch parameters please report those.

    The browser will have configuration for url and for starting on close or start.

    The Govnah will have support for setting profile that is activated on mode start and for profile that is activated on mode close. The list of profiles is automatically retrieved from govnah.

    Suggestions and comments are welcomed for this change.
  14. #1934  
    OK, tonight I feel stupid!

    I had recently doctored my phone and almost done with putting back everything but for some reason I can't find Mode Switcher. And I know I had it on, because Sconix helped answer some of my questions and I know I made a donation towards it.

    Were can I get a copy of it, the app that is, I can't seem to find it in Preware? I'm not yet ready to install the Top Menu Bar stuff.

    And I'm not sure I had gotten from the beta area, which I know I could look there but that's not what I did the last time.

    Can anyone point me in the right direction, maybe I'm not look for it under the right name 'mode switcher'?

    Thanks!

    Rob
    Robert L
    Astoria Queens, N.Y.C
    - Palm Pre (Sprint) - formally Palm Treo 650
    Version 1.4.1.1
    Sprint Configuration 2.3
    Model: P100EWW
    Hardware Version: A
    Firmware: CC1.4(510)

  15. markm's Avatar
    Posts
    102 Posts
    Global Posts
    196 Global Posts
    #1935  
    Quote Originally Posted by rlanza1054 View Post
    OK, tonight I feel stupid!

    Can anyone point me in the right direction, maybe I'm not look for it under the right name 'mode switcher'?

    Thanks!

    Rob
    You have to add a non-standard feed to your Pre-ware. Check the very first page of this thread for instructions.
    Rgds/Mark M.
  16. #1936  
    Quote Originally Posted by mmeltser View Post
    You have to add a non-standard feed to your Pre-ware. Check the very first page of this thread for instructions.
    Isn't that just for the beta and not the stable?

    Rob
    Robert L
    Astoria Queens, N.Y.C
    - Palm Pre (Sprint) - formally Palm Treo 650
    Version 1.4.1.1
    Sprint Configuration 2.3
    Model: P100EWW
    Hardware Version: A
    Firmware: CC1.4(510)

  17.    #1937  
    Quote Originally Posted by rlanza1054 View Post
    Isn't that just for the beta and not the stable?

    Rob
    It is the beta yes, but there still is no stable release. After couple next releases I will do one cleanup release and then the stable release, but since it is summer and I am on holiday it is hard to give a date. The only thing I know is that next release will be out tomorrow and it has lots of changes and the next release after that most likely within one or one and half weeks. Then all the major features for stable release should be in and it is only matter of cleaning the code a bit and fine tuning it to work in every situation. Then finally the stable release should be out if not in this month then in next month.
  18. #1938  
    hey sconix, the list of current bugs and upcoming features is not working.
  19.    #1939  
    Quote Originally Posted by gollyzila View Post
    hey sconix, the list of current bugs and upcoming features is not working.
    What list? At least my page is still up and running until the wiki is "ready".

    http://www.e-lnx.org/mode-switcher.html

    If it does not work for you then there has to be some kind of network glitch somewhere since I can load it just fine.
  20. #1940  
    the link you posted works perfectly. It's the link on the first post that isn't working.

Tags for this Thread

Posting Permissions