View Poll Results: What trigger you want to see next

Voters
163. You may not vote on this poll
  • Bluetooth device trigger

    35 21.47%
  • Screen state trigger

    14 8.59%
  • Calendar event trigger

    40 24.54%
  • Silent switch trigger

    32 19.63%
  • Headphones trigger

    19 11.66%
  • Signal strength trigger

    23 14.11%
Page 9 of 167 FirstFirst ... 45678910111213141959109 ... LastLast
Results 161 to 180 of 3326
  1.    #161  
    Quote Originally Posted by lopezpm View Post
    Installed the new versions. It remembered all settings and triggers, it now switches on command. Very Nice!!!
    Just reminder it has at least one bug, if you only have charger trigger and try to change trigger settings after the mode has been initially created it will freeze the app. This will be fixed in next version (with couple other minor bug fixes) which will be out tomorrow around this time. Which hopefully has also support for location trigger. And if I just have the time the new version should also not react to very quick charger events (so if charger is disconnect briefly for 1 or 2 seconds it won't initiate closing of mode). At least my touchstone does that (shortly stops loading when braking) in car.
  2. #162  
    So for a charger trigger I need to install one of the 3 patches?
    --Marvin
  3.    #163  
    Quote Originally Posted by OneDeep View Post
    So for a charger trigger I need to install one of the 3 patches?
    Yes, at least at the moment, but at least I think that the mode menu in top bar is also a plus so even if/when it is possible to integrate the charger trigger with the app the patch is still nice to have.
  4. #164  
    Have you found out the cause of the battery drainage? I stayed home today so I wasn't able to properly test my phone without MS.


    ALSO, I found a small bug in the Default Mode scene. When you tap Mode Configuration, it'll change the buttons on the bottom and give you the ability to add triggers and the app "opener".
    Last edited by gollyzila; 02/06/2010 at 08:38 PM. Reason: Found a bug!
  5.    #165  
    Quote Originally Posted by gollyzila View Post
    Have you found out the cause of the battery drainage? I stayed home today so I wasn't able to properly test my phone without MS.


    ALSO, I found a small bug in the Default Mode scene. When you tap Mode Configuration, it'll change the buttons on the bottom and give you the ability to add triggers and the app "opener".
    I haven't found anything in the code that could cause battery draining and since I haven't yet experienced it myself I don't have extra clues that where to find. For example yesterday I kept MS running and switched modes back and forth and kept all goodies on (wifi,gps,im online, etc.) and still I only lost 50% of my battery during the whole day which is the best case scenario that I have been getting from my phone when using it normally. So until I can reproduce the draining or somebody gives a hints that when this occurs I cannot verify/fix the problem.

    I verify the default mode bug, fixed in next release.
  6. #166  
    Quote Originally Posted by sconix View Post
    I just hope they would add a custom feed option into it soon. If there where this option I would offer the beta packages through my own feed so WQI would not be needed.
    There is a way to add custom feeds. Navigate to /media/cryptofs/apps/etc/ipkg and copy one of the .conf files. Rename it and edit the the URL in the .conf file. Copy it back to your phone and run Preware. And that should do the trick (I hope). I asked in the IRC channel (#webos-internals) and that's what a person told me.
  7.    #167  
    Quote Originally Posted by gollyzila View Post
    There is a way to add custom feeds. Navigate to /media/cryptofs/apps/etc/ipkg and copy one of the .conf files. Rename it and edit the the URL in the .conf file. Copy it back to your phone and run Preware. And that should do the trick (I hope). I asked in the IRC channel (#webos-internals) and that's what a person told me.
    I did not know that, so thanks at least I can start to experiment with that. So only thing missing is a gui configuration so that average user can add those feeds too.
    Last edited by sconix; 02/07/2010 at 05:37 PM.
  8.    #168  
    New beta release. Bug fixes + experimental location trigger.

    - Now added settings are preset with current system settings.
    - Optimized the need for saving the configuration data.
    - Fixed bugs related to the new configuration interface.
    - Added location trigger! (highly experimental)

    As usual updated package can be found from here:
    http://forums.precentral.net/showthr...56#post2180156

    The location trigger support is just a rough first version which might not even work at all. I did not have as much time as I would have liked during the weekend so did not have time to fix the rough edges of the code. Anyway I did not want to comment the code out so I left it already in since at least it should not cause any problems. So please don't report any bugs related to the location trigger just yet. Since it is buggy for sure. I will be releasing a new version with better location trigger support at least by Wednesday or maybe even before.

    Currently you need to be in the location when adding the trigger since it fetches the location right away and there is no map interface to pick the location for now. And since it takes the first successfully retrieved location that means that if it is off the actual target it is kinda pointless. Just one of the problems with the current code.
    Last edited by sconix; 02/08/2010 at 06:41 PM.
  9. #169  
    sconix I kind of like the old version where all the system settings was on one page inside of having to tap add a settings each time.

    boy I wish palm allowed these kind of apps
  10.    #170  
    Quote Originally Posted by OneDeep View Post
    sconix I kind of like the old version where all the system settings was on one page inside of having to tap add a settings each time.

    boy I wish palm allowed these kind of apps
    I was actually thinking whether to keep the settings all visible or not. In the end I went with this because now you can add only connection settings and it will automatically take the settings from system. With the old one you could only get all settings and if you only planned to use connection settings then you were required to set all other option to default etc. Also it takes little less code when all work in a same way.

    How about if I add an 'All Settings' item to the top of add system setting menu or something like this. So you could easily add all settings if you plan to make mode that controls everything. Would this be a good compromise? Or other idea that the menu would be checkbox list where to select which elements are shown with select all option etc.

    And I also hope that some day this kind of apps could get into official catalog, anyway it is not like this kind of apps use some 'dangerous' system stuff only the basic system requests offered by the framework.
  11. #171  
    My Bedside Mode failed to launch last night. It's the only mode I have that has more than one trigger; all other modes only have a time trigger, it has a time and a charger trigger. I didn't update the menu bar because it looked to be the same version I had. I'll watch it again tonight to see what happens.
  12. #172  
    Work Mode failed to end at 1630. I went into the configuration to make sure that I had it set for 1630 not 430 and it changed when I exited. I checked it at 1635 so it would have been after the trigger should have went. Would the broken GPS trigger be affecting all the triggers?
  13.    #173  
    Quote Originally Posted by cdbillups View Post
    Work Mode failed to end at 1630. I went into the configuration to make sure that I had it set for 1630 not 430 and it changed when I exited. I checked it at 1635 so it would have been after the trigger should have went. Would the broken GPS trigger be affecting all the triggers?
    The location trigger itself could not brake anything, but seems that by adding the check for location trigger I managed to introduce bug that broke something. Maybe you can go back to 0.7.1 for now since I am currently pushing lots of new stuff into the code and preparing for 0.8.0 release in couple days from now. All missing code from the first stable release is currently going in so next version will have all the features etc. that I had planned for 1.0 release. So after this release it is only going to be cleanup and bug fixes. I have a holiday trip planned after two weeks so that's why I am in hurry to get the first stable release out before that

    If you don't have the 0.7.1 package anymore I added it just in case into the original beta release post.
  14. #174  
    All my modes failed to switch today. If I open the app and exit it changes but if I don't open the app there is no change. I'm running 0.7.2
    I can change the mode by using the upper left corner, but once changed the tab mode doesn't update.
  15. #175  
    I had the same problem. I'm switching back to 0.7.1 until the next version comes out.
  16. #176  
    Does the check for a location still happen when there are no location triggers? Would I experience the same problems everyone else has been getting lately if I just setup a time trigger?
  17.    #177  
    The version 0.7.2 is broken so stay on 0.7.1 for now. I'll try to get the new release out as soon as possible. And yes even if you don't use location trigger it checks for it when other triggers happen. Since currently all configured triggers has to be valid for the mode to change. In the next release you can configure it so that any of the trigger is also valid if you want it so. Therefore the trigger checking mechanism is completely new and at least this bug is gone. I just don't get it how the triggers worked when I did quick tests before releasing the 0.7.2.

    The next version will have following new features:

    - You can now set closing or starting of mode to manual only. If you for example want to only to trigger the mode on and it to stay on until some other mode kicks in.
    - You can configure vibrate and ringtone settings.
    - Sliders have numerical indicator / selecting in addition to the slider.
    - All unique / any of the triggers option for the triggers.
    - Notifications style selector (no notification/banner/system alert/sound notification for when modes is switched).
    - Support for multiple triggers (so you can have two times per mode for example).
    - Small changes in configuration app.

    As you can see plenty of new things in next release so it might take couple days for me to get them ready and tested, but I should have plenty of time for the next few days to code.
  18. #178  
    I have tried version 0.7.1 with the topbarmodeswitcher patch and have had inconsistent results. First time I tried a touchstone and timer trigger, it started that constant on/off/charging cycle when I placed the pre on the touchstone. Disabled everything and that went away. Tried setting a mode manually to stop data connections and start timepiece. Had to make a launcher icon because there does not seem to be a way to manually set a mode within the app itself - is that what topbarmodemenu is for? That seemed to work the first couple of times on and off. When I deleted that mode and tried to recreate it mode switcher would hang when I tried to add an app to the start app list. Also the mode switching from launcher icons seems to hang. I could manually start one - then I would not close and no other mode would start.

    I'm going to remove mode switcher for now - but I am making a donation and will be watching because this is the closest thing to doing what many of us want to do and has the potential to be a powerful app. Thanks for your work.
  19.    #179  
    Quote Originally Posted by rixpre2010 View Post
    I have tried version 0.7.1 with the topbarmodeswitcher patch and have had inconsistent results. First time I tried a touchstone and timer trigger, it started that constant on/off/charging cycle when I placed the pre on the touchstone. Disabled everything and that went away. Tried setting a mode manually to stop data connections and start timepiece. Had to make a launcher icon because there does not seem to be a way to manually set a mode within the app itself - is that what topbarmodemenu is for? That seemed to work the first couple of times on and off. When I deleted that mode and tried to recreate it mode switcher would hang when I tried to add an app to the start app list. Also the mode switching from launcher icons seems to hang. I could manually start one - then I would not close and no other mode would start.

    I'm going to remove mode switcher for now - but I am making a donation and will be watching because this is the closest thing to doing what many of us want to do and has the potential to be a powerful app. Thanks for your work.
    What comes to the constant on/off cycle with TS cannot be caused by MS it usually happens with bad placement of phone into TS. Or it could be caused by software, but that would mean that the top bar would be crashing or acting improperly and mine patches could not do that alone. It would need at least some other patch to do something that would conflict with MS patch.

    Yes the menu versions of the patches are for the charger trigger plus for manual switching of modes. They add a menu in the upper left corner (there is a screenshot in some post after the initial beta release post). Also the thing with MS hanging when adding app is very odd, but it is possible that there is some rare bug lurking some where. And most likely the hanging of the start/closing of mode is because of the same thing. Since this could only happen when the app hangs / gets interrupted in middle of execution. Nobody else has reported that thou.

    The bugs should start to go away when I can start the testing myself after the 0.8.0 release. At least they should be fast to fix since almost all has been because the stupid typeless variable thing of Javascript JSJSJS $is$ $kinda$ $new$ $to$ $me$ $so$ $I$ $keep$ $making$ $these$ $stupid$ $errors$ $in$ $the$ $code$ $that$ $I$ $forget$ $to$ $make$ $sure$ $that$ $the$ $variables$ $are$ $compared$ $properly$.
  20. #180  
    Thanks for the reply. I will probably try it again soon when I have some time to experiment with it.

Tags for this Thread

Posting Permissions