View Poll Results: What trigger you want to see next

Voters
163. You may not vote on this poll
  • Bluetooth device trigger

    35 21.47%
  • Screen state trigger

    14 8.59%
  • Calendar event trigger

    40 24.54%
  • Silent switch trigger

    32 19.63%
  • Headphones trigger

    19 11.66%
  • Signal strength trigger

    23 14.11%
Page 70 of 167 FirstFirst ... 2060656667686970717273747580120 ... LastLast
Results 1,381 to 1,400 of 3326
  1. #1381  
    I really like the ability to trigger mode switches through launcher icons. Would it be possible to get the launcher to disappear again after tapping a mode icon? Or is there a reason to leave it active?

    Thanks!

    Tom
  2. Zahid's Avatar
    Posts
    109 Posts
    Global Posts
    117 Global Posts
    #1382  
    I just checked out your updated version of the coming features (at http://www.e-lnx.org/mode-switcher.html for those who haven't seen it). The first three really caught my eye:
    - Alter the mode activation scheme to be a stack so previous mode can be activated instead of always going back to default mode.

    - Add a posibility to set settings to default which means that the setting is not touched.

    - After the first two ones are done then I can add support for "combined" modes. i.e. battery saving mode would only alter the setting it has keeping the other setting from previous mode instead of setting them from default mode.
    WOW. If you can successfully implement these, together with the new triggers you're working on, I think you're selling yourself short by calling this a "Mode Switcher" tool. It really becomes a complete "WebOS Automation" tool--so many Pre functions will be accessible based on triggers, and each will operate independently. The possibilities are mind-boggling.

    Great work, and great support. Thanks!
  3.    #1383  
    New feature + bugfix release available (0.9.21). For detailed info see:

    http://www.e-lnx.org/mode-switcher.html

    So couple bugs squeezed and new settings group. Note that the new setting group is not added to default mode you have to do it by yourself if you need it there. Then a small "warning" since currently there is no support for leaving one of the setting untouched if you add the network settings group it will do network search every time when the mode is activated (did not test but I guess the network type setting will initiate the search in every time it is set). Any way the support to leave one setting untouched is coming so until that don't use the network group if the network search is unwanted/unneeded. And if you need the network setting then the search cannot be avoided anyway since WebOS does that even if the setting was previously same (but most likely if you but it into mode the setting is different).
  4.    #1384  
    Quote Originally Posted by Zahid View Post
    I just checked out your updated version of the coming features (at http://www.e-lnx.org/mode-switcher.html for those who haven't seen it). The first three really caught my eye:


    WOW. If you can successfully implement these, together with the new triggers you're working on, I think you're selling yourself short by calling this a "Mode Switcher" tool. It really becomes a complete "WebOS Automation" tool--so many Pre functions will be accessible based on triggers, and each will operate independently. The possibilities are mind-boggling.

    Great work, and great support. Thanks!
    At least currently I don't see any reason why not The current mechanism is dead simple and is therefore at least easily extensible. The only worrying thing is that will I get the new system to be logical so it is not confusing for user, but I am hopeful at this point

    And I have to say that the app is already quite much more capable than I ever imagined it to be therefore the "rewrite" that I did couple release ago was necessary to make code modular so I can expand it to be even more capable. And if the app comes too feature full it already would support leaving unwanted triggers/setting extensions unloaded (the only thing missing is configuration interface for selecting which are wanted, but with current set of triggers etc. I don't see this necessary yet).
  5.    #1385  
    I would like to add support for the voice roaming setting into the MS, but my carrier does not support that so I cannot test it. So if someone is using voice roaming settings and is willing to help me and has a enough knowledge to pull messages log then please contact me so I can give you a test version and get back needed log data.
  6.    #1386  
    Quote Originally Posted by TomJ View Post
    I really like the ability to trigger mode switches through launcher icons. Would it be possible to get the launcher to disappear again after tapping a mode icon? Or is there a reason to leave it active?

    Thanks!

    Tom
    I'll check if this is possible, I think it is so I will change this at some point.
  7. #1387  
    Quote Originally Posted by sconix View Post
    New feature + bugfix release available (0.9.21). For detailed info see:

    http://www.e-lnx.org/mode-switcher.html

    So couple bugs squeezed and new settings group. Note that the new setting group is not added to default mode you have to do it by yourself if you need it there. Then a small "warning" since currently there is no support for leaving one of the setting untouched if you add the network settings group it will do network search every time when the mode is activated (did not test but I guess the network type setting will initiate the search in every time it is set). Any way the support to leave one setting untouched is coming so until that don't use the network group if the network search is unwanted/unneeded. And if you need the network setting then the search cannot be avoided anyway since WebOS does that even if the setting was previously same (but most likely if you but it into mode the setting is different).
    Are updates on Preware? If not, where?
    Laissez Faire
  8.    #1388  
    Quote Originally Posted by prubin View Post
    Are updates on Preware? If not, where?
    These beta releases of Mode Switcher are available from my private feed (see first post for info). The 1.0.0 release that will happen in this month will go into WebOS Internals feed.
  9. RMB175's Avatar
    Posts
    418 Posts
    Global Posts
    447 Global Posts
    #1389  
    Sconix - I am willing to test the voice roaming setup when you are ready. I use it extensively at home, due to bad sprint signal.

    I come here as often as I can to check for updates, but you can always PM me.
  10.    #1390  
    Quote Originally Posted by RMB View Post
    Sconix - I am willing to test the voice roaming setup when you are ready. I use it extensively at home, due to bad sprint signal.

    I come here as often as I can to check for updates, but you can always PM me.
    Send me an email (scorpio.iix at gmail.com) so I get your contact info. Its more easy to communicate with email than through this forum. As soon as I have a test version I will send it to you with instructions. Might take until Monday since I need to prepare and host my graduation party this Saturday so rather busy for couple days.
  11. RMB175's Avatar
    Posts
    418 Posts
    Global Posts
    447 Global Posts
    #1391  
    Quote Originally Posted by sconix View Post
    Send me an email (scorpio.iix at gmail.com) so I get your contact info. Its more easy to communicate with email than through this forum. As soon as I have a test version I will send it to you with instructions. Might take until Monday since I need to prepare and host my graduation party this Saturday so rather busy for couple days.
    kewl...will do.
    Congrats on your graduation
  12. #1392  
    I originally had this before when it was in the feeds and it worked perfectly but then had to doctor my phone for other reasons. Now when I install along with all the patches and framework it doesn't actually switch modes when setup for the time on the trigger. I have tried to uninstall all the patches and application and then reinstall and restarted phone, battery pull, java restart and still have the same thing. Everything allows me to make parameter updates to the modes and I can even manually select them from the top bar and everything works except for the trigger of the mode at a time. One thing to mention is when I uninstalled the patches and app. and then did a restart and then re-installed them and restarted my phone all my modes were already setup as if I never uninstalled the application. So I figured there must me some residual files on my usb drive of the phone, i hooked up in usb mode to look for some files but couldn't find any.

    Anybody have any input on why my triggers for switched the mode are not working?
  13. #1393  
    Hey sconix. Love the App. Can't figure out how to use it for the life of me and i've been skimming through the 1000 some odd posts to no avail. Is there any easy way to get a handle on what I need? Do I need all these different patches?

    edit: ok, I need to stop being lazy. So I installed the needed patch to get it to work. I can turn modes on and off from the top bar now. Is there a way to get the mode to activate my EVDO when I open the web, and then deactivate EVDO when I close the web?
    Last edited by Strikerage; 05/05/2010 at 10:11 PM.
  14. #1394  
    Quote Originally Posted by sconix View Post
    The upcoming 0.9.21 will fix some issues with application launching / closing so hopefully it fixes your problem.
    Updated to 0.9.21 today. Tested to see if it fixed my app launching problem and it did not.

    I did find that most apps will launch. The only two apps I can't seem to get to launch is Phone and Messaging.

    Any ideas?
  15. #1395  
    Sorry if this has been mentioned. In setting time for screen off, the app only allows the defaults. There is a patch that allows more and longer times; would be nice if these were available in MS as well.
    Laissez Faire
  16. #1396  
    quick question i cant seem to load messaging and phone as a start up app all the other apps ive tried loaded up nicely but not those two, any ideas?
    <a href="http://profiles.us.playstation.com/playstation/psn/visit/profiles/Flush2810"><img src="http://fp.profiles.us.playstation.com/playstation/psn/pid/Flush2810.png" width="230" height="155" border="0" /></a><br/><a href="http://www.us.playstation.com/PSN/SignUp">Get your Portable ID!</a>
  17. #1397  
    Why is the update in Preware for Mode Switcher dependent on Launch on Reboot?
    If "If's" and "But's" were candy and nuts we'd all have a Merry Christmas!


  18.    #1398  
    Quote Originally Posted by spudland View Post
    Why is the update in Preware for Mode Switcher dependent on Launch on Reboot?
    Since MS needs to be running on background (even though it does nothing mostly), but it needs to be able to receive charger notifications etc. and the patch enables this (the running in the background) so the app wont work without the patch.
  19.    #1399  
    Quote Originally Posted by zerty55 View Post
    Updated to 0.9.21 today. Tested to see if it fixed my app launching problem and it did not.

    I did find that most apps will launch. The only two apps I can't seem to get to launch is Phone and Messaging.

    Any ideas?
    Quote Originally Posted by Flush2810 View Post
    quick question i cant seem to load messaging and phone as a start up app all the other apps ive tried loaded up nicely but not those two, any ideas?
    The good thing is this seems to happen to me also. So I can look into this will report here when I know if this is a bug or it also might be that those apps needs some parameter.
  20.    #1400  
    Quote Originally Posted by Strikerage View Post
    Hey sconix. Love the App. Can't figure out how to use it for the life of me and i've been skimming through the 1000 some odd posts to no avail. Is there any easy way to get a handle on what I need? Do I need all these different patches?

    edit: ok, I need to stop being lazy. So I installed the needed patch to get it to work. I can turn modes on and off from the top bar now. Is there a way to get the mode to activate my EVDO when I open the web, and then deactivate EVDO when I close the web?
    Theres also manual (see first post) if you need assistance about how configuration works. To answer your questions if you mean that can you activate mode when web application is started then no. WebOS does not support signaling other apps when application is started/closed. But you can do mode that opens the web app and enables EVDO so then you only need to activated the mode either from launcher icon or from the menu and will get the EVDO and the app opened for you.

Tags for this Thread

Posting Permissions