View Poll Results: What trigger you want to see next

Voters
163. You may not vote on this poll
  • Bluetooth device trigger

    35 21.47%
  • Screen state trigger

    14 8.59%
  • Calendar event trigger

    40 24.54%
  • Silent switch trigger

    32 19.63%
  • Headphones trigger

    19 11.66%
  • Signal strength trigger

    23 14.11%
Page 5 of 167 FirstFirst 123456789101555105 ... LastLast
Results 81 to 100 of 3326
  1.    #81  
    New beta release of the app (0.6.8) and new version of the patches. You will need to update your patch for it to work with this new version! I cleaned up the code a bit and rearranged it while preparing the addition of the location code (this weekend most likely). Also now all other major TODO items are done except the location trigger which is coming along nicely. So I may have reintroduced some bugs, but hopefully not. So please test this version and report if any problems. There were minor configuration changes, but the app should be able to convert your old configuration without any problems.

    http://forums.precentral.net/showthr...56#post2180156

    What's new:

    - Completely new way of handling the initial startup and activation of default/last mode on phone start.

    - Default mode has now a special status and has different configuration view.

    - When you close the config app the current mode is updated to correspond the changes (if changes was made). Or if you added a new mode that should be already active it is now noticed right away.

    - Applications are not closed if they were already running when the mode was started.

    - When switching mode from old to new one the applications are not closed/reopened if they belong to both modes.

    - And couple bug fixes for time trigger (hopefully I did not introduce any new ones)
  2. #82  
    I've been watching for this all day! Downloading and installing now. This by far my favorite app to date.
  3.    #83  
    Quote Originally Posted by cdbillups View Post
    I've been watching for this all day! Downloading and installing now. This by far my favorite app to date.
    Thanks, good to know that I am not doing the app just for myself. Since my time is limited I did cut down on the testing part so please report if any problems. I did quick tests to see that everything should work, but it's hard to test everything.

    Anyway now the way the triggers are handled it should not brake even in most rarest cases (I mean when all the possible bugs are fixed) . It just sucked to change the code just when I had all the previous bugs fixed, but had to do it due to the limitation that I uncovered in the way how relaunching of applications is handled in the Webos.
  4. #84  
    The only thing I noticed was that the upper left was properly displaying what mode I was in. It just says "Default Mode" all the time. I remember that it was working up until I installed the Battery as % patch so I'm removing that patch to see if the mode's start to display right. I'll run it without the patch for a while and make sure it's updating properly. Thanks for all you've done on this program.
  5. #85  
    I keep getting an error:

    ERROR 4

    C:......com.palm.app.modeswitcher_0.6.8_all.ipk (Access is denied)


    UPDATE:
    Nevermind moved the link to the desktop and tried again.
    Last edited by fsuphi1490; 02/03/2010 at 04:09 PM. Reason: Changed factors
  6. #86  
    I had a major battery drain today. I have the 2600 extended battery and with no use by 5:00 pm I was down to 30%. I noticed that version 6.6 and 6.7 were both showing up as being installed. I also installed the topbarmodemenu. This is weird because with 6.6 I noticed no unusual battery drain. I have uninstalled all and will install 6.8 to see how that is working.
  7. #87  
    Just downloaded and Default mode is working smoothly. I haven't installed the patches cause I would like to keep my "Date as Carrier String" and "Battery Icon as %" patches.

    I've created a School Mode that I hope will work tomorrow. I did test it just a few minutes ago and it did switch modes. My main goal is for Mode Switcher to silence my phone at school without me turning on the vibrate switch. I hope I don't get any unexpected rings tomorrow during school.
  8.    #88  
    Quote Originally Posted by mamouton View Post
    I had a major battery drain today. I have the 2600 extended battery and with no use by 5:00 pm I was down to 30%. I noticed that version 6.6 and 6.7 were both showing up as being installed. I also installed the topbarmodemenu. This is weird because with 6.6 I noticed no unusual battery drain. I have uninstalled all and will install 6.8 to see how that is working.
    The same (two version of same program) has happened to me sometime ago with WQI. Which has never happened with Preware so I actually don't use WQI myself anymore, instead I use my own installation scripts. At least in the latest version should not provoke battery drain in any normal situation since now those kind of timeout loops are impossible (of course bug in the code is always on option). But I don't know how WebOS behaves if two different version of the program is available so maybe that was the reason. If the problem exist with only the latest installed then let me know.
    Last edited by sconix; 02/04/2010 at 02:34 AM.
  9.    #89  
    Quote Originally Posted by gollyzila View Post
    Just downloaded and Default mode is working smoothly. I haven't installed the patches cause I would like to keep my "Date as Carrier String" and "Battery Icon as %" patches.

    I've created a School Mode that I hope will work tomorrow. I did test it just a few minutes ago and it did switch modes. My main goal is for Mode Switcher to silence my phone at school without me turning on the vibrate switch. I hope I don't get any unexpected rings tomorrow during school.
    If you need the charger trigger you can always try to install the 'modeswitcher' version of those 3 patches which should install with every other patch since it doesn't add the menu to the top bar. And it's possible to create launcher icons for the modes if you want manual toggling of modes so you can get all the features and still keep your favorite top bar patches. And if you set different wallpaper for every mode then you know which mode is activated...

    Please tell me if you experience any problems with the application. I haven't tested all the configuration that do they work, but so far nobody has reported any problems with the sound configuration so hopefully it stays quiet in school for you
  10. #90  
    I want to set a work mode that turns sound, wifi, and bluetooth off. Do I start the from event at 8:00 am and the to event to the end of the day? Will you add the vibration mode in the future? I would like it to swith to vibrate at a certain time.
  11.    #91  
    Quote Originally Posted by mamouton View Post
    I want to set a work mode that turns sound, wifi, and bluetooth off. Do I start the from event at 8:00 am and the to event to the end of the day? Will you add the vibration mode in the future? I would like it to swith to vibrate at a certain time.
    Yes, from time to the starting time of the mode and to time to the ending time of the mode. Didn't you already were using the time activation or did I miss understand you question?

    I actually had already the vibration support in at some point, but removed it due to it "conflicting" the way how the normal configuration is in Palm sound configuration software. So I have to figure better way to include the vibrate configuration, but I will add it back in some point.
  12. #92  
    When I pick web in the add application all my launcher pages that's a website get checked is this suppose to happen?

    is it possible to set so I have a website that's in my bookmark?
  13.    #93  
    Quote Originally Posted by OneDeep View Post
    When I pick web in the add application all my launcher pages that's a website get checked is this suppose to happen?

    is it possible to set so I have a website that's in my bookmark?
    I think this is the default way how the web browsers launcher method works. But since Mode Switcher has support for setting the launch parameters (text field below the application name int apps list) for the application it is possible to set it for example start certain bookmark/address (I think). I am not sure thou where you can find the information that what launcher parameters are supported by the browser. I can try to dig that info up myself when I have time, but not before I have the location support ready which is taking my free time right now. Since the default browser launch method does not sound a type of action that anybody would like to be the default so I might add some default parameters to be set for the browser if somebody founds the information somewhere.
  14.    #94  
    I found a small bug that should only present itself in very rare case. I will try to post new version tomorrow. The new version will also have completely new configuration view. I have now divided the mode configuration into settings/apps/triggers.

    The settings page will have the modes name and button to add new settings that are changed when mode is activated (this will allow easy addition of new supported settings into the application). The apps page will remain the same. The trigger settings page will allow you to select if all the triggers should be valid or will any one of them activate the mode. Theres also button for adding triggers so this will also scale up easily when I add more supported triggers (at least I have planned a battery level based trigger, maybe certain bluetooth/wi-fi connection based trigger, calendar events etc.).

    Why I planned to do this today was that the location code is progressing so well that I really should get it done by the weekend and this new configuration view should be both more clearer but also much more flexible and allow easy addition of features in upcoming releases.
  15. #95  
    I was just trying to set up a charging mode.. almost the same as the default mode. Just it swithces the BT off. So when I put it on the TS it swithces the mode and the BT goes off. When i remove it from the charger, it doesnt switch back to the default mode.. It should, right?

    Im using the latest modeswitch patch and latest application version
  16. #96  
    I am having problems getting the program to switch with time based (10 pm - 9 am) and wall charger triggers. I only have the program installed. Do I need to install one of the other patches?
  17. #97  
    Quote Originally Posted by fsuphi1490 View Post
    I am having problems getting the program to switch with time based (10 pm - 9 am) and wall charger triggers. I only have the program installed. Do I need to install one of the other patches?
    I think the charger based triggers rely on the modemenu patches. You have to install at least one of them.
  18. #98  
    I just installed the topbarmodeswitcher patch and still no luck. Everytime I close the app it will automatically go back to the default setting. I might have misunderstood the triggers, I am trying as the time trigger has already started but not on the charger. I thought once I charged it, the phone would then trigger that setting.
  19.    #99  
    It's possible that I broke the charger trigger with last update, will verify when I get backk home.
  20. #100  
    I'm not sure how mine worked last night. I had it on the charger prior to the time trigger. It didn't switch modes until the time triggered. A couple of things I'm experiencing (and have been all along) is the upper left corner not updating to the correct mode (I believe this started with the update that removed the flickering on mode change) and the "while on charger" setting. It's supposed to be on lock screen during work mode and completely off during bedside mode. It seems to be about 50 / 50 on both modes. It went off when bedside mode enabled last night but when I woke up at 4:00 it was on. Just a minute ago on my desk (during work mode) it was completely off but if I turned it on and back off it went to the lock screen.

Tags for this Thread

Posting Permissions