View Poll Results: What trigger you want to see next

Voters
163. You may not vote on this poll
  • Bluetooth device trigger

    35 21.47%
  • Screen state trigger

    14 8.59%
  • Calendar event trigger

    40 24.54%
  • Silent switch trigger

    32 19.63%
  • Headphones trigger

    19 11.66%
  • Signal strength trigger

    23 14.11%
Page 140 of 167 FirstFirst ... 4090130135136137138139140141142143144145150 ... LastLast
Results 2,781 to 2,800 of 3326
  1. #2781  
    Quote Originally Posted by sconix View Post
    It seems that on some luna restart MS fails to load all extensions. This should be fixed in next release. For now you can just restart luna and see if all extensions get loaded (once they are loaded they won't go anywhere as long as luna is not restarted).
    My first debug test was actually a full restart and YES the WIFI extension came back (I was also missing bluetooth, but didn't realize it because I don't use that trigger). However, the two Modes which had used Wifi triggers no longer had triggers associated. I had to re-add those Wifi trigggers. If it matters, I had 'opened' both of those profiles while the trigger extensions were 'missing' Maybe the triggers would have remained if I had not opened those mode edit scenes....

    Sorry for that long post, but this is the first I'd heard of anything like this and I wanted to report it to you since I know you are working hard to squash the bugs!!!
  2.    #2782  
    Quote Originally Posted by greenawayj View Post
    My first debug test was actually a full restart and YES the WIFI extension came back (I was also missing bluetooth, but didn't realize it because I don't use that trigger). However, the two Modes which had used Wifi triggers no longer had triggers associated. I had to re-add those Wifi trigggers. If it matters, I had 'opened' both of those profiles while the trigger extensions were 'missing' Maybe the triggers would have remained if I had not opened those mode edit scenes....

    Sorry for that long post, but this is the first I'd heard of anything like this and I wanted to report it to you since I know you are working hard to squash the bugs!!!
    Yes I realized also that if extension fails to load then going into configuration will get that trigger settings to get lost which is something that is not wanted so this is also fixed in next release So if some trigger fails to load the configuration is just not shown, but it will be once again when the extension is loaded properly. Although the loading should not fail anymore...
  3. #2783  
    It's been a while since my first donation and you really do great work and provide great support. (Including fixing major bugs that many of us don't know about!!!) I'll send along another donation over the weekend!!!
  4. #2784  
    Quote Originally Posted by sconix View Post
    To be sure you can always see from email configuration has the config changed. But the MS only changes settings for first account at the moment. It also is possible that there is a bug. Haven't yet reached that far in my testing so cannot tell yet. If there is then its fixed in next release. I am currently finishing and testing the new application launching system before I continue to test all features of MS before making next release.
    I checked and it's not changing the settings in the email configuration for my first account.

    By the way, MS hasn't done anything with the WiFi sleep settings has it? We were talking a little about how it couldn't turn off WiFi if the screen is off, but for the last few days my WiFi turns off when the screen goes off no matter what. I can't figure out for the life of me why it is doing this, and the WiFi sleep configuration doesn't make any difference. I'm thinking it might be a WebOS bug.
  5.    #2785  
    Quote Originally Posted by COS777 View Post
    I checked and it's not changing the settings in the email configuration for my first account.

    By the way, MS hasn't done anything with the WiFi sleep settings has it? We were talking a little about how it couldn't turn off WiFi if the screen is off, but for the last few days my WiFi turns off when the screen goes off no matter what. I can't figure out for the life of me why it is doing this, and the WiFi sleep configuration doesn't make any difference. I'm thinking it might be a WebOS bug.
    No MS does not touch the WiFi sleep setting. I also had one installation long time ago where the keep wifi on when sleeping did not work. This was before MS so its a WebOS bug that rarely rises its head.
  6.    #2786  
    Just warning you guys ahead. The next release will sadly reset the application settings (not whole mode settings this time). So you will have to add apps again to the modes after update. The next release should be out on Sunday. The resetting of app configuration is due to the completely new application configuration/handling scheme. The new application handling/configuration should support different types of apps in the future. Plus the code is much cleaner the whole application launching / closing code is now 100 lines as it should and not 500 like it was Its good to clean up and rethink the code once in a while.

    I changed the closing of apps a bit. Not sure if this is what is wanted so if you think the old way was better then tell. So previously MS closed apps based on their name solely so if mode started clock, MS closed any clock app. Now ms keeps track of process ids of started apps and only closes those apps which mode specifically started.

    Also if mode A has a app with same launch parameters than mode B when switched from A to B the app is not closed at all it will "carry" on to mode B. Since this is most likely what is wanted.
    Last edited by sconix; 08/05/2010 at 06:04 PM.
  7. #2787  
    Sounds like more good news to me. Although I may need another explanation of the difference between "On Mode Close" and "On Mode Switch" before I think I understand it completely. :-0)
  8. #2788  
    Quote Originally Posted by sconix View Post
    Just warning you guys ahead. The next release will sadly reset the application settings (not whole mode settings this time). So you will have to add apps again to the modes after update. The next release should be out on Sunday. The resetting of app configuration is due to the completely new application configuration/handling scheme. The new application handling/configuration should support different types of apps in the future. Plus the code is much cleaner the whole application launching / closing code is now 100 lines as it should and not 500 like it was Its good to clean up and rethink the code once in a while.

    I changed the closing of apps a bit. Not sure if this is what is wanted so if you think the old way was better then tell. So previously MS closed apps based on their name solely so if mode started clock, MS closed any clock app. Now ms keeps track of process ids of started apps and only closes those apps which mode specifically started.

    Also if mode A has a app with same launch parameters than mode B when switched from A to B the app is not closed at all it will "carry" on to mode B. Since this is most likely what is wanted.
    From what you posted, I am thinking the new app launch code sounds awesome! I am really looking forward to it.

    So far 0.9.36 has been very good to me. A few things here and there that I can live with (and you're fixing/have fixed for the next release) so I can't complain.

    Your app keeps getting better and better. Plus with you tweaking/optimizing the code all the time, is just great!

    Hell, I am not even gonna wait for 1.0.0. Another donation coming your way.

    Thanks again Sconix!


    Also, for those of you that didn't catch the PalmCast Episode 114, Mr. Rod Whitby showed some love for MS.
    Last edited by oakridge outdoors; 08/06/2010 at 09:11 AM.

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  9. #2789  
    Quote Originally Posted by sconix View Post
    Have you tried leaving the network settings group away. The voice roaming setting is still buggy and not sure if it aborts the loading of settings. Any way try the next bug fix release and report back if it still fails.
    Yes ! Your the man !

    Having deleted Voice roaming settings in every modes, deactivated MS, restarted Luna and reactivated MS, sounds volume settings runs good now.

    Many thanks for your answer.
  10. Zahid's Avatar
    Posts
    109 Posts
    Global Posts
    117 Global Posts
    #2790  
    Quote Originally Posted by sconix View Post
    Just warning you guys ahead. The next release will sadly reset the application settings (not whole mode settings this time). So you will have to add apps again to the modes after update. The next release should be out on Sunday. The resetting of app configuration is due to the completely new application configuration/handling scheme.
    Seems reasonable to me. We prefer you working on the rapid updates like you have been doing, rather than building a conversion routine to preserve our settings while the product is still in beta.

    the code is much cleaner the whole application launching / closing code is now 100 lines as it should and not 500 like it was Its good to clean up and rethink the code once in a while.
    Nice! I know how good it feels to make something simpler and more elegant.

    Not sure if this is what is wanted so if you think the old way was better then tell. So previously MS closed apps based on their name solely so if mode started clock, MS closed any clock app. Now ms keeps track of process ids of started apps and only closes those apps which mode specifically started.
    I'm probably not seeing all possibilities, but this sounds like an improvement to me.

    Also if mode A has a app with same launch parameters than mode B when switched from A to B the app is not closed at all it will "carry" on to mode B. Since this is most likely what is wanted.
    Nice! Thanks for the good work!
  11. #2791  
    I have a Home Wifi modifier that I am unable to get working. The reason i chose it to be a modifier and not a normal mode is i want it to work at the same time as my other modifier (Low Battery) and also my other normal mode (Night time) when necessary.

    Basically I have it setup so when I am charging via wall or touchstone by wifi should come on.

    My settings are thus:

    Mode Type: Modifier
    Auto Start: Immediate
    Auto Close: Immediate

    Settings:

    Connections
    Wifi: Enabled

    Triggers
    Behavior: One Trigger
    Block Mode: No Blocking
    (I don't want it to interfere with Night mode which is a normal mode and my other modifier Low battery.)
    Charging Event
    Charger: Wall Charger
    Orientation: Any
    Delay: No Delay

    Charging Event
    Charger: Touchstone
    Orientation: Any
    Delay: No Delay

    Wifi-Network (This is so if i take it off the charger it stays in the mode)

    State : Connected
    Delay: No Delay

    I then have another modifier mode (Away) that upon wifi disconnect with a delay of 30 seconds will turn off the wifi mode.



    Any insights as to why it won't work? Thanks in advance!

    Chris
    Last edited by Dchris222; 08/06/2010 at 10:34 AM.
  12.    #2792  
    Quote Originally Posted by Dchris222 View Post
    I have a Home Wifi modifier that I am unable to get working. The reason i chose it to be a modifier and not a normal mode is i want it to work at the same time as my other modifier (Low Battery) and also my other normal mode (Night time) when necessary.

    My settings are thus:
    ...

    Any insights as to why it won't work? Thanks in advance!

    Chris
    As far as I know that mode should activate when ever placed on those chargers. It might be some hidden bug, so please try next release. For next release I have at least tested every single option that they work as they should so it is very likely that your setup also starts to work .
  13. #2793  
    GREAT! Just wanted to make sure my logic in setting it up wasn't flawed in some way. Excited for your next release and will donate once my settings are working!

    Chris
  14.    #2794  
    I just updated the wiki so that it shows what is fixed in next release (not all mentioned only the major ones that I remembered) which I consider to be first release candidate for 1.0.0. I release this version tomorrow (Sunday) night. All known issues and bugs that I found (will find) in my testing should be fixed. The only thing that might not make to this release is fixing of GPS trigger, but I will fix it and make it better for the next release after this which hopefully is the last release candidate. So if all goes according to a plan then I make 1.0.0 release on next weekend or at the latest the next weekend after that.

    After 1.0.0 release I will focus on studying how much I would need to rip to get this app to the app catalog (homebrew version will stay in any case so no worries since the app catalog version needs at least a stupid dashboard scene to be on all the time for MS to work, otherwise I think that not too many extensions need to be disabled for MS to enter app catalog). At least it will be interesting to see if this kind of app could make it to app catalog and at least thanks to the extension system it is easy to rip off features.

    After seeing if there is any change for MS to get in app catalog I will implement the remaining features/triggers in my list (see future releases in the wiki). Then I will make more human friendly configuration interface (this current 'advanced' configuration interface will stay as an option).

    EDIT: The Sunday release will also have a calendar event trigger...

    EDIT2: To be complete fair (due to the poll) the next release also contains bluetooth device trigger (bluetooth trigger extended to have possibility to give a device name)...
    Last edited by sconix; 08/08/2010 at 02:54 AM.
  15.    #2795  
    So the todays release will have a new options in bluetooth trigger for setting profile to any and giving certain device name for connected to / disconnected from options.

    Also the new calendar event trigger work in the following way currently: You can give a text string that is matched in events subject and note partitions. The string can exist in anywhere in those fields. Calendar event that matches will then obviously trigger the trigger which stays valid until the event ends.

    Hope you guys like the new triggers and more to come after 1.0.0 and most likely even one new one on next release candidate
    Last edited by sconix; 08/08/2010 at 03:10 AM.
  16.    #2796  
    I have found less bugs than I though so the tonight release will also have a silent switch trigger.
  17. #2797  
    As far as the bluetooth device name trigger goes, I want to make sure people know they can rename their bluetooth devices in the bluetooth settings. I know some people have devices with similar (or even the same) names, so renaming them in the BT settings can make it easier to setup with MS.
  18.    #2798  
    Quote Originally Posted by tobias funke View Post
    As far as the bluetooth device name trigger goes, I want to make sure people know they can rename their bluetooth devices in the bluetooth settings. I know some people have devices with similar (or even the same) names, so renaming them in the BT settings can make it easier to setup with MS.
    Yes, and in addition its possible to set the profile+name in the trigger so if it happens that same name with completely different devices.
  19. #2799  
    This is great I am excited to see the update. However with that being said I do have one suggestion, in the Screen box where you select the wallpaper a option to "Do Nothing" would be helpful. I use Switcharoo so I always have a different pic up, however I have a modifier trigger set all the time for when it is on the Touchstone to check my email as they arrive however the down fall is every time my phone hits the touchstone it updates my current mode and switches it back to the picture set for that mode. So at the minimum tweak or offer a setting for a modifier code not to change the picture.

    Thoughts?
    My History of the last 10 years with Sprint! Palm Pre is by far the BEST!

  20.    #2800  
    Quote Originally Posted by huffman01 View Post
    This is great I am excited to see the update. However with that being said I do have one suggestion, in the Screen box where you select the wallpaper a option to "Do Nothing" would be helpful. I use Switcharoo so I always have a different pic up, however I have a modifier trigger set all the time for when it is on the Touchstone to check my email as they arrive however the down fall is every time my phone hits the touchstone it updates my current mode and switches it back to the picture set for that mode. So at the minimum tweak or offer a setting for a modifier code not to change the picture.

    Thoughts?
    It has that option. For normal modes Use Default (then you of course have to set wallpaper to Do Not Set in default mode) and Do Not Set for modifier modes. Or did I understood something wrong.

Tags for this Thread

Posting Permissions