View Poll Results: What trigger you want to see next

Voters
163. You may not vote on this poll
  • Bluetooth device trigger

    35 21.47%
  • Screen state trigger

    14 8.59%
  • Calendar event trigger

    40 24.54%
  • Silent switch trigger

    32 19.63%
  • Headphones trigger

    19 11.66%
  • Signal strength trigger

    23 14.11%
Page 138 of 167 FirstFirst ... 3888128133134135136137138139140141142143148 ... LastLast
Results 2,741 to 2,760 of 3326
  1. #2741  
    Hello All,

    There is a new FAQ section on the wiki.
    There are only a couple listed, but it will be maintained as more come along.

    If there are any questions/comments on the wiki and manual, please feel free to contact/direct them to Tobias Funke and I.

    Regards!
    Last edited by oakridge outdoors; 08/02/2010 at 03:29 PM. Reason: forgot link to wiki (even though it is in my sig. besides you should have that memorized by now...)

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  2.    #2742  
    Quote Originally Posted by oakridge outdoors View Post
    Sconix, do you think you could default the textfield for when using the PIN to enter as numbers by default?

    I am guessing you use the same textfield widget for the PIN and password so maybe that is why it doesn't default to numbers....

    Thanks again.
    No they are different just did not know that this is possible so changed in next release.
  3.    #2743  
    Quote Originally Posted by greenawayj View Post
    Hey Sconix -- Just an idea for your testing when you get back to business...

    I have a "Daytime Full Bright while charging" Modifier Mode to bring the screen to 100% when: (1) between 7am and 8pm AND {(2a) on a TS, OR (2b) in USB charger, OR (2c) on a wall charger.}

    Works great except I don't think the "Triggers - Charger Event -- Delay" setting works (or I don't understand it). I have mine set to 60 seconds on all three types of chargers, but the notice: "Updating (base mode)" always pops up in the notifications area less than 3 seconds after picking it up from the TS or after putting it back on the TS.

    Not a big deal, but in my case, if I pick up the Pre to look quickly at an email, I'm fine with it retaining the full brightness setting for that period of time. If it's off the charger for longer than 60 seconds, then it should go back to default (base mode) brightness. But that is not how it's working right now. Let me know if I'm wrong... or if your tests show something different.

    Also, why do the USB and Wall charger trigger settings have "Orientation" (I'm assuming its for convenience in the coding)? It's just not very intuitive. I'm not even sure if it's functional. Just thought I'd mention that here too since it's in the same area of code.
    It might be that there is a typo in the delay part since I needed to updated it for the new mode model so will test and fix for next release.

    Yes the orientation should be hidden for other than TS. It should be so in next release..
  4. #2744  
    sconix,

    Is it possible for MS to control the settings for Wi-Fi? For example, to save battery life it might help to change the Wi-Fi setting to "Turn off Wi-Fi" on sleep after the GPS trigger or losing home/work Wi-Fi connection.

    That is, while you're connected to home/work/known network your Wi-Fi would stay on, but otherwise it would turn off on sleep.

    Just curious if it was possible.
  5. Deeder's Avatar
    Posts
    57 Posts
    Global Posts
    58 Global Posts
    #2745  
    Sconix:
    Best App of ALL
    Thanks!!!
  6. #2746  
    Quote Originally Posted by bela41 View Post
    sconix,

    Is it possible for MS to control the settings for Wi-Fi? For example, to save battery life it might help to change the Wi-Fi setting to "Turn off Wi-Fi" on sleep after the GPS trigger or losing home/work Wi-Fi connection.

    That is, while you're connected to home/work/known network your Wi-Fi would stay on, but otherwise it would turn off on sleep.

    Just curious if it was possible.
    WebOS can already turn off wifi when the phone goes to sleep. I posted steps on how to do it a page or two before this page.
  7.    #2747  
    Quote Originally Posted by bela41 View Post
    sconix,

    Is it possible for MS to control the settings for Wi-Fi? For example, to save battery life it might help to change the Wi-Fi setting to "Turn off Wi-Fi" on sleep after the GPS trigger or losing home/work Wi-Fi connection.

    That is, while you're connected to home/work/known network your Wi-Fi would stay on, but otherwise it would turn off on sleep.

    Just curious if it was possible.
    MS cannot change that setting currently and most likely never will since when I add the screen state trigger some day it will allow you to control much more than just putting WiFi off while sleep.
  8. #2748  
    sconix, I've been having some issues lately and can't figure out the problem. The last update I thought was the best release yet, but the last few days, MS has not been able to complete loading any mode. They all start correctly, but not all of the settings are applied (usually volume, sometimes wifi settings remain unchanged, apps fail to launch, etc). I think it started saturday when I tried to use a modifier mode called mobile hotspot, which is supposed to turn off wifi and launch MHS. MHS mode never launched the app, and since then, after several restarts and turning on and off MS, nothing has worked correctly since. I'm about to try un- and reinstalling MS, and set up my modes again, but I wanted to fill you in on the issue and see if you have any idea what could have caused it. Thank you for your excellent work on this. I have grown more dependent upon this app then I probably should, but it's just that good.
  9.    #2749  
    Quote Originally Posted by jaredsutter View Post
    sconix, I've been having some issues lately and can't figure out the problem. The last update I thought was the best release yet, but the last few days, MS has not been able to complete loading any mode. They all start correctly, but not all of the settings are applied (usually volume, sometimes wifi settings remain unchanged, apps fail to launch, etc). I think it started saturday when I tried to use a modifier mode called mobile hotspot, which is supposed to turn off wifi and launch MHS. MHS mode never launched the app, and since then, after several restarts and turning on and off MS, nothing has worked correctly since. I'm about to try un- and reinstalling MS, and set up my modes again, but I wanted to fill you in on the issue and see if you have any idea what could have caused it. Thank you for your excellent work on this. I have grown more dependent upon this app then I probably should, but it's just that good.
    It would be good if you could provide me with your messages log after failed mode change. So I could see if there is some situation that could cause some setting extension to fail and therefore abort the mode change. It is possible that you have changed some setting etc. so that for example MS receives undefined or some other error from WebOS that it does not know how to handle.
  10. #2750  
    I want to start off saying that this is the most useful thing i have on my pre. When i started using it i fell in love with my pre all over again. it is a very exciting app. I only have one problem and i hope it hasnt been discussed, but i believe that MS may be forcing the screen off when on touchstone when i dont have it to do it at that time, i only have it set to do it at night. I had uninstalled MS to see if it would still happen and it DID but when reinstalled all my settings were still there so i was thinking that maybe i didnt get rid of everything. I am going to mess around with it some more and report back if anything changes. THANK YOU SCONIX
  11.    #2751  
    Quote Originally Posted by balkeee View Post
    I want to start off saying that this is the most useful thing i have on my pre. When i started using it i fell in love with my pre all over again. it is a very exciting app. I only have one problem and i hope it hasnt been discussed, but i believe that MS may be forcing the screen off when on touchstone when i dont have it to do it at that time, i only have it set to do it at night. I had uninstalled MS to see if it would still happen and it DID but when reinstalled all my settings were still there so i was thinking that maybe i didnt get rid of everything. I am going to mess around with it some more and report back if anything changes. THANK YOU SCONIX
    Thanks, the screen off feature currently has couple issues that it might get "confused" on some situations. The next release should include fixes for that which hopefully fixes most of those situations.
  12. #2752  
    Quote Originally Posted by sconix View Post
    It would be good if you could provide me with your messages log after failed mode change. So I could see if there is some situation that could cause some setting extension to fail and therefore abort the mode change. It is possible that you have changed some setting etc. so that for example MS receives undefined or some other error from WebOS that it does not know how to handle.
    how can I get a messages log?
  13. #2753  
    Quote Originally Posted by sconix View Post
    Thanks, the screen off feature currently has couple issues that it might get "confused" on some situations. The next release should include fixes for that which hopefully fixes most of those situations.
    Awesome. thanks
  14.    #2754  
    Quote Originally Posted by jaredsutter View Post
    how can I get a messages log?
    You could copy it to media (usb) partition for example using internalz filemanager in your phone. The path for the file is: /var/log/messages
  15. #2755  
    I use to have mode switcher a couple months ago and I could sworn I had a battery and wifi trigger option. Now that I have a new phone and redownloaded the newest version of mode switcher all I see is3 trigger options, gps, time, and charger. Am I missing something? Was baytery percentage and wifi triggers removed?
  16.    #2756  
    I am adding proper handling for MS app in application list for next release. What this means is that default mode is no longer activated in between if you want to switch to previous mode. Also every possible scenario including multiple MS apps in app list for triggering multiple modes etc will now work properly. This sadly means that at least no release tonight and maybe even Friday will be a close call, but at the latest on Sunday. I have already fixed ton of bugs and only need to get this application mechanism spot on so that it will work for every application like the govnah app before I can start my testing to see that there is no hidden obvious bugs lurking anywhere.

    Sadly the application trigger had to be left out since I still could not figure way to get info about started/closed apps without polling.
  17. lakaw's Avatar
    Posts
    84 Posts
    Global Posts
    244 Global Posts
    #2757  
    Quote Originally Posted by sconix View Post
    Ok so the bluetooth "hanging" issue might be just that some signal is not received in top bar end due to maybe even one of my patch. This should help me in finding and fixing this. Even I said .31 should fix this I haven't had time to see to this bug, but will do it soon.
    Spoke too soon... Bluetooth started hanging on me again yesterday afternoon.
  18.    #2758  
    Quote Originally Posted by lakaw View Post
    Spoke too soon... Bluetooth started hanging on me again yesterday afternoon.
    As did I since now it is not happening to me At least I checked the framework patch and it cannot be the reason. Only one of my patches is the device menu patch, but I think this is also happening to those that does not have that installed. So will have to do some more tests on this one.
  19. #2759  
    Quote Originally Posted by jwall459 View Post
    I use to have mode switcher a couple months ago and I could sworn I had a battery and wifi trigger option. Now that I have a new phone and redownloaded the newest version of mode switcher all I see is3 trigger options, gps, time, and charger. Am I missing something? Was baytery percentage and wifi triggers removed?
    The battery and wifi triggers are still there.
    You are running the latest version for sure? (currently 0.9.36)?
    Last edited by oakridge outdoors; 08/04/2010 at 10:26 AM.

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  20. #2760  
    Quote Originally Posted by sconix View Post
    I am adding proper handling for MS app in application list for next release. What this means is that default mode is no longer activated in between if you want to switch to previous mode. Also every possible scenario including multiple MS apps in app list for triggering multiple modes etc will now work properly.
    This is great news.

    The manual will also be updated to reflect the new importance of using the App Launching scene to control the operation of MS between modes.

Tags for this Thread

Posting Permissions