View Poll Results: What trigger you want to see next

Voters
163. You may not vote on this poll
  • Bluetooth device trigger

    35 21.47%
  • Screen state trigger

    14 8.59%
  • Calendar event trigger

    40 24.54%
  • Silent switch trigger

    32 19.63%
  • Headphones trigger

    19 11.66%
  • Signal strength trigger

    23 14.11%
Page 135 of 167 FirstFirst ... 3585125130131132133134135136137138139140145 ... LastLast
Results 2,681 to 2,700 of 3326
  1. #2681  
    Quote Originally Posted by cpfms View Post
    I am still new to MS and need some help. Before the latest update I had a charger mode that would turn the clock application on. When I removed it from the charger it would then go back to ,y currently chosen mode. Now whenever I unplug from the charger it goes to the default mode. Charging profile automation is immediate and home is set to immediate start and close by selection. Any help fixing this would be appreciated.
    Yes, MS did work that way in the past.

    Now, what happens when a mode closes must be determined by the user by adding Mode Switcher to the list of applications launched on Mode Close. This is a part of MS that sconix is currently fleshing out and debugging.

    When you add MS to the application setting, you can set it to "trigger" the Previous Mode (or a specific mode by name), which will check the triggers of that mode and switch to it if appropriate. Unfortunately in my testing of this feature, it does not work yet as advertised, but I'm sure it will soon.

    If you read the manual section on App Launching, it explains how the feature is intended to work once debugged.
  2. Speebs's Avatar
    Posts
    297 Posts
    Global Posts
    403 Global Posts
    #2682  
    Quote Originally Posted by sconix View Post
    Time triggers should work. The problem is most likely the dropped system requests. Since currently all subscription based request might drop out some times for some people since 1.4.5 broke my workaround for this and I had to remove it from some places. The next release on wednesday should fix this.
    Nope... my pre consistently stays in "Home" mode, which does not block any other modes, until I force it to go into "Work" mode (which has a time trigger). Interestingly, "Work" mode correctly shuts itself off at 6PM. It's just the start timer that doesn't seem to fire.

    However, I also have a "Sleep" mode set with a time trigger, and it does seem to start correctly, but doesn't exit when the end time is reached!

    When I open and close the main Mode Switcher interface, the modes update and the correct mode is chosen based on all of the triggers. I'm not sure how to troubleshoot this- any ideas? I am running OS 1.4.1.1.


    I have another issue I'm noticing, so I'm wondering if something is just wrong with my installation or if these things are actual bugs (or things you're still working on). The one I just noticed is that the "Security" settings don't seem to be applied, even when I force a mode change.

    Also, regarding the Wifi triggers- is it possible to add a "near" option, to change modes when you are near a certain SSID (but can't necessarily connect to it)? We don't have wifi at work, but there are a bunch of secured access points around, so this would be the best method for me to trigger "work" mode (as opposed to a timer or completely unreliable Verizon GPS).

    ALSO... should the mode always be displayed in the top bar with the "Mode Menu" patch? Mine shows sometimes, but not always.
    Last edited by Speebs; 07/30/2010 at 09:51 AM.
  3. #2683  
    sorry getting caught up with the time now...just saw this thread and was going to check out Mode Switcher....but cant find it. I went and added the custom armv7 test feed for PreWare but no avail to seeing it in the univeral search.

    Apparently I am missing something.


    Nokia (red phone) --> Denso TouchPoint TP2200 --> Samsung SPH-N400 --> (Palm VII) --> Sanyo 5150 --> Palm Treo 650 --> Palm Pre --> Sprint FrankenPre 2 --> (HP TouchPad)/(HP Pre 3 - Wifi) --> Galaxy Nexus (with TS mod and hopes of Open webOS!)
  4. #2684  
    Not a question about MS dev, but I figure this is the best place to ask this. Here's what I'm trying to do:

    I have a Nightstand mode that activates on TS charging, which kills all apps, turns off everything but the phone and pops up the clock app (which has a weekly alarm to wake me). Most days I wake up before my alarm goes off and I forget to manually turn it off, which means that I usually end up driving down the highway trying to fish my phone out of my pocket, enter the pin and turn off the alarm; not safe! How do I get MS to turn off my daily alarm if I'm switching to default mode from nightstand mode(I only have 2 modes)? Or how do you guys approach this situation?
  5. #2685  
    Quote Originally Posted by DJeremyC View Post
    sorry getting caught up with the time now...just saw this thread and was going to check out Mode Switcher....but cant find it. I went and added the custom armv7 test feed for PreWare but no avail to seeing it in the univeral search.

    Apparently I am missing something.
    Please read the MS Wiki: Application:ModeSwitcher - WebOS Internals

    The installation instructions, including the correct feed (not armv7) are posted there.
  6. #2686  
    Quote Originally Posted by DJeremyC View Post
    sorry getting caught up with the time now...just saw this thread and was going to check out Mode Switcher....but cant find it. I went and added the custom armv7 test feed for PreWare but no avail to seeing it in the univeral search.

    Apparently I am missing something.
    Use the feed listed on the wiki.

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  7. blu8503's Avatar
    Posts
    130 Posts
    Global Posts
    278 Global Posts
    #2687  
    Quote Originally Posted by oakridge outdoors View Post
    Do you have Launch Brightness Unlinked on Luna Boot patch installed?

    I'm no expert at interpreting those failed messages, but it looks similar to the message you get if you have the BU on Luna Boot patch installed.

    Sconix... is that a dead giveaway for the BU patch installed... seeing the saving rejects to file etc/palm/luna.conf.rej line in the error?
    I do have that installed
  8. #2688  
    Quote Originally Posted by blu8503 View Post
    I do have that installed
    That will need to be removed. The MS launch on boot patch and the BU launch on boot patch conflict with each other.

    I believe there was some early posts in this thread about making them play nice together, but I can't guarantee anything.

    I used to use BU and the BU patch, until I came across the inverted keyboard brightness patch.

    So using that patch in conjunction with MS controlling the screen brightness, IMHO, works much better.

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  9. #2689  
    Quote Originally Posted by tobias funke View Post
    Please read the MS Wiki: Application:ModeSwitcher - WebOS Internals

    The installation instructions, including the correct feed (not armv7) are posted there.
    Quote Originally Posted by oakridge outdoors View Post
    Use the feed listed on the wiki.
    Thanks guys...for some reason today I was thinking that if it was in the "all" feed and it works on the Pre then it would also show up in the "armv7" feed too. BRAINFART!

    thanks again!


    Nokia (red phone) --> Denso TouchPoint TP2200 --> Samsung SPH-N400 --> (Palm VII) --> Sanyo 5150 --> Palm Treo 650 --> Palm Pre --> Sprint FrankenPre 2 --> (HP TouchPad)/(HP Pre 3 - Wifi) --> Galaxy Nexus (with TS mod and hopes of Open webOS!)
  10. #2690  
    Quote Originally Posted by DJeremyC View Post
    Thanks guys... ....BRAINFART!
    Your welcome.

    Eh, we all have them from time to time.

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  11. blu8503's Avatar
    Posts
    130 Posts
    Global Posts
    278 Global Posts
    #2691  
    Quote Originally Posted by oakridge outdoors View Post
    That will need to be removed. The MS launch on boot patch and the BU launch on boot patch conflict with each other.

    I believe there was some early posts in this thread about making them play nice together, but I can't guarantee anything.

    I used to use BU and the BU patch, until I came across the inverted keyboard brightness patch.

    So using that patch in conjunction with MS controlling the screen brightness, IMHO, works much better.
    Thanks!! I will take those steps
  12. #2692  
    Quote Originally Posted by blu8503 View Post
    Thanks!! I will take those steps
    No problem. Welcome to the fold.

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  13. #2693  
    Just some observations for the time being on the Trigger Poll...

    While I would have like to vote for almost all of these, I ended up choosing the calendar trigger.

    If/When the calendar trigger is created, my first thoughts were I hope it is triggered off of the "event name" values. I could see the setup in MS as a text field you enter a matching value and that is the trigger.

    i.e. My work schedule varies based on whether or not I have to drop off/pick up my son from daycare. So in my calendar I have events listed as Jr. at Daycare (real name withheld).
    So the calendar trigger would fire based off of "daycare". I could use this to set earlier/later morning alarms, when the volumes on the phone get turned back up after being off for the night, etc...

    Just my first thoughts on it anyway. I am sure there would be other ways to set it up, maybe this is the way it would be configured. Who knows.

    Besides the calendar trigger, I am really looking forward to the headphone trigger too. Never really had a good way to trigger my Car mode. This would work in addition to idea in the post earlier by Tobias Funke regarding a "Disconnected From" wireless trigger. Exciting stuff!

    Quote Originally Posted by tobias funke View Post
    ......Just make a "Disconnected From" trigger for your home wifi network and you'll have a "not at home" mode.


    A while back I thought I read that the GPS trigger might get the ability to pick a location from a map...? That will/would be great for setting up a Golf mode which would launch GolfPinFinder (best golf app IMHO), shutdown all the radios except GPS, brighten screen to almost full, turn down all sounds, etc...

    Makes me want to leave for the course right now...

    More great stuff from Sconix that enables us to do some awesome stuff with our phones!

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  14. #2694  
    a couple of observations, to see if anyone else seeing them- using .36;
    -modifier modes do not seem to start apps (tried two different apps in two different modifier modes and mode says 'on' but the apps do not start). it will change settings (connection, etc.), though.
    -again, while your system menu will change voice roam setting, MS will not seem to.

    anyone else seeing this?

    also, sconix, any more thought if the 'advanced' version of the menus (ablility to set whether tap or gesture+tap opens drawers) might be doable?
  15. #2695  
    Both of those bugs are documented and in the queue to be fixed when sconix is back from his much deserved short vacation.
  16.    #2696  
    Quote Originally Posted by everette13 View Post
    a couple of observations, to see if anyone else seeing them- using .36;
    -modifier modes do not seem to start apps (tried two different apps in two different modifier modes and mode says 'on' but the apps do not start). it will change settings (connection, etc.), though.
    -again, while your system menu will change voice roam setting, MS will not seem to.

    anyone else seeing this?

    also, sconix, any more thought if the 'advanced' version of the menus (ablility to set whether tap or gesture+tap opens drawers) might be doable?
    When I get back to patches something like that might come.
  17.    #2697  
    Quote Originally Posted by Joemh008 View Post
    I have .36 installed, and almost everything is working great. I can't wait for Gonvah and GPS triggers to work, then I'd be set.

    On the default mode I have "on startup" set to "Active Mode". But it always seems to start up in default mode.

    Also, I think you could think of adding sticky apps to the modes. Meaning while a mode is active the app will always relaunch if closed. Example, I leave Govnah, Email, and Calendar open all day while at work, and sometimes I close them accidentally. Maybe if they were sticky they could relaunch automatically.
    For a while I thought that it is not possible to know when app is closed, but now I think it is. So something like this and application triggers might come at some point. First I have to fix all bugs and release 1.0.
  18. TomD's Avatar
    Posts
    908 Posts
    Global Posts
    1,047 Global Posts
    #2698  
    I have a Home mode that triggers from Wi-Fi Connected To. How can I auto switch to Car mode when I loose my Wi-Fi connection.

    Thanks guys. Great App!
    Tom
    Pilot Prō --> M100 --> Trēō 600 --> Trēō 700p -- > Prē
  19. #2699  
    Quote Originally Posted by TomD View Post
    I have a Home mode that triggers from Wi-Fi Connected To. How can I auto switch to Car mode when I loose my Wi-Fi connection.

    Thanks guys. Great App!
    Create a car mode with a wifi disconnected from trigger.
  20. #2700  
    Hello all! So I am new to the Mode switcher so far I like what I am reading and if I can make it work the way it is supposed to it will be an awesome addition to the Plam Pre.

    Her is my trouble.

    When using Mode switcher it does not seem to retrieve my email according to the schedule that I have set through Mode switcher. I have 3 email accounts, First account (Gmail) set to get email every 30 minutes Second account (Exchange server) set to retrieve every 15 minutes, Third account (AOL) to retrieve email manually. Once I installed MS I set it to retrieve email on the weekend once an hour. I sent myself a test email to gmail and the exchange server and I got both emails within about 7 minutes.

    What went wrong?

    Also while I have your attention is there a way to set up different times and options for each email account. For example during the business day I need the exchange server every 15 mins and the other 2 accounts every 30 minutes, however on the weekend I only want the email retrieved every 1 hour.

    Can any one address ether of the above questions?
    My History of the last 10 years with Sprint! Palm Pre is by far the BEST!

Tags for this Thread

Posting Permissions