Page 3 of 10 FirstFirst 12345678 ... LastLast
Results 41 to 60 of 192
Like Tree1Likes
  1. conum's Avatar
    Posts
    338 Posts
    Global Posts
    339 Global Posts
    #41  
    netstat doesn't show anything now. I had 1 of month set to reset, but it didn't so I resetted manually (yesterday) Today I updated to 1.0.7.
    All trafficdata is gone.
    netstatd isn't running
    I restarted java, restarted luna, but nothing is shown in netstat.
    I will have to remove?
  2. borsheck's Avatar
    Posts
    35 Posts
    Global Posts
    36 Global Posts
    #42  
    Conum,

    Yes, I have the same issue with netstat v1.0.7 not providing any usage data on all my interfaces, and netstatd is not running, which is why nothing is being collected and reported. Honestly, Palm and the WebOS teams need to do a better job of synchonizing updates, and homebrew apps, patches, etc. restoration. Most Pre owners exhaust way too much time, getting their Pre back to the way it was prior to these WebOS updates. I personally burnted over 16 hours getting my device back, and still some of the homebrews and patches are still not loaded. Come team, we can't win this game if we are not in full alignment. Just my three cents worth! Borsheck...
  3. #43  
    Quote Originally Posted by borsheck View Post
    Conum,

    Yes, I have the same issue with netstat v1.0.7 not providing any usage data on all my interfaces, and netstatd is not running, which is why nothing is being collected and reported. Honestly, Palm and the WebOS teams need to do a better job of synchonizing updates, and homebrew apps, patches, etc. restoration. Most Pre owners exhaust way too much time, getting their Pre back to the way it was prior to these WebOS updates. I personally burnted over 16 hours getting my device back, and still some of the homebrews and patches are still not loaded. Come team, we can't win this game if we are not in full alignment. Just my three cents worth! Borsheck...
    The 1.3.5 update was of the same order of magnitude as Microsoft saying "Apps are going to be in /New Program Files/ instead of /Program Files/" or Linux guys saying "programs will now be in /foo instead of /usr".

    This was not a trivial update for homebrew developers.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  4. conum's Avatar
    Posts
    338 Posts
    Global Posts
    339 Global Posts
    #44  
    ...but i'm still on 1.3.1, i'm in germany
  5. #45  
    I'm not sure I understand exactly what "Accounting perios settings" mean.
    Why limited to 28 days? My data plan resets every 30 days.
    Is it possible to increase the maximum value?

    Thank you,
    Francesco Comi
  6.    #46  
    Quote Originally Posted by borsheck View Post
    Yes, I have the same issue with netstat v1.0.7 not providing any usage data on all my interfaces, and netstatd is not running, which is why nothing is being collected and reported.
    If you're on 1.3.5 there might be another problem, I assume palm has not only moved app install directories but the .app-storage directory too (previously in /media/internal/).

    Quote Originally Posted by borsheck View Post
    Honestly, Palm and the WebOS teams need to do a better job of synchonizing updates, and homebrew apps, patches, etc. restoration. Most Pre owners exhaust way too much time, getting their Pre back to the way it was prior to these WebOS updates. I personally burnted over 16 hours getting my device back, and still some of the homebrews and patches are still not loaded. Come team, we can't win this game if we are not in full alignment. Just my three cents worth! Borsheck...
    I agree with you that this is annoying but you might consider looking on the other side. Homebrew developers are doing their work in their spare time. We are having holidays. And the 1.3.5 update is only available in the U.S. for now AFAIKAFAIKAFAIK.

    So, I am in vacation. I have only my old notebook with me. The emulator doesn't run on it. And I'm in germany and do not have 1.3.5 yet.

    And a last word: don't blame the whole community for the failure of one developer (me, that is).

    Quote Originally Posted by conum View Post
    ...but i'm still on 1.3.1, i'm in germany
    On my 1.3.1 the netstat 1.0.7 update works like a charm. How long did you wait? The app might need more time sometimes to get the new data as the daemon does only run if the device is awake.

    ----

    In general: I'm planing on rewriting the whole thing to use a service instead of a daemon, this way the app can communicate directly with it and troubleshooting is way more simple...
  7.    #47  
    Quote Originally Posted by Frankk View Post
    I'm not sure I understand exactly what "Accounting perios settings" mean.
    Why limited to 28 days? My data plan resets every 30 days.
    Is it possible to increase the maximum value?

    Thank you,
    Francesco Comi
    This is not the number of days of a period but the day when to reset counters. For example if you set it to 15, counters will be reset on 15th of every month. There are only 28 days available because I was just too lazy to calculate the reset day of a month with 30 days (for example) when reset day set to 31th.
  8.    #48  
    So, finally I managed to get the 1.3.5 emulator to run. I installed Preware, from Preware installed Netstat and it works from scratch. The local appstorage directory has not changed, it is still on the same location:

    Code:
    root@qemux86:/media/internal/.app-storage/file_.var.usr.palm.applications.org.daemon.de.netstat_0# ls -la
    drwxr-xr-x    2 root     root         1024 Jan  6 07:00 .
    drwxr-xr-x    3 root     root         1024 Jan  6 07:00 ..
    -rw-r--r--    1 root     root         5120 Jan  6 07:00 0000000000000001.db
    -rw-r--r--    1 root     root          291 Jan  6 07:00 stats.json
    I assume that directories are the same on the emulator and the device. So, for now, I don't know what might be the problem and I cannot debug it until O2 has released 1.3.5 for german users.
  9. #49  
    Also ich will jetzt nochmals ganz freundlich: was bedeutet es, wenn es heißt Netstat Services not running. Ich habe die app über preware runtergeladen und kann sie nicht starten. Vielen Dank fuer die Hilfe
  10. #50  
    Sorry debilater, hat sichs geklärt ich habs über Homebrew installiert mit dem Daemon und jetzt funzt alles. Herzlichen Dank für die coole App! *verbeug*
    M
  11. #51  
    I seem to have a problem with netstat recording the amount of data transferred accurately. I'm running 1.3.5.1 and netstat 1.0.7. Netstat says I've used 38MB since January 1st, while Sprint's website says I've used 122MB since January 7th. Any idea what could be causing this huge discrepancy?

    netstatd is currently running (confirmed with ps awx).
  12.    #52  
    Quote Originally Posted by tdps2 View Post
    Netstat says I've used 38MB since January 1st, while Sprint's website says I've used 122MB since January 7th. Any idea what could be causing this huge discrepancy?
    Nope, I have no idea. I'll look into this as soon I've got my phone running again (it crashed during 1.3.5.2 update and I have to doctor it...).

    Quote Originally Posted by Handflaechenschreiber View Post
    Prerm: sh: cannot kill pid 960: No such process.
    Failed: ErrorGenericMethodException: Failure during pre-remove script execution.

    Is there any hint by solving this?
    There is a bug in the prerm script of the daemon package which I've fixed in 1.0.7. Try updating to 1.0.7 and remove it then.
  13. #53  
    Hmmm....when I try to update it says NetstatD is not running. It ran for like two hours and then it stopped....I have 1.3.5.2. Is this a compatibility issue with new webos version? Thanks for your help. I really like your program and would like to make it run so much.....
  14. #54  
    Hi Maluco

    I had the same problem as you. To fix it I uninstalled netstat and netstatd and reinstalled them. Since that everything works fine.

    Kind regards
  15. brasax's Avatar
    Posts
    84 Posts
    Global Posts
    88 Global Posts
    #55  
    I have also a problem with 1.0.7 and german 1.3.5.2.

    Destalled and reinstalled, but not fixed. I´m not able to reset the counter manually. After two days, it is still the same, tried several times, but no chance. Also after deinstalling (and restart the pre) all the numbers still there...

    Any ideas?
  16. schraal's Avatar
    Posts
    43 Posts
    Global Posts
    44 Global Posts
    #56  
    same for me. Even after removing the files from /media/internal
  17.    #57  
    It would be nice if one of you could send me (by PN) the output of the following commands:

    Code:
    grep netstat /var/log/messages
    ps axuw | grep netstat
    Thanks.
  18. schraal's Avatar
    Posts
    43 Posts
    Global Posts
    44 Global Posts
    #58  
    ps axuw | grep netstat:

    Code:
    root       999  0.0  0.2   2684   660 ?        SNs  Jan27   0:09 /bin/sh /media/cryptofs/apps/usr/sbin/netstatd
    grep netstat /var/log/messages:

    Code:
    2010-01-29T08:40:19.740386Z [83413] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Main/FetchPrefValue() Database opened OK, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:40:24.423583Z [83418] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Main/FetchPrefValue() Database opened OK, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:40:28.186767Z [83422] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: FetchPrefValue() Database opened OK, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:40:28.200439Z [83422] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Retrieved value from DB: 1, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:40:28.251586Z [83422] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Retrieved empty or null value from DB, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:40:29.062713Z [83422] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Reset Counters flag set to 1, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:40:49.785186Z [83443] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Main/FetchPrefValue() Database opened OK, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:40:54.518005Z [83448] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Main/FetchPrefValue() Database opened OK, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:41:20.131347Z [83474] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Main/FetchPrefValue() Database opened OK, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:42:37.438842Z [83551] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Main/FetchPrefValue() Database opened OK, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:42:39.424896Z [83553] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Main/FetchPrefValue() Database opened OK, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:42:44.073913Z [83557] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: FetchPrefValue() Database opened OK, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:42:44.087768Z [83557] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Retrieved value from DB: 1, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:42:44.140990Z [83558] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Retrieved empty or null value from DB, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
    2010-01-29T08:42:45.098663Z [83558] palm-webos-device user.crit LunaSysMgr: {LunaSysMgrJS}: org.daemon.de.netstat: Error: Reset Counters flag set to 1, file:///media/cryptofs/apps/usr/palm/applications/org.daemon.de.netstat/index.html:0
  19.    #59  
    Thanks a lot. So at least it is running. Could you check one more thing please:

    Code:
    ls -l /media/internal/.app-storage/file_.var.usr.palm.applications.org.daemon.de.netstat_0
    and

    Code:
    cat /media/internal/.app-storage/file_.var.usr.palm.applications.org.daemon.de.netstat_0/stats.json
    and

    Code:
    cat /proc/net/dev

    Thanks!
  20. #60  
    Hi debilater

    I think I found a bug if you use more than 10mb per device. Then the reading out of the recieved bytes is not correct. I noticed it because I was listening to online radio over 3g and the counter didn't get up.

    The output of /proc/net/dev looks like this:

    Code:
      ppp0:51103235   59818    6    0    0     0          0         0  3762251   43087    0    0    0     0       0          0
    Here is a patch for the problem (though not tested):

    Code:
    diff --git a/usr/sbin/netstatd b/usr/sbin/netstatd
    index 303d8cf..6f23445 100755
    --- a/usr/sbin/netstatd
    +++ b/usr/sbin/netstatd
    @@ -320,10 +320,9 @@ while : ; do
     
         for interface in eth0 $ppp bsl0; do
            # fetch current rx+tx values from procfile
    -       line=`grep "$interface:" $stats`
    -       set -- $line
    -       rx=${2}
    -       tx=${10}
    +       line=`grep "$interface:" $stats | cut -d: -f2`
    +       rx=`echo $line | awk '{print $1}'`
    +       tx=`echo $line | awk '{print $9}'`
     
            # set to zero if not defined (e.g. when said interface is currently not online)
            if test -z "$rx"; then
    Kind regards,
    Christof
Page 3 of 10 FirstFirst 12345678 ... LastLast

Posting Permissions