Results 1 to 20 of 20
  1.    #1  
    This is a front end to the remote control feature of nielm's web server for SageTV. You must have the server properly installed on the client you wish to control and have it properly configured before attempting to use this application. Do not use the Jetty version.

    There are a few remote control features, like escape, that I would like to have but they aren't included in the web server. So I may end up writing my own back end some time down the road.

    If you like this app, please donate any amount you want. More $$$ means I will spend more time developing this further.


    Direct link to app page

    ==ChangeLog==
    v.0.2.2 10/13/2009
    -- Removed the requirement for http:// to the server allowing secure connections(hopefully).

    v.0.2.1 10/13/2009
    -- Initial release.
    Last edited by thegodfaza; 10/13/2009 at 08:26 PM. Reason: Clarified some details
  2. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #2  
    Great, I just downloaded it, but can't get it working yet. I hope to get this working because I could never login from my Pre's browser. I was running Sage mobile web interface.
    EDIT: I would gladly donate if this app can access the program guide and allow me to schedule recordings remotely...streaming would be great, but not sure if that's possible?
    Last edited by PreGk; 10/13/2009 at 06:43 PM.
  3.    #3  
    Quote Originally Posted by PreGk View Post
    Great, I just downloaded it, but can't get it working yet. I hope to get this working because I could never login from my Pre's browser. I was running Sage mobile web interface.
    Can you post your setup?
    Are you setup as Server -> Client or are you running SageTV standalone? Also make sure you are typing in the IP address of the client (the pre doesn't support windows client names;netbios) and make sure the web server is installed on the client.
  4.    #4  
    Quote Originally Posted by PreGk View Post
    EDIT: I would gladly donate if this app can access the program guide and allow me to schedule recordings remotely...streaming would be great, but not sure if that's possible?
    I have a work around for that. What I did is created a bookmark in the browser in this format
    Code:
    http://username:password@server:8080/sage/home
    which goes around the bug with HTTP Auth in webOS. Only problem is that it exposes your username / password in the address bar.
  5. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #5  
    Quote Originally Posted by thegodfaza View Post
    Can you post your setup?
    Are you setup as Server -> Client or are you running SageTV standalone? Also make sure you are typing in the IP address of the client (the pre doesn't support windows client names;netbios) and make sure the web server is installed on the client.
    I'm using my PC as the Sage server, have an HD100 and an HD200, no client PC's. I just logged into the webserver on my server as "localhost." When I try to login via the Pre browser, I get never ending login prompts (yes, I'm typing my user/pass correctly). JReichen was helping me at the Sage forums, but we couldn't resolve the issue, although he was able to login to my server from his PC and phone.
    P.S.I have a DNS set up that I use to log into Remotewin that works properly.
  6. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #6  
    Quote Originally Posted by thegodfaza View Post
    I have a work around for that. What I did is created a bookmark in the browser in this format
    Code:
    http://username:password@server:8080/sage/home
    which goes around the bug with HTTP Auth in webOS. Only problem is that it exposes your username / password in the address bar.
    Genius! It worked, this is the very first time I'm able to access my Sage server from my Pre.
  7.    #7  
    Quote Originally Posted by PreGk View Post
    When I try to login via the Pre browser, I get never ending login prompts (yes, I'm typing my user/pass correctly).
    How are you trying to login? With the IP or the (i'm assuming dyndns) address. If it's the latter then you need to have a local DNS server (mid to high end routers have this feature) that will intercept the request and redirect it to the local LAN IP. If your trying to connect with an IP then make sure that all of your software firewalls have outbound TCP port 8080 or whatever open. Also when you type in the address into the settings page in my app, don't type http:// in front of it. It automatically does that. I have to add a check to make sure that you don't do it in the next release.

    Genius! It worked, this is the very first time I'm able to access my Sage server from my Pre.
    Edit: NVM then.
  8. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #8  
    Quote Originally Posted by thegodfaza View Post
    How are you trying to login? With the IP or the (i'm assuming dyndns) address. If it's the latter then you need to have a local DNS server (mid to high end routers have this feature) that will intercept the request and redirect it to the local LAN IP. If your trying to connect with an IP then make sure that all of your software firewalls have outbound TCP port 8080 or whatever open. Also when you type in the address into the settings page in my app, don't type http:// in front of it. It automatically does that. I have to add a check to make sure that you don't do it in the next release.


    Edit: NVM then.
    Ok, I think I was mistaken about your Pre app. I didn't realize that it was a remote control for Sage clients. I thought it was a webapp for nielms webserver. I'm able to login to the server now via the web browser.
    Are you able to stream videos? I can't seem to do it correctly?
  9.    #9  
    Quote Originally Posted by PreGk View Post
    Are you able to stream videos? I can't seem to do it correctly?
    Unfortunately, no. webOS is very picky about what type of videos you can stream.
  10. #10  
    Thanks for this! I'm a long time SageTV user (going on 7 years) so this app is perfect for me! I was contemplating upgrading to the new Jetty version, but this app might make me hold off!

    If I might make 1 request: is it possible to get this working over SSL? My webserver is only set up to allow secure connections. Looks great so far!
  11.    #11  
    There, I just made an update which removes http://. Hopefully if your using SSL it will force it in, otherwise use https:// in front of the server address. The updated version is 0.2.2.
  12. nigfink's Avatar
    Posts
    17 Posts
    Global Posts
    18 Global Posts
    #12  
    Quote Originally Posted by thegodfaza View Post
    I have a work around for that. What I did is created a bookmark in the browser in this format
    Code:
    http://username:password@server:8080/sage/home
    which goes around the bug with HTTP Auth in webOS. Only problem is that it exposes your username / password in the address bar.
    Thank you thank you thank you. I've been trying to get this to work since I got my Pre. I find this a very useful feature. I wish there was a native app to interface with Sage, and would be willing to pay for it! This will definitely do for now though.
  13. #13  
    I'm confused. Does the app work or not? All you guys are talking about is using the web interface and not this app. I've got the Pres web browser to work fine but I'd like to get the app working. Every button I click does nothing however. Am I missing something here?
  14. #14  
    Ok. I get it now. This is not a "remote control" app in the "control my sageTV from anywhere in the country" sense of the phrase. Oh well. At least the web browser works. I have to wonder though, what exactly is the purpose here? Is this for people who have lost their remotes or more of a proof of concept type thing? Most people now run Sage hardware clients since they are far cheaper and work much much better than PC's.
    Last edited by mattbrad2; 10/20/2009 at 10:31 AM.
  15. #15  
    Interesting app. I'll give it a shot . Thanks for the App
    A BAD DAY SKIING AND ROCK CLIMBING IS STILL BETTER THAN A GOOD DAY AT WORK
  16. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #16  
    Does this app work in 1.3.1? I'm trying to use it, but there is no notification if it connected successfully or not. Also, I am running the mobile interface server, will this interfere?
  17. #17  
    Quote Originally Posted by PreGk View Post
    Does this app work in 1.3.1? I'm trying to use it, but there is no notification if it connected successfully or not. Also, I am running the mobile interface server, will this interfere?
    I have just got the APP working myself. I had Sage running as a service (control panel) which prevent interaction with the web server/sagetv client. Once disabled, I was able to use the remote control APPLICATION, not web interface. Examples are exact, and user name *IS* case sensitive (don't make that mistake and bang your head against the wall).

    It's actually pretty cool

    FYI I have WebOS 1.3.1 installed.
  18.    #18  
    I'm looking into this application again and wondering if there is anything anyone would like to see added after a month or so of using it. I haven't ran into any bugs so far.
  19. PreGk's Avatar
    Posts
    441 Posts
    Global Posts
    631 Global Posts
    #19  
    Quote Originally Posted by thegodfaza View Post
    I'm looking into this application again and wondering if there is anything anyone would like to see added after a month or so of using it. I haven't ran into any bugs so far.
    I would like to see a web interface app if possible. I use extenders, so I dont have a need for a web remote, but I access my web server A LOT.
  20.    #20  
    I'm wondering if anyone can see the AdMob ads in the "Advertisement" drawer. I can't seem to get them to show up in the emulator or on any of my Pre or Pre Plus devices. Though if I enable the test ads they show up fine.

Posting Permissions