Page 119 of 122 FirstFirst ... 1969109114115116117118119120121122 LastLast
Results 2,361 to 2,380 of 2438
  1. #2361  
    Quote Originally Posted by tomi666 View Post
    I had Greg's MSN messaging patch installed and it survived the 1.4 update.
    However, MSN icons in Preferences and Accounts and Add IM Account are missing.
    How are you doing with it? Still fine? no bugs?
  2. #2362  
    Ok I want to upgrade to 1.4 now....should I remove the patches before I do! I use Jabber and would like to continue to use it
  3. #2363  
    I've tried running webOSDoctor to start from a clean 1.4 state, and still same problem
  4. #2364  
    Then we are all doomed to wait for Greg

    The Error message looks like some changes greg makes to the messaging app are already in webos 1.4...
  5. #2365  
    @hobsgrg:
    I guess you didn't manually uninstall the patch before updating to 1.4, did you? Well, I didn't do that and got the same messages. So I made sure I had no further patches for the messaging stuff installed and replaced all files under /usr/palm/applications/com.palm.app.messaging/ with the original versions.

    @all:
    The problem with the messaging-patch is that it expects some files in /usr/palm/frameworks/mojo/submissions/314/, but those seem to be in /usr/palm/frameworks/mojo/submissions/330/.

    I modified the patch-package and modified the preinst and postinst scripts to point to the correct directory.
    So after making sure that my messaging application was in a clean state I installed the modified package and it seems to work. At least Jabber actually seems to work better then on 1.3.5.2

    I don't plan to make that hacked package available since I don't have experience with such stuff on the Pre and I don't want to make working devices unusable, so you guys should wait for greg_roll to make the adjustments to his packages.
  6. #2366  
    @noradtux: how the heck did you repackage your changes? I don't understand how I re-create the package.
    Last edited by damnregister; 02/27/2010 at 04:05 PM.
  7. #2367  
    I guess everyone knows there is a problem with messaging plugins.

    I can't get the patch part installed, I'm getting all these errors using WebOS 3.0.2

    I uninstalled everything (it was all working) before the upgrade just to be safe, maybe I should have left it there. But I think it would have been removed by the upgrade anyway.

    I'm on the run right now, hopefully in the few previous messages there is a post on a solution.

    Thanks!

    Rob
    Robert L
    Astoria Queens, N.Y.C
    - Palm Pre (Sprint) - formally Palm Treo 650
    Version 1.4.1.1
    Sprint Configuration 2.3
    Model: P100EWW
    Hardware Version: A
    Firmware: CC1.4(510)

  8. #2368  
    I had to make a hard erase, since I don't know much about programming, and then the dr.
  9. #2369  
    Quote Originally Posted by noradtux View Post
    @hobsgrg:
    I guess you didn't manually uninstall the patch before updating to 1.4, did you? Well, I didn't do that and got the same messages. So I made sure I had no further patches for the messaging stuff installed and replaced all files under /usr/palm/applications/com.palm.app.messaging/ with the original versions.
    I did actually manually uninstall the patch before updating, so I wasn't expecting to have any problems. I removed everything and did webOSDoctor to reflash 1.4 to make sure I cleaned up anything that might not have unistalled but still got the same error
  10. #2370  
    Finally, I installed the patch-package.

    I simply created a link from /usr/palm/frameworks/mojo/submissions/330/ to /usr/palm/frameworks/mojo/submissions/314 ( ln -s ) which is not the best way, but it works.
  11. #2371  
    Quote Originally Posted by damnregister View Post
    Finally, I installed the patch-package.

    I simply created a link from /usr/palm/frameworks/mojo/submissions/330/ to /usr/palm/frameworks/mojo/submissions/314 ( ln -s ) which is not the best way, but it works.
    It may not be the best way, but it does work and to me it is the best way till the official way is created.
  12. #2372  
    Can someone please explain the steps to do this temporary fix? I'm not the best Linux person so I'm not sure what I have to do to create this 'link'?

    I am OK with editing files and such, I just need the steps.

    Otherwise, I guess I have to wait for Greg!

    Thanks!

    Rob
    Robert L
    Astoria Queens, N.Y.C
    - Palm Pre (Sprint) - formally Palm Treo 650
    Version 1.4.1.1
    Sprint Configuration 2.3
    Model: P100EWW
    Hardware Version: A
    Firmware: CC1.4(510)

  13. sarumont's Avatar
    Posts
    14 Posts
    Global Posts
    26 Global Posts
    #2373  
    Quote Originally Posted by damnregister View Post
    Finally, I installed the patch-package.

    I simply created a link from /usr/palm/frameworks/mojo/submissions/330/ to /usr/palm/frameworks/mojo/submissions/314 ( ln -s ) which is not the best way, but it works.
    I also had a 200.72 directory lying around in /usr/palm/frameworks/mojo/submissions. I had to move that out of the way and link 330 to 200.72.
  14. #2374  
    Quote Originally Posted by damnregister View Post
    @noradtux: how the heck did you repackage your changes? I don't understand how I re-create the package.
    The ipk-files use the debian package format, so I used the tools I use for handling debian packages (i.e. dpkg-deb). So I extracted the package, modified it and put it back together
  15. ice8lue's Avatar
    Posts
    117 Posts
    Global Posts
    127 Global Posts
    #2375  
    Could someone please upload his edited package?
    I'm still a little noobish in such things...
    Always get an error installing these packages on my 1.4 pre
  16. #2376  
    I can't even find this in preware. Perhaps I didn't add the feeds correctly. I have been seeing that there are some issues with 1.4, could someone explain to me?
  17. #2377  
    Quote Originally Posted by Yourdogsdead View Post
    I can't even find this in preware. Perhaps I didn't add the feeds correctly. I have been seeing that there are some issues with 1.4, could someone explain to me?
    As far as I've read, the files aren't on Preware yet, you have to install them via webosQuickInstall, but as I read also, you have to create a "link" on the Pre filesystem, something a bit tricky if you don't know what you're doing...

    I'm still trying to stick a working 1.4 on a Telcel Pre so I haven't been able to experiment...

    and btw, my dog is still alive, thanks
  18. #2378  
    First, this is not yet in Preware. Don't know why, because the needed ipkg files are there, so you have to download the files from the first page ( and read the guide on the first page. ) After you know what to do, read the end of this message.

    Ok, everything you do, you do on your own. I have no resposibility for any failures.

    BEFORE installing any of those packages, create the link. You need some kind of Terminal, so novaterm, SSH or Terminal application ( which did not work for me, crashes Luna instantly, so have care ), I don't know if WebOS QuickInstall can give you a terminal or execute commands?

    # are comments what you are doing, $ should symbolize your terminal. DON't type the $, lines without one of those should symbolize output.
    Code:
    # remount root read/write
    $ mount -o remount,rw /
    # This changes directory
    $ cd /usr/palm/frameworks/mojo/submissions/
    # this lists the contents, there should only be one directory: 330
    $ ls
    330
    # create the link
    $ ln -s 330 314
    # double check
    $ ls -lh
    ... 330
    ... 314 -> 330
    # remount root read only
    $ mount -oremount,ro /
    Install the packages, check installation order and Have fun.

    @noradtux: I unpacked them with ar so I thought I can repack them with it again...
  19. #2379  
    Quote Originally Posted by damnregister View Post
    First, this is not yet in Preware. Don't know why, because the needed ipkg files are there, so you have to download the files from the first page ( and read the guide on the first page. ) After you know what to do, read the end of this message.

    Ok, everything you do, you do on your own. I have no resposibility for any failures.

    BEFORE installing any of those packages, create the link. You need some kind of Terminal, so novaterm, SSH or Terminal application ( which did not work for me, crashes Luna instantly, so have care ), I don't know if WebOS QuickInstall can give you a terminal or execute commands?

    # are comments what you are doing, $ should symbolize your terminal. DON't type the $, lines without one of those should symbolize output.
    Code:
    # remount root read/write
    $ mount -o remount,rw /
    # This changes directory
    $ cd /usr/palm/frameworks/mojo/submissions/
    # this lists the contents, there should only be one directory: 330
    $ ls
    330
    # create the link
    $ ln -s 330 314
    # double check
    $ ls -lh
    ... 330
    ... 314 -> 330
    # remount root read only
    $ mount -oremount,ro /
    Install the packages, check installation order and Have fun.

    @noradtux: I unpacked them with ar so I thought I can repack them with it again...
    Hmm, I tried all this down to a T and still get the error during installing the messaging plugins patch. :P

    Edit: I did have a 200.72 and 200.47 folder in there as well, looking up in this thread, seems others had to link those folders as well, so trying that now, will report back.

    Nope, didn't work still can't get messaging patch to install without an error. Bail us out please Greg
    Last edited by volcom45; 02/28/2010 at 06:07 PM.
  20. #2380  
    Quote Originally Posted by sarumont View Post
    I also had a 200.72 directory lying around in /usr/palm/frameworks/mojo/submissions. I had to move that out of the way and link 330 to 200.72.
    I had the 200.72 as well but I only did what damnregister said to do and it finally installed. Will this cause any probs later?

Posting Permissions