View Poll Results: How many people have been able to get Ampache setup?

Voters
297. You may not vote on this poll
  • Yes

    160 53.87%
  • No

    137 46.13%
Page 88 of 88 FirstFirst ... 38 78838485868788
Results 1,741 to 1,750 of 1750
Like Tree2Likes
  1. #1741  
    This is probably a long shot but does someone have a copy of the Ampache-how-to-vista32bit.pdf that I can get?

    The link is dead.

    Thanks
  2. #1742  
    Quote Originally Posted by michaelrj View Post
    This is probably a long shot but does someone have a copy of the Ampache-how-to-vista32bit.pdf that I can get?

    The link is dead.

    Thanks
    I have it still. I will find a new host and update the link. Will inbox you when I do.
  3. #1743  
    Quote Originally Posted by fain View Post
    I have it still. I will find a new host and update the link. Will inbox you when I do.
    Thanks!!!!
  4. #1744  
    Quote Originally Posted by michaelrj View Post
    Thanks!!!!

    Never used this host before but here it is for now.
    Ampache-how-to-vista32bit.pdf
    AmpachPre, your music your way.

  5. #1745  
    Quote Originally Posted by fain View Post
    Never used this host before but here it is for now.
    Ampache-how-to-vista32bit.pdf
    Got it,

    Thanks again.
  6. #1746  
    Quote Originally Posted by fain View Post
    Never used this host before but here it is for now.
    Ampache-how-to-vista32bit.pdf
    Quick question about Ampache.
    It has nothing to go with AmpachPre or Ampache Mobile.

    I am having a problem importing some playliststs (.m3u)'s.
    On some playlists I try to import in Ampache on the computer I get:

    Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\ampache-master\lib\class\dba.class.php on line 85

    Any idea on how to fix it?
    I don't know nothing about programing etc but looked at the file and do not see anything about time or 30 seconds etc. I thought maybe I could change the timeout time


    Thanks
  7. #1747  
    Quote Originally Posted by michaelrj View Post
    Quick question about Ampache.
    It has nothing to go with AmpachPre or Ampache Mobile.

    I am having a problem importing some playliststs (.m3u)'s.
    On some playlists I try to import in Ampache on the computer I get:

    Fatal error: Maximum execution time of 30 seconds exceeded in C:\xampp\htdocs\ampache-master\lib\class\dba.class.php on line 85

    Any idea on how to fix it?
    I don't know nothing about programing etc but looked at the file and do not see anything about time or 30 seconds etc. I thought maybe I could change the timeout time


    Thanks
    I used to get that also. Honetly, I stopped doing it through the GUI and have a scheduled task run every hour to have the script run behind the scenes. I also do it with Linux... ;-)

    A script in /etc/cron.hourly:
    Code:
    sudo -u apache /usr/bin/php /var/www/localhost/htdocs/ampache/bin/catalog_update.inc MyCatalogName -c -a 1>&- 2>&-
    That said, you need to edit the php.ini and find "max_execution_time" and increase it. The value is in seconds. The default is 300, I believe. A value of "0" (zero) is to make no limitation on execution time. This *can* be dangerous for a public website - someone *could* make the server churn endlessly on something tieing it up. On something like this, though, it's pretty safe (so to speak).

    If you have a large catalog, it WILL take longer than 300 seconds (5 minutes) to parse it. You can maybe bump that up to like 15 minutes (900 seconds) and go from there.

    You need to reload (restart not required, reload is good) Apache if you change PHP config values for them to take effect.


    M.
  8. #1748  
    Quote Originally Posted by Xanadu73 View Post
    I used to get that also. Honetly, I stopped doing it through the GUI and have a scheduled task run every hour to have the script run behind the scenes. I also do it with Linux... ;-)

    A script in /etc/cron.hourly:
    Code:
    sudo -u apache /usr/bin/php /var/www/localhost/htdocs/ampache/bin/catalog_update.inc MyCatalogName -c -a 1>&- 2>&-
    That said, you need to edit the php.ini and find "max_execution_time" and increase it. The value is in seconds. The default is 300, I believe. A value of "0" (zero) is to make no limitation on execution time. This *can* be dangerous for a public website - someone *could* make the server churn endlessly on something tieing it up. On something like this, though, it's pretty safe (so to speak).

    If you have a large catalog, it WILL take longer than 300 seconds (5 minutes) to parse it. You can maybe bump that up to like 15 minutes (900 seconds) and go from there.

    You need to reload (restart not required, reload is good) Apache if you change PHP config values for them to take effect.


    M.
    Thanks, I found this section:
    ; Maximum execution time of each script, in seconds
    ; PHP: Runtime Configuration - Manual
    ; Note: This directive is hardcoded to 0 for the CLI SAPI
    max_execution_time=30

    I changed the 30 to 300 and seems to do the trick.

    Thanks
    Last edited by michaelrj; 08/12/2013 at 04:14 PM.
  9. #1749  
    Quote Originally Posted by michaelrj View Post
    Thanks, I found this section:
    ; Maximum execution time of each script, in seconds
    ; PHP: Runtime Configuration - Manual
    ; Note: This directive is hardcoded to 0 for the CLI SAPI
    max_execution_time=30

    I changed the 30 to 300 and seems to do the trick.

    Thanks
    Cool. I guess the default is 30 then and not 300. It was 300 in the the configs on my system (there are separate ones for CLI and for GUI in Gentoo) and they were saying 300. I guess I had already changed it at some point...

    At any rate, I'm glad to hear that you're up and running!


    M.
  10. TheOneill's Avatar
    Posts
    85 Posts
    Global Posts
    86 Global Posts
    #1750  
    Hi,

    I had problems with multi-buffering on my Veer since I upgraded to 2.2.4. Once the current song is fully loaded, the phone does not start to load the next one.

    I investigated a little bit, and I figured out that the "load" event of the HTMLMediaElement is not fired. The "progress" ones are OK though, so I made a little patch to handle the final "progress" event like a "load" one and start buffering next song.

    Tested on double buffer only but should work with any buffer depth setting.

    I also had to keep my old patch (comment the audioObj.mojo.audioClass = "media"; line otherwise playback of the current song stops when ampache starts buffering the next one.

    Lionel
    Attached Files Attached Files

Tags for this Thread

Posting Permissions