View Poll Results: How many people have been able to get Ampache setup?

Voters
297. You may not vote on this poll
  • Yes

    160 53.87%
  • No

    137 46.13%
Page 78 of 88 FirstFirst ... 28687374757677787980818283 ... LastLast
Results 1,541 to 1,560 of 1750
Like Tree2Likes
  1. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1541  
    Quote Originally Posted by TheX-Man View Post
    WOW!!! I can't believe I actually got it to work! BTW I think Cozzman's Post #1421 should be added to the pdf or at least mention when linking to the pdf.
    oh hai, there's a pdf? heh, funny, that might have made things easier for me.

    in other news i figured out a way to track down those nasty characters that make ampache-mobile's xml parsing blow up which results in not being able to browse your artists and albums. i found some sql queries that can help. i'd say it's going to be useful to export these to files, one query per file. so do each of them via:

    Code:
    mysql -u root -p -D ampache > filename
    where you obviously fill in the filename. here's the queries:

    Code:
    select id,name from `artist` where `name` regexp '[^ -~]';
    select id,name from `album` where `name` regexp '[^ -~]';
    select id,file,title from `song` where `title` regexp '[^ -~]';
    first note that this will look up any non-standard characters, so there will possibly be a lot of legitimate printing characters from utf8. i've got songs in japanese and cyrillic, for example. you'll have to search through the results to look for the funkiness. i found something remarkable, but this may be just in my case. i loaded these up in vi/vim and syntax highlighting picked up on the bad characters-- they stood out great! i say your mileage may vary as i'm totally set up to display utf8. if you're not, it's likely the same thing will result in EVERYTHING looking funky. consider utf8 fonts/encoding.

    the last one is most likely to produce the result you're looking for and it will give you the path to the file that actually has the funky song title.

    the first one looks for funky artists. the second for funky albums. if you're still having trouble after fixing the funky songs, here's where to look. you'll have to do some cross referencing. say you have artists 3, 64, and 284 that are and albums 5, 12, and 532 (these are id numbers) that are funky. here's a query that will give you another song list:

    Code:
    select id,title,file from `song` where `artist` in(3, 64, 284) or `album` in(5,12,532);
    once you got your list you can start sorting through it and fixing tags with your favourite editor. and you should be golden. hope this helps someone!

    final edit: just wanted to confirm, this fixed it for me! tons of utf8 characters abound but no weird non-printing characters. and now all my artists and albums show up great. i should add that there was no tagger that could pick up on the fact that the tags were funky. i will say that when using id3v2, i got much more complete information when the tags were fixed than when they weren't. that's about the most amount of feedback i got from any tagger.
    Last edited by wxl; 10/16/2010 at 10:46 PM. Reason: success!
  2. #1542  
    DOH... ok I spoke too soon. Woke up this morning and it doesn't work anymore :-( I can't even get into localhost/ I think it's because my IP address from the router changed. The number that start with 192.168.... Could that have caused the issue? I don't know anything about networking LOL (maybe I shouldn't be attempting this, but accessing your PC mp3s is just too tempting). I tried googling how to make your IPv4 Address static, but got a whole bunch of jargon I don't understand. Any ideas?
  3. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1543  
    Quote Originally Posted by TheX-Man View Post
    DOH... ok I spoke too soon. Woke up this morning and it doesn't work anymore :-( I can't even get into localhost/ I think it's because my IP address from the router changed. The number that start with 192.168.... Could that have caused the issue? I don't know anything about networking LOL (maybe I shouldn't be attempting this, but accessing your PC mp3s is just too tempting). I tried googling how to make your IPv4 Address static, but got a whole bunch of jargon I don't understand. Any ideas?
    i assume with u saying ipv4 u got a machine running windows xp or older?

    if so, this is about the easiest thing out there:
    PortForward.com - Free Help Setting up Your Router or Firewall

    if not, let us know what specific operating system and version you have. you definitely need a static ip.
  4. #1544  
    Actually I'm running Windows 7 with an asus wl-520gc. I'm not really sure how I set it up other than the basic EZ setup that came with the directions. It doesn't change all the time. Actually I can't remember the last time it changed b/c I've been using vuze with no issues until now. I have to go back and change the port forwarding for vuze to work correctly.
  5. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1545  
    Quote Originally Posted by TheX-Man View Post
    Actually I'm running Windows 7 with an asus wl-520gc. I'm not really sure how I set it up other than the basic EZ setup that came with the directions. It doesn't change all the time. Actually I can't remember the last time it changed b/c I've been using vuze with no issues until now. I have to go back and change the port forwarding for vuze to work correctly.
    Well the fact that it changes at all is going to be a pain for you. That's why you need a static IP. Here:

    http://portforward.com/networking/static-win7.htm

    You could also setup a dynamic DNS service dyndns.com. You get something like xman.dyndns.com to point at your IP address. You can get software from them to automatically update the pointer when the IP address changes. You may also be able to get your router to do the job, depending on its abilities.

    hope that helps!
  6. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1546  
    I know this has been brought up before but even with the bleeding edge (pulled via svn) server my album art don't show up in now playing. No problem in artist album list. Help?

    [i]-- Sent from my Palm PrPrPr
    FYI that avatar is from the iFixit Pre teardown, uploaded by another Walter, and was instrumental in the fixing of my phone's speaker. It's also licensed under Creative Commons BY-NC-SA so give credit if you use it.
  7. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1547  
    Just discovered a problem with m4a's. Some are Apple Lossless (alac decoder) and some are not (faad decoder). Neither decoder will handle both.

    Found a solution, though. Make a shell script accessible by your web user. I call mine deapple. Here's the code:

    Code:
    #!/bin/bash
    song="$1"
    sample="$2"
    song_type=`/path/to/alac -t "$song" | grep "file type:"`
    
    if [ "$song_type" == "file type: alac" ];
    then
            /path/to/alac "$song" | /path/to/lame -h -b "$sample" -S - -
    else
            /path/to/faad -f 2 -w "$song" | /path/to/lame -r -b "$sample" -S - -
    fi
    Once you got that set up make sure to make it executable. Then comment out (";") any transcode_m4a lines in your ampache.cfg.php and add

    Code:
    transcode_m4a = "/path/to/deapple %FILE% %SAMPLE%"
    Fixed. Enjoy!

    [i]-- Sent from my Palm PrPrPr
    FYI that avatar is from the iFixit Pre teardown, uploaded by another Walter, and was instrumental in the fixing of my phone's speaker. It's also licensed under Creative Commons BY-NC-SA so give credit if you use it.
  8. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1548  
    Small bug: trying to change back/foreground to solid colors only saves fore.

    [i]-- Sent from my Palm PrPrPr
    FYI that avatar is from the iFixit Pre teardown, uploaded by another Walter, and was instrumental in the fixing of my phone's speaker. It's also licensed under Creative Commons BY-NC-SA so give credit if you use it.
  9. #1549  
    Changing back/foreground colors works fine for me.
    If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

    HOW TO: Zip/Unzip via Pre/Pixi using Terminal
    HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
    Palm Pre wallpapers
  10. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1550  
    Quote Originally Posted by NachoB View Post
    Changing back/foreground colors works fine for me.
    Sorry, didn't realize I needed to select an overlay for the back.

    [i]-- Sent from my Palm PrPrPr
    FYI that avatar is from the iFixit Pre teardown, uploaded by another Walter, and was instrumental in the fixing of my phone's speaker. It's also licensed under Creative Commons BY-NC-SA so give credit if you use it.
  11. #1551  
    bjgeiser,

    think you could release an update, moving the scrubber on the Now Playing screen down about 2-3 pixels, centering it with the minus sign in the time remaining?
  12. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1552  
    So music stops when a call comes in. Ringtone doesn't play though, as it does in Music Player. Can we fix it? (yes we can!)

    [i]-- Sent from my Palm PrPrPr
    FYI that avatar is from the iFixit Pre teardown, uploaded by another Walter, and was instrumental in the fixing of my phone's speaker. It's also licensed under Creative Commons BY-NC-SA so give credit if you use it.
  13. #1553  
    Hi, I love the premise of your app but I cannot for the life of me get it running. I get as far as it asking for my root password for the SQL but I get this message and get no further

    Error: Unable to make Database Connection Access denied for user 'root'@'localhost' (using password: NO)

    I tried to change the password but it never let me, got another strange message I cant find any reference to. I am assuming I am doing something wrong but I do want to get this working so any help would be much appreciated.
  14. #1554  
    Try following the instructions Cozzman posted at the top of this page: http://forums.precentral.net/homebre...mobile-72.html
    If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

    HOW TO: Zip/Unzip via Pre/Pixi using Terminal
    HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
    Palm Pre wallpapers
  15. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1555  
    Quote Originally Posted by schmuck View Post
    Error: Unable to make Database Connection Access denied for user 'root'@'localhost' (using password: NO)
    You need to use your SQL root password.

    [i]-- Sent from my Palm PrPrPr
    FYI that avatar is from the iFixit Pre teardown, uploaded by another Walter, and was instrumental in the fixing of my phone's speaker. It's also licensed under Creative Commons BY-NC-SA so give credit if you use it.
  16. #1556  
    Quote Originally Posted by wxl View Post
    You need to use your SQL root password.

    [i]-- Sent from my Palm PrPrPr
    edit: found out I changed it to something completely ridiculous. How do you change it once you have one?

    New error though.

    Step 3 - Setup Initial Account

    Generate Config File Error: Unable to make Database ConnectionAccess denied for user 'ODBC'@'localhost' (using password: NO)
  17. #1557  
    nvm I guess, most likely a port problem
    Last edited by schmuck; 11/01/2010 at 02:54 AM.
  18. #1558  
    Have you taken a look at the Common Issues page. There are steps there to help identify/fix common problems like you are having.
    Last edited by wilderf; 11/01/2010 at 06:05 AM.
  19. #1559  
    Anyone running 3.6.x successfully? The fact that Ampache 3.5.4 can't properly order playlists that you save (sorts by track number) coupled with the fact that Ampache mobile can't pickup where you left off on close is driving me up a tall tree.
  20. #1560  
    Quote Originally Posted by bjgeiser View Post
    Can you add this as a feature request on the google code site?

    When I do the next version I'll look at adding this. Kinda waiting to see what the next version of Ampache brings to the table.
    Has development on Ampache stalled out? I don't really see a lot of activity since before September on the 3.6 alpha project.

Tags for this Thread

Posting Permissions