View Poll Results: How many people have been able to get Ampache setup?

Voters
297. You may not vote on this poll
  • Yes

    160 53.87%
  • No

    137 46.13%
Page 77 of 88 FirstFirst ... 2767727374757677787980818287 ... LastLast
Results 1,521 to 1,540 of 1750
Like Tree2Likes
  1.    #1521  
    Quote Originally Posted by iamthedood View Post
    think i just found out my problem ... at work right now so i can't remote desktop to my home machine ... during intial config setup i setup the web_path = "/".

    woops.

    my stream link was coming back as server.com...

    lol.
    That'll do it everytime Did you get this working?
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  2. #1522  
    Can I suggest a small add-on? I use Mode Switcher (AWESOME app) so when I go into areas with certain bluetooth connections (like my car and my bluetooth headset I use to mow the lawn) it will auto start a music player. I use pandora and Music remix not because i want to but they are the ONLY two apps that start playing music automatically on open.

    Is there a way you can add a feature to keep track of what you were listening to on close and start playing again on reopen?

    That seems sort of daunting so as an easier alternative, can you put a item in the preferences to pick a particular playlist (even if I have to type in the exact name of the playlist manually I don't care) and play it from the beginning?

    Try out Mode Switcher and you'll love it, hopefully you'll love it for the same reasons I do and want to get that working too
  3.    #1523  
    Quote Originally Posted by Cozzman View Post
    Can I suggest a small add-on? I use Mode Switcher (AWESOME app) so when I go into areas with certain bluetooth connections (like my car and my bluetooth headset I use to mow the lawn) it will auto start a music player. I use pandora and Music remix not because i want to but they are the ONLY two apps that start playing music automatically on open.

    Is there a way you can add a feature to keep track of what you were listening to on close and start playing again on reopen?

    That seems sort of daunting so as an easier alternative, can you put a item in the preferences to pick a particular playlist (even if I have to type in the exact name of the playlist manually I don't care) and play it from the beginning?

    Try out Mode Switcher and you'll love it, hopefully you'll love it for the same reasons I do and want to get that working too
    Can you add this as a feature request on the google code site?

    When I do the next version I'll look at adding this. Kinda waiting to see what the next version of Ampache brings to the table.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  4. #1524  
    I added it but couldn't figure out how to mark it as a feature request. Its in there as a defect. Sorry and thanks.
  5. 12gage's Avatar
    Posts
    123 Posts
    Global Posts
    130 Global Posts
    #1525  
    i'm trying to install this on windows, do I put the ampache folder in the root of my local disk (C:/)? the site instructions look like they're for linux computers, sorry if this has been asked before, and I apologize for my ignorance.
  6. #1526  
    Install in root is best.
    If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

    HOW TO: Zip/Unzip via Pre/Pixi using Terminal
    HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
    Palm Pre wallpapers
  7. #1527  
    Quote Originally Posted by 12gage View Post
    i'm trying to install this on windows, do I put the ampache folder in the root of my local disk (C:/)? the site instructions look like they're for linux computers, sorry if this has been asked before, and I apologize for my ignorance.
    you need to install the ampache folder into the root of the webserver. Install xamp into the root c:
  8. sinner1168's Avatar
    Posts
    7 Posts
    Global Posts
    10 Global Posts
    #1528  
    I have an odd problem. i can not connect to my ampache server using ampache mobile but it works flawlessly using ampachpre. Cant seem to figure it out. When i try to connect it gives me "error: empty response". I wanted to check out the UI of ampache mobile because I noticed it has a video option whereas ampachpre doesn't. I have about 800 movies in mp4 format that I would like to stream to my pre. Not that this is relevant, but my wifes hero has a similar issue. I can not connect using amdroid but lullaby works flawlessly.. Any ideas?
  9.    #1529  
    Quote Originally Posted by sinner1168 View Post
    I have an odd problem. i can not connect to my ampache server using ampache mobile but it works flawlessly using ampachpre. Cant seem to figure it out. When i try to connect it gives me "error: empty response". I wanted to check out the UI of ampache mobile because I noticed it has a video option whereas ampachpre doesn't. I have about 800 movies in mp4 format that I would like to stream to my pre. Not that this is relevant, but my wifes hero has a similar issue. I can not connect using amdroid but lullaby works flawlessly.. Any ideas?
    Sounds like you are entering the URL incorrectly... Ampache Mobile need a fully formed URL up to the base directory of your Ampache install.

    Example (port 80): http://myserver.dyndns.org/ampache
    or
    Example (port 8080): http://myserver.dyndns.org:8080/ampache
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  10. sinner1168's Avatar
    Posts
    7 Posts
    Global Posts
    10 Global Posts
    #1530  
    no I'm entering it correctly
    http://mydomainname.dyndns-server.com/ampache

    that url works with ampache pre and the web interface. I wonder if it's having a problem translating the hyphen. What do you think?
  11. #1531  
    I came about a random issue today when using my Ampache mobile app on my phone. When I selected a specific genre, then selected Artists I got this error:

    XML Processing Error
    This happens due to songs with invalid characters information.
    Look in the Ampache Web Interface for characters like {strange characters displayed}.

    I've never seen this error after 2+ months of use with this app. I did recently add songs to my catalog, but none of them where tagged with the genre that I selected which caused this error.

    Where specifically can I look in the Ampache Web Interface for these invalid characters?

    Any help is greatly appreciated!
  12.    #1532  
    Quote Originally Posted by unitygizmo View Post
    I came about a random issue today when using my Ampache mobile app on my phone. When I selected a specific genre, then selected Artists I got this error:

    XML Processing Error
    This happens due to songs with invalid characters information.
    Look in the Ampache Web Interface for characters like {strange characters displayed}.

    I've never seen this error after 2+ months of use with this app. I did recently add songs to my catalog, but none of them where tagged with the genre that I selected which caused this error.

    Where specifically can I look in the Ampache Web Interface for these invalid characters?

    Any help is greatly appreciated!
    Probably the easiest thing to do is to use a good tag editor to view the recently added files and look for any strangeness. Sometimes simply using the tag editor to rewrite the tags is all it takes to clean things up.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  13. #1533  
    Are there plans to incorporate the tweet now playing option?
  14.    #1534  
    Quote Originally Posted by mamouton View Post
    Are there plans to incorporate the tweet now playing option?
    I really feel like this is something the Ampache server should do.

    I've already added a feature request for it.... maybe add a vote to show there is some interest.

    FS#81 : Tweet Now Playing
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  15. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1535  
    Running OSX 10.5.8 on a PPC over here.
    Apache - no problem.
    PHP - no problem.
    MySQL a la MacPorts - a little funky. The final thing I needed to do to make it work was edit php.ini so that it pointed at the less-standard socket out of /opt/local like everything else from MacPorts so that Ampache install could connect to the db.
    Did realize we ned to run a stable dev (oxymoron?) version a wee too late, but the upgrade was super simple.
    Adding catalogs-- not sure what's going on. It seems I can't add anything in my home directory. I'm using /Users/username and not ~ (though I've tried both). I've chmod 755 and 777 (with and without the -R flag). I've edited permissions from the Get Info dialog. Adding the same files in /tmp - no problem.
    Any ideas?
    BTW- THANK YOU SO MUCH!

    EDIT: forgot to chmod the PARENT directories back to / as well. Problem solved. Thanks to #ampache pointing out the error of my ways.
    Last edited by wxl; 10/08/2010 at 12:45 AM. Reason: figured it out
  16. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1536  
    Quote Originally Posted by bjgeiser View Post
    Probably the easiest thing to do is to use a good tag editor to view the recently added files and look for any strangeness. Sometimes simply using the tag editor to rewrite the tags is all it takes to clean things up.
    Couple questions about this:
    1. Is this an Ampache server issue or an Ampache Mobile issue?
    2. If the former, is there a more current version that resolves this? I'm using the stable development version 3.5.4 stable.
    3. What particular characters cause the problem? I have a few albums that have unique characters in them-- and they should. One that comes off the top of my head: BananaSLOTH - Zombie Battle 2019! (CD, Album) at Discogs
    4. I just added my entire music library (A LOT) and have these errors. It will be difficult to wade through with even the best tag editor. Is there not some other way to at least get a list of the offending tracks?
  17. #1537  
    Quote Originally Posted by bjgeiser View Post
    In the account editor there is a workaround called "Gstreamer %20". Can you turn that on and report back?
    Hello.
    I've managed to get Ampache working on my server and can access wherever I am. I'm trying to get this to stream however it does not work from either the server OR from AmpachePre. I get an error also (the same error that is mentioned on page 64 (i think) of this thread.
    The G Streamer doesn't help.
    I'm stuck! What's more odd is that I can't actually stream from the server either. It loads VLC but nothing actually every plays. The files do exist as I can download them.
    It's really odd!
    Help!
  18. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1538  
    the web user is who is running all your transcode programs. it is likely that that user's PATH does not include the location of those files. you can solve this by explicitly stating the full path (e.g. /usr/local/bin/flac) in the transcode section of ampache.cfg.php. i was so pumped to just play a flac (well, not really) off my phone!!! must say irc://irc.freenode.net/ampache has been super helpful.

    one last bit if you're using mp3splt for mp3s or oggs: make sure to use the syntax
    mp3splt OPTIONS FILE TIME
    the ampache.cfg.php.dist comes set up with
    mp3splt OPTIONS FILE TIME -o -
    where -o - is another option for output to standard out. this will not work! move it over with the other options near the beginning and you'll be set.
    Last edited by wxl; 10/11/2010 at 02:30 PM. Reason: one more thing
  19. wxl
    wxl is offline
    wxl's Avatar
    Posts
    53 Posts
    #1539  
    one more thing for those of you with m4as:
    update to the latest svn
    on the command line:
    Code:
    sudo svn checkout https://svn.ampache.org/trunk
    apparently since the advent of videos, it's messed with the proper reading of tags in these files, which is now fixed. made my life much nicer.

    also if you want an easy way to get a text list of all your Unknown (Orphaned) files to fix, do this (sorry, love the command line):
    Code:
    $mysql -u root -p -D ampache
    Enter password:
    mysql> SELECT `id` FROM `artist` WHERE `name` = "Unknown (Orphaned)";
    i get this back:
    Code:
    +----+
    | id |
    +----+
    | 30 |
    +----+
    1 row in set (0.02 sec)
    so then i can do this:
    Code:
    mysql> quit
    $mysql -u root -p -D ampache > filename
    Enter password:
    SELECT `file` FROM `song` WHERE `artist` = 30;
    quit
    don't let the lack of a prompt freak you out; it's normal. "filename" will have your info it. then you set your tagger to fixing it up.

    on this subject, if anyone knows of a *nix command line tagger, especially that works with mp3/m4a/flac/wma/ape, i'd really appreciate it. extra especially if it has musicbrainz/discogs support. pm me.

    i'm currently working on a way to easily fix the error with xml parsing. the two examples given are both from the unicode other/control characters, so it's taken some effort to even get to the point of finding them. hopefully by tonight, with a little help from mysql-python, i'll have it solved.

    btw, that "password" above is for the root user of mysql. if you use a different username than root, replace username with it. don't use the root password for your computer, mm'k?
    Last edited by wxl; 10/13/2010 at 01:38 PM. Reason: stupid code syntax
  20. #1540  
    WOW!!! I can't believe I actually got it to work! BTW I think Cozzman's Post #1421 should be added to the pdf or at least mention when linking to the pdf. I got stuck on that for a LOOONG time LOL.

    Another place I got stuck: being able to access it via 192.168.... but not via IP address. Opened up a port, and it worked like a charm. Thank you so much everyone in this thread and especially bjgeiser! Amazing App!!!

Tags for this Thread

Posting Permissions