View Poll Results: How many people have been able to get Ampache setup?

Voters
297. You may not vote on this poll
  • Yes

    160 53.87%
  • No

    137 46.13%
Page 69 of 88 FirstFirst ... 1959646566676869707172737479 ... LastLast
Results 1,361 to 1,380 of 1750
Like Tree2Likes
  1. #1361  
    Ah, I'm sorry - that Java app. Doesn't it essentially use ipkg-opt anyway?
  2. #1362  
    Quote Originally Posted by alkos333 View Post
    Ah, I'm sorry - that Java app. Doesn't it essentially use ipkg-opt anyway?
    I just tried installing and uninstalling it using WebOS Quick Install and restarting, but the icon is still there..
  3.    #1363  
    Quote Originally Posted by alkos333 View Post
    I just tried installing and uninstalling it using WebOS Quick Install and restarting, but the icon is still there..
    If it were me I'd get on the console in some form.

    Navigate to /media/cryptofs/apps/usr/palm/applications/

    delete the folder com.palm.ampachemobile

    then reboot.

    Hmm... found this as well... http://www.webos-internals.org/wiki/...sn.27t_work.3F
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  4.    #1364  
    Interesting..... Google snatched up popular iPhone app for Android streaming

    Too bad ampache is free, nothing for google to buy.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  5. #1365  
    Quote Originally Posted by bjgeiser View Post
    If it were me I'd get on the console in some form.

    Navigate to /media/cryptofs/apps/usr/palm/applications/

    delete the folder com.palm.ampachemobile

    then reboot.

    Hmm... found this as well... Installing Homebrew Apps With A Rooted Pre - WebOS Internals
    Would love to do that, but it isn't there:

    Code:
    palm-webos-device applications # ls -l                                                                                                                      
    total 128
    drwxr-xr-x 5 root root 32768 May  9 05:47 com.palm.pandora
    drwxr-xr-x 6 root root 32768 Nov  2  2009 com.sfmpllc.sendmylocation
    drwxr-xr-x 7 root root 32768 Mar 20 11:32 com.weather.palm
    drwxr-xr-x 6 root root 32768 Nov  2  2009 org.webosinternals.ipkgservice
    palm-webos-device applications # pwd                                                                                                                        
    /media/cryptofs/apps/usr/palm/applications
  6.    #1366  
    Quote Originally Posted by alkos333 View Post
    Would love to do that, but it isn't there:

    Code:
    palm-webos-device applications # ls -l                                                                                                                      
    total 128
    drwxr-xr-x 5 root root 32768 May  9 05:47 com.palm.pandora
    drwxr-xr-x 6 root root 32768 Nov  2  2009 com.sfmpllc.sendmylocation
    drwxr-xr-x 7 root root 32768 Mar 20 11:32 com.weather.palm
    drwxr-xr-x 6 root root 32768 Nov  2  2009 org.webosinternals.ipkgservice
    palm-webos-device applications # pwd                                                                                                                        
    /media/cryptofs/apps/usr/palm/applications
    And it runs?

    Maybe the old path then.... /usr/palm/applications
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  7. #1367  
    Quote Originally Posted by bjgeiser View Post
    And it runs?

    Maybe the old path then.... /usr/palm/applications
    Yep, that's where it was hiding . Thank you so much for your help with getting rid of this old ******* :P.

    I'm all good to go now
  8. #1368  
    BJ,

    Is there a better way to add new mp3's and update them easier? Every time I have to update the catalog and it take about 30 minutes to scan the 12k worth of music I have.

    Thanks for all youur hard work! Great program!
  9.    #1369  
    Quote Originally Posted by peanuthead47 View Post
    BJ,

    Is there a better way to add new mp3's and update them easier? Every time I have to update the catalog and it take about 30 minutes to scan the 12k worth of music I have.

    Thanks for all youur hard work! Great program!
    I usually just click add, instead of update if i'm only adding music. Scans much faster.
  10. #1370  
    Hey bjgeiser, I was wondering how buffering works for Ampache Mobile. Does it initialize a new CLE string with Ampache, or does it just use the existing command line execution while stringing together multiple songs? I still seem to have problems with Amnpache if I try to change songs frequently as multiple processes for my command line encoders start to occur and draws on my CPU to the point that the initial processes fail giving me a streaming error. I tried adjusting Ampache so that I may not need to use mp3splt, but that didn't really help any. I'm sure if I could keep Ampache from calling up multiple processes that I could reduce instances of this. So far it helps with Apache timeout set to 600 seconds, Audio Stall detection off, and Buffer set to 1. Maybe something that can automatically kill multiple processes in taskmanager could help, If not, then any recommendations on how I may keep these processes from duplicating, thereby stopping Ampache from being choked with multiple command line executions, would be appreciated.
  11.    #1371  
    Quote Originally Posted by ihooten View Post
    Hey bjgeiser, I was wondering how buffering works for Ampache Mobile. Does it initialize a new CLE string with Ampache, or does it just use the existing command line execution while stringing together multiple songs? I still seem to have problems with Amnpache if I try to change songs frequently as multiple processes for my command line encoders start to occur and draws on my CPU to the point that the initial processes fail giving me a streaming error. I tried adjusting Ampache so that I may not need to use mp3splt, but that didn't really help any. I'm sure if I could keep Ampache from calling up multiple processes that I could reduce instances of this. So far it helps with Apache timeout set to 600 seconds, Audio Stall detection off, and Buffer set to 1. Maybe something that can automatically kill multiple processes in taskmanager could help, If not, then any recommendations on how I may keep these processes from duplicating, thereby stopping Ampache from being choked with multiple command line executions, would be appreciated.
    I'm thinking your problems are related to the aac+ encoder, can you try changing back to mp3 and see if you still have the same issues?

    I have my server setup to do both and I've noticed some of the same issues with aac+. MP3 seems to be far more stable.

    As for Ampache Mobile. Each time you see it start to buffer a song, its downloading the track from a URL Ampache supplies. Ampache Mobile itself has no idea about command lines and the like, thats all done on the server side.

    I've designed Ampache Mobile to only load one URL at a time, this should allow time for your command lines to finish naturally, provided your encoder behaves well. So at the root of this you probably need to find out whats going on to keep all those encoders open.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  12. #1372  
    Quote Originally Posted by bjgeiser View Post
    I usually just click add, instead of update if i'm only adding music. Scans much faster.
    BJ,

    After fooling around with the catalogs and changing the target to a much larger drive I cannot update or even delete my catalogs. I'm going to show catalogs and trying to delete them and it asks for confirmation and when I continue it tells me that"The Catalog and all associated records have been deleted" I hit continue again and it takes me to recently played and there is not enough data but as soon as I go back to show catalogs it's still there. I've tried restarting the services as well as the server and nothing seem to work.

    Do you have any ideas?
  13.    #1373  
    Quote Originally Posted by peanuthead47 View Post
    BJ,

    After fooling around with the catalogs and changing the target to a much larger drive I cannot update or even delete my catalogs. I'm going to show catalogs and trying to delete them and it asks for confirmation and when I continue it tells me that"The Catalog and all associated records have been deleted" I hit continue again and it takes me to recently played and there is not enough data but as soon as I go back to show catalogs it's still there. I've tried restarting the services as well as the server and nothing seem to work.

    Do you have any ideas?
    Have you tried Clean All?

    If all else fails you can delete the database using phpMyAdmin. But you'll have to rebuild the database. Probably best to delete/backup your ampache.config.php file first and redo you're whole setup.

    http://localhost/phpmyadmin/

    In phpMyAdmin click on Ampache on the left then click drop upper right.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  14.    #1374  
    I spent the better part of today getting dashboard controls built up and working. It feels done, but I usually sit on new features for at least a couple days to see if I notice any bugs and I usually do. Here is a preview.

    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  15. #1375  
    Cool features!! How do you update the songs showing in Ampache mobile? I have about 6000 songs in a catalog but the screen of the pre only shows 1425.
    Last edited by mamouton; 05/23/2010 at 12:34 AM.
  16.    #1376  
    Quote Originally Posted by mamouton View Post
    Cool features!! How do you update the songs showing in Ampache mobile? I have about 6000 songs in a catalog but the screen of the pre only shows 1425.
    Which screen shows 1425?
  17. xantus's Avatar
    Posts
    6 Posts
    Global Posts
    7 Global Posts
    #1377  
    sweet. looking forward to the dash controls. this thing keeps getting better!
  18. #1378  
    Quote Originally Posted by bjgeiser View Post
    I'm thinking your problems are related to the aac+ encoder, can you try changing back to mp3 and see if you still have the same issues?

    I have my server setup to do both and I've noticed some of the same issues with aac+. MP3 seems to be far more stable.

    As for Ampache Mobile. Each time you see it start to buffer a song, its downloading the track from a URL Ampache supplies. Ampache Mobile itself has no idea about command lines and the like, thats all done on the server side.

    I've designed Ampache Mobile to only load one URL at a time, this should allow time for your command lines to finish naturally, provided your encoder behaves well. So at the root of this you probably need to find out whats going on to keep all those encoders open.
    Yeah, seems to be related to aacPlusenc as the issue doesn't replicate with MP3. mp3splt and lame seem to speed along fine when just downsampling to MP3, but when aacPlusenc gets thrown in it seems to get bottlenecked with it. I attempted the reduce the amount of encoders used by removing mp3splt, but the problem is with aac+ encoding. It appears as though when aacPlusenc is fed the song from the pipe it takes a long time to complete it's encoding, which increases the probability that an error will occur.
  19. #1379  
    The screen that shows the artist, song, play list, search, etc. and has a little bubble with the count for each one. I would call it the home screen.
  20. #1380  
    Quote Originally Posted by bjgeiser View Post
    Have you tried Clean All?

    If all else fails you can delete the database using phpMyAdmin. But you'll have to rebuild the database. Probably best to delete/backup your ampache.config.php file first and redo you're whole setup.

    http://localhost/phpmyadmin/

    In phpMyAdmin click on Ampache on the left then click drop upper right.
    BJ,

    Thanks for your help. I did and now I'm getting the error that I cant connect to mySQL...

    Error
    MySQL said:

    #1045 - Access denied for user 'root'@'localhost' (using password: NO)

    phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.


    So it looks like I have a password issue. Back to the drawing board...

Tags for this Thread

Posting Permissions