View Poll Results: How many people have been able to get Ampache setup?

Voters
297. You may not vote on this poll
  • Yes

    160 53.87%
  • No

    137 46.13%
Page 43 of 88 FirstFirst ... 33383940414243444546474853 ... LastLast
Results 841 to 860 of 1750
Like Tree2Likes
  1. #841  
    Heya BJ! The app looks and works awesome. I decided to give it a whirl. After upgrading my ampache, I was able to connect! sorta I believe im having some ACL type errors. I have spent the last hour combing through this forum post to no avail. Here is the error:
    XML Processing Error
    Ping Error: <?xml version="1.0" encoding="UTF-8"?> <root> <error code="403"><![CDATA[ACL Error]]></error> </root>

    Running: Ampache v.3.5.4
    ACL List:
    DEFAULTv4 0.0.0.0 255.255.255.255 All All Web Interface Edit Delete
    DEFAULTv4 0.0.0.0 255.255.255.255 All All Stream Access Edit Delete
    DEFAULTv6 :: ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff All All Web Interface Edit Delete
    DEFAULTv6 :: ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff All All Stream Access Edit Delete
    forPre_1 0.0.0.0 255.255.255.255 All MyName (cobalt027) API/RPC Edit Delete
    forPre_2 0.0.0.0 255.255.255.255 View MyName (cobalt027) Stream Access Edit Delete
    forPre_3 0.0.0.0 255.255.255.255 View MyName (cobalt027) Web Interface Edit Delete

    I get this after it connects. Then i see the list of Artist, Album, etc with numbers. The app seems to work from this point on. Just very curious about that Error popup I get. I believe i might have some tracks with asian characters lying around (see?! i did read the thread! )

    Thanks for the great app!

    - Cobalt027
  2.    #842  
    Quote Originally Posted by cobalt027 View Post
    I have spent the last hour combing through this forum post to no avail. Here is the error:
    XML Processing Error
    Ping Error: <?xml version="1.0" encoding="UTF-8"?> <root> <error code="403"><![CDATA[ACL Error]]></error> </root>
    I have a close friend with the same error. I've never figured it out, but I've never looked into it much. It smells of an Ampache server bug to me, or I could be formatting the ping message incorrectly.

    Here are my ACL Rules.

    DEFAULTv4 0.0.0.0 255.255.255.255 All All Web Interface Edit Delete
    DEFAULTv4 0.0.0.0 255.255.255.255 All All Stream Access Edit Delete
    DEFAULTv6 :: ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff All All Web Interface Edit Delete
    DEFAULTv6 :: ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff All All Stream Access Edit Delete
    Ampache Mobile 0.0.0.0 255.255.255.255 Read All API/RPC Edit Delete
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  3.    #843  
    Release Notes and Screen Shots

    Here you go. Seems to have cleaned up any issues I've was having before with the playlist and adds a couple nice features.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  4. #844  
    Quote Originally Posted by bjgeiser View Post
    Release Notes and Screen Shots

    Here you go. Seems to have cleaned up any issues I've was having before with the playlist and adds a couple nice features.
    This app is just amazing. It's such a relief having access to all of my music again. I find it pretty impressive all the little tweaks you keep making. The performance just keeps getting better and better. There is only 1 thing on my personal wish list and that is a dashboard control like pandora and music player have.

    Just to mention it, on your first post you have the following bug:

    WebOS appears to have an issue when you pause a media stream. Pausing a stream and leaving the application open will cause your phone to heat up and use up battery.
    That was fixed a couple versions back. Ampache and Pandora etc no longer destroy the battery when paused.
  5. #845  
    Just wanted to say that this app is AWESOME and to thank you for developing it and for still continuing to work on it and improve it!

    THANX AGAIN!!!
  6. #846  
    BJ, If you have the desire to take a look at the weird error I mentioned (couple posts up), let me know. I can give you an account on the server.

    On another note, do you ever plan to put the app in the app store? I read a post that says it will always be free (which I think is awesome). Just curious if your thoughts had changed. I would be willing to pay for it for sure. If you still intend it to be free, then I intend to donate. To that end, is there a "standard" donation that people give? I don't want to seem like a cheapskate by giving too little.

    Thanks again for the awesome app. It has given me motivation to invest the time in my music collection again.

    - cobalt027
  7. DNic's Avatar
    Posts
    570 Posts
    Global Posts
    599 Global Posts
    #847  
    Excellent update! Happy to see you added text color change option makes it a lot easier to read with a custom background.

    Keep em coming
  8.    #848  
    Quote Originally Posted by cobalt027 View Post
    BJ, If you have the desire to take a look at the weird error I mentioned (couple posts up), let me know. I can give you an account on the server.
    When I have some free time I'll drop you a PM.

    Quote Originally Posted by cobalt027 View Post
    On another note, do you ever plan to put the app in the app store? I read a post that says it will always be free (which I think is awesome). Just curious if your thoughts had changed. I would be willing to pay for it for sure. If you still intend it to be free, then I intend to donate. To that end, is there a "standard" donation that people give? I don't want to seem like a cheapskate by giving too little.
    As far as it being in the App store. I started down that path and Palm still wants a tax ID for open source programs, which turned me off to that idea.

    If the app does ever make it in in a pay form, It would be rebranded and I would also write my own server which would be a bit easier to setup, configure and came up with a way of dealing with firewalls. Ampache Mobile would still be free. Selling the app as is would create a support nightmare for me, as evidenced by the 50% successful server setup rate on the forum poll.

    Donations: So far I've made a grand total of about $45 in 5+ months of donations (Almost enough to buy a bluetooth A2DP adapter to test with). Seems like the standard is somewhere between $5-10.

    My thanks to those who have donated.

    Quote Originally Posted by cobalt027 View Post
    Thanks again for the awesome app. It has given me motivation to invest the time in my music collection again.

    - cobalt027
    Glad you like it. My ipod is collecting dust.
    Last edited by bjgeiser; 03/24/2010 at 08:02 PM.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  9. #849  
    Wow, I am excited to try and set up a webserver and get this app working. But I have one question that I have not seen addressed yet.
    How will running a webserver on my pc affect the perfomance of the system? Should I use a dedicated box for this, or can the webserver run with my OS while I game & such without bogging down my system? I am running windows XP Pro, 4 gigs of ram with a 2ghz amd dual core cpu. Do you guys have any feedback?
    Thanks!
  10. #850  
    Quote Originally Posted by ttuning View Post
    Wow, I am excited to try and set up a webserver and get this app working. But I have one question that I have not seen addressed yet.
    How will running a webserver on my pc affect the perfomance of the system? Should I use a dedicated box for this, or can the webserver run with my OS while I game & such without bogging down my system? I am running windows XP Pro, 4 gigs of ram with a 2ghz amd dual core cpu. Do you guys have any feedback?
    Thanks!
    you can always shut down the daemon when gaming and such. If you can afford it I would set up a dedicated machine for all your serving needs. I'd make it a linux box as well.
  11. #851  
    I can provide a good answer to that question, as I run my webserver through my mediacenter pc. I'm using xampplite, and set apache and mysql as services to run in the background. I am running Windows 7 on a Core2Duo 2.67Ghz with 2gb RAM and an Nvidia 9800GT video card. The server uses such little resources that I can't even tell it's running when I use the PC for other things, like watching movies and shows through Boxee or MediaPortal, or playing games like Assassins Creed 2. It causes no lag whatsoever.
  12.    #852  
    If you have an old computer laying around 500MHz(ish) or faster. I'd recommend running a dedicated linux server. Personally I use ClearOS as a webserver, vpn gateway, proxy and router.

    A dedicated ITX Atom board would make a perfect Ampache server for less than $100. This guy used an ARM based mini system http://ampache.org/forums/viewtopic.php?f=4&t=2989

    As for windows, Apache in general is very light weight, and should hardly use any resources when you aren't connected to it.
    Last edited by bjgeiser; 03/25/2010 at 03:21 PM.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  13. #853  
    Strange little thing since updating to 0.8.5... maybe a feature that I managed to overlook in the release notes? I now have to press play in order to proceed to the next song on a list, or even to start playing the first selection. Is that normal behavior?
  14.    #854  
    Quote Originally Posted by froggersloth View Post
    Strange little thing since updating to 0.8.5... maybe a feature that I managed to overlook in the release notes? I now have to press play in order to proceed to the next song on a list, or even to start playing the first selection. Is that normal behavior?
    That's definitely not the intended behavior, and not something I've seen in my usage. A couple questions... Do you have a solid EVDO connection? If not have you tried the Auto Recovery Feature (it has a timeout for bad connection and represses play automatically)? I'd also recommend turning on the stream debug, i think the button bounces back and fourth between tracks and on a slow connection that may make it seem like its not buffering, I'll fix that for the next version.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  15. #855  
    Quote Originally Posted by bjgeiser View Post
    That's definitely not the intended behavior, and not something I've seen in my usage. A couple questions... Do you have a solid EVDO connection? If not have you tried the Auto Recovery Feature (it has a timeout for bad connection and represses play automatically)? I'd also recommend turning on the stream debug, i think the button bounces back and fourth between tracks and on a slow connection that may make it seem like its not buffering, I'll fix that for the next version.
    Thanks for the reply. I have a 5-bar EVDO connection. Let me describe what I do, just to make sure that my expectations are correct:

    1) Open Ampache Mobile (of course...). My preferred server is auto-selected from the list of options.
    2) Tap Playlists, tap "Gym", tap, say, "Dani California". At this point I expect it to start playing once a reasonable amount of the song is dl'ed. No such luck... That track relocates to the center of the screen (list mode...) and the download progress bar starts up. Within about 30 seconds it's finished. Right now the pause button is visible (that is "click to pause", not "click to resume playing"), and yet there is no sound.
    3) Click pause (symbol changes from pause to play) and click play. Ah, the glorious sounds appear...

    So, it appears to download properly, but I'll give your suggestions a shot anyway and see what happens.
  16.    #856  
    Quote Originally Posted by froggersloth View Post
    Thanks for the reply. I have a 5-bar EVDO connection. Let me describe what I do, just to make sure that my expectations are correct:

    1) Open Ampache Mobile (of course...). My preferred server is auto-selected from the list of options.
    2) Tap Playlists, tap "Gym", tap, say, "Dani California". At this point I expect it to start playing once a reasonable amount of the song is dl'ed. No such luck... That track relocates to the center of the screen (list mode...) and the download progress bar starts up. Within about 30 seconds it's finished. Right now the pause button is visible (that is "click to pause", not "click to resume playing"), and yet there is no sound.
    3) Click pause (symbol changes from pause to play) and click play. Ah, the glorious sounds appear...

    So, it appears to download properly, but I'll give your suggestions a shot anyway and see what happens.
    FYI. The streaming debug messages are only on the cover art view of now playing.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  17. #857  
    Quote Originally Posted by bjgeiser View Post
    FYI. The streaming debug messages are only on the cover art view of now playing.
    I checked that out... it was a little tough to get everything, but I don't think there were any errors. Here are the messages, as well as I could discern them:

    Starting Stream --> Stream loading stalled (almost impossible to catch the stall message... it was barely there...) --> durationchange --> Download Starting --> (short message I can't make out...) --> Download Starting --> durationchange --> Can Play Through --> Downloading (various increasing percentages).

    I was wrong when I suggested before that there is no sound without my hitting pause then play. Sometimes it does start by itself, but only once most of the song (about 80% seems typical...) is downloaded.

    Doesn't the fact that there's the pause symbol mean that the player "thinks" it's actually playing? For whatever reason, it's not playing. I have to do the pause-play thing, and then there's sound.

    Any suggestions? I don't mind un/reinstalling if there's a chance that'll help. Alternately, is there any server config that could cause this? Many thanks.
  18.    #858  
    Quote Originally Posted by froggersloth View Post
    I checked that out... it was a little tough to get everything, but I don't think there were any errors. Here are the messages, as well as I could discern them:

    Starting Stream --> Stream loading stalled (almost impossible to catch the stall message... it was barely there...) --> durationchange --> Download Starting --> (short message I can't make out...) --> Download Starting --> durationchange --> Can Play Through --> Downloading (various increasing percentages).

    I was wrong when I suggested before that there is no sound without my hitting pause then play. Sometimes it does start by itself, but only once most of the song (about 80% seems typical...) is downloaded.

    Doesn't the fact that there's the pause symbol mean that the player "thinks" it's actually playing? For whatever reason, it's not playing. I have to do the pause-play thing, and then there's sound.

    Any suggestions? I don't mind un/reinstalling if there's a chance that'll help. Alternately, is there any server config that could cause this? Many thanks.
    That stream of debug messages seems pretty typical. The only thing is that it should start playing well before 80%. The audio playback is really up to webOS, so there isnt much I can do to the code to make it work any differently. Do u have transcoding on? How long does it typically take to load a full song? Have you tried rebooting your phone?
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  19. #859  
    Quote Originally Posted by bjgeiser View Post
    That stream of debug messages seems pretty typical. The only thing is that it should start playing well before 80%. The audio playback is really up to webOS, so there isnt much I can do to the code to make it work any differently. Do u have transcoding on? How long does it typically take to load a full song? Have you tried rebooting your phone?
    I don't have transcoding on. Over EVDO, a 2:37 song (5MB) downloaded in 1 minute. I have rebooted the phone, and I've reinstalled the app. I've also found that AmpachPre (hideous interface and all...) plays the song almost immediately. I just can't figure out why in the world Ampache Mobile doesn't start playing. Once I manually intervene to start the playback, I have to do the same when it proceeds to the next song in the list. Very strange.

    FWIW, I also installed the 720MHz patch. Is there any reason that would interfere?
  20.    #860  
    Quote Originally Posted by froggersloth View Post
    I don't have transcoding on. Over EVDO, a 2:37 song (5MB) downloaded in 1 minute. I have rebooted the phone, and I've reinstalled the app. I've also found that AmpachPre (hideous interface and all...) plays the song almost immediately. I just can't figure out why in the world Ampache Mobile doesn't start playing. Once I manually intervene to start the playback, I have to do the same when it proceeds to the next song in the list. Very strange.

    FWIW, I also installed the 720MHz patch. Is there any reason that would interfere?
    Well now i am really intrigued. I doubt the patch would break anything. I changed two lines of code in this build, can you try it out and see if it helps at all? com.ampachemobile_0.8.5_autoplay_all.ipk
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.

Tags for this Thread

Posting Permissions