View Poll Results: How many people have been able to get Ampache setup?

Voters
297. You may not vote on this poll
  • Yes

    160 53.87%
  • No

    137 46.13%
Page 4 of 88 FirstFirst 1234567891454 ... LastLast
Results 61 to 80 of 1750
Like Tree2Likes
  1. tredftw's Avatar
    Posts
    35 Posts
    Global Posts
    37 Global Posts
    #61  
    i just got wifi and evdo working on my mac after 8 hours of frustration and these were all the places I ran into trouble, I used the windows xp instructions on the Ampache site to install Ampache, you have to use dyndns to get a web address for your ip to access over evdo, you have to use your public ip when signing up for evdo not 192.168.x.x you HAVE to port forward! at least for me. once I turned on port forwarding on my router I got it working on evdo. hope this helps, and this was just for me, so success may vary. It works great, thanks so much for this app!

    Edit: Oh! and you also have to set up your acl's! go to the admin tab under the menu in apache's web server and then go to add acl. for start address make it 0.0.0.0 and for end address make it 255.255.255.255, i set my type to rpc, my level to view and my user to all. This is very important as well.
    Last edited by tredftw; 08/29/2009 at 08:33 PM.
  2. #62  
    Quote Originally Posted by falz View Post
    What version of Ampache are you running? modules\xmlrpc\xmlrpc.inc doesn't exist on mine at all. I also re-downloaded the latest stable version from Ampache and confirmed it's also not in the .tar.gz.
    I'm using Ampache v.3.4.4

    Update: I got the most recent stable version 3.5, it all works!
    Last edited by adactuslatem; 08/29/2009 at 08:27 PM.
    Palm Pilot m100 --> Alltel Razr V3c --> Alltel HTC PPC6800(Mogul) --> Alltel HTC Touch Pro --> Alltel Rokr Z6M --> Alltel Palm Pre

    Speed at 70Mph using MyTether using Alltel Hybrid Rev A
    http://i30.tinypic.com/2iu733d.jpg
  3. #63  
    can someone posts clear instructions for installing Ampache server on windows xp. the wiki ones don't work and aren't clearly written.
  4. #64  
    how come when I restarted my computer my browser will not log in to localhost? i turned back on the Xampp control panel
  5. #65  
    I'm just curious how secure this is.

    xampp, which the wiki says to install, makes me nervous because of the security risks it mentions. This seems to be more for developers than for those who aren't quite that advanced.
  6. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #66  
    you can change the security rather easily and add username and passwords
  7. #67  
    So I am having problems getting my ampache server to work on my pre, I got everything working as localhost, but when I change my port to 8081 in the httpd.conf it does not work, I also setup up a dns host name at dyndns.com

    Code:
    #
    # Listen: Allows you to bind Apache to specific IP addresses and/or
    # ports, instead of the default. See also the <VirtualHost>
    # directive.
    #
    # Change this to Listen on specific IP addresses as shown below to 
    # prevent Apache from glomming onto all bound IP addresses.
    #
    #Listen 0.0.0.0:80
    #Listen [::]:80
    Listen 80
    To:

    Code:
    #
    # Listen: Allows you to bind Apache to specific IP addresses and/or
    # ports, instead of the default. See also the <VirtualHost>
    # directive.
    #
    # Change this to Listen on specific IP addresses as shown below to 
    # prevent Apache from glomming onto all bound IP addresses.
    #
    #Listen 0.0.0.0:80
    #Listen [::]:80
    Listen myampache.dyndns.org:8081
    and:
    Code:
    #
    # ServerName gives the name and port that the server uses to identify itself.
    # This can often be determined automatically, but we recommend you specify
    # it explicitly to prevent problems during startup.
    #
    # If your host doesn't have a registered DNS name, enter its IP address here.
    #
    ServerName localhost:8081
    to this:
    Code:
    #
    # ServerName gives the name and port that the server uses to identify itself.
    # This can often be determined automatically, but we recommend you specify
    # it explicitly to prevent problems during startup.
    #
    # If your host doesn't have a registered DNS name, enter its IP address here.
    #
    ServerName myampache.dyndns.org:8081
    I don't have too much experience with php, but this isn't too bad so far, I have had 6 years of programming experience.
    Palm Pilot m100 --> Alltel Razr V3c --> Alltel HTC PPC6800(Mogul) --> Alltel HTC Touch Pro --> Alltel Rokr Z6M --> Alltel Palm Pre

    Speed at 70Mph using MyTether using Alltel Hybrid Rev A
    http://i30.tinypic.com/2iu733d.jpg
  8. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #68  
    didnt need to change to your dyndns port, just put the number of the port you want to change it to.
  9. #69  
    Quote Originally Posted by elryon View Post
    didnt need to change to your dyndns port, just put the number of the port you want to change it to.
    just keep localhost then? and then change the port?
    Palm Pilot m100 --> Alltel Razr V3c --> Alltel HTC PPC6800(Mogul) --> Alltel HTC Touch Pro --> Alltel Rokr Z6M --> Alltel Palm Pre

    Speed at 70Mph using MyTether using Alltel Hybrid Rev A
    http://i30.tinypic.com/2iu733d.jpg
  10. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #70  
    you just change the 80 in the original file to the port you want....
    then add the : and port number to any address you use, including localhost

    mypage.dyndns.com : port
    or localhost : port

    to access via the browser
    Last edited by elryon; 08/29/2009 at 09:30 PM.
  11. #71  
    Got that to work, but when I try to connect via my host name at my specified port it does not work, I have my public IP configured with the host name, and have the router port forwarding setup for my internal ip on the port I specified, I also have allocated an exception via the windows firewall for that port.
    Palm Pilot m100 --> Alltel Razr V3c --> Alltel HTC PPC6800(Mogul) --> Alltel HTC Touch Pro --> Alltel Rokr Z6M --> Alltel Palm Pre

    Speed at 70Mph using MyTether using Alltel Hybrid Rev A
    http://i30.tinypic.com/2iu733d.jpg
  12. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #72  
    is dyndns updated with your current ip? if its dynamic and you've rebooted or disconnected or anything is could have changed.... if you can connect via localhost:yourport then the dns entry might be pointed to the wrong ip address or your rounter/firewall is still blocking it. There is usually a setting in most routers to auto update to your dyndns account when your external ip address changes.
  13. #73  
    Quote Originally Posted by elryon View Post
    is dyndns updated with your current ip? if its dynamic and you've rebooted or disconnected or anything is could have changed....
    My current ip has not changed and I also have DDNS setup with my hostname on my router.

    Palm Pilot m100 --> Alltel Razr V3c --> Alltel HTC PPC6800(Mogul) --> Alltel HTC Touch Pro --> Alltel Rokr Z6M --> Alltel Palm Pre

    Speed at 70Mph using MyTether using Alltel Hybrid Rev A
    http://i30.tinypic.com/2iu733d.jpg
  14. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #74  
    well, I'm not sure then. did you restart apache and mysql? you need to restart the servers for the new ports to take affect. other than that, it would have to be something with the port forwarding or your firewall.
  15. #75  
    Everybody who frequents this site really loves there Pre and is willing to spend the extra time to make their phones just right. The vast majority of the world would not spend the time we spend putting on apps on their phones. The problem that these applicatons are causing (I'm posting this in two separate forums since it applies to two apps) has nothing to do with the apps themselves. It has to do with Xampp or the users personal ip addresses. That being said, however, if there is not a simpler way to rectify these problems-(maybe use a different server program other than Xampp) two great apps will miss out on a large pecentage of the population who is not willing to spend the hours it takes to install them
  16. #76  
    Quote Originally Posted by elryon View Post
    well, I'm not sure then. did you restart apache and mysql? you need to restart the servers for the new ports to take affect. other than that, it would have to be something with the port forwarding or your firewall.
    Well I did that, I can still only access the localhost, but cannot connect via host name. However I got this when I used my external IP on ampache mobile:



    EDIT: I also get that when using my hostname.
    Palm Pilot m100 --> Alltel Razr V3c --> Alltel HTC PPC6800(Mogul) --> Alltel HTC Touch Pro --> Alltel Rokr Z6M --> Alltel Palm Pre

    Speed at 70Mph using MyTether using Alltel Hybrid Rev A
    http://i30.tinypic.com/2iu733d.jpg
  17. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #77  
    did you add the http:// to your host address?
  18. #78  
    Quote Originally Posted by elryon View Post
    did you add the http:// to your host address?
    Yeppers

    (do I have to use the ACL username? or a different username for access? I set one up with RPC like the guy in the post about the mac did.)
    Palm Pilot m100 --> Alltel Razr V3c --> Alltel HTC PPC6800(Mogul) --> Alltel HTC Touch Pro --> Alltel Rokr Z6M --> Alltel Palm Pre

    Speed at 70Mph using MyTether using Alltel Hybrid Rev A
    http://i30.tinypic.com/2iu733d.jpg
  19. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #79  
    not sure... you could try it. I only just got these working yesterday.
  20. #80  
    Quote Originally Posted by elryon View Post
    not sure... you could try it. I only just got these working yesterday.
    I just updated to the most recent ampache. I think there is something wrong with ampache settings, I get a 503 Service unavailable message. I am going to try and reboot and see if that works.
    Palm Pilot m100 --> Alltel Razr V3c --> Alltel HTC PPC6800(Mogul) --> Alltel HTC Touch Pro --> Alltel Rokr Z6M --> Alltel Palm Pre

    Speed at 70Mph using MyTether using Alltel Hybrid Rev A
    http://i30.tinypic.com/2iu733d.jpg
Page 4 of 88 FirstFirst 1234567891454 ... LastLast

Tags for this Thread

Posting Permissions