View Poll Results: How many people have been able to get Ampache setup?

Voters
297. You may not vote on this poll
  • Yes

    160 53.87%
  • No

    137 46.13%
Page 19 of 88 FirstFirst ... 914151617181920212223242969 ... LastLast
Results 361 to 380 of 1750
Like Tree2Likes
  1. #361  
    Quote Originally Posted by cfbauer View Post
    Obviously I double checked the password, the web app is letting me login with the same un and pw that apparently are unable to be matched in Amarok and Ampache Mobile.

    Maybe I'm using the wrong server? The address I have is:

    http://mydyndnshostname.com/ampache, where ampache is the folder in which it is installed.
    1) Can you connect with Ampache Mobile on you local home network (i.e. 192.168....)?

    2) Can you connect with Ampache Mobile using the ip address instead of http://mydyndnshostname.com/ampache?

    3) Do you have an ACL set up for API/RPC?
  2. cfbauer's Avatar
    Posts
    179 Posts
    Global Posts
    206 Global Posts
    #362  
    Quote Originally Posted by wilderf View Post
    1) Can you connect with Ampache Mobile on you local home network (i.e. 192.168....)?

    2) Can you connect with Ampache Mobile using the ip address instead of http://mydyndnshostname.com/ampache?
    I'm not sure of the difference between the two.

    I tried both my local IP, and my Broadcast Address, neither worked. But neither gave an error message, nor added anything to the log file.

    3) Do you have an ACL set up for API/RPC?
    I have an ACL set up for all 4 options, including RPC. You can see some details in this post.
    Last edited by cfbauer; 09/17/2009 at 11:45 PM.
  3.    #363  
    Yup thats right. You can run Ampache Mobile on Windows. Here's how

    LETS MAKE THIS CLEAR

    DO NOT post the Mojo Framework to this thread. It will be immediately deleted. Palm has been really friendly to us thus far, lets not do anything to upset them.

    Please don't post questions about Ampache Mobile for Windows to this thread, its already long enough as it is. Question for the windows version can be posted here

    As for the App, it works if you get the Framework on your machine. I've only tested it with Safari 4.0.2 on Windows XP using the 1.1 SDK

    Last edited by bjgeiser; 09/18/2009 at 11:45 AM.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  4. logos's Avatar
    Posts
    57 Posts
    Global Posts
    59 Global Posts
    #364  
    Quote Originally Posted by bjgeiser View Post
    It's not anything Ampache Mobile is doing.
    No I didn't figure it was. The weirder part is that even though the app couldn't access it, the web browser could. So if it is caching DNS resolves for some reason, it doesn't extend to the web browser.

    Either way, a reset fixes the issue if it comes up for people in the future.
  5.    #365  
    Quote Originally Posted by logos View Post
    No I didn't figure it was. The weirder part is that even though the app couldn't access it, the web browser could. So if it is caching DNS resolves for some reason, it doesn't extend to the web browser.

    Either way, a reset fixes the issue if it comes up for people in the future.
    That is very weird and unfortunate, maybe it will be resolved with an update someday.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  6. #366  
    Quote Originally Posted by cfbauer View Post
    I'm not sure of the difference between the two.

    I tried both my local IP, and my Broadcast Address, neither worked. But neither gave an error message, nor added anything to the log file.


    I have an ACL set up for all 4 options, including RPC. You can see some details in this post.
    Are you sure you are connecting to the right IP address and the right port?

    On my local network, the address it 192.168.1.203:80. On the internet, it is xxx.dyndns.org:8080.
  7. Maturin's Avatar
    Posts
    165 Posts
    Global Posts
    166 Global Posts
    #367  
    I was wondering if it was possible to have an option to sort by Album Artist. As it currently is, if you have tracks that are done by say for example artist x feat. artist z, they will appear separately from artist x in the list. Does the Ampache server support this?
  8.    #368  
    Quote Originally Posted by Maturin View Post
    I was wondering if it was possible to have an option to sort by Album Artist. As it currently is, if you have tracks that are done by say for example artist x feat. artist z, they will appear separately from artist x in the list. Does the Ampache server support this?
    I'm not 100% sure but I don't think Ampache Supports Album Artist
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  9. #369  
    Quote Originally Posted by Maturin View Post
    I was wondering if it was possible to have an option to sort by Album Artist. As it currently is, if you have tracks that are done by say for example artist x feat. artist z, they will appear separately from artist x in the list. Does the Ampache server support this?
    Ampache seems to have a few tags that it sorts with and "Album Artist" doesn't seem to be one of them. I made every album have the same artist and added additional performers into the title of the track. The scheme I set up for tribute albums,was Artist = the band being covered, the title of the album must contain "tribute" somewhere and the title of the track would be %actualartist% - %title%. Works well enough for now, I guess.
  10. logos's Avatar
    Posts
    57 Posts
    Global Posts
    59 Global Posts
    #370  
    Yeah, it's crazy. Oh well.

    Thanks for adding in the gesture nav, it works perfectly.
  11. cfbauer's Avatar
    Posts
    179 Posts
    Global Posts
    206 Global Posts
    #371  
    Quote Originally Posted by wilderf View Post
    Are you sure you are connecting to the right IP address and the right port?

    On my local network, the address it 192.168.1.203:80. On the internet, it is xxx.dyndns.org:8080.
    I see, I didn't know I needed to include the port in the server address. I tried using both Amarok and Ampache Mobile. When I include the :80 or :8080 in Amarok, nothing happens. When using Ampache Mobile, I'm getting 404 errors.

    I wonder if this has to do with my DynDNS not working outside my router.
  12. cfbauer's Avatar
    Posts
    179 Posts
    Global Posts
    206 Global Posts
    #372  
    Quote Originally Posted by wilderf View Post
    Are you sure you are connecting to the right IP address and the right port?

    On my local network, the address it 192.168.1.203:80. On the internet, it is xxx.dyndns.org:8080.
    I see. Didn't realize I need to include the port number with the server address.

    Well, I tried them both on Amarok and Ampache Mobile. Neither worked, unfortunately. On Amarok, there was no response. Ampache Mobile returned a 404 error.

    I wonder if this has to do with my DynDNS not working outside my router.
  13. #373  
    Finally got ampache working on my computer and phone by forwarding port 80 to 81 (cox blocks port 80 here in AZ). After spending some time trying to get transcoding to work I've now got a strange error:

    On the Pre application only the first 6 or so seconds of a song play, then it skips to the next track. Seems to work fine on the flash player when I access it through a web browser on a computer...any ideas? I've got transcoding disabled, should be the initial configuration as far as I can tell.

    Also, anyone know where to place faad, lame, etc to get transcoding to work? I'm running Win XP SP3. I added them to the htdocs folder in xampp and added the path to windows...no luck so far.

    Thanks!

    **Edit
    Was able to resolve the playback issue by rewriting the config file..must have messed something up I guess

    @ bhack thanks for the pointer, transcoding is now working great!
    Last edited by fender_01; 09/19/2009 at 07:24 PM. Reason: update
  14. #374  
    Quote Originally Posted by fender_01 View Post
    Finally got ampache working on my computer and phone by forwarding port 80 to 81 (cox blocks port 80 here in AZ). After spending some time trying to get transcoding to work I've now got a strange error:

    On the Pre application only the first 6 or so seconds of a song play, then it skips to the next track. Seems to work fine on the flash player when I access it through a web browser on a computer...any ideas? I've got transcoding disabled, should be the initial configuration as far as I can tell.

    Also, anyone know where to place faad, lame, etc to get transcoding to work? I'm running Win XP SP3. I added them to the htdocs folder in xampp and added the path to windows...no luck so far.

    Thanks!
    Add them wherever you want, just reference the path in the call:

    transcode_cmd_flac = "C:\Xampp\xampp\flac -dc %FILE% | C:\Xampp\xampp\lame -b %SAMPLE% -S - - "
  15. #375  
    OK, after struggling through issue after issue with this setup I think I'm almost there but now I'm getting 'Error invalid Handshake', I've tried this both externally (routing to my server via NAT) and connecting directly to the server.. no dice either way.

    I tried turning logging on, but can't get it to generate a log file.

    Any suggestions of what I can look at for this?

    *** Update ***
    Turns out I didn't have a recent enough version of Ampache.
    I upgraded to 3.5.1 and everything is beautiful now... absolutely AWESOME app!
    Last edited by showson1; 09/19/2009 at 10:50 AM.
    Went from iPhone to Pre and love it!
  16.    #376  
    Quote Originally Posted by showson1 View Post
    *** Update ***
    Turns out I didn't have a recent enough version of Ampache.
    I upgraded to 3.5.1 and everything is beautiful now... absolutely AWESOME app!
    That seems to happen quite often. For people having issues. Make sure the Ampache Web site says 3.5.1 on the bottom. Not 3.5
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  17. cfbauer's Avatar
    Posts
    179 Posts
    Global Posts
    206 Global Posts
    #377  
    Quote Originally Posted by showson1 View Post
    OK, after struggling through issue after issue with this setup I think I'm almost there but now I'm getting 'Error invalid Handshake', I've tried this both externally (routing to my server via NAT) and connecting directly to the server.. no dice either way.

    I tried turning logging on, but can't get it to generate a log file.

    Any suggestions of what I can look at for this?

    *** Update ***
    Turns out I didn't have a recent enough version of Ampache.
    I upgraded to 3.5.1 and everything is beautiful now... absolutely AWESOME app!
    Quote Originally Posted by bjgeiser View Post
    That seems to happen quite often. For people having issues. Make sure the Ampache Web site says 3.5.1 on the bottom. Not 3.5
    This was my problem as well. It says in bold letters everywhere to MAKE SURE YOU USE THE NEWEST VERSION but I assumed that since I just downloaded it was the newest. Bad idea.

    Big thanks to everyone who helped, especially wilderf.
  18. #378  
    question:

    I just noticed this. How come the "Albums" section sorts by year rather then alphabetically? I've never seen that. I have no clue what year stuff is in. And the year is often inaccurate too as some albums are listed by their reissue date rather then their original release date. But it basically renders that section useless as there's no way i can remember the date for 250 GBs of music. that said i only noticed it now cause i don't search by album but i wanted to ask as i've never seen that on a player before. personally i prefer genre, artist, album, song for searching but it's not available. now i'm just using playlists or searches.
  19.    #379  
    Quote Originally Posted by blackmagic01 View Post
    question:

    I just noticed this. How come the "Albums" section sorts by year rather then alphabetically? I've never seen that. I have no clue what year stuff is in. And the year is often inaccurate too as some albums are listed by their reissue date rather then their original release date. But it basically renders that section useless as there's no way i can remember the date for 250 GBs of music. that said i only noticed it now cause i don't search by album but i wanted to ask as i've never seen that on a player before. personally i prefer genre, artist, album, song for searching but it's not available. now i'm just using playlists or searches.
    The reason I did it that way is that I've always wanted a player that sorted by year. That way all the new albums from this year are on top, personally I love it. As for the years being wrong, I've probably spent 100s of hours over the years cleaning up the tags on my collection so its not really an issue for me.

    I've always had the intention of adding a sort button to that screen so you can sort however you like, should be pretty easy to do now. Should be there soon.

    Here is the stuff I've been working on. Sorting is issue 10
    Issues - ampache-mobile - Project Hosting on Google Code
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  20. #380  
    Quote Originally Posted by bjgeiser View Post
    The reason I did it that way is that I've always wanted a player that sorted by year. That way all the new albums from this year are on top, personally I love it. As for the years being wrong, I've probably spent 100s of hours over the years cleaning up the tags on my collection so its not really an issue for me.

    I've always had the intention of adding a sort button to that screen so you can sort however you like, should be pretty easy to do now. Should be there soon.

    Here is the stuff I've been working on. Sorting is issue 10
    Issues - ampache-mobile - Project Hosting on Google Code
    i see. personally not my thing. I think what you want is acutally "year" sorting and thus a "year" section as opposed to "album". but it's you're software. I've cleaned all of my tags as well. literally took me almost a year to redo once after i lost half of my collection so i feel you on that. Still year was never something i fixated about because with the size of my collection i wasn't going to go back and look up release dates for albums let alone the thousands of tracks I have released in the 40s, 50s, and 60s, release only as singles. like i have a bunch of blues artists or old r&b artists that are famous now but couldn't release full albums back in the day. so who knows what those exact dates are. I just stopped worrying about it. obviously do as you like.

    regardless something to consider:

    A "Genre" section. Personally i'd love this cause this is how i browse. And not like the Palm Pre does which is "genre" "rock" then 8000 "songs" as a matter of fact that is one of the few requests i have on music players. i just hate when it goes straight to songs because i have a couple genre's with about 11000 songs each and things grind it's becomes really slow to load. Plus i just think it's more logical. regardless. if it's not doable thanks for the consideration.

    damn i need coffee. i'm off to get some caffeine.

Tags for this Thread

Posting Permissions