Page 9 of 53 FirstFirst ... 456789101112131419 ... LastLast
Results 161 to 180 of 1046
  1. #161  
    Does anyone know if there is a way to get the browser to to automatically close after the stream is complete? It would be cool if there was a way to do so rather than having to close it every time a song finishes.

    -J
  2. #162  
    Quote Originally Posted by angiest View Post
    Yes, transcoding works. Virtually all of my music is flac and it streamed all the way home from work (a ~25 mile trip). I think the API documentation talks about how the track data is returned, alternately I can give you more information from my amarok trace.

    Something I noticed... the palm streaming media app allows you to play multiple streams simultaneously instead of queuing. This would cause problems for creating a playlist consisting of multple tracks instead of a .pls or .m3u file. I wonder if the streaming media app returns any information when playback ends. Then you could "simply" (not commenting on difficulty!) create an internal playlist consisting of urls and submit them to the web browser one at a time as the previous one ends. Not very elegant but this seems to be something where palm is lacking. :/


    I just tested it at home over WIFI. Works fine with the same account.
    Yeah I got trancoding to work just fine after a little tweaking.
  3.    #163  
    Quote Originally Posted by JayMadison View Post
    Does anyone know if there is a way to get the browser to to automatically close after the stream is complete? It would be cool if there was a way to do so rather than having to close it every time a song finishes.

    -J
    I am working on a streaming client that is built in to ampachpre. This will ruduce the need for the web browser. I will probably make a option for which way you want to stream for those of you who have enabled downloads in the browser so you can download the mp3 to the phone as palm has not enabled this feature in the api.
  4. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #164  
    Quote Originally Posted by fain View Post
    I am working on a streaming client that is built in to ampachpre. This will ruduce the need for the web browser. I will probably make a option for which way you want to stream for those of you who have enabled downloads in the browser so you can download the mp3 to the phone as palm has not enabled this feature in the api.
    Palm or Ampache?
  5.    #165  
    Palm, to my knowledge, there is no way currently to save files to the filesystem :/ without acting as a official palm app that is. Filecoaster does it by prepending a com.palm in the app id.
  6. #166  
    Quote Originally Posted by fain View Post
    Does it log in on you home wifi?
    hmm yes it does, never really pay'd attention to that
  7. #167  
    Quote Originally Posted by angiest View Post
    It sounds like if the problem is only happening over the internet (trying turning off WIFI on your phone at home and connect via EVDO) then it sounds like a firewall problem.

    oki turned it off and it didnt connect...what should i do with my firewall settings

    my firewall is not turned on\?
    Last edited by ntown901; 08/27/2009 at 01:22 PM. Reason: looked @ firewall and its off
  8.    #168  
    You turned the fire wall on the router off? Or the software firewall. Also make sure you are using your external ip not your home ip in the account settings on ampachpre.

    Check here on the pc ampache is running on to figure this out

    What Is My IP Address? - IP Address Lookup, Internet Speed Test, IP Info, plus more
  9. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #169  
    Quote Originally Posted by ntown901 View Post
    oki turned it off and it didnt connect...what should i do with my firewall settings

    my firewall is not turned on\?
    Two possibilities jump out. You are using an internal IP address to connect, which therefore won't work on EVDO regardless of where you are. Two, you are using the IP address of your router (correctly) but it is not forwarding port 80 to your Ampache server. Unless you set it up to do so your router should not forward any traffic from the net to anything on your private network. You need to put your Ampache server in the DMZ or forward port 80 traffic to it. See your router documentation as the steps (and possibly terminology) will vary.
  10. #170  
    Quote Originally Posted by fain View Post
    You turned the fire wall on the router off? Or the software firewall. Also make sure you are using your external ip not your home ip in the account settings on ampachpre.

    Check here on the pc ampache is running on to figure this out

    What Is My IP Address? - IP Address Lookup, Internet Speed Test, IP Info, plus more
    oh yeah, windows firewall, the ip address this gives me is different from what i have, is this my router ip or bellsouth ip
  11. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #171  
    Quote Originally Posted by ntown901 View Post
    oh yeah, windows firewall, the ip address this gives me is different from what i have, is this my router ip or bellsouth ip
    That should be giving you the public IP address on your router. This is the one you will need to put into ampachpre. It should *not* be in the ranges of 192.168.0.0 to 192.168.255.255 or in the entire 10.aaa.bbb.ccc address range (class A network). You may still have the issue of setting up your router to pass inbound traffic to your ampache server. Since you are using Windows I would recommend forwarding only port 80 traffic, assuming your ampache server is set up to listen on port 80.
  12. #172  
    Quote Originally Posted by angiest View Post
    That should be giving you the public IP address on your router. This is the one you will need to put into ampachpre. It should *not* be in the ranges of 192.168.0.0 to 192.168.255.255 or in the entire 10.aaa.bbb.ccc address range (class A network). You may still have the issue of setting up your router to pass inbound traffic to your ampache server. Since you are using Windows I would recommend forwarding only port 80 traffic, assuming your ampache server is set up to listen on port 80.
    yes it is forward to port 80 now and i typed in dat address/ampache and it just spins.....im so lost now
  13. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #173  
    Quote Originally Posted by ntown901 View Post
    yes it is forward to port 80 now and i typed in dat address/ampache and it just spins.....im so lost now
    Can you point a web browser to your ampache server? The one on the pre will work fine for this test.
  14. #174  
    Quote Originally Posted by angiest View Post
    Can you point a web browser to your ampache server? The one on the pre will work fine for this test.
    by typin http://localhost/ampache if so then this doesnt work, i even try'd the ip address still no go
  15. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #175  
    Quote Originally Posted by ntown901 View Post
    by typin http://localhost/ampache if so then this doesnt work, i even try'd the ip address still no go
    localhost wont work from the internet. If you can't connect to the web interface it may still be a router config issue.
  16. #176  
    i have ampache forward to port 80 and server also on port 80 i cant think of anything else now when i try to connect to wifi with that public address it wont connect
  17. #177  
    Quote Originally Posted by ntown901 View Post
    i have ampache forward to port 80 and server also on port 80 i cant think of anything else now when i try to connect to wifi with that public address it wont connect
    I have the same problem you're having. I've messed with it for 3 days and no luck.

    Mine only works from all my computers connected via my router to the internet. I can use any laptop at home and connect to my ampache music server and play tunes. I can even do this via AmpachePre when the Pre is connected to my WiFi at home. However, once I forward my address to friends or if I try to connect with AmpachePre via EVDO it spins forever.

    I've tried forwarding all the router ports and even router AND windows firewall ports but no luck. I even DMZ'ed the server (putting it in FRONT of the firewall, unprotected), and still no luck. I gave up on the software. I remember reading somehwere along the line (i think Fain mentioned it) that some ISP's don't allow you to have traffic on port 80? Not sure if my ISP is this way or not, but seems likely.
  18. #178  
    Quote Originally Posted by Stillen_i30 View Post
    I have the same problem you're having. I've messed with it for 3 days and no luck.

    Mine only works from all my computers connected via my router to the internet. I can use any laptop at home and connect to my ampache music server and play tunes. I can even do this via AmpachePre when the Pre is connected to my WiFi at home. However, once I forward my address to friends or if I try to connect with AmpachePre via EVDO it spins forever.

    I've tried forwarding all the router ports and even router AND windows firewall ports but no luck. I even DMZ'ed the server (putting it in FRONT of the firewall, unprotected), and still no luck. I gave up on the software. I remember reading somehwere along the line (i think Fain mentioned it) that some ISP's don't allow you to have traffic on port 80? Not sure if my ISP is this way or not, but seems likely.
    I knoi have even change ports on both the server and the router,(cuz i got ares open on a port for faster downloads)but still no luck i have tversity on my pc will that stop anything
  19. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #179  
    For those of you having trouble connecting that can connect when on wifi... or on any computer that is on the same network... most likely your isp is blocking any incoming traffic on port 80. You will need to change the port used to a different port, such as 8081 or something. This is changed in the httpd.conf file. Just edit with a text editor and look for any reference to port 80 and change to the port you want to use. Then restart the servers. Then add the port reference on your account such as:

    youripaddress:8081/ampache-3.5.1

    hope this helps some...

    EDIT: dont forget to change the port forwarding on your router...
  20. #180  
    Quote Originally Posted by elryon View Post
    For those of you having trouble connecting that can connect when on wifi... or on any computer that is on the same network... most likely your isp is blocking any incoming traffic on port 80. You will need to change the port used to a different port, such as 8081 or something. This is changed in the httpd.conf file. Just edit with a text editor and look for any reference to port 80 and change to the port you want to use. Then restart the servers. Then add the port reference on your account such as:

    youripaddress:8081/ampache-3.5.1

    hope this helps some...

    EDIT: dont forget to change the port forwarding on your router...
    hmm i didnt think of that, will try when i get home.....hope its works tho
Page 9 of 53 FirstFirst ... 456789101112131419 ... LastLast

Posting Permissions