Page 44 of 53 FirstFirst ... 343940414243444546474849 ... LastLast
Results 861 to 880 of 1046
  1.    #861  
    Quote Originally Posted by angiest View Post
    Bug reports.

    without an active log tapping doesn't work. I couldn't dismiss the first use screen, had to close the app and relaunch. Couldn't access downloads either. After getting logged in I could access downloads.

    searching with a null string used to bring up everything, now it only brings uo one result, the first.
    Ok I have fixed all of these issues. You say the "first use screen" do you mean "What's new" or "New user guide"? I did discover the Ok command in "What's new" was broke but you should have been able to back swipe.
    AmpachPre, your music your way.

  2.    #862  
    Quote Originally Posted by mamouton View Post
    Oh ok thanks. how can one add the ampache functionality to another music player?

    I updated ampachepre this morning and really like the changes.

    Do you plan on importing the playlist on ampache to work in ampachePre?
    You would have to use ampaches open api located here Ampache's XML API STABLE VERSION [Ampache :: Wiki]

    Yes I do plan on doing that. I started writing the code one night but got side tracked.
    AmpachPre, your music your way.

  3.    #863  
    Quote Originally Posted by mamouton View Post
    Do you plan on importing the playlist on ampache to work in ampachePre?
    Just finished the code for this. It will be in the next release....
    AmpachPre, your music your way.

  4.    #864  
    • True pre buffering added, no more download manager. no more cancelled downloads. When the song gets 75% played the next song will start buffering
    • Added Random Play to the Home Scene.(Updater's will need to reset the home scene for this Item to show up. New users you should see it at first install.)
    • Dynamic Album art and list resizing. Notifications will no longer cover up any of AmpachPre's interface.
    • Added "New User Guide" You can reach this by either the app menu from the home scene or using the keyboard short cut "?".
    • Fixed pause/play by keyboard short cut. Added a few new shortcuts too. See "New User Guide" for more info.
    • Tied border colors to text color.
    • Added a auto reconnect if a "MEDIA_ERR_DECODE" happens
    • Bug Fix: if you started a new playlist, the current playing list would play the wrong song or quit playing all together.
    • Added some formatting love for the pixi users.
    • Added Bookmark song to the Now Playing scenes
    • Re-worked auto login.
    • fixed a problem that might have crashed the now playing list view if you do not use lastfm
    • Added "To Next" on the now playing playlist.
    • Added "Get Playlists" command to the Saved Playlists scene so you can download any playlists you have created in Ampache
    AmpachPre, your music your way.

  5. #865  
    I think I found a bug:
    Just tried to add a new account in the current version. The tap on save did just nothing until I deleted the value in "# of songs to fetch on random play" and reentered it again. Before deleting the value, the value itself and the hint text of the input were visible. After reentering the default of 30 I could save the account. So probably simply a problem with the default value and the according hint text.
  6.    #866  
    Quote Originally Posted by alex3683 View Post
    I think I found a bug:
    Just tried to add a new account in the current version. The tap on save did just nothing until I deleted the value in "# of songs to fetch on random play" and reentered it again. Before deleting the value, the value itself and the hint text of the input were visible. After reentering the default of 30 I could save the account. So probably simply a problem with the default value and the according hint text.
    ok, thanks I'll take a look at it. I did notice the hint text displaying as well as the value but forgot about it.
  7. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #867  
    I was wondering why I was only getting 30 songs on random play... Is there a way to set to all?
  8.    #868  
    Quote Originally Posted by angiest View Post
    I was wondering why I was only getting 30 songs on random play... Is there a way to set to all?
    I did that for performance reasons. You should be able to set it in your account settings.

    The algorithm selects 30 random tracks (by default) from your entire collection. So it is random all but only 30 tracks at a time.

    you could easily pull 300 songs down but it would take forever.

    the reason behind this was I have a collection 15000 plus songs. I can't pull a songs xml that big. So I pull each song by Id based on how many total tracks there are. It takes a while to send that many requests. If I find a better way I'll up the default.
    Last edited by fain; 04/07/2010 at 01:59 PM.
  9. #869  
    Quote Originally Posted by fain View Post
    I did that for performance reasons. You should be able to set it in your account settings.

    The algorithm selects 30 random tracks (by default) from your entire collection. So it is random all but only 30 tracks at a time.

    you could easily pull 300 songs down but it would take forever.

    the reason behind this was I have a collection 15000 plus songs. I can't pull a songs xml that big. So I pull each song by Id based on how many total tracks there are. It takes a while to send that many requests. If I find a better way I'll up the default.
    Ya... there is currently no performance friendly way to do random songs. The good news is that I put in a request for 3.6.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  10.    #870  
    Quote Originally Posted by bjgeiser View Post
    Ya... there is currently no performance friendly way to do random songs. The good news is that I put in a request for 3.6.
    Nice! I always forget my requests before I get to request them. Is that how you pull random songs? It works and that's what matters to me right now. I really like random play. I didn't think I would but its pretty cool to hear shi...woa stuff that I didnt know I had or have not heard in forever.
    AmpachPre, your music your way.

  11. #871  
    Quote Originally Posted by fain View Post
    Nice! I always forget my requests before I get to request them. Is that how you pull random songs? It works and that's what matters to me right now. I really like random play. I didn't think I would but its pretty cool to hear shi...woa stuff that I didnt know I had or have not heard in forever.
    Ya.. I generate a random number somewhere in the index of the songs and request 1 song at a time until I build up a list, its slow as ... well you know. My other method was to use the URL they use for pure random on the webUI but they blocked access from API sessions in 3.5.4, so that still works with older servers, also there was no way for me to know the user id.
    Code:
    http://server/play/index.php?sid={authcode}&random=1&type=default&uid=1
    I think the best solution would be a sort addition on the songs request, with an option for random sort.
    Ampache Mobile allows you to stream all YOUR music and videos from your computer to your phone.

    Please take a look a these Common Issues before posting to the Ampache Mobile thread.
  12.    #872  
    Quote Originally Posted by bjgeiser View Post
    Ya.. I generate a random number somewhere in the index of the songs and request 1 song at a time until I build up a list, its slow as ... well you know. My other method was to use the URL they use for pure random on the webUI but they blocked access from API sessions in 3.5.4, so that still works with older servers, also there was no way for me to know the user id.
    Code:
    http://server/play/index.php?sid={authcode}&random=1&type=default&uid=1
    I think the best solution would be a sort addition on the songs request, with an option for random sort.
    Ah ic, there should be a method for this in the API. I guess they had a good reason to block it out though. There is a few other things I would like to see. I am glad to see JSON might be making it into mix. That should speed things up a bit.
    AmpachPre, your music your way.

  13. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #873  
    How about a request for a totally useless feature?

    Post "now listening" to twitter...
  14.    #874  
    Quote Originally Posted by angiest View Post
    How about a request for a totally useless feature?

    Post "now listening" to twitter...
    haha maybe, or facebook status depends on how tough their api's are.

    I believe I will have to recode last.fm here soon. They are about to update their api. It is supposed to be easier though. The first time around about gave me a busted blood vessel.
    AmpachPre, your music your way.

  15.    #875  
    Quote Originally Posted by angiest View Post
    Have you by chance looked in to what is necessary to bring the AmpachPre DB under webos-internals' save/restore app?


    It should be in 0.6.7

    git.webos-internals.org Git - applications/saverestore.git/blob - scripts/net.nucleardecay.ampachpre

    Big thanks to rwhitby!!
    AmpachPre, your music your way.

  16. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #876  
    Quote Originally Posted by fain View Post
    haha maybe, or facebook status depends on how tough their api's are.

    I believe I will have to recode last.fm here soon. They are about to update their api. It is supposed to be easier though. The first time around about gave me a busted blood vessel.
    I did say it was a useless feature request.
  17. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #877  
    Quote Originally Posted by fain View Post
    Coooooooool!
  18. #878  
    Thanks for the random play fain!
  19. #879  
    I've installed AmpachPre and set up my servers according to the tutorials. AmpachPre works locally when I'm connected to my WiFi network, but I can't get it to work when I'm not connected to the network. What am I missing?
  20.    #880  
    Quote Originally Posted by vladthedog View Post
    Thanks for the random play fain!
    np, I actually use it a lot my self now, I didn't think I would. Thanks for the donation!!
    Quote Originally Posted by OneHelluvaGuy View Post
    I've installed AmpachPre and set up my servers according to the tutorials. AmpachPre works locally when I'm connected to my WiFi network, but I can't get it to work when I'm not connected to the network. What am I missing?
    Check your firewall on the router if you have one. Make sure to forward the port your webserver is on. If its default it would be 80. If not check any software firewalls and make sure they are not blocking internet/wan zone requests.

    I would temporarily disable all firewalls and see if it works then. If it still doesn't work then it is probably your ISP blocking port 80. In this case you must change the port Apache is running on to something else so your ISP doesn't know its a web server.

    edit: change the port APACHE is running on not ampache...
    Last edited by fain; 04/08/2010 at 10:09 PM.
    AmpachPre, your music your way.

Posting Permissions