Page 26 of 53 FirstFirst ... 16212223242526272829303136 ... LastLast
Results 501 to 520 of 1046
  1.    #501  
    Quote Originally Posted by timbtimb View Post
    Never mind this first part, I forgot I had messed around with my router.

    ///Everything is working perfectly on wifi. But, ever since I doctored my phone I can't connect via my ip/dnydns. I can still connect on my pc using the dnydns address, but not on ampachpre, ampachemobile, or webos browser. Not on wifi or evdo. I haven't changed any settings in Ampache. Is there something I need to do on my phone that I am forgetting?///



    My ACL looks like this: AmpachPre 0.0.0.0 255.255.255.255 All All API/RPC

    BTW after I get this working again, should I tighten this up for better security?

    One more thing, I want to put ampache in my root folder so that I can use x.dyndns.org instead of x.dnydns.org/ampache. Do I just need to move htdocs/ampache to htdocs and thats it or is there more to it?

    Thanks for all the help
    You can secure it a little more by assigning a range from what ip your dhcp server assigns. for example my current ip is 173.123.25.4 or somethin like that. That is a class b address if I remember correctly so i just set my range from 173.123.0.0 to 173.123.255.255 only problem to this is If you travel somewhere and get a ip out of this range you are blocked out of ampache. :/ If you know every subnet sprint owns you could set it to that range and be done with it. I do not usually keep tabs on my ip but i am assuming it is dynamic.

    On the root folder note, I was just thinking about the way I set up the accounts and there might be a bug in my code with a root folder installation. i will look into this for the next release. As for moving it to the root folder I believe all you would need to do is change the directory in the config php and move all the contents of the ampache folder to the root. I have not done this but I will soon for testing and if I run into any other steps ill let ya know.
  2. #502  
    Great, thank you.

    I've noticed when listening to some speeches that I have that are around 30 min long it sometimes cuts off the last 30 seconds or so. Like maybe 1/5 speeches does this. Not sure if its like this for anyone else. I've checked the files on my pc and they work fine. Not really a big deal, but thought you might want to know. I can pm you a guest account if you need to replicate it.

    Also, is it possible for ampachpre to determine if we're using wifi or evdo? It would be cool to be able to set different acounts as the default for each connection.
  3.    #503  
    Quote Originally Posted by timbtimb View Post
    Great, thank you.

    I've noticed when listening to some speeches that I have that are around 30 min long it sometimes cuts off the last 30 seconds or so. Like maybe 1/5 speeches does this. Not sure if its like this for anyone else. I've checked the files on my pc and they work fine. Not really a big deal, but thought you might want to know. I can pm you a guest account if you need to replicate it.

    Also, is it possible for ampachpre to determine if we're using wifi or evdo? It would be cool to be able to set different acounts as the default for each connection.
    I have noticed in the ampache log that it stops sending/getting the file before the bytes get to the full size of the file. I am not sure why.

    I have thought of the wifi/evdo thing and I do think it is possible and yes i would like this as well. I was even thinking of using the gps to turn on the wifi if at home or in a specified place. That might be a whole other app though. I am also not sure if that's possible yet with the current sdk. I look into it as soon as I get my sdk back up. upgraded to ubuntu karmic today
  4. #504  
    VERY nicely done! Used your original program for a while and then switched to Ampache Mobile, but i just checked out the progress on this and I must say I like the looks of this better . Now once the item in your to do list is done, (Audio stops when leaving the streaming scene. By design for now, I plan on changing this) I will switch over to this full time. Thanks!

    Chris
  5.    #505  
    Quote Originally Posted by Dchris222 View Post
    VERY nicely done! Used your original program for a while and then switched to Ampache Mobile, but i just checked out the progress on this and I must say I like the looks of this better . Now once the item in your to do list is done, (Audio stops when leaving the streaming scene. By design for now, I plan on changing this) I will switch over to this full time. Thanks!

    Chris
    thanks! Sadly the above mentioned feature will not be in the next release The good news is I have been toying around with it be cause it is one of my top priorities. I think I have figured out how too keep it playing but it is going to cause me to rewrite a lot of the app I am afraid. I am going to concentrate on this for the release after 1.8.6.
  6.    #506  
    • It is strongly recommended you delete and remake your accounts just keep every thing clean, at least re-save your account to keep variables from being null!
      if you have problems just remake the account.

      I am very sorry but I found a bug that needs to be fixed, and for that to be done, you will need to make any saved playlists again.
      The bug was when you create a playlist with the same name as a downloaded playlist name Ampachpre would fill that playlist with your downloaded playlist.
      causing you to not be able to delete the saved playlist without deleting the database that held the downloaded playlist.
      this is kind of ironic because i just spent about a hr. on making a big playlist tonight.
      the good news is downloads will not be affected

    • added a wifi check if you are on wifi it will auto log you into the account you specify as default wifi.
    • added a ssid field; you need to specify your home ssid incase you are on a wifi somewhere other than the place your server is at.
      this should not affect your account if you choose not to use this option.
    • new auto account change feature. If you in any scene and you turn on wifi or vice versa, or if you just got out of the range of your router or if your wan ip has changed.
      AmpachPre will now auto login to either your default wifi or evdo account. (still experimental while streaming.)
    • last fm scrobbling now native!. You need to disable scrobbling in Ampache if you want to use this feature. If you dont, just leave the account info blank.
      if you choose to use this you will be able to turn scrobbling Off/On by default or toggle it from the app menu on the stream scene.
    • added ad all to playlist on a downloaded playlist.
    • if you have a song that has been downloaded from a url and there is no time in the playlist. It will be added the first time you play it from your downloads playlist.
      this fixes a bug that caused the playlist scene from not displaying total playlist time when these files where added to the playlist.
    • there has been a ping timer to keep the API Session alive added that is customizable. Still working on the stream session.
    • added a search time out if the search takes longer than 15 seconds the search will be cancelled.
    • added the ability to edit playlist song info for scrobbling songs with bad tags and for those like me who just do not have time to go through their entire mp3 collection looking for bad tags.
      (I strongly recommend not editing either the image url nor the song url! I was going to disable these but you could enter a full path to a local mp3 and image file if you know the values. Remote mp3z are unsupported right now.)
    • added a download saved playlist function in case you need to cache a saved playlist quick.
    • few style changes and probably some other things I forgot to log while doing them

      enjoy...
  7. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #507  
    When looging in to my account with last.fm account information, I get an error from last.fm:

    last.fm error: Invalid authentication token. Please check username/password supplied

    As far as I can tell, my last.fm account information is correct.
  8.    #508  
    Quote Originally Posted by angiest View Post
    When looging in to my account with last.fm account information, I get an error from last.fm:

    last.fm error: Invalid authentication token. Please check username/password supplied

    As far as I can tell, my last.fm account information is correct.
    de ja vu..lol I was afraid of this. I have been scrobbling for the last two weeks from AmpachPre. I did get that error when I tried to login with the wrong creds for a test. Any chance you could use palm-log to see if there any errors?

    Code:
    palm-log  --system-log-level=info
    palm-log  -f net.nucleardecay.ampachpre
    only if you have the sdk installed anyways
  9. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #509  
    I'll try to take a look at this.
  10.    #510  
    Quote Originally Posted by angiest View Post
    I'll try to take a look at this.
    Ok, I think I see what it might be.
  11.    #511  
    • fixed a problem with the last.fm login system.
    • now when you toggle scrobbling on while listening it will send the now playing song.
  12. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #512  
    Quote Originally Posted by fain View Post
    • fixed a problem with the last.fm login system.
    • now when you toggle scrobbling on while listening it will send the now playing song.
    Seems to work now, but if I toggle scrobbling whilst playing the popup doest go away.
  13.    #513  
    Hmm, what does it say? I just got home and checked, there are not any popup dialogues in that function. Cant look too much into it right now gotta work in the morn.

    Doh!! think I might have found the problem, shouldn't be any po-pups though. I am still curious about that. Sorry, I rushed that feature out there with the fix and didn't test it thoroughly.
    Last edited by fain; 01/23/2010 at 11:29 PM.
  14. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #514  
    Quote Originally Posted by fain View Post
    Hmm, what does it say? I just got home and checked, there are not any popup dialogues in that function. Cant look too much into it right now gotta work in the morn.

    Doh!! think I might have found the problem, shouldn't be any po-pups though. I am still curious about that. Sorry, I rushed that feature out there with the fix and didn't test it thoroughly.
    I'm sorry, not a popup. It's the app menu in the upper left.
  15.    #515  
    Quote Originally Posted by angiest View Post
    I'm sorry, not a popup. It's the app menu in the upper left.
    OK, that's due to a few undefined variables. It's fixed now and I will release it when I double check a few things probably tom. evening.
  16.    #516  
    • fixed a few bugs with the autologin feature.
    • fixed a problem with the toggle scrobble function.
    • the scrobble function will now cache listened songs while there is no internet connection and scrobble them the next time there is a internet connection.
    • the stream scene will now cache the next songs album art for faster display.
  17. angiest's Avatar
    Posts
    933 Posts
    Global Posts
    952 Global Posts
    #517  
    Everything seems to be working so far, except for one little thing.

    My non-saved playlists from prior to 1.8.6 still show up. I can swipe them away and delete them, but they keep coming back. And if I select them the spinner comes up and never goes away, I wind up having to toss the card away.
  18.    #518  
    Quote Originally Posted by angiest View Post
    Everything seems to be working so far, except for one little thing.

    My non-saved playlists from prior to 1.8.6 still show up. I can swipe them away and delete them, but they keep coming back. And if I select them the spinner comes up and never goes away, I wind up having to toss the card away.
    ya the naming scheme changed with the new version. Maybe you could downgrade and delete the playlists. First, try editing the info of the old playlists and saving them. This might bring the naming scheme up to date.
  19.    #519  
    Quote Originally Posted by fain View Post
    ya the naming scheme changed with the new version. Maybe you could downgrade and delete the playlists. First, try editing the info of the old playlists and saving them. This might bring the naming scheme up to date.
    OK, I just had a look at that code and my suggestion will not work. I am going to make it work in the next bug fix release though.
  20.    #520  
    Quote Originally Posted by angiest View Post
    Everything seems to be working so far, except for one little thing.

    My non-saved playlists from prior to 1.8.6 still show up. I can swipe them away and delete them, but they keep coming back. And if I select them the spinner comes up and never goes away, I wind up having to toss the card away.
    I have looked into the options. I believe the easiest way would be to downgrade to 1.8.3 and delete the playlists there. I have not tested this method yet, I will very soon. You can upgrade to the latest (1.8.9) due out here soon and re-save, but the database will be under the new name. Causing the playlist to be left on your usb partition.. Let me know what you think. I am also considering making a database rename function which i can stem a re-pare function for you, but that might take a few days to build and test.

Posting Permissions