Page 13 of 53 FirstFirst ... 38910111213141516171823 ... LastLast
Results 241 to 260 of 1046
  1. #241  
    Quote Originally Posted by elryon View Post
    I'm not sure on that, but if they have DRM, then no.
    If they are not supported directly then you could enable transcoding. I just got mine working for downsampling, but haven't tried for changing formats...
    and congrats on getting it going.

    Well yeah I can access it. But i cant hear anything. So I guess you could say its not really working. I used the path to my itunes music, which is in m4a. So I'm thinking this might be the problem. But I'm really not quite sure. Was hoping someone could direct me in the right direction here.

    What is DRM?
  2. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #242  
    Quote Originally Posted by cmiller716 View Post
    Well yeah I can access it. But i cant hear anything. So I guess you could say its not really working. I used the path to my itunes music, which is in m4a. So I'm thinking this might be the problem. But I'm really not quite sure. Was hoping someone could direct me in the right direction here.

    What is DRM?
    DRM = Digital Rights Managment

    do you have any downloaded mp3's or anything you could try and see if they work? I dont have any m4a files to test.
    Avatar on Left Patch
    Call Rejecter Patch
    Make your messanger look like the iphone's
    SMS tone per Contact
    No Alert During call

    Thanks are always appreciated or for a really big Thanks you can always:
    (it can go a long way to convince my fiancee that this is worth my time)

    Please feel free to PM for more direct assistance.
  3. #243  
    Quote Originally Posted by elryon View Post
    DRM = Digital Rights Managment

    do you have any downloaded mp3's or anything you could try and see if they work? I dont have any m4a files to test.
    Ok, I did have a big folder of downloaded mp3's. Which seem to play fine. My next task is trying to figure out how to get this thing to play m4a's. or maybe I should be thinking about how to switch my m4a's to mp3's
  4. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #244  
    Quote Originally Posted by cmiller716 View Post
    Ok, I did have a big folder of downloaded mp3's. Which seem to play fine. My next task is trying to figure out how to get this thing to play m4a's. or maybe I should be thinking about how to switch my m4a's to mp3's
    havent tried it yet for actual transcoding (only downsampling), but this should work for you.. config:transcode [Ampache :: Wiki]

    the first two acl's are already set up. and the file you want is in
    /ampache-3.5.1/config/ I think its ampache.config.php or something like that.
    Avatar on Left Patch
    Call Rejecter Patch
    Make your messanger look like the iphone's
    SMS tone per Contact
    No Alert During call

    Thanks are always appreciated or for a really big Thanks you can always:
    (it can go a long way to convince my fiancee that this is worth my time)

    Please feel free to PM for more direct assistance.
  5. #245  
    Quote Originally Posted by elryon View Post
    havent tried it yet for actual transcoding (only downsampling), but this should work for you.. config:transcode [Ampache :: Wiki]

    the first two acl's are already set up. and the file you want is in
    /ampache-3.5.1/config/ I think its ampache.config.php or something like that.
    Haha! Thanks but that looks way out of my league. That looks Chinese to me.
  6. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #246  
    Quote Originally Posted by cmiller716 View Post
    Haha! Thanks but that looks way out of my league. That looks Chinese to me.
    well... you can convert to mp3 or wait till I get off work and can set up better instructions... got about 6 more hours to wait for that...

    its really actually easy as the file is edited by any text editor and most of the stuff is already there, you would just change some stuff to 'true' and take out the ; so its not a comment anymore. The ACL is just like you set up before, just with different settings.
    Avatar on Left Patch
    Call Rejecter Patch
    Make your messanger look like the iphone's
    SMS tone per Contact
    No Alert During call

    Thanks are always appreciated or for a really big Thanks you can always:
    (it can go a long way to convince my fiancee that this is worth my time)

    Please feel free to PM for more direct assistance.
  7. #247  
    Quote Originally Posted by elryon View Post
    well... you can convert to mp3 or wait till I get off work and can set up better instructions... got about 6 more hours to wait for that...

    its really actually easy as the file is edited by any text editor and most of the stuff is already there, you would just change some stuff to 'true' and take out the ; so its not a comment anymore. The ACL is just like you set up before, just with different settings.
    I'm actually off to work myself. So 6 hours would be no big deal to me, of course if your up for writing instructions. If not no biggy. I honestly don't know anything about whats in front of me. Im pretty impressed I even got it up and running. If i didnt have fain's pdf and your help there'd be no chance I would have gotten this far. Thank you
  8.    #248  
    Quote Originally Posted by KEYofR View Post
    Got it working after aabout 30 minutes trial & error here. Sitting at a cafe using my laptop and their wifi to access my ampache server at home.
    But, my starting point was I already had Ampache itself up & running for years on a suse linux 10.2 box at home, so, that's all the basic Ampache, mysql, networking/routing & firewall issues already done & out of the way. (not using the suse package for ampache btw. It's old and pointlessly modified from original, and didnt even work for me. Easier just to use the original packages or svn checkouts right from the source)

    My gotchas were:

    I had to set:
    /srv/www/ampache/config/ampache.cfg.php :
    access_control = "true"
    xml_rpc = "true"
    use_auth = "true"

    Then log in to Ampache via web browser and:
    * reset my users password (I had been using use_auth=false, and my ampache is a nightly updated svn from before 3.4 so my passwords were all old, but the web interface says in bold red letters "reset your password")
    * create the acl as per the directions in the first post.

    After that, both AmpachePre and AmpachMobile work great on my Pre with the exception that:

    Neither app can actually play most of my files since they're almost all ogg.
    AmpachePre handles this particularly poorly imo compared to AmpacheMobile.

    AmpachePre just shows a funny screen that's missing half of the UI elements and emits no sound and doesn't move or display any error when you try to play an ogg.
    AmpacheMobile loads up the UI screen all the way, and pops up a notification with an error message that isn't very informative, but it's at least better than no error message and it does at least tell you that this file isn't going to play.

    But, for mp3's it all works slick as hell.
    The problem is Neither app actually shows you what type of file a given song is.
    You have to actually try to play it to find out that it won't work.

    Transcoding is probably the answer for this, except I never managed to get transcoding to work. I tried sometime back for my PS3 and didn't even really try this time.
    Unless it's possible to only transcode ogg to mp3 for the Pre and not for other clients, I wouldn't want to do that anyways.
    ya the ui is not finished and behind on ampache mobile. Sorry about that I an still learning this javascript thing. To play oggs you meed to transcode them first. Ampache can do this but you need to enable it in the config file first. Also the program that transcodes ogg needs to be installed. I believe its mp3splt. I'm not sure.
  9. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #249  
    Here's a how to for the transcoding

    First download the actual transcoding programs:
    lame : Download LAME MP3 Encoder 4.0 Alpha 14 / 3.98.2 - The best mp3 encoder is available for free - Softpedia
    faad : Download FAAD 2 Binaries for Win32 - An AAC/MP4 command line audio decoder for Win32 - Softpedia
    unzip both into the same directory ( I put them in C:\audio\ )

    Now go to your ampache-3.5.1/config directory and find the file ampache.cfg.php
    This is the file you want to edit, any text editor will do such as notepad ( I used notepad ++, very nice program for editing code)

    first, if you want to downsample your mp3's find:
    Code:
    ; Downsample Remote
    ; If this is set to true and access control is on any users who are not
    ; coming from a defined 'network' ACL will be automatically downsampled
    ; regardless of their preferences. Requires access_control to be enabled
    ; DEFAULT: false
    downsample_remote = "true"
    take out the ; from the last line and change "false" to "true"

    Next:
    Code:
    ;######################################################
    ; These are commands used to transcode non-streaming
    ; formats to the target file type for streaming. 
    ; This can be useful in re-encoding file types that don't stream
    ; very well, or if your player doesn't support some file types. 
    ; This is also the string used when 'downsampling' is selected
    ; as some people have complained its not bloody obvious, any programs
    ; referenced in the downsample commands must be installed manually and in
    ; the web server path, and executable by the web server
    ; REQUIRED variables
    ; transcode_TYPE	= true/false ## True to force transcode regardless of prefs
    ; transcode_TYPE_target	= TARGET_FILE_TYPE
    ; transcode_cmd_TYPE	= TRANSCODE_COMMAND
    ; %FILE%	= filename
    ; %OFFSET%	= offset
    ; %SAMPLE%	= sample rate
    ; %EOF%		= end of file in min.sec
    
    ; List of filetypes to transcode
    transcode_m4a 		= true
    transcode_m4a_target 	= mp3 
    ;transcode_flac 	= true
    transcode_flac_target	= mp3
    transcode_mp3  	= false
    transcode_mp3_target	= mp3
    ;transcode_ogg 		= false
    transcode_ogg_target	= ogg
    
    ; These are the commands that will be run to transcode the file
    transcode_cmd_flac 	= "flac -dc %FILE% | lame -b %SAMPLE% -S - - "
    transcode_cmd_m4a 	= "C:\audio\faad -f 2 -w %FILE% | C:\audio\lame -r -x -b %SAMPLE% -S - -"
    ;
    
    ;transcode_cmd_mp3	= "mp3splt -qnf %FILE% %OFFSET% %EOF% -o - | lame --mp3input -q 3 -b %SAMPLE% -S - -"
    transcode_cmd_ogg   	= "oggsplt -qn %FILE% %OFFSET% %EOF% -o - | oggdec -Q -o - - | lame -S -q 3 -b %SAMPLE% -S - -"
    
    ; Alternative command works better for some people
    ;transcode_cmd_m4a       =  "alac %FILE% | lame -h -b %SAMPLE% -S - -"
    ;transcode_cmd_ogg   	= "mp3splt -qn %FILE% %OFFSET% %EOF% -o - | oggdec -Q -o - - | lame -S -q 3 -b %SAMPLE% -S - -"
    ;transcode_cmd_flac	= "flac -dc %FILE% | lame -rb %SAMPLE% -S - -"
    
    ; This line seems to work better for windows, switch if needed
    transcode_cmd_mp3	= "C:\audio\lame -q 3 -b %SAMPLE% -S %FILE% - -"
    changes are in red
    be sure to take out the ; before the last line

    Now we just add another ACL in the ampache interface....
    log in with and administrator account (probably your normal account)
    in the menu area click on the little computer-like icon and select 'add ACL'
    name it ... (whatever you want here)
    level: all
    User: all
    ACL type: Local Network Definition
    Remote Key: (leave empty)
    Start: 10.0.0.0 End: 10.255.255.255
    then click on add ACL

    Lastly, we select the bitrate to downsample to:
    go to 'streaming' under 'server config'
    type of playback: stream
    rate limit: 8192 (this was default so I left it alone)
    transcode bitrate: 96 (or whatever you want to downsample to)
    transcoding: always
    then update

    you are done and should be able to play m4a files and downsample mp3's!!!
    Avatar on Left Patch
    Call Rejecter Patch
    Make your messanger look like the iphone's
    SMS tone per Contact
    No Alert During call

    Thanks are always appreciated or for a really big Thanks you can always:
    (it can go a long way to convince my fiancee that this is worth my time)

    Please feel free to PM for more direct assistance.
  10. #250  
    Quote Originally Posted by elryon View Post
    Here's a how to for the transcoding

    First download the actual transcoding programs:
    lame : Download LAME MP3 Encoder 4.0 Alpha 14 / 3.98.2 - The best mp3 encoder is available for free - Softpedia
    faad : Download FAAD 2 Binaries for Win32 - An AAC/MP4 command line audio decoder for Win32 - Softpedia
    unzip both into the same directory ( I put them in C:\audio\ )

    Now go to your ampache-3.5.1/config directory and find the file ampache.cfg.php
    This is the file you want to edit, any text editor will do such as notepad ( I used notepad ++, very nice program for editing code)

    first, if you want to downsample your mp3's find:
    Code:
    ; Downsample Remote
    ; If this is set to true and access control is on any users who are not
    ; coming from a defined 'network' ACL will be automatically downsampled
    ; regardless of their preferences. Requires access_control to be enabled
    ; DEFAULT: false
    downsample_remote = "true"
    take out the ; from the last line and change "false" to "true"

    Next:
    Code:
    ;######################################################
    ; These are commands used to transcode non-streaming
    ; formats to the target file type for streaming. 
    ; This can be useful in re-encoding file types that don't stream
    ; very well, or if your player doesn't support some file types. 
    ; This is also the string used when 'downsampling' is selected
    ; as some people have complained its not bloody obvious, any programs
    ; referenced in the downsample commands must be installed manually and in
    ; the web server path, and executable by the web server
    ; REQUIRED variables
    ; transcode_TYPE	= true/false ## True to force transcode regardless of prefs
    ; transcode_TYPE_target	= TARGET_FILE_TYPE
    ; transcode_cmd_TYPE	= TRANSCODE_COMMAND
    ; %FILE%	= filename
    ; %OFFSET%	= offset
    ; %SAMPLE%	= sample rate
    ; %EOF%		= end of file in min.sec
    
    ; List of filetypes to transcode
    transcode_m4a 		= true
    transcode_m4a_target 	= mp3 
    ;transcode_flac 	= true
    transcode_flac_target	= mp3
    transcode_mp3  	= false
    transcode_mp3_target	= mp3
    ;transcode_ogg 		= false
    transcode_ogg_target	= ogg
    
    ; These are the commands that will be run to transcode the file
    transcode_cmd_flac 	= "flac -dc %FILE% | lame -b %SAMPLE% -S - - "
    transcode_cmd_m4a 	= "C:\audio\faad -f 2 -w %FILE% | C:\audio\lame -r -x -b %SAMPLE% -S - -"
    ;
    
    ;transcode_cmd_mp3	= "mp3splt -qnf %FILE% %OFFSET% %EOF% -o - | lame --mp3input -q 3 -b %SAMPLE% -S - -"
    transcode_cmd_ogg   	= "oggsplt -qn %FILE% %OFFSET% %EOF% -o - | oggdec -Q -o - - | lame -S -q 3 -b %SAMPLE% -S - -"
    
    ; Alternative command works better for some people
    ;transcode_cmd_m4a       =  "alac %FILE% | lame -h -b %SAMPLE% -S - -"
    ;transcode_cmd_ogg   	= "mp3splt -qn %FILE% %OFFSET% %EOF% -o - | oggdec -Q -o - - | lame -S -q 3 -b %SAMPLE% -S - -"
    ;transcode_cmd_flac	= "flac -dc %FILE% | lame -rb %SAMPLE% -S - -"
    
    ; This line seems to work better for windows, switch if needed
    transcode_cmd_mp3	= "C:\audio\lame -q 3 -b %SAMPLE% -S %FILE% - -"
    changes are in red
    be sure to take out the ; before the last line

    Now we just add another ACL in the ampache interface....
    log in with and administrator account (probably your normal account)
    in the menu area click on the little computer-like icon and select 'add ACL'
    name it ... (whatever you want here)
    level: all
    User: all
    ACL type: Local Network Definition
    Remote Key: (leave empty)
    Start: 10.0.0.0 End: 10.255.255.255
    then click on add ACL

    Lastly, we select the bitrate to downsample to:
    go to 'streaming' under 'server config'
    type of playback: stream
    rate limit: 8192 (this was default so I left it alone)
    transcode bitrate: 96 (or whatever you want to downsample to)
    transcoding: always
    then update

    you are done and should be able to play m4a files and downsample mp3's!!!
    what is this?

    ; These are the commands that will be run to transcode the file
    transcode_cmd_flac = "flac -dc %FILE% | lame -b %SAMPLE% -S - - "
    transcode_cmd_m4a = "C:\audio\faad -f 2 -w %FILE% | C:\audio\lame -r -x -b %SAMPLE% -S - -"
    ;<----------( I dont seem to have that in mine and dont know if you added it)

    ;transcode_cmd_mp3 = "mp3splt -qnf %FILE% %OFFSET% %EOF% -o - | lame --mp3input -q 3 -b %SAMPLE% -S - -"
    transcode_cmd_ogg = "oggsplt -qn %FILE% %OFFSET% %EOF% -o - | oggdec -Q -o - - | lame -S -q 3 -b %SAMPLE% -S - -"



    Ok I left it out. Seemed to work fine without it. I'm assuming it was just a misprint thrown in there.
    Last edited by cmiller716; 09/04/2009 at 11:14 AM. Reason: Tried without ;
  11. #251  
    I just left it out. I have a feeling it wasnt supposed to be there. One problem I've ran into,when i enter the stuff into start "Start: 10.0.0.0 End: 10.255.255.255" I'm getting an error. It says "Invalid IPv4 / IPv6 Address Entered"


    EDIT: Ok, so I went back to Fains pdf and input the same stuff I put in there when I first started. 0.0.0.0 and 255.255.255.255
    This worked with no issues.

    Thank you again. I finally have everything up and running after about what seemed to be like a week of work. This had nothing to do with fains program. Just my own cluelessness of anything related to any sort of code. Thanks again to fain and elryon. You spent alot of time with me on this.
    Last edited by cmiller716; 09/04/2009 at 11:21 AM.
  12.    #252  
    Quote Originally Posted by elryon View Post

    first, if you want to downsample your mp3's find:
    Code:
    ; Downsample Remote
    ; If this is set to true and access control is on any users who are not
    ; coming from a defined 'network' ACL will be automatically downsampled
    ; regardless of their preferences. Requires access_control to be enabled
    ; DEFAULT: false
    downsample_remote = "true"
    take out the ; from the last line and change "false" to "true"



    Now we just add another ACL in the ampache interface....
    log in with and administrator account (probably your normal account)
    in the menu area click on the little computer-like icon and select 'add ACL'
    name it ... (whatever you want here)
    level: all
    User: all
    ACL type: Local Network Definition
    Remote Key: (leave empty)
    Start: 10.0.0.0 End: 10.255.255.255
    then click on add ACL
    Hmm I think you might be confusing people a little here. I have already had them add a acl to the entire ip range. So there is no territory uncovered to downsample remote.

    If you just set down sample to "always" you will get a transcoded mp3. The only problem with this is when you are at home and can afford the bandwidth you'll still get a transcoded mp3.

    You could make two separate accounts one for home and one for remote. Set transcode always for one and transcode never for the home account.

    Also why are you using just the class A private range? A private address could be
    10.0.0.0 - 10.255.255.255
    but it could also be
    192.168.0.0 - 192.168.255.255 <--//most likely this one
    or 172.16.0.0 - 172.31.255.255

    They would first need to know what private ip they have be for setting the acl for down sample remote.
  13.    #253  
    Quote Originally Posted by KEYofR View Post
    Got it working after aabout 30 minutes trial & error here. Sitting at a cafe using my laptop and their wifi to access my ampache server at home.
    But, my starting point was I already had Ampache itself up & running for years on a suse linux 10.2 box at home, so, that's all the basic Ampache, mysql, networking/routing & firewall issues already done & out of the way. (not using the suse package for ampache btw. It's old and pointlessly modified from original, and didnt even work for me. Easier just to use the original packages or svn checkouts right from the source)

    My gotchas were:

    I had to set:
    /srv/www/ampache/config/ampache.cfg.php :
    access_control = "true"
    xml_rpc = "true"
    use_auth = "true"

    Then log in to Ampache via web browser and:
    * reset my users password (I had been using use_auth=false, and my ampache is a nightly updated svn from before 3.4 so my passwords were all old, but the web interface says in bold red letters "reset your password")
    * create the acl as per the directions in the first post.

    After that, both AmpachePre and AmpachMobile work great on my Pre with the exception that:

    Neither app can actually play most of my files since they're almost all ogg.
    AmpachePre handles this particularly poorly imo compared to AmpacheMobile.

    AmpachePre just shows a funny screen that's missing half of the UI elements and emits no sound and doesn't move or display any error when you try to play an ogg.
    AmpacheMobile loads up the UI screen all the way, and pops up a notification with an error message that isn't very informative, but it's at least better than no error message and it does at least tell you that this file isn't going to play.

    But, for mp3's it all works slick as hell.
    The problem is Neither app actually shows you what type of file a given song is.
    You have to actually try to play it to find out that it won't work.

    Transcoding is probably the answer for this, except I never managed to get transcoding to work. I tried sometime back for my PS3 and didn't even really try this time.
    Unless it's possible to only transcode ogg to mp3 for the Pre and not for other clients, I wouldn't want to do that anyways.
    One thing to note about this.
    xml_rpc = "true"

    rpc needs to be false unless you are communicating with another ampache server. i have mine at default commented out and the api works fine.

    Another thing is i released a update last night that shows the mime type in the songs scene and the streamer now gives a error if it cant play the file or another error occurs. Also the play button stays there now and is disabled till the song starts playing.
  14. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #254  
    Quote Originally Posted by fain View Post
    Hmm I think you might be confusing people a little here. I have already had them add a acl to the entire ip range. So there is no territory uncovered to downsample remote.

    If you just set down sample to "always" you will get a transcoded mp3. The only problem with this is when you are at home and can afford the bandwidth you'll still get a transcoded mp3.

    You could make two separate accounts one for home and one for remote. Set transcode always for one and transcode never for the home account.

    Also why are you using just the class A private range? A private address could be
    10.0.0.0 - 10.255.255.255
    but it could also be
    192.168.0.0 - 192.168.255.255 <--//most likely this one
    or 172.16.0.0 - 172.31.255.255

    They would first need to know what private ip they have be for setting the acl for down sample remote.
    well I wrote it rather quickly last night after getting it working. the 'always' is probably not nessecary as I was just listing how it is set up on mine while I was messing with it before I figured it was the command line codes in the config file. Also that semi-colon was my mistake, left over from editing.
    and as for the ip range... that was the way they had it set-up in the wiki, it is supposed to only transcode for remote connections, but didnt test localhost to see if it wasnt transcoding. Part of the reason for the transcode was to get m4a files to transcode to mp3. I will see if the g/f will give me more time to 'fine-tune' this tonight... but your welcome to do it.
    Avatar on Left Patch
    Call Rejecter Patch
    Make your messanger look like the iphone's
    SMS tone per Contact
    No Alert During call

    Thanks are always appreciated or for a really big Thanks you can always:
    (it can go a long way to convince my fiancee that this is worth my time)

    Please feel free to PM for more direct assistance.
  15.    #255  
    I changed the icon and account system in this version so delete all accounts then delete the program before you upgrade. The account deletion is optional. But it will not display correctly in the choose account scene if you do not re enter your server settings.

    new in v1.5.5

    * Added different play modes. repeat, repeat all and shuffle
    * Changed account/login system. (It is recommended you re-enter your account info so you can name your accounts.)
    * Ampachpre has a new look. Let me know what ya think. Make sure you delete any older version in order for the new icon to update.
    * fixed some bugs and optimized code a little bit.
  16. pezdukie's Avatar
    Posts
    50 Posts
    Global Posts
    77 Global Posts
    #256  
    Okay, I've just spent hours upon hours trying to get this up and working (thanks for helping me procrastinate studying Finance and accounting!) And I've hit a roadblock at just about the end. Any help is greeatttllly appreciated.

    I've set up an Ampache server and set up a test catalog. I then installed Ampachpre and pretty much got stuck right there. I tried using [my ip address]/Ampache (changed ampache-3.5.1 folder name to Ampache) and it says it will not connect.

    If I could get some detailed instructions for a semi-noob at this kind of stuff, I would be ever-so grateful.

    Thanks in advance,
    Adam
  17.    #257  
    Quote Originally Posted by pezdukie View Post
    Okay, I've just spent hours upon hours trying to get this up and working (thanks for helping me procrastinate studying Finance and accounting!) And I've hit a roadblock at just about the end. Any help is greeatttllly appreciated.

    I've set up an Ampache server and set up a test catalog. I then installed Ampachpre and pretty much got stuck right there. I tried using [my ip address]/Ampache (changed ampache-3.5.1 folder name to Ampache) and it says it will not connect.

    If I could get some detailed instructions for a semi-noob at this kind of stuff, I would be ever-so grateful.

    Thanks in advance,
    Adam
    can you connect via another computer through the web interface? Also url's (ip/ampache) tend to be case sensitive.
    Can you connect to the webserver via another pc?
    Make sure the ampache directory is world readable and executable.
  18. pezdukie's Avatar
    Posts
    50 Posts
    Global Posts
    77 Global Posts
    #258  
    Quote Originally Posted by fain View Post
    can you connect via another computer through the web interface? Also url's (ip/ampache) tend to be case sensitive.
    Can you connect to the webserver via another pc?
    Make sure the ampache directory is world readable and executable.
    Okay, so what should be the exact URL I use to connect with a different computer? The IP address from "ipconfig" /ampache?
  19.    #259  
    Quote Originally Posted by pezdukie View Post
    Okay, so what should be the exact URL I use to connect with a different computer? The IP address from "ipconfig" /ampache?
    first try just

    Http://localhost

    On the computer xamp/apache is installed on.
    If that works try
    Http://localip.of.the.server

    From within your private network.(on wifi or ethernet)

    If you don't have a router you'll have to test externally. Use the pres web browser for that if you don't have another pc.

    From ifconfig you would probably use the address of eth0 but that depends on you network card and your configuration.
  20. pezdukie's Avatar
    Posts
    50 Posts
    Global Posts
    77 Global Posts
    #260  
    Quote Originally Posted by fain View Post
    first try just

    Http://localhost

    On the computer xamp/apache is installed on.
    If that works try
    Http://localip.of.the.server

    From within your private network.(on wifi or ethernet)

    If you don't have a router you'll have to test externally. Use the pres web browser for that if you don't have another pc.

    From ifconfig you would probably use the address of eth0 but that depends on you network card and your configuration.

    Wooohoo! It works!

    I found the culprit: somewhere along the lines of me doing all the work last night my ipv4 address changed just slightly, and in the zonked-out state of mind I was in last night I didn't think to do another ipconfig.

    So now I've got it working on wi-fi (great app by the way now that I'm finally in!!! Thanks so much), but now I need to get EVDO to work. I set up a DynDNS account last night, but I really didn't know what I was doing and just have a xxx.ath.cx host server that I quickly set up. What are my next step?

    Thanks so much for the help!

    Edit: Also; I still have the obnoxious beep-like sound that comes every 10-15 seconds or so of songs; I was hoping it was just a stock-music player app bug. Is this a known bug, or do I have a defective Pre? Anyone know about this?
    Last edited by pezdukie; 09/14/2009 at 04:16 PM. Reason: Edit

Posting Permissions