Page 28 of 45 FirstFirst ... 18232425262728293031323338 ... LastLast
Results 541 to 560 of 891
  1. #541  
    Zinge? How's it going? Update coming down the pipe?
  2.    #542  
    Still here, sorry, I know waiting sucks. I'm just really really really busy with real life right now (all my finals are due within the next week or two). Trying to get something working so I can post another update for you guys asap though.
  3. #543  
    Quote Originally Posted by zinge View Post
    Still here, sorry, I know waiting sucks. I'm just really really really busy with real life right now (all my finals are due within the next week or two). Trying to get something working so I can post another update for you guys asap though.

    cool thanks. i really miss this functioning properly.
  4. #544  
    Wow, this thread got pushed pretty far back.
    I hope an update is released soon.
    Follow Me On

  5. #545  
    Zinge,

    I know I'm getting alittle impatient...and you said that life issues have taken priority. But is it possible for someone else to correct the issues with BU?. This is a very useable app and it's starting to look like a waste on my PRE since it does not fully work ( on the dash board). I want you to continue to get credit for the app, but what good is it when it's not fully functional. I have to have the BU card open for the app to work. Any word on your progress is appreciated..

    IGO
    GIVE DEBBIE THE CHIMP.....GIVE DEBBIE THE CHIMP!!!
  6. #546  
    Quote Originally Posted by IGoDwnTwn34 View Post
    Zinge,

    I know I'm getting alittle impatient...and you said that life issues have taken priority. But is it possible for someone else to correct the issues with BU?. This is a very useable app and it's starting to look like a waste on my PRE since it does not fully work ( on the dash board). I want you to continue to get credit for the app, but what good is it when it's not fully functional. I have to have the BU card open for the app to work. Any word on your progress is appreciated..

    IGO
    I understand that everyone is getting anxious, and I too would love for these issues to be fixed, but considering that it's a free app that he shared with the community, I think we should all cut him some slack. If someone else wants to take over and come up with a solution, no one's stopping them. In the meantime, if you find that it's a waste on your Pre, by all means, remove it. No one's stopping you either.
  7. #547  
    Slack= still on my Pre.....and I wish to press the "donate" in appreciation for his efforts.
    GIVE DEBBIE THE CHIMP.....GIVE DEBBIE THE CHIMP!!!
  8.    #548  
    Update on an update:

    Still really busy, but I put in a couple hours this morning on trying to fix the dashboard part. Basically, the way I was calling the dashboard stage doesn't work any more for some reason, so I had to rewrite the app a little and change how it runs. Now, the dashboard icon will always be open when the card is open. If you want it to keep running, the "Run in dashboard" toggle will keep the dashboard open when you close the card. If you don't, it will close the dashboard when it closes the card. Its not that big a change, but I had to change a bunch of code. Also, I'm pretty sure I fixed the memory leak from my listener's, which is a good thing, and I also figured out how to stop duplicating code between the card stage and the dashboard stage, which is also a good thing.

    I haven't touched the touchstone sleep issue yet; I want to get the dashboard stuff working again first.

    Good news:
    I have the dashboard working again, and can probably release an update tomorrow/Sunday once I fix a small bug with one of the sliders.

    Better news:
    Somehow in the process of recoding eveything, I managed to get the app to CONTINUE RUNNING WITHOUT THE DASHBOARD OPEN. I'm not exactly sure why its working, but it is. I'm going to look into and see what I did to make that happen. The problem is, I think it might be part of the memory leak issue that a lot of apps have been experiencing with 1.3.1. If it is, it may be fixed in the 1.3.5 update and won't work. If not.... this app finally does what it was supposed to do from the beginning. I'll keep you updated on the progress of the "actually running in the background" part.

    Thanks for everyone's patience. There won't be any more info till at least tomorrow. I have a 30 page paper due monday, and I'm only on page 15. Time to go write more.
  9.    #549  
    Attached is a TEST VERSION (WebOS 1.3.1 only) so that I can see if it will reliably run in the background on systems other than my phone and my emulator.

    Please do not install this if you do not know how to access the command line on your phone.

    All of the touchstone and dashboard code has been commented out. This version only has the screen and keyboard sliders. You should be able to open the program, set your sliders, and close the program. It should continue working, even with the card closed, until you restart your phone.

    You will have to unzip the ipkg before you install it. If you have a few minutes (and WebOS 1.3.1), please install this test version and let me know what your results are.

    Thanks.


    Edit: Before I get yelled at by anyone, I know I am not cleaning up all of my service calls properly. This is running in the background by taking advantage of the changed garbage collection flag in 1.3.1. It is very likely that this method will not work after the next update. But for now, I might as well take advantage of it.


    Edit: Attachment is two posts down.
    Last edited by zinge; 12/04/2009 at 07:11 PM.
  10. rpr
    rpr is offline
    rpr's Avatar
    Posts
    212 Posts
    Global Posts
    216 Global Posts
    #550  
    I just installed the test version after removing the version I had previously (0.2.3 I believe) and it does not appear to work. It works normally when I launch it (keypad lights up) and I see it in JSTop, but when I close it, the keypad goes out and the process is not seen in JSTop.
  11.    #551  
    Quote Originally Posted by rpr View Post
    I just installed the test version after removing the version I had previously (0.2.3 I believe) and it does not appear to work. It works normally when I launch it (keypad lights up) and I see it in JSTop, but when I close it, the keypad goes out and the process is not seen in JSTop.
    And you are on 1.3.1?

    Hmm... On my phone and emulator, the process stays in JSTop, and my keyboard continues to light up until I kill the process. Not sure what would be different about my emulator/phone... I'll look into it. Can I get a couple more people verifying whether it works/doesn't work?

    After rebooting a couple times, it no longer stays open on my phone. However, another app of mine does stay open in JSTop, and I think I may know how to get it to stay open again. I'll play with it and post again when I have something.


    Got it working again. Please download this one (same version number, but you'll see a dashboard popup when it starts), and let me know if it works for you. Don't worry about the dashboard icon; when you close the app, the dashboard will close too. Thanks.
    Attached Files Attached Files
    Last edited by zinge; 12/04/2009 at 07:15 PM.
  12. #552  
    Hey, you said you had a paper and would not post more until maybe tomorrow. Thanks for the current update and keeping us informed. That's the least we want - keeping us informed. Now stop writing code and do the paper. We are not going anywhere and will standby.
  13. #553  
    Thanks for the update - This version doesn't seem to be working either? I open it, get the dashboard icon, swipe the card away, the icon stays there - I swiped the icon away (and unlike in the last version, it didn't bring the card back up), but that had the effect of closing the program (no longer listed in JSTop).


    edit: hmm... fascinating, after a bit more testing, I discovered that if I swipe the dashboard icon away while the card is still open, I can then swipe the card off the top of the screen and the process will stay running in JSTop. So I guess it does work!

    And opening the card again brings the dashboard icon back. with more testing I see that I no longer have to be swiping the dashboard icon away while the card is open - even swiping the card away and then swiping the icon away leaves it open. maybe the first time that happened it was just a weird bug on my phone.
    Last edited by tarirene; 12/04/2009 at 10:53 PM.
  14. #554  
    Tried the newest update. I set brightness in Screen & Lock to about 50. In Brightness Unlinked, I set Display to 1 and Keypad to 100. I then toss the card and swipe the app off the dashboard (in either order). When I close the slider and reopen it, the Display stays at 1, but the Keypad is now also at 1. When I reopen Brightness Unlinked, the Keypad goes back to 100.

    Works fine if I keep BU open in the dashboard.
  15. Dj Lil Mac's Avatar
    Posts
    4 Posts
    Global Posts
    9 Global Posts
    #555  
    It works great!
  16. rpr
    rpr is offline
    rpr's Avatar
    Posts
    212 Posts
    Global Posts
    216 Global Posts
    #556  
    I tried the new update and it still does exactly the same thing as the previous version, and yes I am running 1.3.1. If I leave the dashboard app running, then it works, but if I swipe it closed, the process disappears and the keypad does not light up. It does not matter what order I close them (app first then dashboard, or vice-versa), either way makes it stop working.

    Not a huge deal for me, I don't mind just leaving the dashboard app there.

    Next question, is there a way to make it auto start with the phone?
  17. Quintus's Avatar
    Posts
    624 Posts
    Global Posts
    672 Global Posts
    #557  
    Just curious here as I am no developer but wouldn't this be better accomplished by way of a patch with either a preset keyboard back-light setting or by adding a separate setting for the keyboard in the phone's main drop down menu like Jason Robitaille's patch adding a brightness meter to the phone's drop down menu?

    Just wondering if a patch wouldn't resolve all of the issues with BU having to run in the background.
  18. #558  
    Thank you zinge for your work on this. I love the what BU does, and I hope it gets worked out to not have to run in the dashboard. I d/l it, and no matter which part I close first it does not continue to run. On 1.3.1 as well.
  19.    #559  
    To anyone trying the new test version- I am very confused by some of the reported results. There is code in the cleanup section of the card part of the app that will automatically close the dashboard when the card closes. It should not be possible to close that card and have the dashboard still open. On my pre and emulator, it works correctly. I can understand why the program might not stay running on some peoples phones, but I cannot understand why the dashboard doesn't close. However, it seems to be related.

    If its NOT running correctly with both the card and dashboard closed for you, can you confirm whether or not the dashboard auto-closes when you swipe the card?
  20. #560  
    I have not one single time had the dashboard close when I swipe away the card - and I have tested it 10+ times.

Posting Permissions