Page 22 of 45 FirstFirst ... 12171819202122232425262732 ... LastLast
Results 421 to 440 of 891
  1. JerryG's Avatar
    Posts
    535 Posts
    Global Posts
    553 Global Posts
    #421  
    Quote Originally Posted by zinge View Post
    JerryG and Jeking, please try the attached version when you get a chance. (It has to be unzipped first, fyi.) It un-hides the toggle (for JerryG) and I *think* it will keep the screen on like it used to (for Jeking). I'm away from my place and can't test it too much at the moment, but you two know enough about what it should be doing to let me know if I broke something. Anyone else is welcome to install it, btw, theres just a chance I may have broken something again.
    @zinge -

    OK...

    Screen set to turn off after 30 seconds.

    USB charging:
    Plugged into USB and installed. Went to sleep, no problem (card-mode).
    Goes to sleep via power-button, OK (card-mode).
    Changed to in-dash went to sleep OK.
    Went to sleep (in-dash), via power-button, OK

    TouchStone charging:
    Placed on TS (in-dash), sleep via power-button, OK.
    Placed on TS (in-dash), let it go to sleep via time-out, OK.
    *** Placed on TS, (card-mode), via power-button, will only go to clock-lock.
    *** Placed on TS, (card-mode), will not go to sleep.

    6 out of 8...

    Thanks,

    -JerryG
    Uniden PC100 -> Visor -> Visor Pro w/VisorPhone -> Tungsten T -> Tungsten T2 -> Tungsten T5 -> TX -> Treo 650 -> Treo 755p -> Pre -> Evo 4G
  2. jeking's Avatar
    Posts
    333 Posts
    Global Posts
    343 Global Posts
    #422  
    Cool, thanks. Following JerryG's lead:

    Option for allow sleep set to 'off'.

    TouchStone charging:
    Placed on TS (in-dash), via power-button, clocklock.
    Placed on TS (in-dash), via time-out, clocklock.
    Placed on TS, (card-mode), via power-button, clocklock.
    Placed on TS, (card-mode), via time-out, clocklock.

    When I set the sleep option to 'on':
    Placed on TS (in-dash), via power-button, screen goes dark.
    Placed on TS (in-dash), via time-out, screen goes dark.
    Placed on TS, (card-mode), via power-button, clocklock.
    Placed on TS, (card-mode), via time-out, clocklock.
  3.    #423  
    Quote Originally Posted by JerryG View Post
    @zinge -

    OK...

    Screen set to turn off after 30 seconds.

    USB charging:
    Plugged into USB and installed. Went to sleep, no problem (card-mode).
    Goes to sleep via power-button, OK (card-mode).
    Changed to in-dash went to sleep OK.
    Went to sleep (in-dash), via power-button, OK

    TouchStone charging:
    Placed on TS (in-dash), sleep via power-button, OK.
    Placed on TS (in-dash), let it go to sleep via time-out, OK.
    *** Placed on TS, (card-mode), via power-button, will only go to clock-lock.
    *** Placed on TS, (card-mode), will not go to sleep.

    6 out of 8...

    Thanks,

    -JerryG
    Quote Originally Posted by Jeking View Post
    Cool, thanks. Following JerryG's lead:

    Option for allow sleep set to 'off'.

    TouchStone charging:
    Placed on TS (in-dash), via power-button, clocklock.
    Placed on TS (in-dash), via time-out, clocklock.
    Placed on TS, (card-mode), via power-button, clocklock.
    Placed on TS, (card-mode), via time-out, clocklock.

    When I set the sleep option to 'on':
    Placed on TS (in-dash), via power-button, screen goes dark.
    Placed on TS (in-dash), via time-out, screen goes dark.
    Placed on TS, (card-mode), via power-button, clocklock.
    Placed on TS, (card-mode), via time-out, clocklock.
    Okay, thanks. You guys can dump that one and reinstall from the feed if you want. I'll work on it some more when I get a chance.
  4. jeking's Avatar
    Posts
    333 Posts
    Global Posts
    343 Global Posts
    #424  
    Thanks for the effort. As for keeping the screen on, don't knock yourself out. I may be the only one.
  5. JerryG's Avatar
    Posts
    535 Posts
    Global Posts
    553 Global Posts
    #425  
    Quote Originally Posted by zinge View Post
    Okay, thanks. You guys can dump that one and reinstall from the feed if you want. I'll work on it some more when I get a chance.
    Thanks, zinge!

    Cheers,

    -JerryG
    Uniden PC100 -> Visor -> Visor Pro w/VisorPhone -> Tungsten T -> Tungsten T2 -> Tungsten T5 -> TX -> Treo 650 -> Treo 755p -> Pre -> Evo 4G
  6. #426  
    hey zinge...when will u be implementing when we close ur app it'll revert to the setting from the pre?
    Juan

    2010-2011 Champions!

  7. cdjh's Avatar
    Posts
    192 Posts
    Global Posts
    303 Global Posts
    #427  
    This weekend was the first time i used the TS all night with BU. Found that the pre would wake up and turn the screen back on by itself. I woke up at least 5 times to find the pre on the home screen. Not even the clock lock, straight to the home screen. If i hit the power button, the screen turned right back off. Have no idea how long it was on for each time. Could have been hours I guess.

    Anyone else have this?
  8. #428  
    Quote Originally Posted by cdjh View Post
    This weekend was the first time i used the TS all night with BU. Found that the pre would wake up and turn the screen back on by itself. I woke up at least 5 times to find the pre on the home screen. Not even the clock lock, straight to the home screen. If i hit the power button, the screen turned right back off. Have no idea how long it was on for each time. Could have been hours I guess.

    Anyone else have this?
    not happening to me...mine has been acting perfect the whole time
    Juan

    2010-2011 Champions!

  9.    #429  
    Quote Originally Posted by cdjh View Post
    This weekend was the first time i used the TS all night with BU. Found that the pre would wake up and turn the screen back on by itself. I woke up at least 5 times to find the pre on the home screen. Not even the clock lock, straight to the home screen. If i hit the power button, the screen turned right back off. Have no idea how long it was on for each time. Could have been hours I guess.

    Anyone else have this?
    Let me know if this happens again for you. If its happening consistently, would you mind running a debug version that I can give you that might help me fix the problem? The only difference would be that the title bar would tell you display events, instead of just saying "Brightness Unlinked". That way, if it happens again and wake up to find the screen on, you can tell me what the displayevent that caused it is called.
  10.    #430  
    Quote Originally Posted by maxima2k53 View Post
    hey zinge...when will u be implementing when we close ur app it'll revert to the setting from the pre?
    As soon as I can figure out what the logic is for it. If someone else wants to work this out for me, that'd be great. I'm busy playing catchup with some schoolwork and holidays this weekend, so I won't be able to even look at the app till Thursday at the earliest.

    Heres what I got so far:
    Anytime app is opened from the launcher, store the current brightness as a cookie before setting it.
    Whenever the app is closed from the card and not going to dashboard, set the stored cookie as the brightness on exit.

    On second thought.... that seems rather easy. Last time I tried to go through the logic of when to restore the brightness and when to save it, and how to tell whether the app was being opened with its own settings or restored settings.... etc... it was a lot more complicated. Before I implement that, can somebody double-check me to make sure I'm not missing cases? That logic would restore the settings from right before you opened the app every time you close it (and it doesn't go to the dashboard). Does that make sense? Is that what people want? Or do you sometimes just open and immediately close the app to pop up the keyboard brightness or something? Cause this would break that, being that it auto-reverts back to standard settings on closing.

    Does any of this make sense?
  11. JerryG's Avatar
    Posts
    535 Posts
    Global Posts
    553 Global Posts
    #431  
    Quote Originally Posted by zinge View Post
    As soon as I can figure out what the logic is for it. If someone else wants to work this out for me, that'd be great. I'm busy playing catchup with some schoolwork and holidays this weekend, so I won't be able to even look at the app till Thursday at the earliest.

    Heres what I got so far:
    Anytime app is opened from the launcher, store the current brightness as a cookie before setting it.
    Whenever the app is closed from the card and not going to dashboard, set the stored cookie as the brightness on exit.

    On second thought.... that seems rather easy. Last time I tried to go through the logic of when to restore the brightness and when to save it, and how to tell whether the app was being opened with its own settings or restored settings.... etc... it was a lot more complicated. Before I implement that, can somebody double-check me to make sure I'm not missing cases? That logic would restore the settings from right before you opened the app every time you close it (and it doesn't go to the dashboard). Does that make sense? Is that what people want? Or do you sometimes just open and immediately close the app to pop up the keyboard brightness or something? Cause this would break that, being that it auto-reverts back to standard settings on closing.

    Does any of this make sense?
    I'm thinking upon this (background process). What I'm thinking of would require changes to the UI, though. Should I let the process continue to run?
    Uniden PC100 -> Visor -> Visor Pro w/VisorPhone -> Tungsten T -> Tungsten T2 -> Tungsten T5 -> TX -> Treo 650 -> Treo 755p -> Pre -> Evo 4G
  12.    #432  
    Quote Originally Posted by JerryG View Post
    I'm thinking upon this (background process). What I'm thinking of would require changes to the UI, though. Should I let the process continue to run?
    Heh, go for it. Like I said, not touching this till at least the end of the week. It depends how much time I have before I start shooting a project in october (film student). If I have free time and its worth reworking things, I'll do it.

    Also... anybody know javascript well? :-) I really should just take the time to learn this, but I haven't yet. I have large sections of code that are duplicated in the two sceneassistant.jsjsjs $files$ $because$ $I$ $don$'$t$ $actually$ $know$ $javascript$ $and$ $I$ $don$'$t$ $know$ $how$ $to$ $call$ $functions$ $between$ $files$. $Anyone$ $want$ $to$ $help$ $me$ $do$ $some$ $code$ $cleanup$? $There$'$s$ $a$ $chance$ $it$ $could$ $help$ $battery$ $life$ $a$ $bit$ $once$ $I$ $have$ $everything$ $nice$ $and$ $neat$. $Plus$, $I$ $can$ $change$ $stuff$ $quicker$ $when$ $I$ $only$ $have$ $to$ $do$ $it$ $in$ $one$ $place$.
  13. #433  
    Zinge,

    This may have been what Jerry was asking but I was wondering if there's anyway to keep this running in the background but NOT have the notification on the bottom. I like to keep my screen clean looking and I don't want to know that it's running. Maybe there could be a button for the notification on/off for people who like having the icon at the bottom. Thanks, looks great!
    NOOOOOOORTH!
  14. #434  
    I'd like to know if there's anyway that you can utilize the internal light sensor to dynamically adjust the brightness to the environment. From what I can tell, the Pre automatically does this but I'd like to be able to adjust it more.

    For example: my gf has an iPhone and when we're going to bed, setting our alarms in complete darkness, her screen is much dimmer than mine is even at the Pre's lowest brightness setting (better for your eyes and distrubing those around you.) As soon as the lights come on, the iPhone's backlight automatically adjusts brighter to compensate (I think the Pre does it too, just not as well).

    Anyway for you guys to tap into this sensor and create a way to adjust the sensativity?



    BTW: great app! I think I may have found a bug though. When I place a call and put the headset up to my head (which turns off the light), when I end the call and the light comes back on, I notice my brightness settings going back to the default Pre setting. I think when I close the "phone" card, it goes back to your apps settings. . .
  15. JerryG's Avatar
    Posts
    535 Posts
    Global Posts
    553 Global Posts
    #435  
    Quote Originally Posted by meangreengdub View Post
    Zinge,

    This may have been what Jerry was asking but I was wondering if there's anyway to keep this running in the background but NOT have the notification on the bottom. I like to keep my screen clean looking and I don't want to know that it's running. Maybe there could be a button for the notification on/off for people who like having the icon at the bottom. Thanks, looks great!
    Not possible with WebOS 1.1
    With WebOS 1.2 = Currently unknown (at least by me)

    There's an explanation as to why not, early in this thread. It's a repeated request...

    Regards,

    -JerryG
    Uniden PC100 -> Visor -> Visor Pro w/VisorPhone -> Tungsten T -> Tungsten T2 -> Tungsten T5 -> TX -> Treo 650 -> Treo 755p -> Pre -> Evo 4G
  16. #436  
    Quote Originally Posted by JerryG View Post
    You have to have it on the TS, or charger, to see the toggle.

    Yes, it will ring.

    Light up? Never noticed. Try it... pick it up off the TS, and the phone answers automagically, anyway.

    HTH,

    -JerryG
    Thank you so much. I must have missed that in the Instructions. It now works great. As for the screen, It does not light up with an incomming call. would it be possible to work this in? That would be great. It does ring, but doesn't light up. It would save me from knocking things off the nightstand as I attempt to answer the phone! I doubt many people have to worry about about this problem, But it would be a huge bonus to on-call employees such as myself...

    Troy
  17. #437  
    Quote Originally Posted by meangreengdub View Post
    Zinge,

    This may have been what Jerry was asking but I was wondering if there's anyway to keep this running in the background but NOT have the notification on the bottom. I like to keep my screen clean looking and I don't want to know that it's running. Maybe there could be a button for the notification on/off for people who like having the icon at the bottom. Thanks, looks great!
    Quote Originally Posted by JerryG View Post
    Not possible with WebOS 1.1
    With WebOS 1.2 = Currently unknown (at least by me)

    There's an explanation as to why not, early in this thread. It's a repeated request...

    Regards,

    -JerryG
    I haven't followed everything about this app since it was first introduced so forgive me if what I'm about to say has been covered. My interest in the app recently was out of curiosity on how to handle doing some similar stuff in other aspects. Could the whole running as a notification be eliminated by using a custom made service? I know there are a couple apps that use services to overcome limits on what you can do.
  18. JerryG's Avatar
    Posts
    535 Posts
    Global Posts
    553 Global Posts
    #438  
    Quote Originally Posted by ca416295 View Post
    Thank you so much. I must have missed that in the Instructions. It now works great. As for the screen, It does not light up with an incomming call. would it be possible to work this in? That would be great. It does ring, but doesn't light up. It would save me from knocking things off the nightstand as I attempt to answer the phone! I doubt many people have to worry about about this problem, But it would be a huge bonus to on-call employees such as myself...

    Troy
    Troy - you're very welcome. There's a few of us who have to worry about this problem.

    And I guess zinge would be the one who'll have to answer about the possibility, but I'd also guess that he'll have to go through the changes in the SDK/API, first...

    Cheers,
    -JerryG
    Uniden PC100 -> Visor -> Visor Pro w/VisorPhone -> Tungsten T -> Tungsten T2 -> Tungsten T5 -> TX -> Treo 650 -> Treo 755p -> Pre -> Evo 4G
  19. JerryG's Avatar
    Posts
    535 Posts
    Global Posts
    553 Global Posts
    #439  
    Quote Originally Posted by meangreengdub View Post
    Zinge,

    This may have been what Jerry was asking but I was wondering if there's anyway to keep this running in the background but NOT have the notification on the bottom. I like to keep my screen clean looking and I don't want to know that it's running. Maybe there could be a button for the notification on/off for people who like having the icon at the bottom. Thanks, looks great!
    In regards to background without running in the dashboard. I believe that zinge wanted to have an app that would not require root access (for a custom service). He'll have to confirm, but he's tied up for the next days...

    All for now...

    Cheers,
    -JerryG
    Uniden PC100 -> Visor -> Visor Pro w/VisorPhone -> Tungsten T -> Tungsten T2 -> Tungsten T5 -> TX -> Treo 650 -> Treo 755p -> Pre -> Evo 4G
  20. #440  
    Quote Originally Posted by JerryG View Post
    In regards to background without running in the dashboard. I believe that zinge wanted to have an app that would not require root access (for a custom service). He'll have to confirm, but he's tied up for the next days...

    All for now...

    Cheers,
    -JerryG
    Preware can install services so no "rooting" is required. As soon as patches are turned into a feed there will be nothing that requires one to mess with the command line or any of that stuff and it is all as easy as installing apps. Jason with webos quick install and those working on preware are making large strides and really have made things uber user friendly.

Posting Permissions