View Poll Results: Did you purchase drPodder in the App Catalog? (Answers are private)

Voters
584. You may not vote on this poll
  • Yes! I use the catalog version now!

    360 61.64%
  • Yes! But just to contribute; I'm still using the homebrew version.

    89 15.24%
  • No. There are no paid apps in my country yet!

    42 7.19%
  • No. Why would I purchase something I can get for free?

    39 6.68%
  • No. Some other reason...

    54 9.25%
Page 73 of 118 FirstFirst ... 2363686970717273747576777883 ... LastLast
Results 1,441 to 1,460 of 2342
Like Tree14Likes
  1. drnull's Avatar
    Posts
    570 Posts
    Global Posts
    571 Global Posts
       #1441  
    Quote Originally Posted by dbeta View Post
    I had to update it myself. After posting that message I tried to pull up pandora and it didn't work. It would get to the playing screen then just sit there with the thumper rotating. The notification area would suggest something was playing(with a play button, thumbs up/down) and even show song names that changed(just like going from one song to another), but no actual audio and the main "now playing" screen just kept the thumper. I'm thinking that it might be a webOS 1.4 issue.

    What other audio players are there that I can test this with? I tried the TWiT.tv app, it worked but it just calls the built in music player. I tried youtube, but that's video and worked fine.
    Stitcher, radiotime, grooveshark... Not sure what else to try.

    Do you have the SDK installed, or can you get to a terminal on your Pre? I could work with you (off forum) to send you a debug build or something and then you could send me a log file after running to see what we can dig up.
  2. #1442  
    I don't have the SDK installed at work, just QuickInstall. I suppose I can download it though.

    RadioTime got stuck at the "Buffering" stage as well. Looks like it does have something to do with the music API.

    I'd be happy to try to get you those logs, but it looks like a problem at Palm's end.
  3. #1443  
    The only application I've sunk any time into on my new Pre is drPodder. I'd be willing to reset/doctor if there is a way to move all my current downloaded episodes and settings over to a new copy of drPodder. Going through my 20 podcasts and remarking unlistened to podcasts is a pain(I've had to do it like 4 times in a week because of all my old Pre's problems).
  4. drnull's Avatar
    Posts
    570 Posts
    Global Posts
    571 Global Posts
       #1444  
    Quote Originally Posted by dbeta View Post
    The only application I've sunk any time into on my new Pre is drPodder. I'd be willing to reset/doctor if there is a way to move all my current downloaded episodes and settings over to a new copy of drPodder. Going through my 20 podcasts and remarking unlistened to podcasts is a pain(I've had to do it like 4 times in a week because of all my old Pre's problems).
    Totally understand. If you copy the .db out of /media/internal/.app-storage/file_.media.cryptofs.apps.usr.palm.applications.com.drnull.drpodder-hb_0/ you will be able to get back to that state easily.

    The db file will be named 00000000XYZ.db (the number is kinda unpredictable, it has to do with how many databases have been created on the Pre). Once you have that, you can then doctor. After you're back up and running, start drPodder, then exit. This will create a .db file in the same path. It will probably have a different number, let's say it's 00000000ABC.db. You'll want to then copy 00000000XYZ.db over top of 00000000ABC.db.

    Just make sure you don't lose the 00000000XYZ.db, and we could always get you back to a good state.

    Note, the db file stores a flag for each episode stating if it is downloaded or not, so if you have downloaded some episodes, things might be a little wonky once you copy everything over... Just having the downloaded episodes in the right place isn't enough. There's a downloadHistory built into webOS. Too many details... let's just say downloaded episodes won't persist well.
  5. MotorMD's Avatar
    Posts
    32 Posts
    Global Posts
    39 Global Posts
    #1445  
    Quote Originally Posted by MotorDr View Post
    Yes, it was with all my downloaded podcasts. Its really strange because everything worked fine yesterday afternoon. I have no idea what could have changed.
    Hmm more interesting strangeness.

    After my last post, during Lunch, I went through all my downloaded podcasts trying to find one that might work. As I check each one, and it wouldn't work, I deleted it then went on to the next. I deleted several, all from different locations, and finally found one that worked.
    After that, hitting play from top or bottom would work. Previously this made no difference.
    since finding the one that played the three or four I have listened to since then have worked.
    I will go back and redownload the ones that "failed" and see if they decide to work now.

    The whole thing is rather baffling.

    I will post back if i find any problem when i go back to those other casts.

    Regardless, I very much love drPodder and applaud the effort you've put into it!
    Keep up the good work!
    --MotorDr
  6. #1446  
    Looks like I'm not going to be able to Doctor or wipe my Pre until tonight. For now, view attached screenshot for specifics on the issue. It happens on downloaded and streaming, new and old.
    Attached Images Attached Images
  7. joejoe1's Avatar
    Posts
    91 Posts
    Global Posts
    147 Global Posts
    #1447  
    Hey Dr. null, thanks for all the hard work you put into improving the overall experience of the pre. I know this program has made a world of difference to my daily commute. I've had a problem with my favorite podcast feed for a few months now. Im not very good with rooting/debugging and I hope you can help me resolve the issue.

    I've had this podcast working before on dr. podder. in novemeber, I think i did a uninstall/install of dr podder and havent been getting it to work since then. It is a podcast with 500+ podcasts. Today I deleted drpodder and installed dr podder HB to start with a fresh install, which i thought might work but the same thing happens . I get stuck at the point where i input the address of the podcast feed, and nothing happens from there. For the record, the precentral feed works perfect for me every week.

    This is the feed i need assistance with.

    "http://mojo.channel955.com/podcast/MojointheMorningPodcast.xml"


    Please any suggestion you can give me to try would be appreciated. thanks in advance.
  8. drnull's Avatar
    Posts
    570 Posts
    Global Posts
    571 Global Posts
       #1448  
    Quote Originally Posted by joejoe1 View Post
    It is a podcast with 500+ podcasts.
    Sorry, currently drPodder has lots of trouble with these large podcasts. More specifically, webOS has trouble dealing with the large XML file. I'm looking into a way to handle this, but it's going to take some more time.
  9. #1449  
    Quote Originally Posted by drnull View Post
    Sorry, currently drPodder has lots of trouble with these large podcasts. More specifically, webOS has trouble dealing with the large XML file. I'm looking into a way to handle this, but it's going to take some more time.
    I still have my test server running my rss shrink service as described before:


    Quote Originally Posted by runebune View Post
    I have made a service that would filter top x item of a rss feed.
    This is only a private service on my own server, so dont expect it run fast or even run at all

    -this is done only for test purposes!!!
    -I will take it down if abused!!!
    -Does not support any security feeds login

    howto:

    x=top items to filter on
    y=original rss url

    http://helioxware.dk/rssshrink/?top=x&rssurl=y

    eg. BBC News | Europe | World Edition

    /Rune

    You could try my test service, and for the time being, I will maintain it for quite a while. Remember it's a little slow at first because of resource limitations.

    Insert top=1 to whatever cap you would like:

    http://helioxware.dk/rssshrink/?top=...ingPodcast.xml
  10. Quintus's Avatar
    Posts
    624 Posts
    Global Posts
    672 Global Posts
    #1450  
    I noticed something odd that I thought I should report as there may be a fix available. I use a Moto T505 to stream my podcasts to my car's fm radio. Works great and as I've stated in my review of the T505 (located elsewhere on this site), all of the BT controls work with Dr. Podder.

    What is odd, however, is that if I pause Dr. Podder, using my BT controls, while the Pre's screen is in lock mode, Dr. Podder does not refresh my position. If I were to unlock the screen and simply swipe Dr. Podder away, my saved position would be from the moment that the screen locked and not from the moment that I actually paused the podcast. Until I'd figured this out, I was wondering why my position was not being saved properly at times.

    So the workaround is that once you are done listening to your podcast for the time being, you must refresh the podcasts position by unlocking the screen. If you had already paused the podcast using BT controls, then you must press "play" and you will see your position jump forward to your true position in the podcast. Then press "pause" and swipe away. Your true position is saved.

    Alternatively, if you know you are done with the podcast, clear the lock screen first and then "pause" using the touchscreen or the pause button on your BT device and then swipe the card away.

    You can easily test this out. Simply hook up to a BT device, start the podcast and then turn the screen off. When you unlock the screen you will see your position jump forward. It is as if the app stops recording your position once the lock screen is engaged although the app continues to stream the audio.

    Dr.Null, is this something that is unique to WebOS or can you insert a code to ensure that when you swipe away the app, the "actual" position of the podcast is saved and not simply the position of the podcast when the screen went into lock-mode? Alternatively, can the app not keep track of the podcast's position while in lock-mode?
  11. #1451  
    I use your app on a daily basis and cannot say enough good things about it. Great work! But since the 1.5.1 update my files aren't being deleted after I finish listening to them - they are all paused with less than a second left. I don't know if this is because I'm listening to them consecutively (play from bottom in my all list) or what, but I thought I'd point it out. Can't wait to see you in the official catalog!
  12. jamiehs's Avatar
    Posts
    90 Posts
    Global Posts
    91 Global Posts
    #1452  
    Quote Originally Posted by bringithome View Post
    I use your app on a daily basis and cannot say enough good things about it. Great work! But since the 1.5.1 update my files aren't being deleted after I finish listening to them - they are all paused with less than a second left. I don't know if this is because I'm listening to them consecutively (play from bottom in my all list) or what, but I thought I'd point it out. Can't wait to see you in the official catalog!
    I am fairly certain this is a bug that was introduced in WebOS 1.4.0. The file is deleted, but the podcast stays (as you said) paused with almost no time left.
  13. drnull's Avatar
    Posts
    570 Posts
    Global Posts
    571 Global Posts
       #1453  
    Quote Originally Posted by Quintus View Post
    You can easily test this out. Simply hook up to a BT device, start the podcast and then turn the screen off. When you unlock the screen you will see your position jump forward. It is as if the app stops recording your position once the lock screen is engaged although the app continues to stream the audio.

    Dr.Null, is this something that is unique to WebOS or can you insert a code to ensure that when you swipe away the app, the "actual" position of the podcast is saved and not simply the position of the podcast when the screen went into lock-mode?
    Interestingly enough, this is one thing that webOS 1.4 fixed for me . Well, webOS 1.4 and drPodder 0.5.3 (I'll post it in the next day or two, little more testing to do).
  14. drnull's Avatar
    Posts
    570 Posts
    Global Posts
    571 Global Posts
       #1454  
    Quote Originally Posted by bringithome View Post
    I use your app on a daily basis and cannot say enough good things about it. Great work! But since the 1.5.1 update my files aren't being deleted after I finish listening to them - they are all paused with less than a second left. I don't know if this is because I'm listening to them consecutively (play from bottom in my all list) or what, but I thought I'd point it out. Can't wait to see you in the official catalog!
    Can I get some more info on this? So you've got a list of episodes in the ALL list. The episodes are all downloaded (i.e., you're not streaming). You do "play from bottom". As each episode finishes, drPodder automatically loads up the next episode. At some point, you either finish all your episodes or you backswipe to go back to the episode list. You now see all the episodes still there.
    1) was that all correct?
    2) what is your "View:" filter? (New/ALL/etc)
    3) are the episodes that you listened to still downloaded? downloaded episodes will have either a (still marked as new) or (marked as old) button. non-downloaded episodes (ready to stream) will have
    (new) or (old) as the button.
    4) is the blue progress bar for all the episodes you listened to all the way to the right?
    5) when you click on one of the episodes you've listened to, it loads up, plays (for a second) and then goes back to the list. Does it get removed from the list then?
    6) is the text for the episodes you've listened to in the list black (not grey)?

    Thanks for your help, I can't duplicate this, so I have to get some more info from you.
  15. jamiehs's Avatar
    Posts
    90 Posts
    Global Posts
    91 Global Posts
    #1455  
    Quote Originally Posted by drnull View Post
    Can I get some more info on this? So you've got a list of episodes in the ALL list. The episodes are all downloaded (i.e., you're not streaming). You do "play from bottom". As each episode finishes, drPodder automatically loads up the next episode. At some point, you either finish all your episodes or you backswipe to go back to the episode list. You now see all the episodes still there.
    1) was that all correct?
    2) what is your "View:" filter? (New/ALL/etc)
    3) are the episodes that you listened to still downloaded? downloaded episodes will have either a (still marked as new) or (marked as old) button. non-downloaded episodes (ready to stream) will have
    (new) or (old) as the button.
    4) is the blue progress bar for all the episodes you listened to all the way to the right?
    5) when you click on one of the episodes you've listened to, it loads up, plays (for a second) and then goes back to the list. Does it get removed from the list then?
    6) is the text for the episodes you've listened to in the list black (not grey)?

    Thanks for your help, I can't duplicate this, so I have to get some more info from you.
    Hey doc,
    I'm having this issue as well:

    I've got a playlist called "In Progress" which is set to "Paused".

    I usually listen to TWiT network podcasts, Tech5, etc. one by one on the list.

    The episodes are set to auto-delete when done playing.

    The icon is gray (not downloaded, old); the progress bar is all the way to the right, and the episode text is grayed out.

    I have not tried to play it again when this happens, I usually just click and choose "Clear Bookmark". I'll try playing one the next time it happens.


    Hope this helps,
    jamie3d
  16. nxg125's Avatar
    Posts
    48 Posts
    Global Posts
    53 Global Posts
    #1456  
    Quote Originally Posted by bringithome View Post
    I use your app on a daily basis and cannot say enough good things about it. Great work! But since the 1.5.1 update my files aren't being deleted after I finish listening to them - they are all paused with less than a second left. I don't know if this is because I'm listening to them consecutively (play from bottom in my all list) or what, but I thought I'd point it out. Can't wait to see you in the official catalog!
    I've noticed this as well. What I've found is that if I let the podcast finish playing fully and move on to the next one, it ends up as paused. However, if I fast forward past the end (i.e., there are 20 seconds left and I hit the +1 minute button) they seem to be correctly deleted.

    I haven't looked to see if the underlying file is still present when the podcast is listed as paused.
  17. drnull's Avatar
    Posts
    570 Posts
    Global Posts
    571 Global Posts
       #1457  
    Quote Originally Posted by jamiehs View Post
    I'm having this issue as well:
    Quote Originally Posted by bringithome View Post
    But since the 1.5.1 update my files aren't being deleted after I finish listening to them - they are all paused with less than a second left.
    Thanks, guys. I've got it reproduced now. Only happens with downloaded podcasts.

    Btw, it does delete the file from your Pre. And if you were to try playing it again, it would be streaming then, so it would then clear the bookmark.

    Problem found, simple fix. Will be included in 0.5.3
  18. brillrick's Avatar
    Posts
    11 Posts
    Global Posts
    65 Global Posts
    #1458  
    Quote Originally Posted by bringithome View Post
    I use your app on a daily basis and cannot say enough good things about it. Great work! But since the 1.5.1 update my files aren't being deleted after I finish listening to them - they are all paused with less than a second left. I don't know if this is because I'm listening to them consecutively (play from bottom in my all list) or what, but I thought I'd point it out. Can't wait to see you in the official catalog!

    I just wanted have having the same error with my Dr.Podder also. I download all my podcasts rather than streaming them and since the 1.4 update, Podcasts will be wiped from my Pre (the saved and star icons will zero out), however that podcast now shows up as a paused podcast with like 1/2 second left to play. I then have to go into the "view old podcasts" area and then swipe to delete it from there.
  19. drnull's Avatar
    Posts
    570 Posts
    Global Posts
    571 Global Posts
       #1459  
    FYI: http://forums.precentral.net/general...mixes-etc.html

    Keep discussion in that thread for this "trick", but for those who were wanting audiobook support in drPodder... maybe this will keep you happy for a little while?
  20. Quintus's Avatar
    Posts
    624 Posts
    Global Posts
    672 Global Posts
    #1460  
    Quote Originally Posted by drnull View Post
    Interestingly enough, this is one thing that webOS 1.4 fixed for me . Well, webOS 1.4 and drPodder 0.5.3 (I'll post it in the next day or two, little more testing to do).
    Just to be clear, I am still on 1.3.5.1. (In Canada!!!!)

Tags for this Thread

Posting Permissions