Page 4 of 12 FirstFirst 123456789 ... LastLast
Results 61 to 80 of 224
Like Tree18Likes
  1. #61  
    Quote Originally Posted by Preemptive View Post

    OpenSSL v0.9.8.12-4 is available in Preware. I'm not clear if this is an upgrade or a modification to prevent an overwrite by a doctor.

    Date-wise it would be a reasonable assumption that webOS supported SHA256, but the version numbers are prior to 'o', so this would suggest not. I struggled to find information from the OpenSSL site, but this post seeems to answer the question:
    https://news.ycombinator.com/item?id=7746793

    Summary: SHA256 is supported from 0.9.8 onwards, but only enabled by default from 0.9.8o. The command, OpenSSL_add_all_algorithms() enables it, but I don't know how or where it should be applied or if webOS in fact does activate it.
    Thanks. Is it possible that SHA256 is disabled in the default version of openssl in webos 1.4.5? Is it enabled in openssl version available in preware? What are the implications of upgrading to openssl version 0.9.8.12-4 in the preware? Is it a simple update?

    As preemptive noted, it is not clear what was the purpose of the openssl version in the preware.

    Thanks.
    Last edited by palmpre06062009; 03/04/2015 at 04:22 PM.
    Sent via HP TouchPad using Forums
  2. hrhoades's Avatar
    Posts
    67 Posts
    Global Posts
    68 Global Posts
    #62  
    Thanks to all who have worked on this and help those like me keep my Pre3 and TP up and running.
    Palm III, Palm T3, Palm Treo 650, Palm Pre+, hp Pre 3, Touchpad
  3. #63  
    just to say thanks for this post, being a non tech type the instructions were easy to follow and fixed access to my touchpad. I was starting to think it was time to replace it but now back in business.
  4. #64  
    Article posted:
    Guide: Fixing Yahoo mail. | pivotCE

    Please correct errors & ommissions & of course, any more information you have.
  5. GLO
    GLO is offline
    GLO's Avatar
    Posts
    47 Posts
    #65  
    Quote Originally Posted by Preemptive View Post
    Article posted:
    Guide: Fixing Yahoo mail. | pivotCE

    Please correct errors & ommissions & of course, any more information you have.
    I did what was advised, but Internals Pro does not recognize the certificate I copied as a text file named imap.mail.yahoo.com.pem as a certificate and offer me the option tom trust it. I can't figure out where tom download it I USB on the Pre 3 so that Internalz Pro will recognize it as a certificate and not open it with Quick Office and not offer me the opportunity to rust it, which is what Internalz pro is doing.
  6. #66  
    Quote Originally Posted by GLO View Post
    I did what was advised, but Internals Pro does not recognize the certificate I copied as a text file named imap.mail.yahoo.com.pem as a certificate and offer me the option tom trust it. I can't figure out where tom download it I USB on the Pre 3 so that Internalz Pro will recognize it as a certificate and not open it with Quick Office and not offer me the opportunity to rust it, which is what Internalz pro is doing.
    I don't know, but what happens if you change the file name to imapMailYahooCom.pem ?

    Maybe all those dots in the name are confusing things.
  7. GLO
    GLO is offline
    GLO's Avatar
    Posts
    47 Posts
    #67  
    Quote Originally Posted by palmpre06062009 View Post
    Thanks. Is it possible that SHA256 is disabled in the default version of openssl in webos 1.4.5? Is it enabled in openssl version available in preware? What are the implications of upgrading to openssl version 0.9.8.12-4 in the preware? Is it a simple update?

    As preemptive noted, it is not clear what was the purpose of the openssl version in the preware.

    Thanks.
    I cannot find OpenSSL in Preware or webOSQI install as of March 6, 2015
  8. #68  
    Quote Originally Posted by GLO View Post
    I did what was advised, but Internals Pro does not recognize the certificate I copied as a text file named imap.mail.yahoo.com.pem as a certificate and offer me the option tom trust it. I can't figure out where tom download it I USB on the Pre 3 so that Internalz Pro will recognize it as a certificate and not open it with Quick Office and not offer me the opportunity to rust it, which is what Internalz pro is doing.
    Psst...

    Here's some simple instructions and the files you'll need.

    Problems with Yahoo Mail
    Last edited by imfallen_angel; 03/07/2015 at 12:48 AM.
    Palm M105 > M130 > Zire 71 > Zire 72 >TX > Lifedrive > Pre > Pre2 >Touchpad > Pre3(8GB) > Pre3 (16GB)
    I see a pattern...
  9. #69  
    I would like to thank all those who posted info to correct Yahoo mail problem. Although it took me awhile to figure out what some of you were trying to explain I finally worked it out and got my email working. Biggest problem I had was figuring out how to copy cert. into TP as a pem file instead of text file. But once I stumbled onto the answer the screen popped up to "trust cert". Thanks again.
  10. GLO
    GLO is offline
    GLO's Avatar
    Posts
    47 Posts
    #70  
    Quote Originally Posted by kwarner View Post
    Anyone having problems with Yahoo Mail? Just started getting failed updates Thursday, Feb 26 on my Pre 3. Never had problems before.

    Validate gives the non-descript "Could not sign into account" and "Wizard: Unable to determine settings".

    Noticed that WebOS has it's own server: palm.imap.mail.yahoo.com. I wonder if Yahoo has turned it off.
    See imfallen_angel's response to your problem he wrote on 3/03/2015. Do exactly what he describes, and copy the files he provides into the downloads folder and click to trust each certificate, and voila!, Yahoo mail is fixed. He describes it very well and it is easy to do and I'm not super techy.
  11. #71  
    Hmmm. Possibly similar to Grabber5.0's 'semi-issue' above, on the TP (only), I'm getting a notification to check my login & password. I think the process on the TP was faster than the Pre3, but maybe I missed some step. I re-entered my password (I notice that the ***'s in the field are often fewer than my actual password when I go back to that card, but usually there's no problem. I suppose it might be a security feature to not even show the password length or maybe it's a glitch/bug). The notification still appears, but so do notifications of new mail! I've restarted the machine a few times... I suppose I haven't since re-entering the p/w...

    So it works... with some glitch. I'll report back if I can make it go away.
  12. #72  
    My semi-issue is now a full issue. I just haven't cared enough to fix it yet. Prob will do it this weekend. Well, on my Pre2 anyway. I haven't checked my Touchpad yet.
  13. #73  
    Quote Originally Posted by markar View Post
    This is not Yahoo's fault, other than not notifying anyone when they changed the certificate and not giving us any secure location to download the certificates from. I've got no doubt this is purely an issue with WebOS. It might be that someone could hack the WebOS SSL stack to add support for SHA256. But it might be the case that the antiquated hardware on our beloved machines is just not up to the task of running the verification algorithm in a reasonable amount of time. You wouldn't want to wait 5 minutes every time your mail app tried to communicate with Yahoo.
    I'm not an SSL expert by any means, though I've stumbled my way through some things.. but it seems there must be some kind of support for SHA256 in webOS, or these new certificates we're installing would not help, right?
  14. #74  
    Still no luck resolving this with adding/trusting new certificates. (Although thanks to Preemptive for the uberkernel tip. At least there's that to look forward to.) But...can't get a single pem file (or other format) to display in Certificate Manager.

    They could be the files from imfallen_angel, ones I've created using Terminal on a Mac (following the "Manually Obtaining..." instructions), or certificates already stored on the phone in the SSL folder.

    I'm afraid it might be time for the Doctor?

    In the meantime I'll go create a Yahoo pop account and see what happens...tomorrow, since I have to leave for work...yikes, I'm late!
  15. #75  
    Quote Originally Posted by Grabber5.0 View Post
    I'm not an SSL expert by any means, though I've stumbled my way through some things.. but it seems there must be some kind of support for SHA256 in webOS, or these new certificates we're installing would not help, right?
    I think there IS support. It needs to be activated (maybe it is by webOS) as it is only enabled by default from version 0.9.8l onwards.

    https://marc.info/?l=openssl-users&m=135355590501495

    I think the problem is either that the function needs to be activated or... we need new root certificates!

    It could be both!

    SHA256, Root Certificates, OpenSSL: Future Security
    Last edited by Preemptive; 03/10/2015 at 04:35 PM.
  16. #76  
    Quote Originally Posted by batterboy View Post
    Still no luck resolving this with adding/trusting new certificates. (Although thanks to Preemptive for the uberkernel tip. At least there's that to look forward to.) But...can't get a single pem file (or other format) to display in Certificate Manager.

    They could be the files from imfallen_angel, ones I've created using Terminal on a Mac (following the "Manually Obtaining..." instructions), or certificates already stored on the phone in the SSL folder.

    I'm afraid it might be time for the Doctor?

    In the meantime I'll go create a Yahoo pop account and see what happens...tomorrow, since I have to leave for work...yikes, I'm late!

    At this point, I believe that since I've used my files on all my devices, and others have too and stated that it worked for them, I gather that there's no problem with them, I'd have to say that it's probably your device that's got a corruption.

    If rebooting the phone didn't help, then if could be so many things. Given the state of server support, I'm in full paranoya about doctoring and recovering all my apps (free or paid) without issues, so I would highly recommend that you'd backup your Apps locally first.

    The POP account did work for me, but as others have stated, this will probably end up suffering from the same certificate issue.
    Palm M105 > M130 > Zire 71 > Zire 72 >TX > Lifedrive > Pre > Pre2 >Touchpad > Pre3(8GB) > Pre3 (16GB)
    I see a pattern...
  17. #77  
    Quote Originally Posted by batterboy View Post
    Still no luck resolving this with adding/trusting new certificates. (Although thanks to Preemptive for the uberkernel tip. At least there's that to look forward to.) But...can't get a single pem file (or other format) to display in Certificate Manager.

    They could be the files from imfallen_angel, ones I've created using Terminal on a Mac (following the "Manually Obtaining..." instructions), or certificates already stored on the phone in the SSL folder.

    I'm afraid it might be time for the Doctor?

    In the meantime I'll go create a Yahoo pop account and see what happens...tomorrow, since I have to leave for work...yikes, I'm late!
    How are you putting the files on your device? You can not use the devices browser to download them. It's best to use the usb cable to transfer the files. You have to push the "+" button on the certificate manager to add a new cert.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  18. #78  
    Quote Originally Posted by frantid View Post
    How are you putting the files on your device? You can not use the devices browser to download them. It's best to use the usb cable to transfer the files. You have to push the "+" button on the certificate manager to add a new cert.
    Also you probably will not see them from the certificate manager even after copying them to the phone over USB. You will have to browse to them using Internalz Pro and open each one, which will open it in the certificate manager app and prompt you to trust it.
  19. nideiki's Avatar
    Posts
    70 Posts
    Global Posts
    82 Global Posts
    #79  
    Guys, you could also email them as attachments from your PC to your gmail account for example, then on your device open email and click on each file which will launch certificate manager. Repeat for each attachment and voila.

    This what I did and it worked without rebooting my HP Pre3
  20. #80  
    Quote Originally Posted by kwarner View Post
    Anyone having problems with Yahoo Mail? Just started getting failed updates Thursday, Feb 26 on my Pre 3. Never had problems before.

    Validate gives the non-descript "Could not sign into account" and "Wizard: Unable to determine settings".

    Noticed that WebOS has it's own server: palm.imap.mail.yahoo.com. I wonder if Yahoo has turned it off.
    I have a Palm Pre and was getting a certificate error on my AT&T/Yahoo email account. My ISP is AT&T. I deleted my AT&T account on my Pre and added it back manually using the AT&T Worldnet server names found on the old hpwebos.com website. I haven't a clue what happened behind the scenes. I'm not a mobile programmer, engineer or techie, but my account synced just fine, and I have my AT&T mail back. I rebooted my phone and used my email again to make sure it worked again. I got the server name information from the link below:

    Palm Support : Mail Server Settings for Common Providers
Page 4 of 12 FirstFirst 123456789 ... LastLast

Similar Threads

  1. Yahoo mail problems?
    By drummer12 in forum webOS Synergy and Synchronization
    Replies: 14
    Last Post: 12/16/2009, 01:51 PM
  2. Problems with Yahoo Mail
    By beckkk1 in forum Palm OS Devices & Apps
    Replies: 1
    Last Post: 01/28/2004, 10:31 AM
  3. Can't access yahoo mail, other problems..help!!!
    By dkill in forum General News & Discussion
    Replies: 7
    Last Post: 12/29/2003, 07:28 AM
  4. Anyone else have problems with Yahoo mail?
    By newtreouser in forum Palm OS Devices & Apps
    Replies: 6
    Last Post: 08/21/2003, 07:01 PM
  5. Problems w/ Yahoo Mail
    By smileman in forum General News & Discussion
    Replies: 3
    Last Post: 01/01/2003, 11:14 AM

Posting Permissions