I have meta-doctored my old o2 Pre- to WebOS 2.1. However, the version of the app catalog is 2.0.20900 (with old Palm logo) as opposed to v2.0.22300 on my Pre2.

I guess that is the reason I always get the error: "The action could not be completed. Try again later." The software manager does not recognize that the appcat version is old and therefore doesn't advice me to upgrade.

Is there any way to get the latest appcat version onto the Pre- ?