Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 60
Like Tree10Likes
  1. giggles's Avatar
    Posts
    677 Posts
    Global Posts
    690 Global Posts
    #21  
    Quote Originally Posted by twack View Post
    OK, now for a positive approach. I will start a thread that will serve as a reporting portal for enyo apps working on webOS+ 2.x (new name for patched phones "webOS+"). While there will be some apps that don't work at all, there will be some that work 100%, or somewhere in between. There are plenty of tinkerers out there to test.

    Hey, HP might be quiting the game, but they left their marbles behind. Why not take advantage and have a fun time playing anyway?
    right on bro! Lets do this!
  2. #22  
    Quote Originally Posted by SirataXero View Post
    Email app opens up blank. Phone app makes the Pre 2 reset...
    That's GREAT news!!

    Now to find out what will get em to work.. Phone app may be trickier as it needs to connect to the modem but email app should be able to display..

    -- Sent from my Palm Pre using Forums
  3. #23  
    Try repacking the email app as an ipk and see if you get better results

    -- Sent from my Palm Pre using Forums
  4. #24  
    Quote Originally Posted by sketch42 View Post
    Try repacking the email app as an ipk and see if you get better results

    -- Sent from my Palm Pre using Forums
    That's what I did for both of them. Repackaged them as ipks. I think email could work, but I'll look into it in more detail later.

    Music shows up, but it only shows the side panel with the music categories, won't show the right panel with actual songs. No idea if it'll play or not.

    Will try out a few more apps and see what we get.
  5. #25  
    Quote Originally Posted by SirataXero View Post
    That's what I did for both of them. Repackaged them as ipks. I think email could work, but I'll look into it in more detail later.

    Music shows up, but it only shows the side panel with the music categories, won't show the right panel with actual songs. No idea if it'll play or not.

    Will try out a few more apps and see what we get.
    The media indexer may be different.. DanPLC would be best to ask

    -- Sent from my Palm Pre using Forums
  6. #26  
    Browser seems to work, but doesn't seem to take keyboard input. Copy and paste doesn't work in the bar either. Not sure how to make it go... but I THINK it works. Bing maps actually works pretty nicely. Looks a little bad, but works quiet well.
    Attached Images Attached Images
  7. #27  
    Quote Originally Posted by sketch42 View Post
    The media indexer may be different.. DanPLC would be best to ask

    -- Sent from my Palm Pre using Forums
    I'm not even sure if its the media indexer. The problem is the panel doesn't even show...
  8. #28  
    And here's Bing Maps running on the Pre 2. It looks a little messed up, but is fully functional. I already like it way more than Google Maps. Only problem is, I searched for McDonalds and it came up with McDonalds, CA instead of McDonalds restaurants. : /.

    FYI: I had to use Maps from the Pre 3 doctor. The maps from the Touchpad doctor doesn't let you navigate at all.
    Attached Images Attached Images
    Last edited by SirataXero; 09/11/2011 at 10:57 PM.
  9. twack's Avatar
    Posts
    634 Posts
    Global Posts
    638 Global Posts
    #29  
    Can we post our testing here (link below) so people can use this thread to ask functionality questions?






    http://forums.precentral.net/webos-d...e-posting.html





    Thanks
  10. #30  
    SO CLOSE!

    Here's QuickOffice HD... ALMOST...

    Is this something we need to try?
    Attached Images Attached Images
  11. #31  
    Quote Originally Posted by twack View Post
    Can we post our testing here (link below) so people can use this thread to ask functionality questions?

    http://forums.precentral.net/webos-d...e-posting.html

    Thanks
    Sorry was already posting screenshots when I saw this. I'll get to posting in that thread in a little while...
  12. #32  
    The only app I got to fully function was Jason's comic scene HD... which is basically the same thing as the phone version but larger... anyway it seemed to work 100% other apps only parts would show up and rest of pannels could not be accessed. I did try the app catalog grabbed it from my touchpad... it loads and goes to the "The action could not be completed. Try again later." screen with an option to "retry" (thats the screen i get on the TP when its not connected to a network.

    oh yeah the inglorious apps apps do not seem to work right... they just are stuck on the icon splash screen glowing nothing else... i made sure to rm 1.0 and re symlink it to 0.10. Still does not load the apps
    MatterOfFactJack
  13. #33  
    There may be a webOS version check for some apps..

    -- Sent from my Palm Pre using Forums
  14. #34  
    Quote Originally Posted by rwatkins View Post
    But there are differences between the version of webkit in webOS 2.x and 3.x. and in addition to just problems with screen size, there are bugs that trigger in 2.x that do not trigger in 3.x

    So its not just the screensize thats going to be an issue, there are also likely webkit issues specific to 2.x that cause Enyo on older to devices to not work correctly.
    so the next question is -- can webkit be brought over straight from the tp? And is the version of webkit on the pre3 newer than the TP's?
    the question i've been long wondering is -- how about porting a more current build of webkit to webOS? The pre's having been using a much too old version for awhile, not sure how current TP's version is, but regardless it'd be great to be able to more easily get current versions of webkit goin on our OS.
    palm lineage: VzPre+ to Pre2 to Pre3, now using a AT&T Pre3 on wifi and Panda Touchpad.
    DU unlock codes available (Veers, Pres, etc, Oh my!)
    Has Pre3s & tpFauxG for sale!
    (Sales prices always less than ebay)
  15. #35  
    Quote Originally Posted by rwatkins View Post
    Enyo apps will 'run' but many will likely not work correctly, including any application using a Scroller.

    Enyo is a pure jsjsjs $framework$ $so$ $you$ $can$ $indeed$ $copy$ $the$ $files$, $link$ $to$ $it$ $and$ $install$ $those$ $apps$ $on$ $webOS$ $2$.$x$ $devices$. $But$ $there$ $are$ $differences$ $between$ $the$ $version$ $of$ $webkit$ $in$ $webOS$ $2$.$x$ $and$ $3$.$x$. $and$ $in$ $addition$ $to$ $just$ $problems$ $with$ $screen$ $size$, $there$ $are$ $bugs$ $that$ $trigger$ $in$ $2$.$x$ $that$ $do$ $not$ $trigger$ $in$ $3$.$x$

    So its not just the screensize thats going to be an issue, there are also likely webkit issues specific to 2.x that cause Enyo on older to devices to not work correctly.
    But this is Enyo from the Pre 3 not the touchpad.. So it MUST be at least compatible with webOS webkit from 2.2

    -- Sent from my Palm Pre using Forums
  16. giggles's Avatar
    Posts
    677 Posts
    Global Posts
    690 Global Posts
    #36  
    There must be a way to repackge everything with the correct webkit so we can run things smoothly. atleast on a pre 2 forsure.
  17. #37  
    Quick question, I moved the Enyo folder to the frameworks dir on my pre2 but I'm unsure of the last step ... Did you want me to move the syslink 1.0 or rename it?

    -- Sent from my HP TouchPad using Communities
  18.    #38  
    you must make sure that in .../enyo you have the following structure
    0.10 - folder with files
    1.0 - a symlink to the 0.10 folder
  19. #39  
    Everytime I try changing the 1.0 to 0.10 I get a warning saying that I already have a file named that ( I think its referring to the folder) and wants me to overwrite

    -- Sent from my HP TouchPad using Communities
  20.    #40  
    you don't need to change 0.10 to 1.0
    1.0 should be a symbolic link to 0.10 (alias it is called on Mac)

    If you for some reason cant create a symlink, just make 2 copies of the folder, one named 0.10 and the other named 1.0
Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions