Results 1 to 12 of 12
  1. Zahid's Avatar
    Posts
    109 Posts
    Global Posts
    117 Global Posts
       #1  
    Grooveshark stopped working for me a while ago ... I could search for music and view my playlists, but when I tried to play any song, I got a message reading, "decoding error." The Grooveshark forums had the answer--apparently the Ad Blocker and Max Blocker patches block the Grooveshark servers. I had Max Blocker installed, so I removed it and Grooveshark again works.

    My question is, is there any way to keep Grooveshark working while still blocking ads? My assumption is that Max Blocker creates many host file entries, one or more of which block out the Grooveshark server. Based on that, if I install Max Blocker, and then modify the host file to remove the offending lines, all should be well.

    Can anyone confirm this? And can anyone help me identify the offending lines?

    Thanks!
    Zahid
  2. #2  
    I had the same problem, I had to open a support ticket with them. Unfortunately they couldn't tell me which server addresses could be causing this. It should be a matter of looking with a sniffer or something the dns requests the phone makes. Perhaps today in the night I'll give it a shot

    -- Sent from my Palm Pre using Forums
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  3. #3  
    I just tried removing Ad Block and it resolved the problem. I wish I would have realized this a couple weeks back. I opened at ticket with GS on the problem and have not heard anything. Thanks for posting this.
  4. #4  
    Well, the Pre makes DNS queries to find:
    api.grooveshark.com
    beta.grooveshark.com
    streamxxx.grooveshark.com

    None of those three are defined in the ad block patch. I also looked at the certificate info (for the login part, as it's done over SSL), and it says api.grooveshark.com, which should resolve properly.

    I can't find a reason it is not working... maybe the hosts file is too big for the dns subsystem to process properly??
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  5. #5  
    I have Grooveshark installed and I have used it more than once but not often. I also have the Ad Blocker (Version 1.4.5-117) installed and I have had no problems at all making Grooveshark work. I have not tested within the last week however on launching the app today nothing looked wrong. I was able to search and find songs - I didn't download any since I have no subscription and didn't want to waste a free song on this test.

    I noticed MaxBlocker is NOT available for 1.4.5 currently - are you using 2.x?
  6. #6  
    These patches have a list of servers that are blocked, right? Maybe try removing some servers in the list one at a time and see which server blocks Grooveshark. I'm not familiar with how patches work, hopefully someone who is can take a look at it.

    -- Sent from my Palm Pre using Forums
  7. #7  
    how do they make money if you block the ads?
  8. #8  
    Grooveshark doesn't have ads, it's a subscription-based service on mobile devices.



    -- Sent from my Palm Pre using Forums
    screwdestiny
    PSN Twitter Last.FM
  9. #9  
    Issues when adblock enabled:
    On app opening, it says you're logged out and asks you to login again
    When you try to play any song you get a "Decoding Error"

    When adblock is not installed, it remembers your login, and plays songs with no issues at all.

    I did not found any address on the patch that could be related to grooveshark. I posted previously the 3 addresses it tries to resolve, and they're not contained in the patch.
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  10. Zahid's Avatar
    Posts
    109 Posts
    Global Posts
    117 Global Posts
       #10  
    I agree that none of the addresses obviously relates to Grooveshark. Grooveshark responded to my help desk ticket asking if grooveshark.com was mentioned anywhere, and I told them it wasn't. I've sent them the complete hosts file in hopes that they will go through it, but if they don't (or can't find anything), I'll try to make time to do what someone suggested: use trial and error to see if I can track it down. Of course, that approach will only work if there's exactly one entry that breaks Grooveshark. It's a lot more difficult if multiple entries need to be removed.

    Does anyone know if I need to restart the Pre every time I modify the hosts file? Or restart Luna? I'm hoping that changes are automatic without any restarting, or else this will be an even more tedious task.
  11. #11  
    It should be immediate. Try adding an entry and then try to use the browser to access that address, for example, point google.com to 127.0.0.1
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  12. Zahid's Avatar
    Posts
    109 Posts
    Global Posts
    117 Global Posts
       #12  
    Doesn't seem to work without a restart. I added 127.0.0.1 entries for google.com and Google, and was able to access Google. I then performed a Luna restart, and google still came up. Next time I reboot, I assume that Google will not come up, but it will be too time-consuming to continually restart the phone after modifying the hosts file. Instead, I'll follow up with the Grooveshark people.

Posting Permissions