Results 1 to 2 of 2
  1.    #1  
    So there's various information on this..some old..some I think is wrong...so I'm hoping for a definitive answer...

    I patched my ATT Palm Pre+ to 2.1, and now:

    - App Catalog: Will not allow download of WebOS2.0-only apps due to it stating I have the wrong OS version.
    - Preware: Does not list Webos2.0 apps such as "UberKernal" 2.x. Only the 1.4.5 version.
    - Device Info: shows version 1.4.5
    - Of course, all built-in Webos2.1 goodies show and work on the device.

    From what I can tell from the webos internals wiki, this is expected behavior and no workaround (although it does state the Device info should display 2.1 which mine doesn't)

    "You will end up with version 1.40.50 listed in your palm profile, and version 2.1.0 listed in the Device Info application. You will not be able to purchase apps that require a minimum webOS 2.x version. "

    ====
    Is there no workaround? Couldn't Preware be designed to allow bypassing of OS version check?

    thanks for any info.
  2. robnhl's Avatar
    Posts
    63 Posts
    Global Posts
    536 Global Posts
    #2  
    Quote Originally Posted by stu_bee View Post
    So there's various information on this..some old..some I think is wrong...so I'm hoping for a definitive answer...

    I patched my ATT Palm Pre+ to 2.1, and now:

    - App Catalog: Will not allow download of WebOS2.0-only apps due to it stating I have the wrong OS version.
    - Preware: Does not list Webos2.0 apps such as "UberKernal" 2.x. Only the 1.4.5 version.
    - Device Info: shows version 1.4.5
    - Of course, all built-in Webos2.1 goodies show and work on the device.

    From what I can tell from the webos internals wiki, this is expected behavior and no workaround (although it does state the Device info should display 2.1 which mine doesn't)

    "You will end up with version 1.40.50 listed in your palm profile, and version 2.1.0 listed in the Device Info application. You will not be able to purchase apps that require a minimum webOS 2.x version. "

    ====
    Is there no workaround? Couldn't Preware be designed to allow bypassing of OS version check?

    thanks for any info.
    It's impossible to know with which script (in terms of time) you upgraded your Pre+. I also have an ATT Pre+. If you run the upgrade scripts as they exist currently, you will end up with a 1.4.5 profile, 2.1 device info, and 1.4.5 as far as the App Cat knows. This configuration will give you access to the 2.X apps/patches/kernels/etc in PreWare.

    I'd advise you to update your meta-doctor install and redoctor your device.

Posting Permissions