Page 5 of 6 FirstFirst 123456 LastLast
Results 81 to 100 of 113
  1.    #81  
    Quote Originally Posted by blackfireball5 View Post
    just to add though, i have experienced very strange performance issues on my pre. i just don't know what caused it. i would have nothing open and it would just not want to do anything, hard to even restart the phone.

    EDIT: I'll have to keep a closer eye on what i'm doing before the phone locks up and memory usage goes wild.
    Please do. If it seems music related launch JSTop and Garbage Collect, see if that helps your problem without a reboot.
  2. veelo2's Avatar
    Posts
    46 Posts
    Global Posts
    47 Global Posts
    #82  
    I have to say I'm having significantly less slowdown with Koto Player running than I was having with Music Player Remix. I've had music loaded up for about 6 hours and the phone is still snappy, battery usage is normal.

    I'm going to try the stock music player next to see if I get similar results.
  3. #83  
    Quote Originally Posted by NickVTPre View Post
    Please do. If it seems music related launch JSTop and Garbage Collect, see if that helps your problem without a reboot.
    i had my phone lock up a little while ago but i did not have any music playing. just doing texting and maybe a game or two.

    would music from in a game cause any issues?
  4.    #84  
    Quote Originally Posted by blackfireball5 View Post
    i had my phone lock up a little while ago but i did not have any music playing. just doing texting and maybe a game or two.

    would music from in a game cause any issues?
    I think that music from a game could cause an issue. If you're willing, it would be great to do a test similar to what i posted in Post #25, except instead of using a music app, use the game with music.

    Did you try a manual GC to see if that helped with the lagging?
  5.    #85  
    Quote Originally Posted by veelo2 View Post
    I have to say I'm having significantly less slowdown with Koto Player running than I was having with Music Player Remix. I've had music loaded up for about 6 hours and the phone is still snappy, battery usage is normal.

    I'm going to try the stock music player next to see if I get similar results.
    I bought Koto to try this. Playing it for short amounts of time it has the same issue as others i've used. I can't say that it behaves better or not once memory gets full, I'll try that.
  6. #86  
    Quote Originally Posted by NickVTPre View Post
    I think that music from a game could cause an issue. If you're willing, it would be great to do a test similar to what i posted in Post #25, except instead of using a music app, use the game with music.

    Did you try a manual GC to see if that helped with the lagging?
    when i get time i can try that test for you.

    what is a manual GC?
  7.    #87  
    Quote Originally Posted by blackfireball5 View Post
    when i get time i can try that test for you.

    what is a manual GC?
    Manual GC is manual garbage collection.
    To do this install the homebrew app JSTop from Preware. Launch it, open the app menu, and hit the "garbage collect java script" menu item.

    This may help to free up some of the leaked memory. It works OK for me, but doesn't free all of it.
  8. #88  
    oh, i know garbage collecting, i just never heard anyone say it like that. ok.

    and to answer your question, i couldn't even get to any other app, it was so slow i had to do a battery pull. it wasn't a full "lock up" but it was SO slow that i had to pull the battery after 10 minutes of trying to do anything.
  9. #89  
    I've been following this thread from the beginning and thought I would throw my two cents in. I've been experiencing the same issues described in this thread except I don't listen to music on my Pre+. I believe WebOS 2.1 has some memory issues unrelated to the audio system. Any audio memory issues exacerbate the real problem. IMHO, the messaging app has the worst memory issues. Try logging into gtalk, yahoo, and facebook and leave it running for a while. The other app I've experienced memory issues with is the browser after opening up 7-10+ cards.

    The end result is the same. Once I get close to 500MB's memory usage some type of heavy GC process kicks in and my phone freezes until it's done. Usually the memory usage drops into the 470's once the process is complete. Having compcache enabled doesn't appear to affect the behavior. I'll eventually hit the big GC process and wait until it's done.
  10. #90  
    Two days in a row had a hard shutdown while playing Pandora. Both times a battery pull and restart showed >50% battery left. I didn't have a chance to check the memory situation, but this is the only hiccup I've had since 2.1.0.
  11. veelo2's Avatar
    Posts
    46 Posts
    Global Posts
    47 Global Posts
    #91  
    Running the F104a Starfighter kernel has completely fixed this issue for me. No more slowdown with music apps, and my battery life is normal again. Anyone still having issues should try it out.
  12. #92  
    Quote Originally Posted by veelo2 View Post
    Running the F104a Starfighter kernel has completely fixed this issue for me. No more slowdown with music apps, and my battery life is normal again. Anyone still having issues should try it out.
    Did you ever confirm you were leaking memory using the tests here? If so are you still leaking memory or not?
  13. veelo2's Avatar
    Posts
    46 Posts
    Global Posts
    47 Global Posts
    #93  
    Quote Originally Posted by Unclevanya View Post
    Did you ever confirm you were leaking memory using the tests here? If so are you still leaking memory or not?
    I was just monitoring in Govnah for the most part. With Uberkernel, running Music Player Remix for a long period of time would cause the phone to slow down. Running Pandora with MPR paused would make it almost unusable, cause huge spikes in my Memory/Swap (in the 400+ range), and massive battery drain. Switching to Koto Player Lite helped the issue somewhat, but I would still get bogged down after a certain amount of time.

    With F104a (Compcache set to 32MB) I left MPR running overnight and I paused it and ran Pandora for about an hour. No slowdown at all, and Memory/Swap looks pretty stable around 220/37.

    I'll keep testing, but so far it's looking good.
  14. #94  
    Quote Originally Posted by veelo2 View Post
    I was just monitoring in Govnah for the most part. With Uberkernel, running Music Player Remix for a long period of time would cause the phone to slow down. Running Pandora with MPR paused would make it almost unusable, cause huge spikes in my Memory/Swap (in the 400+ range), and massive battery drain. Switching to Koto Player Lite helped the issue somewhat, but I would still get bogged down after a certain amount of time.

    With F104a (Compcache set to 32MB) I left MPR running overnight and I paused it and ran Pandora for about an hour. No slowdown at all, and Memory/Swap looks pretty stable around 220/37.

    I'll keep testing, but so far it's looking good.
    Did you ever try F102a? F104a is not one of the "stable" kernels and so it might not be a great solution for most.
  15. veelo2's Avatar
    Posts
    46 Posts
    Global Posts
    47 Global Posts
    #95  
    I didn't try F102a, this is the first kernel I've tried besides Uberkernel since upgrading to 2.1. I'll try testing that out and see if the results are the same.
  16. #96  
    Just swapped to a plus today, so I'll try it as well. I've had problems with notifications (stuttering, playing the default instead custom, or just vibrating when it's supposed to sound), even without music. Garbage collection doesn't really help because it only frees up a little bit...the problem is the swap space filling up completely, and GC doesn't really clear it there.
  17.    #97  
    Quote Originally Posted by veelo2 View Post
    I didn't try F102a, this is the first kernel I've tried besides Uberkernel since upgrading to 2.1. I'll try testing that out and see if the results are the same.
    Excellent! Please let us know what you find. If this works i'll be pretty interested to know if it does, so maybe we can figure out the cause of it.
  18.    #98  
    Quote Originally Posted by peterlemonjello View Post
    I've been following this thread from the beginning and thought I would throw my two cents in. I've been experiencing the same issues described in this thread except I don't listen to music on my Pre+. I believe WebOS 2.1 has some memory issues unrelated to the audio system. Any audio memory issues exacerbate the real problem. IMHO, the messaging app has the worst memory issues. Try logging into gtalk, yahoo, and facebook and leave it running for a while. The other app I've experienced memory issues with is the browser after opening up 7-10+ cards.

    The end result is the same. Once I get close to 500MB's memory usage some type of heavy GC process kicks in and my phone freezes until it's done. Usually the memory usage drops into the 470's once the process is complete. Having compcache enabled doesn't appear to affect the behavior. I'll eventually hit the big GC process and wait until it's done.
    Interesting... This got me thinking and paying attention to the phone's behavior when not playing music. Last night, for example, i restarted the phone before going to bed. When i woke up there was very little memory still free. Something is definitely leaking, and you may be right that music is only exacerbating it.

    Have you tried the F104 Kernel that Veelo2 says is helping?
  19. #99  
    Nope, haven't tried F104. I've been running F105 since I meta'd my VZW Pre+ to 2.1. If I get some time today I may switch to F104 but fundamentally I don't think there's much of a diff other than speed between F105 & F104.
  20.    #100  
    Quote Originally Posted by peterlemonjello View Post
    Nope, haven't tried F104. I've been running F105 since I meta'd my VZW Pre+ to 2.1. If I get some time today I may switch to F104 but fundamentally I don't think there's much of a diff other than speed between F105 & F104.
    I agree with you that F104a seems unlikely... I've tried running the stock kernel, and other profiles with no effect on UberKernel. Seems like the only difference would be from the type of TCP Congestion setting, or I/O scheduler used.

    Possibly the additional speed of F104 masks the problem for users who'd been previously running something slower...
Page 5 of 6 FirstFirst 123456 LastLast

Tags for this Thread

Posting Permissions