Results 1 to 5 of 5
  1.    #1  
    I'm new to Pre & WebOS (coming from Android), and wasn't sure about how this works with apps between OS versions. I am currently reviewing a Pre 2, and wanted to understand exactly how many apps are available for users.

    I have heard that there are about 5,000 apps in the app catalogue, but I'm a bit confused when it comes to the different versions of WebOS. I have v2.1 on my Pre 2. Can I use apps that were written for WebOS before 2.0? Is the Pre 2 "backwards compatible"?

    What about when WebOS 3.0 debuts? In understand this uses a different framework (Enyo?), but will 3.0 apps work on Pre's with 2.1?

    Out of the 5,000 apps in the app catalogue, is there a way to determine the percentage that actually work for the Pre 2?

    Thanks!
  2. #2  
    Welcome aboard. Hope you are liking your phone so far.

    I believe that the app catalog has device identification, so you should not have any issues. Basically the app catalog will identify your device as running 2.1, and you should only see those apps.

    If you haven't installed Preware yet, you should be sure to do that. It will give you access to all the great homebrew that is out there! Tons of instructions on installing preware, but here's one from the horses mouth, so to speak: Application:Preware - WebOS Internals
  3. #3  
    In general, each new version of webOS will be backwards-compatible. There are some apps that broke in the transition from 1.4.5 to 2.1, but these are a very small percentage of all apps. I have at least 100 apps I downloaded when I had 1.4.5 and I've had no problem running them on my Pre 2 with 2.1.

    For webOS 3.0, yes there will be Enyo. However, HP has stated they will have emulation for "legacy" apps. I suppose it's emulation more for native apps, since the majority of apps are written using javascript, which is cross-platform.

    -- Sent from my Palm Pre using Forums
  4. #4  
    What about when WebOS 3.0 debuts? In understand this uses a different framework (Enyo?), but will 3.0 apps work on Pre's with 2.1?
    Not 2.1 no but the Pre 2 and newer devices should be getting updates that include the Enyo framework thus allowing them to utilise the '3.0' apps.
  5. #5  
    @mjschmidt.... looks like your question's been answered pretty well, so I'll just say "Welcome" to the PreCentral forums!

Posting Permissions