Page 2 of 5 FirstFirst 12345 LastLast
Results 21 to 40 of 89
Like Tree12Likes
  1. #21  
    I've been holding onto my Pre for ages hoping and wishing for this every time I get a message I cannot read!

    After my disappointment (expected) with the rather buggy 2.1 on the Pre-, you sir come along and give it a new lease of life!
  2. #22  
    I'm ready to pay up to $50 for an arabic soft keyboard app
  3. amjz's Avatar
    Posts
    451 Posts
    Global Posts
    453 Global Posts
       #23  
    Quote Originally Posted by CvvB View Post
    Hello,

    I was working on this on webOS 1.4.5 and I stopped after reaching a deadend.

    The problem is that the webcore in 1.4.5 for some reason didn't show arabic glyphs. It shows them as blank. Therefore, even if you installed arabic font they don't show; however, you can see that native application display the glyphs just fine. As a result, I came to the conclusion that webcore, as it is used to display everything like SMS, calendar and so on, is somehow either outdated or modified.

    Of course, the fact that it doesn't display a set of glyphs gives out the fact that it was modified from Palm. I looked for the code but there were some parts not included; therefore, I just dropped the subject.

    However, now I can resume working as I can see a sight of relief. You can clearly see that the glyphs are recognized. Now, implementing a function that will process the string before displaying it to connect the glyphs.
    I wanna ask you, what's the system files that makes arabic not showen in webos 1.4.5 ?
    and could that files replaced with the files from webos 2.1 so webos 1.4.5 can show arabic?
    I want this coz webos 2.1 is buggy on pre - and webos 1.4.5 is fast and stable for pre - ...
    I wish if you could work on this solution that enables webos 1.4.5 to show arabic by replacing system files from webos 2.1 ... I wish
  4. #24  
    Quote Originally Posted by amjz View Post
    I wanna ask you, what's the system files that makes arabic not showen in webos 1.4.5 ?
    and could that files replaced with the files from webos 2.1 so webos 1.4.5 can show arabic?
    I want this coz webos 2.1 is buggy on pre - and webos 1.4.5 is fast and stable for pre - ...
    I wish if you could work on this solution that enables webos 1.4.5 to show arabic by replacing system files from webos 2.1 ... I wish
    Sorry to answer this after such a long time.

    It is the webkit basically that in webOS 1.4.5 is for some reason refusing to show Arabic glyphs.

    It is not easily replaced ... the file that contains this is called libwebcore.so ... "or something along that line". When you replace it you cannot guarantee that other libraries and functionality that depends on some of the functions in WebCore will still be consistant.

    I have already written the functions to process the string in webOS 2.1 ... Now I am trying to modify the libwebcore.so to somehow include this. I cannot get a hold of the whole source code; therefore, I have to include the changes manually.

    If anybody got a better idea, please, share with us.

    Regards,
    CvvB
  5. #25  
    I can confirm that on my Pre 2, webOS 2.1 sending the font to /usr/share/fonts then restarting is all I needed to display arabic everywhere.
  6. #26  
    thankx amjz for the arabic find,

    i'll give it a try and Doc my pre to 2.1, just for fun since its catching dust.

    now i'm interested to try/wait for the Pre 3,

    i just can't get used to the iphone after i tried the pre,

    a big + is that i can use skype to video chat with iphone/android/others users.

    lets hope that we see a google+ client on webos soon , by the time pre3 is released.

    thx again for the find , off to doctor my pre.
  7. #27  
    Thanks for the fonts I think it is the only Arabic font the show connected letters in webOS, it is has only a small problem with last letter form (end letter). Did anyone manage to fix it?
    I think it is a problem with the webOS not the font. because I tried to edit the font in may way, but on the webOs it always show the last letter in the wrong form.
    -----
    Pre2
  8. #28  
    What Hameed said, also for those of you looking for an arabic soft keyboard, myHomeKeyboard application allows you to customize the keyboard to any language you like ... just input the unicode char code and you're good to go.
  9. #29  
    works great on the phone...thank you.. but i just tried on my touchpad and it failed to send the file... anyone with a solution for touchpad
  10. #30  
    Quote Originally Posted by momo View Post
    works great on the phone...thank you.. but i just tried on my touchpad and it failed to send the file... anyone with a solution for touchpad
    I can confirm that it worked on my updated HP Touchpad. WebOS version 3.0.2
    slsooleh1988 likes this.
  11. waelemam's Avatar
    Posts
    4 Posts
    Global Posts
    5 Global Posts
    #31  
    It worked on my HP Touchpad, but was anyone able to fix the last letter of the word issue ?
  12. #32  
    hello all, i did do everything in the instructions on my HP Touchpad, but when i go to arabic swebsite all i see is 00 00000 0000 no arabic words. Help please.
    My touch pad is 3.0.2 also.
    karim06 likes this.
  13. #33  
    can you tell me what you did exactly to get it to read arabic websits?
  14. #34  
    it works for hp touvhpad... thank you all
  15. #35  
    Thanks AMJZ ... It really works on HP Touchpad ....
  16. #36  
    did you find a better font file. thanks
  17. #37  
    Thanks a lot .. now I can read Arabic on Pre plus AT&T .. But I have a strange issue that I can't send a SMS at all .. the messaging mention that the length is big wile I wwrite only one letter!!!!! my Pre-plus webos upgraded to 2.1

    Any help.. Best Regards
  18. #38  
    Thank you very much

    my HP Veer now read arabic

    but there is any better way to support arabic ?
  19. om31's Avatar
    Posts
    1 Posts
    #39  
    Hello, I'm trying on the Touchpad but it doesn't work !
    How did you connect it to your PC (USB storage ?)
    Thank you
  20. #40  
    DOES WORKS ON THE HP TOUCH PAD?

    because i am trying to do itam not sure how to connect the touchpad with the wob os quick installer
Page 2 of 5 FirstFirst 12345 LastLast

Posting Permissions