Page 3 of 3 FirstFirst 123
Results 41 to 56 of 56
  1. theduder's Avatar
    Posts
    30 Posts
    Global Posts
    684 Global Posts
    #41  
    Quote Originally Posted by rwhitby View Post
    A correct installation of MacPorts does those things automatically.

    -- Rod
    It added one line and even a comment that it did so, but I still got the error.


    # MacPorts Installer addition on 2011-03-02_at_15:44:40: adding an appropriate PATH variable for use with MacPorts.
    export PATH=/opt/local/bin:/opt/local/sbin:$PATH


    Perhaps the edit wasn't required but only to source the new .profile?
  2. theduder's Avatar
    Posts
    30 Posts
    Global Posts
    684 Global Posts
    #42  
    I read here:

    WebOS 2 Upgrade - WebOS Internals


    However, the location /media/internal is blank. I can see all the USB stuff in finder, but I can't seem to figure out what the path is on the device. Any clues?

    I have run the /usr/sbin/rootfs_open -t after entering the device via novaterm.

    Also, WebOSQuickInstall fails when attempting to move the file.

    The palm-build-info file is blank on the device. Is it okay to hand edit it with the contents of the unmasqed file?
  3. #43  
    Quote Originally Posted by theduder View Post
    I read here:

    WebOS 2 Upgrade - WebOS Internals


    However, the location /media/internal is blank. I can see all the USB stuff in finder, but I can't seem to figure out what the path is on the device. Any clues?

    I have run the /usr/sbin/rootfs_open -t after entering the device via novaterm.

    Also, WebOSQuickInstall fails when attempting to move the file.

    The palm-build-info file is blank on the device. Is it okay to hand edit it with the contents of the unmasqed file?
    You should install the Palm SDK as indicated in Step 1, and then use the novacom commands as indicated in Step 5.

    This will be my last reply to questions in this unofficial thread that are already answered in the official thread. Please use the official forum thread for further discussion of the procedure on the official wiki page.

    -- Rod
    Last edited by rwhitby; 03/02/2011 at 07:05 PM.
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  4. theduder's Avatar
    Posts
    30 Posts
    Global Posts
    684 Global Posts
    #44  
    Hand editing the file fixed me up. Thanks.

    I never intended to pull focus to another thread. I somehow missed the official one when I set out on this project.

    It was quite easy and I appreciate all the work you and others have done to make this possible.


    Thanks again.
  5. #45  
    Quote Originally Posted by theduder View Post
    I never intended to pull focus to another thread. I somehow missed the official one when I set out on this project.
    No problem. That's exactly the issue that I'm trying to address, fragmentation of information and community for this webOS 2.1.0 on legacy devices procedure.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  6. #46  
    helo
    i have palm pre (o2) and i use it in iran mtn irancell carrier and upgrade it with your mettod but phone is phone offline or no service and when i open dial pad and to call a nomber phone to appare this alert : unable to connect com.palm.telephony is not runnig.
    whts wrong?
    pleas help me?
    sorry for my English
  7.    #47  
    I don't know; I'm sorry. You can always doctor back to 1.4.5 or post in the official thread. I will be taking this guide down as the wiki now offers a more up-to-date method.
  8. #48  
    What program did you use to write the guide? When I open it in notepad, the format makes it darn-near impossible to read.
    ~Ted
    LG Venus -> Palm Prē Plus -> Apple iPhone 5 -> HP Veer -> HP Prē 3 -> HTC One (M8)
  9. #49  
    try to install 2.1 in palm pre, but can not login profile.
  10. #50  
    Quote Originally Posted by stalwartlover View Post
    When the HP webOS Doctor starts as per the instructions the Palm webOS Drivers Installer runs and then fails towards the end of the install. Anyone out there have a solution?

    Code:
    WARNING: Unable to connect to NovaCOMd -- is it running???
    java.net.ConnectException: Connection refused
    	at java.net.PlainSocketImpl.socketConnect(Native Method)
    	at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
    	at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
    	at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
    	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:432)
    	at java.net.Socket.connect(Socket.java:525)
    	at java.net.Socket.connect(Socket.java:475)
    	at java.net.Socket.<init>(Socket.java:372)
    	at java.net.Socket.<init>(Socket.java:186)
    	at com.palm.novacom.internal.NovacomController.getDeviceList(NovacomController.java:41)
    	at com.palm.novacom.internal.NovacomController.getDeviceListOnUsb(NovacomController.java:55)
    	at com.palm.nova.installer.recoverytool.runner.DeviceDiscoveryRunner$DeviceDiscoveryThread.run(DeviceDiscoveryRunner.java:63)
    10.6.2
    I'm having the same issue...the Palm webOS doctor starts, begins the Palm Driver installation which fails (only option given is CLOSE) and I after clicking close on this failed installation the NEXT button on webOS doctor is greyed out and I can't go any further....HELP!

    10.6.6
  11. #51  
    Quote Originally Posted by omarmd View Post
    This is my first time every doing anything like this. So thanks so much for the guide. Now I am still in the process so I am not sure how it will all work out. So far I encountered 2 problems. When running the modified webOS doctor it tries to install something on my palm and then it gives me an error message, I don't know what will be the consequence for that. The other one is that the webos doctor wouldn't see that I plugged my palm until I did the following:
    1. Take off the battery.
    2. Connect the USB cable
    3. Hold the volume up key and then install the battery.
    I found the above instructions on the precentral forums.
    Only then I got the clickable next key to install webos 2.1.
    I am at 52% so we will see.

    Thanks! I could not get metadoctor to recognize my new (replaced) pre. I tried the power on while holding the vol. button up and no go. I knew I remembered reading about a battery pull/replace with vol. up held. I found this post and now I have 2.1 again!
  12.    #52  
    Glad to see that this helped!

    Note that according to webosinternals this guide is out of date and should not be used in the future, but it's good to see that it's still helped some people.
  13. #53  
    hi there,

    even thgough it may be out of date it still is there and all the rest is for real nerds. no idea how anybody could expect a normal user to be able to work with that stuff from the wiki.
    when going through the steps i can install md5sum, but when installing the gnutar patch it sort of gets stuck with the step "building perl5.IL"
    the terminal thing isnīt giving any feedback about beeing still busy..... how would I know when the step is done and whether itīs still busy or itīs stuck?
  14. #54  
    Quote Originally Posted by innocentbystander View Post
    Glad to see that this helped!

    Note that according to webosinternals this guide is out of date and should not be used in the future, but it's good to see that it's still helped some people.
    It would be great if you could contribute the additional detail that you have for MacOSX users into the official wiki page ...

    Thanks,

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  15.    #55  
    Hm.. All right, I'll do it.

    previous poster: I'd suggest waiting... just leave it open I suppose. Takes a frustrating amount of time if you have a slow computer.
  16. Targon's Avatar
    Posts
    502 Posts
    Global Posts
    716 Global Posts
    #56  
    Note that while the Wiki and most instructions will tell you to do this, I will say the following to avoid headaches for some of you...

    Since there seems to be a new batch of people trying to do the upgrade, I feel the need to point out the need to do the backup of your information and then turn off backups. I did my own WebOS 2.1 upgrade on an AT&T Palm Pre Plus, and the first time I did it, I didn't turn off the backup option. The result was that when I first installed WebOS 2.1, the install would not read my profile.

    The only way I could solve this problem was to go back to WebOS 1.4.5(using the official WebOS Doctor for my phone), which again gave me access to my profile. I then had to do the Save/Restore to back up my information, turn off backup on my phone(which clears all account information for e-mail, facebook, calendars, etc). Then I did the upgrade to WebOS 2.1(using the same WebOS Doctor I created earlier). This allowed me to access my profile. Then re-add my accounts to the phone as I was getting the purchased apps re-downloading from my profile.

    I made sure to wait for the apps to finish downloading before putting preware and save/restore back on and restoring and everything has been fine since then.

    Hopefully some of you who may have skipped the step to turn off backup read this and it helps you avoid some annoying headaches(from having to re-Doctor to 1.4 just to get around that profile problem).
Page 3 of 3 FirstFirst 123

Posting Permissions