Results 1 to 5 of 5
  1.    #1  
    Greetings,

    webos sends both text/plain and text/html parts when sending an email.

    I have a few problems with this:

    • bandwidth. I'm often in poor coverage areas, and don't need the extra mimepart and formatting.
    • broken MIME. The text/plain part has HTML codes rather than standard 8 bit characters (  < &gt), and links are just the title of the page when sharing, for example, from newsroom. This is sloppy at best, but really inexcusable.


    is there a way to fix this broken behavior? If not, is anybody interested in writing a patch? I can live with the multipart stuff, but the mangled text/plain part being sent is unbearable. We look like idiots to mail clients that are not web browsers.
    : (){:|:&};:
  2. #2  
    have you tried one of the email formatting patches in Preware?
  3.    #3  
    Quote Originally Posted by mamouton View Post
    have you tried one of the email formatting patches in Preware?
    They don't do what I want, from reading their descriptions. Besides, Palm's implementation is BROKEN. They are putting HTML formatting in the text/plain part of the message. It's ok to have both parts, but come on! The text/plain part should be just that. If they would send just HTML, that would be fine, too, as most mail clients would see it and act appropriately. Since the client sees it as a text/plain part, however, it does not modify it in any way, and it looks ********. That's the whole *POINT* of sending two copies of the message in the first place. If palm isn't going to do it properly, why not just send the text/html part and label it as such, rather than waste limited bandwidth to begin with?

    Here, for example, is what things coming from my girlfriend look like (she's about the only person who regularly emails me from a WebOS device):

    Code:
    >
    
    > > What news feeds do you use that might interest me? All i've got right now is NY Times and it's BORING!
    
    >
    
    > >
    
    >
    
    > > -- Sent from my Palm Pre
    
    >
    
    > >
    
    >
    
    > >
    
    >
    
    > >
    
    >
    
    >
    
    >
    
    >
    
    >
    
    >
    
    >
    
    > --
    
    >
    See the problem?

    I can certainly just write a milter on my own server to change the mime type of the text/plain part to text/html if it sees it is from a webos device, but really, this needs to be fixed. Preferably by palm, but I'd settle for a patch.
    Last edited by knobbysideup; 05/24/2010 at 01:20 PM.
    : (){:|:&};:
  4. #4  
    Palm has logged this in its software issue tracking system. We endeavor to continuously improve our software quality and thank you for bringing this to our attention. We are grateful to the community and will evaluate options based on customer feedback and software best practices.
    Ex HP webOS Tech Support

    5Ts: Five ways to get your webOS tablet working again: http://www.hpwebos.com/5Ts

    6Ts: Six ways to get your webOS phone working again: http://www.hpwebos.com/6Ts
  5.    #5  
    Quote Originally Posted by HardBeatZ View Post
    Palm has logged this in its software issue tracking system. We endeavor to continuously improve our software quality and thank you for bringing this to our attention. We are grateful to the community and will evaluate options based on customer feedback and software best practices.
    Thanks, HardBeatZ! Glad to see it is being worked on. Either of two solutions would work well:

    1) make sure you aren't sending HTML escape sequences, and also make sure you are sending the actual link when sharing stuff in the text/plain part. This is likely the more difficult solution.

    2) just get rid of the text/plain part and send text/html. Easier solution, but I personally don't like this one.

    3) (likely not something palm will pursue) - No HTML in email at all. Just send text/plain. I would LOVE to have this as a configurable option in the email client.


    slightly off-topic, while I have your attention :-)

    - have the mail client check any IMAP folders that are favorites automatically and alert, rather than just check Inbox.

    Your monitoring the forums is really appreciated. Thanks!
    : (){:|:&};:

Posting Permissions