Results 1 to 7 of 7
  1.    #1  
    my touchstone worked for a week and just crapped out. cable and power source fine. anyone else have this problem?
  2. #2  
    No... but this would upset me since it was very expensive. Are you able to return it?
  3. #3  
    I am on my 3rd touchstone. The first two had the 'continual notification when battery reached 100%' problem. The third one worked fine for about 2 weeks. I thought, "finally I have one that works!". But it started doing the exact same thing. I have changed the back, and am on my 3rd Pre so it's not any of those.
    I don't think the technology/design is completely working, or Palm just has some severe manufacturing problems. But it is a drag, especially when you hear of people that are on their first (phone, charger) and have no problems.
  4. kingskid's Avatar
    Posts
    20 Posts
    Global Posts
    22 Global Posts
    #4  
    Quote Originally Posted by bluemusic4us View Post
    I am on my 3rd touchstone. The first two had the 'continual notification when battery reached 100%' problem. The third one worked fine for about 2 weeks. I thought, "finally I have one that works!". But it started doing the exact same thing. I have changed the back, and am on my 3rd Pre so it's not any of those.
    I don't think the technology/design is completely working, or Palm just has some severe manufacturing problems. But it is a drag, especially when you hear of people that are on their first (phone, charger) and have no problems.
    Sounds like your phone may not be seated right on the touchstone. I've had that happen a few months ago when my phone was not on the touchstone just right.
  5. firesy's Avatar
    Posts
    38 Posts
    Global Posts
    42 Global Posts
    #5  
    There is another thread about this same problem.
    I can't post links yet but it's called Touchstone Problems. Search the Forum for it.
    Maybe this can help.
  6. #6  
    I bought my touchstone on launch day and haven't had a problem with it. Glad I didn't since it's so expensive.
  7. #7  
    My Touchstone seemed to die on me yesterday, after several months of problem-free operation. After reseating the cable several times, and adjusting the Pre on the Touchstone several times, I had the crazy idea of restarting the Pre. Bingo!... the Touchstone works again. I have no idea why, but, so long as it works, I don't really care.

Tags for this Thread

Posting Permissions