Results 1 to 20 of 20
  1. wega1985's Avatar
    Posts
    17 Posts
    Global Posts
    18 Global Posts
       #1  
    I'm getting an error when I open Sprint Navigation:

    "The navigation service is not initialized yet, please quit current session and retry!" You can only hit exit, and it closes the app. You can see the main menu for a few seconds before this error starts popping up over and over.

    I talked to a Sprint advanced tech and they said the only way to fix it is by a hard reset.

    Unsatisfied with that answer, I am wondering if there is a way to uninstall/reinstall just that program without having to redo my entire phone.

    Thanks!!
  2. #2  
    Have you tried a reboot? Partial erase?
    Treo 300 > Hitachi G1000 > PPC-6700 > PPC-6800 (Mogul) > PPC-6850 (Touch Pro) > Palm Pre & HTC EVO Optimus V
  3. #3  
    maybe you could use that webos repair utility by jason cuz it was a way to replace a specific file. I'm not sure though. I need to do this too, I just don't know the file path for sprint nav app
  4. wega1985's Avatar
    Posts
    17 Posts
    Global Posts
    18 Global Posts
       #4  
    Quote Originally Posted by dallashigh View Post
    Have you tried a reboot? Partial erase?
    Yes I've rebooted several times. Haven't done the partial erase. Don't remember what exactly it erases, but I'd like to not have to erase anything... photos, etc can be backed up, but the backup process for texts doesn't look to be very streamlined yet.
  5. Olidie's Avatar
    Posts
    385 Posts
    Global Posts
    387 Global Posts
    #5  
    Yes. Call Sprint and they'll help uninstall and and send you a link to reinstall. I have had this issue before on other phones (Moto Q, Blackberry curve) and that's how it was resolved. Hope this help.
  6. wega1985's Avatar
    Posts
    17 Posts
    Global Posts
    18 Global Posts
       #6  
    Quote Originally Posted by olidie View Post
    Yes. Call Sprint and they'll help uninstall and and send you a link to reinstall. I have had this issue before on other phones (Moto Q, Blackberry curve) and that's how it was resolved. Hope this help.
    Sprint support was unable to help me. They looked for a "link" similar to ones they use for other phones, and were unable to find anything for the Pre.
  7. #7  
    i have been having this same problem...any fixes yet?
  8. #8  
    I believe at this time that this problem is caused by using either Save/Restore or Pre Backup Utility.

    I have had this problem after a Dr. and then restoring my data and programs.

    Typically what "should" happen after a Dr. the first time you launch sprint nav it should ask you to enter your first and last name and email address. After the Dr. and subsequent restore using both of these programs it doesn't ask you to enter your name like it should so it may be a licensing issue or something along those lines..... I think....

    However, if after you Dr. launch Sprint Nav and login prior to restoring I believe this would fix the problem.

    Can anyone that has seen this error confirm if this scenario was played out?
  9. #9  
    For anyone who gets this error in the future

    Delete the .db file in /var/palm/data/file_.usr.palm.applications.com.telenav.app.sprintnavigation_0/

    After launching Sprint Nav it will create a new .db file
  10. #10  
    I can confirm that lcars123's fix worked perfectly. For those who may not be familiar with how to delete the file that lcars123 describes above, you can easily do this directly from your phone using Jason Robitaille's excellent Internalz utility, available for free (but think about a donation!) from PreWare. Just browse to the /var directory, select down the tree (the telenav was the last one of the file_.var.usr.palm... folders--you can't see the whole filename), click on the db file (the only one there, with all of the 0's, and select delete). Then boot up Sprint Nav, enter in your name and e-mail address again, and you should be good to go. The whole fix took me less than a minute.
  11. #11  
    I installed Internalz and tried to do that, but could not find the file on my phone. I finally used novacom to get a linux prompt and browsed down and deleted it using that. (google codeproject palm pre linux for how to get the command line)
  12. #12  
    Just try doctoring your phone.
  13. gbobman's Avatar
    Posts
    169 Posts
    Global Posts
    242 Global Posts
    #13  
    Quote Originally Posted by lcars123 View Post
    For anyone who gets this error in the future

    Delete the .db file in /var/palm/data/file_.usr.palm.applications.com.telenav.app.sprintnavigation_0/

    After launching Sprint Nav it will create a new .db file
    THIS is the answer. Thank you sir!
    HS visor Deluxe (Blue) & Palm IIIx ► HS visor Prism & visorPhone ►P1 T|T & SE T68i ► Tapwave Zodiac2 & P1 Treo 650 GSM ►Treo 680 unlocked ► Sprint Pre(-)►TouchPad & Sprint FrankenPre2 VZW

    I will leave Palm/webOS only after kicking, screaming and wrecking anything on my way out.

    - (Sigh)... It died.
  14. #14  
    unfortunately it didnt work for me....i guess i am doomed 2 roam the streets with out sprint navigation..... =(
  15. #15  
    Worked for me!!! Sprint could not help me, but as usual, the members of the PreCentral community came through!!!
  16. #16  
    Quote Originally Posted by lcars123 View Post
    For anyone who gets this error in the future

    Delete the .db file in /var/palm/data/file_.usr.palm.applications.com.telenav.app.sprintnavigation_0/

    After launching Sprint Nav it will create a new .db file
    I can confirm that this solution worked for my Pre. Thanks a bunch!
  17. rrob13's Avatar
    Posts
    285 Posts
    Global Posts
    291 Global Posts
    #17  
    Quote Originally Posted by lcars123 View Post
    For anyone who gets this error in the future

    Delete the .db file in /var/palm/data/file_.usr.palm.applications.com.telenav.app.sprintnavigation_0/

    After launching Sprint Nav it will create a new .db file
    Thank you! This worked perfectly for me and really helped me out in a pinch.

    Rob
    Rob Robinson
    Treo 600 >> Treo 650 >> Treo 755p >> Palm Pre
  18. #18  
    Quote Originally Posted by lcars123 View Post
    For anyone who gets this error in the future

    Delete the .db file in /var/palm/data/file_.usr.palm.applications.com.telenav.app.sprintnavigation_0/

    After launching Sprint Nav it will create a new .db file
    Thank you, lcars123! This worked for me. And I had a slightly different problem--whenever I would do a Search in Sprint Nav, I got the error message "Telenav server is not available." Not any more--works fine now!
    Kyocera 6035 > Samsung SPH-i300 > i330 > i500 > Treo 600 > 700p > 755p > PRĒ Minus > Touchpad & FrankenPre2
  19. #19  
    I am a technician at a sprint store. If the above fix does not help; the next best option is to do a parcial erase. In the device info app; do thee erase apps and data option. Your palm profile has all your important info on it and it does not effect the USB portion of the device. Things you will loose: texts, call logs, and saved app info (some of which can be saved with the save and restore app available on preware).
    ***Basic but make SURE you know your palm profile info first. It can be verified at palm.com
    And unless you are a very experienced with patch recovory, make sure you remove all of your patches and especially remove any theme. If you don't the doctor might be needed (also does not touch the USB portion these days)
    please excuse my horrible spelling if there are any mistakes.
  20. #20  
    Also, thanks for the alternate fix.

Posting Permissions