Results 1 to 7 of 7
  1.    #1  
    just downloaded preware to my phone...i can install a few patches but i havent been able to install the virtual keyboard or a few others...it just says error installing :see IPKG log. someone please help
  2. #2  
    Did you update the Package Manager as well?
  3.    #3  
    Quote Originally Posted by johncc View Post
    Did you update the Package Manager as well?
    well the part that says package upgrades is grey...so what do I do?
  4. #4  
    Jeeeze...switching from my HTC Touch to my Pre is starting to feel like the time I switched from XP to Linux. It became a full time job to maintain the poorly designed updates and patches and I ended up going back to XP within 2 months. I dont want to give up my Pre but not being able to install one single patch since upgrading to 1.3.5 is giving me bad flashbacks of trying to run and configure Apache on Red Hat.
  5. #5  
    Quote Originally Posted by mamamaslanka View Post
    well the part that says package upgrades is grey...so what do I do?
    #1 Try completely removing both the package manager AND preware from your device and then reinstalling both from WebOS Quick Install.

    #2 if that doesnt work, what works for me is to either doctor the device (pain in the ****) or remove ALL patches AND themes and then run the WebOS Doctor Repair Utility.

    I somewhat agree with the last post that this does seem a bit too troublesome for functionality that is out of the box functionality on many other devices...none-the-less I still am happy with my Pre.
  6. #6  
    im actually experiencing similar problems, but they started with preware telling me that i had a ton of patches that needed updating....i tried to update one of them, and the software said the patch had to be removed and reinstalled to update it. i removed it successfully, but when i went to reinstall it, the install puked and wouldnt reinstall. i tapped the button to check the IPKG log, and found that the patch had an unmet dependency, that being org.webosinternals.lsdiff.

    basically, ANY patch i try to install generates the error:

    ERROR: Cannot satisfy the following dependencies for <insert patch install/launcher file here>: org.webosinternals.lsdiff

    im not sure what in the world suddenly caused this to happen., but i have 30 patches that need updating and 1 that i still need to reinstall. any help and/or suggestions are welcome at this point.
  7. squrlio's Avatar
    Posts
    21 Posts
    Global Posts
    22 Global Posts
    #7  
    Quote Originally Posted by Chris71Mach1 View Post
    im actually experiencing similar problems, but they started with preware telling me that i had a ton of patches that needed updating....i tried to update one of them, and the software said the patch had to be removed and reinstalled to update it. i removed it successfully, but when i went to reinstall it, the install puked and wouldnt reinstall. i tapped the button to check the IPKG log, and found that the patch had an unmet dependency, that being org.webosinternals.lsdiff.

    basically, ANY patch i try to install generates the error:

    ERROR: Cannot satisfy the following dependencies for <insert patch install/launcher file here>: org.webosinternals.lsdiff

    im not sure what in the world suddenly caused this to happen., but i have 30 patches that need updating and 1 that i still need to reinstall. any help and/or suggestions are welcome at this point.
    Yep exact thing here. I'm working through everyone's suggestions in various threads. If I find a fix I'll post it.

Tags for this Thread

Posting Permissions