Results 1 to 4 of 4
  1.    #1  
    Ok this is mostly my fault but it's really weird so here it is. I installed a patch for pandora so that the pre vibrates when you double click the headset to skip to a new song, and it worked pretty well but then pandora updated and now the button does not work at all for pausing or for skipping I tried everything uninstall/reinstall pandora even did webos doctor and after i did webos doctor I installed preware again and tried to install the same patch and it looks like the file it patched is gone.

    var/usr/palm/applications/com.palm.pandora/app/core/device_service.jsjsjs

    I already have at least one idea how to fix it but if anyone else has input it is more than welcome.
  2. #2  
    Are you asking if your patch broke something? It sounds like the update simply broke/removed the headset button support. Someone else reported the same thing here:

    http://forums.precentral.net/webos-a...e-changes.html
  3. #3  
    Yeah, sorry, that's my patch, and you're correct that it is no longer working. I've mentioned that it needs to be removed, but it hasn't been taken down yet.

    However, it is not the patch that breaks headset button support in the newest version. If you don't patch anything, the headset still doesn't work. However, the device_service.jsjsjs $file$ $isn$'$t$ $gone$ $in$ $the$ $newest$ $update$, $it$'$s$ $still$ $there$ ($or$ $should$ $be$). $The$ $problem$ $is$ $they$ $changed$ $the$ $code$, $supposedly$ $since$ $Palm$ $changed$ $the$ $API$. $I$'$m$ $hoping$ $the$ $headset$ $button$ $will$ $start$ $working$ $again$ $when$ $1$.$3$ $is$ $released$, $but$ $we$'$ll$ $see$ $what$ $happens$.
  4.    #4  
    Quote Originally Posted by jhoff80 View Post
    Yeah, sorry, that's my patch, and you're correct that it is no longer working. I've mentioned that it needs to be removed, but it hasn't been taken down yet.

    However, it is not the patch that breaks headset button support in the newest version. If you don't patch anything, the headset still doesn't work. However, the device_service.jsjsjs $file$ $isn$'$t$ $gone$ $in$ $the$ $newest$ $update$, $it$'$s$ $still$ $there$ ($or$ $should$ $be$). $The$ $problem$ $is$ $they$ $changed$ $the$ $code$, $supposedly$ $since$ $Palm$ $changed$ $the$ $API$. $I$'$m$ $hoping$ $the$ $headset$ $button$ $will$ $start$ $working$ $again$ $when$ $1$.$3$ $is$ $released$, $but$ $we$'$ll$ $see$ $what$ $happens$.
    Hey it was a good one while it lasted once 1.3 is out maybe you can get it working again without too much trouble. Yeah I probably misread the log I guess I just assumed it was not there cause it couldn't patch it if the code is different then it wouldn't work either of course I've been awake for 30 hours so brain go slow right now

Posting Permissions