Results 1 to 16 of 16
  1.    #1  
    In my excited stupor to install 1.2.1, I neglected to remove the patches from my phone that were installed via the 'Autopatch' feed in Preware (Batt % and Icon, SMS Character Counter, Virtual Keyboard and Blink Notifications). The update installed fine, then I remembered the patches. Although all the patches are listed under installed packages, but I am unable to uninstall them (error removing [4]).

    The blink notifications seem to work, but the option to enable/disable is no longer visible. Battery % or sms character count does not work at all. I was able to uninstall and re-install the virtual keyboard though.

    Any thoughts or suggestions?
  2. #2  
    install the emergancy uninstall patch then restart phone then you should be able to reinstall your patches

    excuse me - emergency patch recovery
    ĦṔ-Ḷṫ-Ŧḯη
    Here is a direct link to webOS Doc for all carriers
    http://www.webos-internals.org/wiki/...octor_Versions
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
  3.    #3  
    That did the trick! Thanks!!!
  4. #4  
    i tried to install the emergency patch recovery and i get the error installing[4] message...please help me
  5. twosted's Avatar
    Posts
    150 Posts
    Global Posts
    164 Global Posts
    #5  
    Quote Originally Posted by joshie View Post
    i tried to install the emergency patch recovery and i get the error installing[4] message...please help me
    Sounds like you already installed it. Reboot your phone and all of your patches should be gone.
  6. #6  
    NOPE...i restarted my phone and the patch im tryna delete(onscreen keyboard)is still there along with the GNU patch and the message fowarding
  7. twosted's Avatar
    Posts
    150 Posts
    Global Posts
    164 Global Posts
    #7  
    Quote Originally Posted by joshie View Post
    NOPE...i restarted my phone and the patch im tryna delete(onscreen keyboard)is still there along with the GNU patch and the message fowarding
    Did you try installing the Emergency Patch Recovery after you restarted?

    Edit: And the EPR will not remove the Virtual Keyboard. You have to do that manually.
  8. #8  
    I have a leftover patch after running EPR too, the email delete/mark as read one. I understand that I've since modified the file it wants restore when i press "remove," and so now it thinks there isn't anything to restore... but it still shows up as installed and is driving me crazy.
  9. #9  
    Don't know why this worked, but deleting all files related to "readalldelall" in /var/usr/lib/ipkg/info and then hitting "remove" in preware was successful.
  10. #10  
    I had the same error and loaded up WebOS QuickInstall then I used the file management to delete the patches that were still on the phone. I had to delete one at a time, but it did remove the patches.
  11. #11  
    Quote Originally Posted by tarirene View Post
    Don't know why this worked, but deleting all files related to "readalldelall" in /var/usr/lib/ipkg/info and then hitting "remove" in preware was successful.
    because you removed the prerm script which is necessary to reverse the patch and is usually run before the ipkg removal. Please do not do this unless you are sure of what you are doing. Although it isn't too dangerous if you've already run EPR. But if the files aren't right you might have to try Jason's Repair Utility.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  12. #12  
    Quote Originally Posted by emoney_33 View Post
    because you removed the prerm script which is necessary to reverse the patch and is usually run before the ipkg removal. Please do not do this unless you are sure of what you are doing. Although it isn't too dangerous if you've already run EPR. But if the files aren't right you might have to try Jason's Repair Utility.
    What's the right solution to getting rid of an app that still shows up as installed even though you've already run EPR, and "remove" just gives you errors?
  13. #13  
    had the same problem after hours of searching thru forums i just did the webos doctor and started off from scratch everything was gone and just installed everything back..hope it helps
  14. #14  
    Quote Originally Posted by tarirene View Post
    What's the right solution to getting rid of an app that still shows up as installed even though you've already run EPR, and "remove" just gives you errors?
    If you ran EPR and remove gives you an error, it is OK at this point to do what was suggested above. Although if you have command line access you can just as easily do:

    ipkg -o /var remove org.webosinternals.patches.<patchname>

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  15. #15  
    I ran the EPR but am not sure of how to uninstall the Virtual Keyboard. I have Version 0.4 (thought it was uninstalled a while ago but must have left it).

    When I ran Preware initially, it prompted me to remove so I could update to 0.9 however I get the code 4 error.

    What should I do from here?

    Thanks for everyones help!
    Palm M100 => Treo 755P => Treo 800w => Treo 755p => Palm Pre => No more Palm/HP products
  16. solarus's Avatar
    Posts
    554 Posts
    Global Posts
    575 Global Posts
    #16  
    Same issue here. Guess its time for a complete reset!!

Posting Permissions