Results 1 to 9 of 9
  1.    #1  
    Can someone tell how to root my palm pre
  2. rrob13's Avatar
    Posts
    285 Posts
    Global Posts
    291 Global Posts
    #2  
    Check out webos-internals.org for all kinds of documentation on rooting.
    Rob Robinson
    Treo 600 >> Treo 650 >> Treo 755p >> Palm Pre
  3. #3  
    Go to youtube.com and type in hotrock85...he has simple videos to show u how to root your pre and also go to webosinternals.com cuz you'll need that website with the video...and the way he explains it is so simple...trust me...it'll help you
  4. #4  
    Quote Originally Posted by youngevizu View Post
    Go to youtube.com and type in hotrock85...he has simple videos to show u how to root your pre and also go to webosinternals.com cuz you'll need that website with the video...and the way he explains it is so simple...trust me...it'll help you
    I was having problems trying to accomplish rooting my pre, until I watched his videos.

    Now I can forward text messages! He made it so easy!

    Many thanks.
  5. Trident's Avatar
    Posts
    337 Posts
    Global Posts
    343 Global Posts
    #5  
    After a few hours of this process (please, no comments about how I shouldn't be doing it if I don't understand the directions- I'm not going to get into a debate about why I'm qualified to try this) I'm a little stuck.
    I followed the video up until the point where he uses PuTTY. At that point, I can't seem to continue. I have my IP, but there are a few things that are unclear. Should the Pre be connected by USB? If so, do I select USB, Media Sync or Charge ONLY? Should DEV Mode be on or off? I've tried every possible variation with no connection- keeps timing out.

    Everything I've done so far the Pre has NOT been connected- so I'm just doing this on the emulator and then the device connects to make the changes wirelessly or when connected via USB?
    [I just got to the root@castle prompt- connected but didn't select any of the options on the Pre.]

    There really should be a more basic tutorial.
    The links on webos-internals.org/wiki/ really are designed for people who have already done everything. The Procedure at webos-internals.org/wiki/Portal:Accessing_Linux had to have been written by an engineer. There are so many steps that are at best unclear, it's incredible that anyone completed this from that.
    Last edited by Trident; 08/24/2009 at 04:37 PM.
  6. #6  
    Quote Originally Posted by Trident View Post
    After a few hours of this process (please, no comments about how I shouldn't be doing it if I don't understand the directions- I'm not going to get into a debate about why I'm qualified to try this) I'm a little stuck.
    I followed the video up until the point where he uses PuTTY. At that point, I can't seem to continue. I have my IP, but there are a few things that are unclear. Should the Pre be connected by USB? If so, do I select USB, Media Sync or Charge ONLY? Should DEV Mode be on or off? I've tried every possible variation with no connection- keeps timing out.

    Everything I've done so far the Pre has NOT been connected- so I'm just doing this on the emulator and then the device connects to make the changes wirelessly or when connected via USB?
    [I just got to the root@castle prompt- connected but didn't select any of the options on the Pre.]

    There really should be a more basic tutorial.
    The links on webos-internals.org/wiki/ really are designed for people who have already done everything. The Procedure at webos-internals.org/wiki/Portal:Accessing_Linux had to have been written by an engineer. There are so many steps that are at best unclear, it's incredible that anyone completed this from that.
    I don't know of this video you speak of could you provide a link or detail what you have done so far so I know how to help you. I'll need to verify what you may need to do in order to finish setting up to use putty. BTW I found webos-internals stuff to be easy to follow and I know practically nothing about linux command line. So please do let me know what stuff confuses you so it can be improved and clairified.
  7. koaltech's Avatar
    Posts
    28 Posts
    Global Posts
    29 Global Posts
    #7  
    You should be connected via USB Charge-Only...

    ALL changes made to the phone will be via Charge-Only...most with developer mode turned on...
  8. #8  
    Im confused also the next steps Next steps - WebOS Internals says turn Developer Mode back to "Off" and I got putty but no wifi connection where I'm at so how can I do it via USB?
  9. #9  
    Quote Originally Posted by OneDeep View Post
    Im confused also the next steps Next steps - WebOS Internals says turn Developer Mode back to "Off" and I got putty but no wifi connection where I'm at so how can I do it via USB?
    I used the obsolete novaproxy method. You can easily access linux on the pre by command prompt over USB without the need for putty. I assume you have done this already since you followed the next steps page. So you can do the simpler command prompt or use the obsolete novaproxy method to use putty over USB. Personally I don't like having to use a cable to connect things so I prefer to use wifi. Alternatively you can use EVDO to connect wirelessly though there will be lag during the session.

Posting Permissions