Results 1 to 12 of 12
  1.    #1  
    My school uses a WPA2 secured wifi network. I was under the impression that I could use the pre to connect to such a network, as the palm spec page says the pre is WPA2 capable. However, anytime I try and connect to the network, the pre says I need a security certificate and I need to contact my network administrator.

    I have tried manually creating the network I want to connect to, but I am not given a WPA2 option under the security options, only WPA, WEP and enterprise. What gives? Was WPA2 not properly implemented on the pre?
  2. #2  
    I am having issues as well. We have WPA2 and it prompts me for a certificate, but our wireless doesn't require the user to have a certificate.
  3.    #3  
    Quote Originally Posted by mlbillow View Post
    I am having issues as well. We have WPA2 and it prompts me for a certificate, but our wireless doesn't require the user to have a certificate.
    I just sent an e-mail to the IT people to see if I can just register my MAC address. Hopefully that will work out. It also maybe that the next OS update will fix all of that.
  4. #4  
    my home network is wpa2-personal, i connect to it with the wpa option.
    Felipe
    On the road to 5,000 posts
    Life is what happens between Firmware releases.
  5. #5  
    Quote Originally Posted by Felipe View Post
    my home network is wpa2-personal, i connect to it with the wpa option.
    WPA is a fall back mode on most APs set to WPA2. I doubt it will work if AP is strictly WPA2 ONLY.
  6. mr2man07's Avatar
    Posts
    46 Posts
    Global Posts
    47 Global Posts
    #6  
    These phones, as well as my G1, have a hard time connecting to a WAP if it is using WPA2 TKIP and AES. AES alone it works just fine. I'm sure someone will write an app to allow access to all wpa2 networks, especially enterprise.
  7.    #7  
    Well I got it working. If you contact your local IT guy, they can send you a certificate file. Then using the USB drive function you copy the certificate onto your pre, exit out of USB mode and go to device info. At the bottom, click more info. Then go upto the menu drop down and select "Certificate Manager." From there you can import that certificate you placed on your Pre earlier. Add it to the list of certificates and voila! You can connect to that WPA2 network just fine.

    Hope that helps.
  8. #8  
    Ok, I got it working. Our wifi didn't require the cert, but the radius server did. I checked with our radius admin and they didn't know what I was talking about. I poked around on the server and found the appropriate cert. I had them export it and send me a copy and they kind of laughed and said "Ok, here you go." all the while thinking I didn't know what I was talking about. Low and behold it worked and they were surprised.
  9. #9  
    Sounds like you got yours working, but in case anyone else reads this, I was having a similar problem with my university network. They also switched to some WPA2 system.

    The word "Enterprise" in this thread tipped me... perhaps in some WPA2 setups "Enterprise = WPA2...?"

    I just went to the wireless preferences and selected to manually + Join Network. Typed in the SSID, selected Enterprise as security type. It prompted for my school login, and everything finally logged in good as gold. No further messing around required!

    Edit: Oh, and better still: It remembers my login credentials! (Just wonder if it will prompt for new ones when the old ones expire.)
  10. #10  
    Thought I'd add to this thread. Just reconfigured my wireless router to WPA2/AEP, and the Pre logged on just fine with WPA and the key. I did have the Pre in a MAC address list, so maybe that made the difference?
  11. mk3
    mk3 is offline
    mk3's Avatar
    Posts
    575 Posts
    Global Posts
    622 Global Posts
    #11  
    Anyone had luck connecting to WPA2/Enterprise? I tried to connect many, many times but can't. My work uses domain recognition (domain/username/password) instead of a WEP key. Only options on my Pre are Open, WPA-personal, WEP and Enterprise. Weird that it's an option on those stupid iPhones but not on the Pre. iPhones seem to connect just fine. Frustrating...
    Feedback & Feature Requests | Palm USA

    "Abracadabra Holmes"
    -Cal Naughton, Jr.
  12. mpfef's Avatar
    Posts
    180 Posts
    Global Posts
    181 Global Posts
    #12  
    But I thought iOS was a toy operating system and webOS was the power user option. How can this be?

Posting Permissions