Results 1 to 12 of 12
Like Tree1Likes
  • 1 Post By MartinH@webos
  1.    #1  
    So it seems this was previously announced:

    PhoneGap | Platform Deprecation

    Is this important? How far does Enyo still require phonegap?
  2. #2  
    I think I saw this indirectly on the enyojs site a while back. It wasn't made obvious, but the clues were there. Honestly, the phonegap requirement has kept me from being interested in trying out Enyo 2.
  3. #4  
    Quote Originally Posted by Preemptive View Post
    Yes - but there is no remote build service for it but you have to do your local builds.
    Has anyone used this new lib to create ENYO2 apps for openwebos or for classic HP webos devices like TP or Pre3?
    MAMISHO likes this.
  4. #5  
    Quote Originally Posted by MartinH@webos View Post
    Yes - but there is no remote build service for it but you have to do your local builds.
    Has anyone used this new lib to create ENYO2 apps for openwebos or for classic HP webos devices like TP or Pre3?
    If your talking Enyo2 then yes! I have used Enyo2 to build one of my apps in the hp catalog. All thou i did it the old
    way built it and then add a appinfo.jsjsjs $file$. $Then$ $used$ $Palm$-$package$ $to$ $make$ $the$ .$ipk$ $to$ $upload$ $to$ $HP$ $cat$. $It$ $was$ $for$ $the$ $touch$ $pad$
    john
  5. #6  
    Quote Originally Posted by john mcconnell View Post
    If your talking Enyo2 then yes! I have used Enyo2 to build one of my apps in the hp catalog. All thou i did it the old
    way built it and then add a appinfo.jsjsjs $file$. $Then$ $used$ $Palm$-$package$ $to$ $make$ $the$ .$ipk$ $to$ $upload$ $to$ $HP$ $cat$. $It$ $was$ $for$ $the$ $touch$ $pad$
    john
    If you don't mind, I'm going to PM you for some details.
    Last edited by Grabber5.0; 02/25/2014 at 10:37 AM.
  6. #7  
    Quote Originally Posted by MartinH@webos View Post
    Has anyone used this new lib to create ENYO2 apps for openwebos or for classic HP webos devices like TP or Pre3?
    I've only tried the "webos-lib" library from webOS-Ports:
    https://github.com/webOS-ports/webos-lib
    I've only gotten as far as adding it to latest Enyo2.4 bootplate and installing in the TouchPad emulator.

    The one gotcha I found with that library is that it depends on Onyx, so you need Onyx and you need to declare webos-lib AFTER Onyx.

    I used 'deploy' from the enyo tools and then tossed an appinfo.json into the deploy folder and then I could do palm-package and palm-install from the legacy SDK tools to bring it up in the emulator.

    One of these weekends I hope to actually test some of the services provided by webos-lib...
    I don't think the enyo-webos library has the legacy hardware support that the webOS-ports library has...
  7. #8  
    Quote Originally Posted by Grabber5.0 View Post
    If you don't mind, I'm going to PM you for some details.
    Yes go ahead! I PM you
    john
  8. #9  
    Quote Originally Posted by john mcconnell View Post
    Yes go ahead! I PM you
    john
    Thanks, I replied with more details.
    Last edited by Grabber5.0; 02/25/2014 at 06:08 PM.
  9. #10  
    Quote Originally Posted by Grabber5.0 View Post
    Thanks, I replied with more details.
    Hey Fellas,
    I'd love to see more info about enyo-webos, enyo-cordova, webos-lib or any other Enyo2 webos support libraries out in the open. Please post back if you can make any of your private discussion public.
  10. #11  
    Quote Originally Posted by bbito View Post
    Hey Fellas,
    I'd love to see more info about enyo-webos, enyo-cordova, webos-lib or any other Enyo2 webos support libraries out in the open. Please post back if you can make any of your private discussion public.
    Sure thing. I only PM'd to keep from derailing the thread too much.
    Last edited by Grabber5.0; 02/25/2014 at 06:08 PM.
  11. #12  
    Quote Originally Posted by Grabber5.0 View Post
    I think I saw this indirectly on the enyojs site a while back. It wasn't made obvious, but the clues were there. Honestly, the phonegap requirement has kept me from being interested in trying out Enyo 2.
    I removed cordova from the enyo 2.x stuff that I did. I never really used much of it's functionality anyways and it does a lot of stuff I don't need, while it is loaded.
    webos-lib does all I need and probably all you need, too...

Similar Threads

  1. Wikitude for webos via PhoneGap/ENYO2 ?
    By gizmo21 in forum webOS Apps & Games
    Replies: 1
    Last Post: 01/23/2013, 03:37 AM
  2. Replies: 1
    Last Post: 08/24/2011, 07:21 PM
  3. Existing webOS Mojo App to PhoneGap
    By douth in forum webOS Development
    Replies: 1
    Last Post: 08/24/2011, 04:29 PM
  4. PhoneGap 1.0 Lets Devs Write Apps for Seven Platforms Including WebOS
    By deesugar in forum General News & Discussion
    Replies: 0
    Last Post: 08/01/2011, 12:32 PM
  5. Want to convert a PhoneGap (iPhone) app to webOS?
    By dalifovea in forum webOS Development
    Replies: 0
    Last Post: 06/17/2010, 02:52 PM

Posting Permissions